Introducing Starling

Errata for Introducing Starling

Submit your own errata for this product.


The errata list is a list of errors and their corrections that were found after the product was released. If the error was corrected in a later version or reprint the date of the correction will be displayed in the column titled "Date Corrected".

The following errata were submitted by our customers and approved as valid errors by the author or editor.

Color Key: Serious Technical Mistake Minor Technical Mistake Language or formatting error Typo Question Note Update



Version Location Description Submitted By Date Submitted Date Corrected
PDF, Other Digital Version
Page 3
1rs paragraph

Figure 2: below starling.display.DisplayObjectContainer each 4 entries are starling.display.TextField where it should be: starling.display.Button starling.display.Sprite starling.display.Stage starling.display.TextField

Note from the Author or Editor:
Will send updated figure. Thibault

Anonymous  Feb 29, 2012  Apr 09, 2012
Safari Books Online
9
Code sample Startup.as

The Startup.as references a "Stats" class, that isn't imported and I can't seem to find referenced in that chapter. Potentially it's referring to this class: http://forum.starling-framework.org/topic/starling-port-of-mrdoobs-stats-class

Note from the Author or Editor:
Oh good catch! Thanks, will be updated asap! Thibault

Doug Daniels  Jan 20, 2012  Apr 09, 2012
PDF
Page 19
onAdded() event

The final line of code in the onAdded() function is: s.addEventListener(Event.ENTER_FRAME, onFrame); There is no variable named s in this code example - that is only introduced in the next example. s should be replaced by either q or this.

Note from the Author or Editor:
Thanks! Will send the updated pdf with updates.

Sharon Hanlon  Jan 22, 2012  Apr 09, 2012
PDF
Page 20
package import statements

the import of starling.text.TextField should be in bold, indicating a new line that must be added to existing code.

Note from the Author or Editor:
Will send PDF.

Sharon Hanlon  Jan 22, 2012  Apr 09, 2012
PDF
Page 24
Game.onAdded() event

Why subtract the sprite width from the stage, then add half of it back again? I believe the following lines could be simplified from this: customSprite.x = (stage.stageWidth - customSprite.width >> 1) + (customSprite.width >> 1); customSprite.y = (stage.stageHeight - customSprite.height >> 1) + (customSprite.height >> 1); to this: customSprite.x = stage.stageWidth >> 1; customSprite.y = stage.stageHeight >> 1;

Note from the Author or Editor:
Will send the PDf updated.

Sharon Hanlon  Jan 23, 2012  Apr 09, 2012
PDF
Page 32
code

The text in the paragraph at the bottom says that the following code will scale the quad. It does not. It only prints the distance between the touch points.

John R. Nyquist  Oct 20, 2012  Nov 14, 2012
PDF
Page 40
code

Several lines of code that are added or changed have not been bolded. For example the data type of the vector, the data type of the image, the addition of the setting of destX and destY.

John R. Nyquist  Oct 20, 2012  Nov 14, 2012
PDF
Page 41, 42
onAdded() and onFrame() events

Both of these functions have a line that calculates the destY of the sausage, but they both use stage.stageWidth in the function. They should use stage.stageHeight instead.

Note from the Author or Editor:
Will send updated PDF.

Sharon Hanlon  Jan 25, 2012  Apr 09, 2012
PDF
Page 42
text

Second paragraph: As expected, the Image object exposes all the APIs herited Should say: As expected, the Image object exposes all the APIs inherited

John R. Nyquist  Oct 20, 2012  Nov 14, 2012
PDF
Page 45
text

Second paragraph: Because we might be calling this hit detection test one each frame, Should say: Because we might be calling this hit detection test once each frame,

John R. Nyquist  Oct 20, 2012  Nov 14, 2012
PDF
Page 46
code

This: var bmd:BitmapData = new BitmapData(radius * 2, radius * 2, true, color); Should be: var buffer:BitmapData = new BitmapData(radius * 2, radius * 2, true, color);

John R. Nyquist  Oct 20, 2012  Nov 14, 2012
PDF
Page 47
Figures

In figures 22 and 23, the top box says: starling.events.Sprite I believe it should say: starling.display.Sprite

John R. Nyquist  Oct 20, 2012  Nov 14, 2012
PDF
Page 48
text first paragraph

3rd line: is that the surface being drawn does not get renerated automatically when changing a Should say: is that the surface being drawn does not get regenerated automatically when changing a

John R. Nyquist  Oct 20, 2012  Nov 14, 2012
PDF
Page 53
code, 1st line

This: var xml:XML = XML(new spriteSheetXML()); Should be: var xml:XML = XML(new SpriteSheetXML());

John R. Nyquist  Oct 20, 2012  Nov 14, 2012