Apache Cookbook

Errata for Apache Cookbook

Submit your own errata for this product.


The errata list is a list of errors and their corrections that were found after the product was released. If the error was corrected in a later version or reprint the date of the correction will be displayed in the column titled "Date Corrected".

The following errata were submitted by our customers and approved as valid errors by the author or editor.

Color Key: Serious Technical Mistake Minor Technical Mistake Language or formatting error Typo Question Note Update



Version Location Description Submitted By Date Submitted Date Corrected
Printed
Page 14-16
Entire section

Section 1.6 deals with using ApacheToolbox to install Apache with modules but doesn't mention that the toolbox only works with older versions of Apache (1.3). The website www.apachetoolbox.com changelog shows that the author hasn't made any changes since 06/21/05.

Note from the Author or Editor:
I don't know that I'd classify this as an error, so much as a missing detail. Yes, we should add a sentence to the effect: ApacheToolbox only works with Apache 1.3, and there are no plans to update it for Apache 2.0 or 2.2 at this time. That's probably ok, though, since installing third-party modules tends to be a lot less complicated with Apache 2.x anyways.

Anonymous  Oct 09, 2008 
Printed
Page 130
Last paragraph

In Apache 2.2, the AuthDigestFile is no longer available. Thus, the original text AuthDigestFile "/www/acl/.htpasswd-dav-test" should be replaced with AuthDigestProvider file AuthUserFile "/www/acl/.htpasswd-dav-test"

Note from the Author or Editor:
Not sure what to do with this. I don't remember if we claimed to cover Apache 2.2, which was far from widely adopted at press time. Anything in the auth chapter really needs to be updated for 2.2, and the example, for the most part, won't work with 2.2. Should a disclaimer to that effect be added somewhere? Is it time for a new edition?

Anonymous