<!DOCTYPE html>
<html lang="en">
<head>
  <title>10 top Python resources on O’Reilly’s online learning platform - O&#39;Reilly Media</title>

  <!-- Meta -->
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
      <meta property="twitter:card" content="summary_large_image" />
      <meta property="twitter:site" content="@OReillyMedia" />
      <meta property="twitter:title" content="10 top Python resources on O’Reilly’s online learning platform" />
      <meta property="twitter:description" content="Our most-used Python resources will help you stay on track in your journey to learn and apply Python." />
      <meta property="description:site" content="Our most-used Python resources will help you stay on track in your journey to learn and apply Python." />
      <meta property="twitter:url" content="https://www.oreilly.com/ideas/10-top-python-resources-on-oreillys-online-learning-platform" />
      <meta property="fb:pages" content="15137500430" />
      <meta property="og:type" content="article" />
      <meta property="og:site_name" content="O&#39;Reilly Media" />
      <meta property="og:title" content="10 top Python resources on O’Reilly’s online learning platform" />
      <meta property="og:description" content="Our most-used Python resources will help you stay on track in your journey to learn and apply Python." />
      <meta property="og:url" content="https://www.oreilly.com/ideas/10-top-python-resources-on-oreillys-online-learning-platform" />
      <meta property="article:published_time" content="2018-10-22T10:00:00Z" />
      <meta name="description" content="Our most-used Python resources will help you stay on track in your journey to learn and apply Python." />
      <meta name="date" content="2018-10-22" />
      <meta property="og:image" content="https://d3ucjech6zwjp8.cloudfront.net/1400x933/digital-1742687_1920_crop-7813ea2ae8095e3ef173a390ddf23640.jpg" />
      <meta property="twitter:image" content="https://d3ucjech6zwjp8.cloudfront.net/1400x933/digital-1742687_1920_crop-7813ea2ae8095e3ef173a390ddf23640.jpg" />
      <meta name="thumbnail" content="https://d3ucjech6zwjp8.cloudfront.net/360x240/digital-1742687_1920_crop-7813ea2ae8095e3ef173a390ddf23640.jpg" />
      <meta name="graphic_medium" content="https://d3ucjech6zwjp8.cloudfront.net/360x240/digital-1742687_1920_crop-7813ea2ae8095e3ef173a390ddf23640.jpg" />
      <meta name="oreilly:topic" content="Software Engineering" />
      <meta name="oreilly:keywords" content="programming,python,resources,learning to code,learning python" />
  
  

  <!-- Assets -->
  <script type="text/javascript" src="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-f09526a22a.js"></script>
  <link rel="stylesheet" type="text/css" href="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-e83b91017e.css">
    
  
  <!-- Extra Assets -->
  
  
  

  <link rel="stylesheet" type="text/css" href="https://cdn.oreillystatic.com/assets/css/mkto-multiform-subscribe-20180320.css">

  <script type="text/javascript">
    dataLayer = [];
  </script>

    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5P4V6Z');</script>
  <!-- End Google Tag Manager -->
  

  

    <script type="text/javascript">
    function createKeenWebAutoCollector(){window.keenWebAutoCollector=window.KeenWebAutoCollector.create({projectId:'551456c8672e6c2f4f5ee426',writeKey:'e737a463e3a57a914ddf707a34ad2c319c2e1c52999fe5f8087e41a71676675f90298cfd1a4e30ecf3f25e337db4b579c28c2bf784b26bdd6e9b7cc595b045098b94483dea878b17a65a56b5307b97ac3834670c2484fb8effa01cbacd55dba355850b97cad116b4b0e434dc64bc359c',onloadCallbacks:window.keenWebAutoCollector.onloadCallbacks}),window.keenWebAutoCollector.loaded()}function initKeenWebAutoCollector(){window.keenWebAutoCollector.domReady()?window.createKeenWebAutoCollector():document.addEventListener("readystatechange",function(){window.keenWebAutoCollector.domReady()&&window.createKeenWebAutoCollector()})}window.keenWebAutoCollector={onloadCallbacks:[],onload:function(a){this.onloadCallbacks.push(a)},domReady:function(){return["ready","complete"].indexOf(document.readyState)>-1}};
  </script>
  <script async type="text/javascript" src="https://d26b395fwzu5fz.cloudfront.net/keen-web-autocollector-1.0.8.min.js" onload="initKeenWebAutoCollector()"></script>
  

  <script type="text/javascript">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</script>

  <!-- Start Visual Website Optimizer Asynchronous Code -->
  <script type='text/javascript'>
    var _vwo_code=(function(){
    var account_id=244658,
    settings_tolerance=2000,
    library_tolerance=2500,
    use_existing_jquery=false,
  // DO NOT EDIT BELOW THIS LINE
  f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
  </script>
  <!-- End Visual Website Optimizer Asynchronous Code -->

  <!-- Marketo -->
  <script src="https://app-ab24.marketo.com/js/forms2/js/forms2.min.js" type="text/javascript"></script>

</head>
<body class="body t-software-engineering" data-section="ideas" >
  <div class="flashes"></div>
    <header id="page-header">
  <div id="header-bar" class="t-bkg">
    <h1 class="logo t-bkg" >
  <a href="/" class=" logo-white ">
  <svg role="heading" aria-label="O'Reilly">
    <title>O'Reilly</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
  </svg>
  </a>
</h1>
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>


    <div class="right">
      <div id="search" class="hide">
        <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
      </div>
      <div id="user">
        <a href="https://www.oreilly.com/sign-in.html" class="t-c--d">Sign In</a>
      </div>
    </div>
    <a id="menu-toggle" class="invert" ><span class="icon icon-white icon-menu">
  <svg role="img" id="close" class="is-hidden">
    <title>Close Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#close"></use>
  </svg>
  <svg role="img" id="open">
    <title>Open Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#menu"></use>
  </svg>
</span></a>
  </div>
     <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/jupyter" >Jupyter</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

  
  <div id="mobile-menu">

    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
         <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/jupyter" >Jupyter</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

    
  </div>

</header>



  <!-- Linked In -->
  <script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
  
<!-- Load Facebook SDK for JavaScript -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<main aria-live="polite">
  <article class="article" itemscope itemtype="http://schema.org/Article">
              <header class="article-header">
      <div class="flag t-bkg--before bg-software-engineering--before flag--small">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
  
  

  <h1 class="title t-c" itemprop="headline">10 top Python resources on O’Reilly’s online learning platform</h1>

      <p class="dek" itemprop="alternativeHeadline">Our most-used Python resources will help you stay on track in your journey to learn and apply Python.</p>
  

   <time class="date">October 22, 2018</time>

</header>

      

      <div class="article-body" itemprop="articleBody">
        
                              <figure class="article-image right">
  <img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/digital-1742687_1920_crop-7813ea2ae8095e3ef173a390ddf23640.jpg" alt="Binary" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/digital-1742687_1920_crop-7813ea2ae8095e3ef173a390ddf23640.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/digital-1742687_1920_crop-7813ea2ae8095e3ef173a390ddf23640.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/digital-1742687_1920_crop-7813ea2ae8095e3ef173a390ddf23640.jpg 1440w" sizes="(min-width: 1390px) 420px, (min-width: 600px) 45vw, 100vw" class=""/>
  <figcaption>Binary
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://pixabay.com/en/digital-abstract-binary-code-1742687/">Pixabay</a>)
        
        
      </span>
    
    
  <figcaption>

</figure>
          
                      <aside data-type="note">
  <p><a href="https://www.safaribooksonline.com/search/?query=python&extended_publisher_data=true&highlight=true&is_academic_institution_account=false&source=user&include_assessments=false&include_case_studies=true&include_courses=true&include_orioles=true&include_playlists=true&sort=relevance&utm_source=oreilly&utm_medium=newsite&utm_campaign=10-top-python-resources-on-oreillys-online-learning-platform_top_cta">Access the Python resources on our online learning platform and learn how to make Python work for you</a>.</p>
</aside>

          
        

        

        <p>We dove into the data on <a href="https://www.safaribooksonline.com/home/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=10-top-python-resources-on-oreillys-online-learning-platform_body_link">our online learning platform</a> to identify the most-used Python resources. These are the items our platform subscribers regularly turn to as they apply Python in their projects and organizations.</p>

<p><em><a href="https://www.safaribooksonline.com/videos/introduction-to-python/9781491904794?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=10-top-python-resources-on-oreillys-online-learning-platform_body_link"><strong>Introduction to Python</strong></a></em> — Jessica McKellar teaches you Python’s core concepts and data types through hands-on exercises and useful projects.</p>

<p><em><a href="https://www.safaribooksonline.com/library/view/python-for-data/9781491957653/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=10-top-python-resources-on-oreillys-online-learning-platform_body_link"><strong>Python for Data Analysis, 2nd Edition</strong></a></em> — Wes McKinney shares practical case studies that show you how to solve a broad set of data analysis problems effectively. You’ll learn the latest versions of pandas, NumPy, IPython, and Jupyter in the process.</p>

<p><em><a href="https://www.safaribooksonline.com/library/view/learning-python-5th/9781449355722/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=10-top-python-resources-on-oreillys-online-learning-platform_body_link"><strong>Learning Python, 5th Edition</strong></a></em> — Mark Lutz leads you through an in-depth, hands-on introduction to the core Python language. It’s an ideal way to begin, whether you’re new to programming or a professional developer versed in other languages.</p>

<p><em><a href="https://www.safaribooksonline.com/library/view/deep-learning-with/9781617294433/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=10-top-python-resources-on-oreillys-online-learning-platform_body_link"><strong>Deep Learning with Python</strong></a></em> — François Chollet introduces the field of deep learning using the Python language and the powerful Keras library. This book builds your understanding through intuitive explanations and practical examples.</p>

<p><em><a href="https://www.safaribooksonline.com/library/view/learn-python-3/9780134693866/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=10-top-python-resources-on-oreillys-online-learning-platform_body_link"><strong>Learn Python 3 the Hard Way: A Very Simple Introduction to the Terrifyingly Beautiful World of Computers and Code, 1st Edition</strong></a></em> — Zed A. Shaw helps you learn Python using 52 exercises. Read them. Type their code precisely. Fix your mistakes. Watch the programs run.</p>

<p><em><a href="https://www.safaribooksonline.com/library/view/fluent-python/9781491946237/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=10-top-python-resources-on-oreillys-online-learning-platform_body_link"><strong>Fluent Python</strong></a></em> — Luciano Ramalho takes you through Python’s core language features and libraries, and shows you how to make your code shorter, faster, and more readable at the same time.</p>

<p><em><a href="https://www.safaribooksonline.com/library/view/automate-the-boring/9781457189906/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=10-top-python-resources-on-oreillys-online-learning-platform_body_link"><strong>Automate the Boring Stuff with Python</strong></a></em> — Al Sweigart teaches simple programming skills to automate everyday computer tasks.</p>

<p><em><a href="https://www.safaribooksonline.com/library/view/python-crash-course/9781457197185/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=10-top-python-resources-on-oreillys-online-learning-platform_body_link"><strong>Python Crash Course</strong></a></em> — Eric Matthes takes you through a fast-paced, thorough introduction to programming with Python that will have you writing programs, solving problems, and making things that work in no time.</p>

<p><em><a href="https://www.safaribooksonline.com/library/view/effective-python-59/9780134034416/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=10-top-python-resources-on-oreillys-online-learning-platform_body_link"><strong>Effective Python: 59 Specific Ways to Write Better Python</strong></a></em> — Brett Slatkin helps you master a truly “Pythonic” approach to programming, bringing together 59 Python best practices, tips, and shortcuts, and explaining them with realistic code examples.</p>

<p><em><a href="https://www.safaribooksonline.com/library/view/python-cookbook-3rd/9781449357337/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=10-top-python-resources-on-oreillys-online-learning-platform_body_link"><strong>Python Cookbook, 3rd Edition</strong></a></em> — Packed with practical recipes written and tested with Python 3.3, this unique cookbook by David Beazley and Brian K. Jones is for experienced Python programmers who want to focus on modern tools and idioms.</p>


        
                              <aside data-type="note">
  <p><a href="https://www.safaribooksonline.com/search/?query=python&extended_publisher_data=true&highlight=true&is_academic_institution_account=false&source=user&include_assessments=false&include_case_studies=true&include_courses=true&include_orioles=true&include_playlists=true&sort=relevance&utm_source=oreilly&utm_medium=newsite&utm_campaign=10-top-python-resources-on-oreillys-online-learning-platform_bottom_cta">Access the Python resources on our online learning platform and learn how to make Python work for you</a>.</p>
</aside>

          
        

                  <div class="image-credit">
  Article image: Binary
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://pixabay.com/en/digital-abstract-binary-code-1742687/">Pixabay</a>).
        
        
      </span>
    
    
</div>
        

                  <div class="article-tags">
Tags:
  <a href="https://www.oreilly.com/tags/resources">Resources</a>&nbsp;

</div>
        

      </div>

      <div class="article-meta">

  <div class="article-share">
  <div class="article-share-text"> Share </div>
  <ol>
    <li><a href="https://twitter.com/share" class="twitter-share-button" data-via="oreillymedia" data-show-count="false">Tweet</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></li>
    <li>  <div class="fb-share-button" 
    data-href="https://www.oreilly.com/ideas/10-top-python-resources-on-oreillys-online-learning-platform" 
    data-layout="button_count">
  </div></li>
    <li><script type="IN/Share" data-url="https://www.oreilly.com/ideas/10-top-python-resources-on-oreillys-online-learning-platform" data-counter="right"></script></li>
  </ol>
  <hr>
</div>

  

  

</div>


      <hr class="t-bkg section-divider" />


      <aside class="article-related">
      <section class="block-rows columns-4 ">

    

    <section class="block-group">
                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/learning/how-can-i-pass-parameters-to-a-command-in-c"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/how-can-i-pass-parameters-to-a-command-in-c-ce9584e25b982abeb33f7e93b9470655.png" alt="Screen from &#34;How can I pass parameters to a command in C#?&#34;" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/how-can-i-pass-parameters-to-a-command-in-c-ce9584e25b982abeb33f7e93b9470655.png 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/how-can-i-pass-parameters-to-a-command-in-c-ce9584e25b982abeb33f7e93b9470655.png 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/how-can-i-pass-parameters-to-a-command-in-c-ce9584e25b982abeb33f7e93b9470655.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-software-engineering--before">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/learning/how-can-i-pass-parameters-to-a-command-in-c">How can I pass parameters to a command in C#?</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/jeremy-mcpeak" itemprop="name">Jeremy McPeak</a></span>
</div>
    
          <p class="dek">Learn how to pass data to a command without violating the command pattern in C#.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/learning/how-do-i-use-the-singleton-pattern-in-c"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/how-do-i-use-the-singleton-pattern-in-c-d504563009d13d76dc6a5ceb74284746.png" alt="Screen from &#34;How do I use the singleton pattern in C#?&#34;" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/how-do-i-use-the-singleton-pattern-in-c-d504563009d13d76dc6a5ceb74284746.png 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/how-do-i-use-the-singleton-pattern-in-c-d504563009d13d76dc6a5ceb74284746.png 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/how-do-i-use-the-singleton-pattern-in-c-d504563009d13d76dc6a5ceb74284746.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-software-engineering--before">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/learning/how-do-i-use-the-singleton-pattern-in-c">How do I use the singleton pattern in C#?</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/jeremy-mcpeak" itemprop="name">Jeremy McPeak</a></span>
</div>
    
          <p class="dek">Learn how to create thread-safe instances with the singleton pattern in C#.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/learning/how-should-i-format-transact-sql-queries"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/how-should-i-format-rransact-sql-queries-0a9711bb48b88325ab1491bb83f2af74.png" alt="Screen from &#34;How should I format Transact-SQL queries?&#34;" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/how-should-i-format-rransact-sql-queries-0a9711bb48b88325ab1491bb83f2af74.png 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/how-should-i-format-rransact-sql-queries-0a9711bb48b88325ab1491bb83f2af74.png 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/how-should-i-format-rransact-sql-queries-0a9711bb48b88325ab1491bb83f2af74.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-software-engineering--before">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/learning/how-should-i-format-transact-sql-queries">How should I format Transact-SQL queries?</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/mark-long" itemprop="name">Mark Long</a></span>
</div>
    
          <p class="dek">Learn the formatting possibilities for Transact-SQL queries and develop your own code structure.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/learning/how-do-i-locate-data-in-my-sql-server-tables-using-sql-server-management-studio-diagrams"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/how-do-i-locate-data-4f650182c2104a7047fec7feb1d9e1ba.png" alt="Screen from &#34;How do I locate data in my SQL Server tables using SQL Server Management Studio diagrams?&#34;" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/how-do-i-locate-data-4f650182c2104a7047fec7feb1d9e1ba.png 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/how-do-i-locate-data-4f650182c2104a7047fec7feb1d9e1ba.png 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/how-do-i-locate-data-4f650182c2104a7047fec7feb1d9e1ba.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-software-engineering--before">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/learning/how-do-i-locate-data-in-my-sql-server-tables-using-sql-server-management-studio-diagrams">How do I locate data in my SQL Server tables using SQL Server Management Studio diagrams?</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/mark-long" itemprop="name">Mark Long</a></span>
</div>
    
          <p class="dek">Locate data quickly and easily with the SQL Server Management Studio diagram tool.</p>

    
    
  </div>
</article>

      
  	</section>
    

</section>
  
</aside>

  </article>
</main>








  <footer role="contentinfo">
  <div class="footer-inner">

    <div class="about-us">
      <h3 class="title">About Us</h3>
      <ul>
        <li><a href="http://oreilly.com/about/">Our Company</a></li>
        <li><a href="http://oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
        <li><a href="http://oreilly.com/careers/">Careers</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Contact Us</a></li>
      </ul>
    </div>
    <div class="site-map">
      <h3 class="title">Site Map</h3>
      <ul>
        <li><a href="/ideas">Ideas</a></li>
        <li><a href="/topics/oreilly-learning">Learning</a></li>
        <li><a href="/topics">Topics</a></li>
        <li><a href="/all">All</a></li>
      </ul>
    </div>
    <div class="social">
      <ul>
        <li><a   class="icon-link " href="https://www.facebook.com/OReilly/"><span class="icon icon-facebook t-fill icon--white icon--large">
  <svg role="img">
    <title>facebook</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#facebook"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://twitter.com/oreillymedia"><span class="icon icon-twitter t-fill icon--white icon--large">
  <svg role="img">
    <title>twitter</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#twitter"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.youtube.com/user/OreillyMedia"><span class="icon icon-youtube-large t-fill icon--white icon--large">
  <svg role="img">
    <title>youtube-large</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#youtube-large"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://plus.google.com/+oreillymedia"><span class="icon icon-google t-fill icon--white icon--large">
  <svg role="img">
    <title>google</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#google"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.linkedin.com/company/oreilly-media"><span class="icon icon-linkedin t-fill icon--white icon--large">
  <svg role="img">
    <title>linkedin</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#linkedin"></use>
  </svg>
</span></a>
</li>
      </ul>
    </div>
  </div>
  <div class="legal">
	  <a href="/" class="logo logo-block t-bkg logo--medium">
<svg>
   <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
</svg>
</a>
  	<p class="copyright">&copy; 2018 O'Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><br>
  <a class="t-c" href="http://oreilly.com/terms/">Terms of Service</a>  <span class="bullet">&bull;</span>	<a class="t-c" href="http://oreilly.com/privacy.html">Privacy Policy</a> <span class="bullet">&bull;</span> <a class="t-c" href="http://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a>
	</div>
	<figure class="animal"><img src="https://d3ebicv0uqgr7t.cloudfront.net/images/tarsier.png" class="animal-img" alt="Animal"></figure>
</footer>



  
  

    <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5P4V6Z"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
  

  
</body>
</html>
