<!DOCTYPE html>
<html lang="en">
<head>
  <title>Automated root cause analysis for Spark application failures - O&#39;Reilly Media</title>

  <!-- Meta -->
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
      <meta property="twitter:card" content="summary_large_image" />
      <meta property="twitter:site" content="@OReillyMedia" />
      <meta property="twitter:title" content="Automated root cause analysis for Spark application failures" />
      <meta property="twitter:description" content="Reduce troubleshooting time from days to seconds." />
      <meta property="description:site" content="Reduce troubleshooting time from days to seconds." />
      <meta property="twitter:url" content="https://www.oreilly.com/ideas/automated-root-cause-analysis-for-spark-application-failures" />
      <meta property="fb:pages" content="15137500430" />
      <meta property="og:type" content="article" />
      <meta property="og:site_name" content="O&#39;Reilly Media" />
      <meta property="og:title" content="Automated root cause analysis for Spark application failures" />
      <meta property="og:description" content="Reduce troubleshooting time from days to seconds." />
      <meta property="og:url" content="https://www.oreilly.com/ideas/automated-root-cause-analysis-for-spark-application-failures" />
      <meta property="article:published_time" content="2017-11-07T12:00:00Z" />
      <meta property="article:author" content="Adrian Popescu" />
      <meta property="article:author" content="Shivnath Babu" />
      <meta name="description" content="Reduce troubleshooting time from days to seconds." />
      <meta name="author" content="Adrian Popescu, Shivnath Babu" />
      <meta name="date" content="2017-11-07" />
      <meta property="og:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/spiral-1007770_1920_crop-fbac6113c4d6ca6418dc08d53ad8daf1.jpg" />
      <meta property="twitter:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/spiral-1007770_1920_crop-fbac6113c4d6ca6418dc08d53ad8daf1.jpg" />
      <meta name="thumbnail" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/spiral-1007770_1920_crop-fbac6113c4d6ca6418dc08d53ad8daf1.jpg" />
      <meta name="graphic_medium" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/spiral-1007770_1920_crop-fbac6113c4d6ca6418dc08d53ad8daf1.jpg" />
      <meta name="oreilly:topic" content="Data science" />
      <meta name="oreilly:parent_topic" content="Data" />
      <meta name="oreilly:keywords" content="data,big data,data analysis,spark,spark failure,troubleshooting,root cause analysis" />
  
  

  <!-- Assets -->
  <script type="text/javascript" src="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-bb2079ffdc.js"></script>
  <link rel="stylesheet" type="text/css" href="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-1e80a7b592.css">
    
  
  <!-- Extra Assets -->
  
  
  

  <script type="text/javascript">
    dataLayer = [];
  </script>

    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5P4V6Z');</script>
  <!-- End Google Tag Manager -->
  

  <!-- Start Adobe Digital Tag Manager Header-->
    <script src="//assets.adobedtm.com/cdb881fdfcc417bad9035bdbc61f4a2b2135b110/satelliteLib-2d3d7e7aff56a08b02334ccd859df32171807210.js"></script>
  

  <!-- End Adobe Digital Tag Manager Header-->

  <script type="text/javascript">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</script>

  <!-- Start Visual Website Optimizer Asynchronous Code -->
  <script type='text/javascript'>
    var _vwo_code=(function(){
    var account_id=244658,
    settings_tolerance=2000,
    library_tolerance=2500,
    use_existing_jquery=false,
  // DO NOT EDIT BELOW THIS LINE
  f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
  </script>
  <!-- End Visual Website Optimizer Asynchronous Code -->

</head>
<body class="body t-data" data-section="ideas" >
  <div class="flashes"></div>
    <header id="page-header">
  <div id="header-bar" class="t-bkg">
    <h1 class="logo t-bkg" >
  <a href="/" class=" logo-white ">
  <svg role="heading" aria-label="O'Reilly">
    <title>O'Reilly</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
  </svg>
  </a>
</h1>
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>


    <div class="right invert">
      <div id="search" class="hide">
        <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
      </div>
      <div id="user">
        <!-- <a href="#feedback"  class="t-c--d feedback" id="feedback">Feedback</a> -->
        <a class="t-c--d login" id="log-in-loading">Loading...</a>
        <a href="?log-in" class="t-c--d login" id="log-in">Log in</a>
        <a href="?log-out" class="t-c--d capture_end_session login" id="log-out">Log out</a>
        <a href="/user/preferences"  class="t-c--d login" id="preferences"><span class="icon icon-configure icon--small t-fill ">
  <svg role="img">
    <title>configure</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#configure"></use>
  </svg>
</span></a>
      </div>
    </div>
    <a id="menu-toggle" class="invert" ><span class="icon icon-white icon-menu">
  <svg role="img" id="close" class="is-hidden">
    <title>Close Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#close"></use>
  </svg>
  <svg role="img" id="open">
    <title>Open Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#menu"></use>
  </svg>
</span></a>
  </div>
     <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

  
  <div id="mobile-menu">

    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
         <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

    
  </div>

</header>



  <!-- Linked In -->
  <script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
  
<!-- Load Facebook SDK for JavaScript -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<main aria-live="polite">
  <article class="article" itemscope itemtype="http://schema.org/Article">
              <header class="article-header">
        <div class="flag-follow " data-status="" id="">
      <div class="flag t-bkg--before bg-data--before flag--small">
  
            <a href="/topics/data-science" >Data science</a>
    
    
  
</div>
  
  <span class="cta">
    <span class="icons">
      
      
    </span>
    <span class="messages">
      
      
    </span>
</span>
</div>

  
  

  

  <h1 class="title t-c" itemprop="headline">Automated root cause analysis for Spark application failures</h1>

      <p class="dek" itemprop="alternativeHeadline">Reduce troubleshooting time from days to seconds.</p>
  

  <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/d2af2-adrian-popescu" itemprop="name">Adrian Popescu</a></span><span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/b0c79-shivnath-babu" itemprop="name">Shivnath Babu</a></span>
</div> <time class="date">November 7, 2017</time>

</header>

      

      <div class="article-body" itemprop="articleBody">
        
                              <figure class="article-image right">
  <img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/spiral-1007770_1920_crop-fbac6113c4d6ca6418dc08d53ad8daf1.jpg" alt="Spiral stone relief" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/spiral-1007770_1920_crop-fbac6113c4d6ca6418dc08d53ad8daf1.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/spiral-1007770_1920_crop-fbac6113c4d6ca6418dc08d53ad8daf1.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/spiral-1007770_1920_crop-fbac6113c4d6ca6418dc08d53ad8daf1.jpg 1440w" sizes="(min-width: 1390px) 420px, (min-width: 600px) 45vw, 100vw" class=""/>
  <figcaption>Spiral stone relief
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://pixabay.com/en/spiral-carved-stone-church-relief-1007770/">Pixabay</a>)
        
        
      </span>
    
    
  <figcaption>

</figure>
          
                      <aside data-type="note">
  <p>To learn how to use analytic tools to manage your big data infrastructure, check out Shivnath Babu's session "<a href="https://conferences.oreilly.com/strata/strata-ca/public/schedule/detail/64115?intcmp=il-data-confreg-lp-stca18_20171101_new_site_automated_root_cause_analysis)_for_spark_application_failures_post_top_cta_session_link">Using Machine Learning to Simplify Kafka Operations</a>" at the Strata Data Conference in San Jose, March 5-8, 2018&mdash;<a href="https://conferences.oreilly.com/strata/strata-ca/public/register?intcmp=il-data-confreg-lp-stca18_20171101_new_site_automated_root_cause_analysis)_for_spark_application_failures_post_top_cta_reg_link">registration is now open</a>.</p>
</aside>

          
        

        

        <p>Spark’s simple programming constructs and powerful execution engine have brought a diverse set of users to its platform. Many new big data applications are being built with Spark in fields like health care, genomics, financial services, self-driving technology, government, and media. Things are not so rosy, however, when a Spark application fails.</p>



<p>Similar to applications in other distributed systems that have a large number of independent and interacting components, a failed Spark application throws up a large set of raw logs. These logs typically contain thousands of messages, including errors and stacktraces. Hunting for the root cause of an application failure from these messy, raw, and distributed logs <a href="https://www.safaribooksonline.com/library/view/strata-hadoop/9781491976166/video302427.html">is hard for Spark experts</a>—and a nightmare for the thousands of new users coming to the Spark platform. We aim to radically simplify root cause detection of any Spark application failure by automatically providing insights to Spark users like what is shown in Figure 1.</p>


<figure class="center" id="id-6YOix"><img alt="Insights from automatic root cause analysis improve Spark user productivity" src="https://d3ansictanv2wj.cloudfront.net/Figure1-large-2-63eea0099f2c7452dc23b8478c45f46d.jpg"><figcaption><span class="label">Figure 1. </span>Insights from automatic root cause analysis improve Spark user productivity. Source: Adrian Popescu and Shivnath Babu.</figcaption></figure>


<p id="F1">Spark platform providers like <a href="http://docs.aws.amazon.com/emr/latest/ReleaseGuide/emr-spark.html">Amazon</a>, <a href="https://azure.microsoft.com/en-us/services/hdinsight/apache-spark/">Azure</a>, <a href="https://databricks.com/">Databricks</a>, and <a href="https://cloud.google.com/dataproc/">Google</a> clouds as well as application performance management (APM) solution providers like <a href="http://unraveldata.com/">Unravel</a> have access to a large and growing data set of logs from millions of Spark application failures. This data set is a gold mine for applying state-of-the-art artificial intelligence (AI) and machine learning (ML) techniques. In this blog, we look at how to <a href="https://users.cs.duke.edu/~shivnath/papers/fa_icde09.pdf">automate the process of failure diagnosis</a> by building predictive models that continuously learn from logs of past application failures for which the respective root causes have been identified. These models can then automatically predict the root cause when an application fails<a href="#_ftn1"><sup>[1]</sup></a>. Such actionable root-cause identification improves the productivity of Spark users significantly.</p>



<h2>Clues in the logs</h2>



<p>A number of logs are available every time a Spark application fails. A distributed Spark application consists of a driver container and one or more executor containers. The logs generated by these containers have information about the application as well as how the application interacts with the rest of the Spark platform. These logs form the key data set that Spark users scan for clues to understand why an application failed.</p>



<p>However, the logs are <a href="https://www.safaribooksonline.com/library/view/strata-hadoop/9781491976166/video302427.html">extremely verbose and messy</a>. They contain multiple types of messages, such as informational messages from every component of Spark, error messages in many different formats, stacktraces from code running on the Java Virtual Machine (JVM), and more. The complexity of Spark usage and internals make things worse. Types of failures and error messages differ across Spark SQL, Spark Streaming, iterative machine learning and graph applications, and interactive applications from Spark shell and notebooks (e.g., Jupyter, Zeppelin). Furthermore, failures in distributed systems routinely propagate from one component to another. Such propagation can cause a flood of error messages in the log and obscure the root cause.</p>



<p>Figure 2 shows our overall solution to deal with these problems and to automate root cause analysis (RCA) for Spark application failures. Overall, the solution consists of:</p>

<ul>
	<li>Continuously collecting logs from a variety of Spark application failures</li>
	<li>Converting logs into feature vectors</li>
	<li>Learning a predictive model for RCA from these feature vectors</li>
</ul>

<p>Of course, as with any intelligent solution that uses AI and ML techniques, the devil is the details!</p>

<figure class="center" id="id-RBQi8"><img alt="root cause analysis of Spark application failures" src="https://d3ansictanv2wj.cloudfront.net/Figure2-large-969a1f1059ce5c839e5239acf8654e3b.jpg"><figcaption><span class="label">Figure 2. </span>Root cause analysis of Spark application failures. Source: Adrian Popescu and Shivnath Babu.</figcaption></figure>

<h3>Data collection for training</h3>

<p>As the saying goes: garbage in, garbage out. Thus, it is critical to train RCA models on representative input data. In addition to relying on logs from real-life Spark application failures observed on customer sites, we have also invested in a lab framework where root causes can be artificially injected to collect even larger and more diverse training data.</p>



<h3>Structured versus unstructured data</h3>

<p>Logs are mostly unstructured data. To keep the accuracy of model predictions to a high level in automated RCA, it is important to combine this unstructured data with some structured data. Thus, whenever we collect logs, we are careful to collect trustworthy structured data in the form of key-value pairs that we additionally use as input features in the predictive models. These include Spark platform information and environment details of Scala, Hadoop, OS, and so on.</p>



<h3>Labels</h3>

<p>ML techniques for prediction fall into two broad categories: supervised learning and unsupervised learning. We use both techniques in our overall solution. For the supervised learning part, we attach root-cause labels with the logs collected from an application failure. This label comes from a taxonomy of root causes that we have created based on millions of Spark application failures seen in the field and in our lab. Broadly speaking, the taxonomy can be thought of as a tree data structure that categorizes the full space of root causes. For example, the first non-root level of this tree can be failures caused by:</p>

<ul>
	<li>Configuration errors</li>
	<li>Deployment errors</li>
	<li>Resource errors</li>
	<li>Data errors</li>
	<li>Application errors</li>
	<li>Unknown factors</li>
</ul>

<p>The leaves of this taxonomy tree form the labels used in the supervised learning techniques. In addition to a text label representing the root cause, each leaf also stores additional information such as: (a) a description template to present the root cause to a Spark user in a way that she will easily understand (like the message in Figure 1), and (b) recommended fixes for this root cause. We will cover the root-cause taxonomy in a future <a href="http://unraveldata.com/blog/">blog</a>.</p>



<p>The labels are associated with the logs in one of two ways. First, the root cause is already known when the logs are generated, as a result of injecting a specific root cause we have designed to produce an application failure in our lab framework. The second way in which a label is given to the logs for an application failure is when a Spark domain expert manually diagnoses the root cause of the failure.</p>



<h3>Input Features</h3>

<p>Once the logs are available, there are various ways in which the feature vector can be extracted from these logs. One way is to transform the logs into a bit vector (e.g., 1001100001). Each bit in this vector represents whether a <a href="https://gab41.lab41.org/three-things-we-learned-about-applying-word-vectors-to-computer-logs-c199070f390b">specific message template is present in the respective logs</a>. A prerequisite to this approach is to extract all possible message templates from the logs. A more traditional approach for feature vectors from the domain of information retrieval is to represent the logs for a failure as a <a href="https://en.wikipedia.org/wiki/Bag-of-words_model">bag of words</a>. This approach is mostly similar to the bit vector approach except for a couple of differences: (a) each bit in the vector now corresponds to a word instead of a message template, and (b) instead of 0s and 1s, it is more common to use numeric values generated using techniques like <a href="https://en.wikipedia.org/wiki/Tf%E2%80%93idf">TF-IDF</a>.</p>



<p id="F2">More recent advances in ML have popularized <a href="https://nlp.stanford.edu/projects/glove/">vector embeddings</a>. In particular, we use the <a href="https://arxiv.org/abs/1405.4053">doc2vec</a> technique<a href="#_ftn2"><sup>[2]</sup></a>. At a high level, these vector embeddings map words (or paragraphs, or entire documents) to multidimensional vectors by evaluating the order and placement of words with respect to their neighboring words. Similar words map to nearby vectors in the feature vector space. The doc2vec technique uses a three-layer neural network to gauge the context of the document and relate similar content together.</p>



<p>Once the feature vectors are generated along with the label, a variety of supervised learning techniques can be applied for automatic RCA. We have evaluated both shallow as well as deep learning techniques, including random forests, support vector machines, Bayesian classifiers, and neural networks.</p>



<h2>Conclusion</h2>



<p id="F3">The overall results produced by our solution are very promising. We are currently enhancing the solution in some key ways. One of these is to quantify the degree of confidence in the root cause predicted by the model in a way that users will easily understand. Another key enhancement is to speed up the ability to incorporate new types of application failures. The bottleneck currently is in generating labels. We are working on <a href="https://users.cs.duke.edu/~shivnath/papers/icac08.pdf">active learning techniques</a><a href="#_ftn3"><sup>[3]</sup></a> that nicely <a href="https://github.com/stanford-futuredata/macrobase">prioritize the human efforts</a> required in generating labels. The intuition behind active learning is to pick the unlabeled failure instances that provide the most useful information to build an accurate model. The expert labels these instances and then the predictive model is rebuilt.</p>



<p>Manual failure diagnosis in Spark is not only time consuming, but <a href="https://www.safaribooksonline.com/library/view/strata-hadoop/9781491976166/video302427.html">highly challenging</a> due to correlated failures that can occur simultaneously. Our unique RCA solution enables the diagnosis process to function effectively even in the presence of multiple concurrent failures as well as noisy data prevalent in production environments. Through automated failure diagnosis, we remove the burden of manually troubleshooting failed applications from the hands of Spark users and developers, enabling them to focus entirely on solving business problems with Spark.</p>


<aside data-type="sidebar" id="id-RNaSZ">
<p><strong>References:</strong></p>

<div id="_ftn1">
<p><a href="#_ftn1"><sup>[1]</sup></a> S. Duan, S. Babu, and K. Munagala, “<a href="https://users.cs.duke.edu/~shivnath/papers/fa_icde09.pdf">Fa: A System for Automating Failure Diagnosis</a>”, International Conference on Data Engineering, 2009. <a href="#F1">(Return)</a></p>
</div>

<div id="_ftn2">
<p><a href="#_ftn2"><sup>[2]</sup></a> Q. Lee and T. Mikolov, “<a href="https://arxiv.org/abs/1405.4053">Distributed Representations of Sentences and Documents</a>”, International Conference on Machine Learning, 2014 <a href="#F2">(Return)</a></p>
</div>

<div id="_ftn3">
<p><a href="#_ftn3"><sup>[3]</sup></a> S. Duan and S. Babu, "<a href="https://users.cs.duke.edu/~shivnath/papers/icac08.pdf">Guided Problem Diagnosis through Active Learning</a>", International Conference on Autonomic Computing, 2008 <a href="#F3">(Return)</a></p>
</div>
</aside>

<p><em>To learn how to use analytic tools to manage your big data infrastructure, check out Shivnath Babu's session "<a href="https://conferences.oreilly.com/strata/strata-ca/public/schedule/detail/64115?intcmp=il-data-confreg-lp-stca18_20171101_new_site_automated_root_cause_analysis)_for_spark_application_failures_post_end_cta_session_link">Using Machine Learning to Simplify Kafka Operations</a>" at the Strata Data Conference in San Jose, March 5-8, 2018—<a href="https://conferences.oreilly.com/strata/strata-ca/public/register?intcmp=il-data-confreg-lp-stca18_20171101_new_site_automated_root_cause_analysis)_for_spark_application_failures_post_end_cta_reg_link">registration is now open</a>.</em></p>


<p><strong>Related resource:</strong></p>

<p><em><a href="https://www.safaribooksonline.com/library/view/spark-the-definitive/9781491912201/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=20171101_automated_root_cause_analysis_for_spark_application_failures_related_resource_book_link">Spark: The Definitive Guide</a></em>, by Bill Chambers and Matei Zaharia</p>




        
                  
        

                  <div class="image-credit">
  Article image: Spiral stone relief
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://pixabay.com/en/spiral-carved-stone-church-relief-1007770/">Pixabay</a>).
        
        
      </span>
    
    
</div>
        

        

      </div>

      <div class="article-meta">

  <div class="article-share">
  <div class="article-share-text"> Share </div>
  <ol>
    <li><a href="https://twitter.com/share" class="twitter-share-button" data-via="oreillymedia" data-show-count="false">Tweet</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></li>
    <li>  <div class="fb-share-button" 
    data-href="https://www.oreilly.com/ideas/automated-root-cause-analysis-for-spark-application-failures" 
    data-layout="button_count">
  </div></li>
    <li><script type="IN/Share" data-url="https://www.oreilly.com/ideas/automated-root-cause-analysis-for-spark-application-failures" data-counter="right"></script></li>
  </ol>
  <hr>
</div>

  

      <article class="block block-common person with-link">
  

  

  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/people/d2af2-adrian-popescu">Adrian Popescu</a>
    
    
    </h2>
    

    
          <p class="dek">Adrian Popescu is a data engineer at Unravel Data Systems working on performance profiling and optimization of Spark applications. He has more than eight years of experience building and profiling data management applications. He holds a PhD in computer science from EPFL, a master of applied science from the University of Toronto, and a bachelor of science from University Politehnica, Bucharest. His PhD thesis focused on modeling the runtime performance of a class of analytical workloads that include iterative tasks executing on in-memory graph...</p>

    
          <a class="btn btn--xsmall" style="float: right;" href="/people/d2af2-adrian-popescu">more</a>
    
  </div>
</article>

      <article class="block block-common person with-link">
  

  

  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/people/b0c79-shivnath-babu">Shivnath Babu</a>
    
    
    </h2>
    

    
          <p class="dek">Shivnath Babu is the CTO at Unravel Data Systems and an adjunct professor of computer science at Duke University. His research focuses on ease-of-use and manageability of data-intensive systems, automated problem diagnosis, and cluster sizing for applications running on cloud platforms. Shivnath cofounded Unravel to solve the application management challenges that companies face when they adopt systems like Hadoop and Spark. Unravel originated from the Starfish platform built at Duke, which has been downloaded by more than 100 companies. Shivna...</p>

    
          <a class="btn btn--xsmall" style="float: right;" href="/people/b0c79-shivnath-babu">more</a>
    
  </div>
</article>

  

</div>


      <hr class="t-bkg section-divider" />


      <aside class="article-related">
      <section class="block-rows columns-4 ">

    

    <section class="block-group">
                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/how-intelligent-data-platforms-are-powering-smart-cities"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/marina_bay_and_the_singapore_skyline_at_dusk_-_20110311-be0e3734d4b48afd99e42cdd89e4157a.jpg" alt="Marina Bay and the skyline of the Central Business District of Singapore at dusk, by William Cho." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/marina_bay_and_the_singapore_skyline_at_dusk_-_20110311-be0e3734d4b48afd99e42cdd89e4157a.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/marina_bay_and_the_singapore_skyline_at_dusk_-_20110311-be0e3734d4b48afd99e42cdd89e4157a.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/marina_bay_and_the_singapore_skyline_at_dusk_-_20110311-be0e3734d4b48afd99e42cdd89e4157a.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-data--before">
  
            <a href="/topics/data-science" >Data science</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/how-intelligent-data-platforms-are-powering-smart-cities">How intelligent data platforms are powering smart cities</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/4e7ad-ben-lorica" itemprop="name">Ben Lorica</a></span>
</div>
    
          <p class="dek">Smart cities and smart nations run on data.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/beyond-algorithms-optimizing-the-search-experience"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/card_puncher_-_nara_-_513295-17a33e71f1a0f5d83ce3fd9b064d1f0b.jpg" alt="A woman posed with a Hollerith pantograph: the keyboard is for the 1920 population card, and a 1940 census form." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/card_puncher_-_nara_-_513295-17a33e71f1a0f5d83ce3fd9b064d1f0b.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/card_puncher_-_nara_-_513295-17a33e71f1a0f5d83ce3fd9b064d1f0b.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/card_puncher_-_nara_-_513295-17a33e71f1a0f5d83ce3fd9b064d1f0b.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-data--before">
  
            <a href="/topics/data-science" >Data science</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/beyond-algorithms-optimizing-the-search-experience">Beyond algorithms: Optimizing the search experience</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/e9a1c-daniel-tunkelang" itemprop="name">Daniel Tunkelang</a></span>
</div>
    
          <p class="dek">Making search smarter through better human-computer interaction.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Runnable code</span>
        <span class="icon icon-code t-fill">
  <svg role="img">
    <title>code</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#code"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/learning/introducing-pandas-objects"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/pandas_objects-95b49105fb69c49cb1c7a119d6e897c5.png" alt="Pandas table" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/pandas_objects-95b49105fb69c49cb1c7a119d6e897c5.png 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/pandas_objects-95b49105fb69c49cb1c7a119d6e897c5.png 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/pandas_objects-95b49105fb69c49cb1c7a119d6e897c5.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-data--before">
  
            <a href="/topics/data-science" >Data science</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/learning/introducing-pandas-objects">Introducing Pandas Objects</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/89c9c-jake-vanderplas" itemprop="name">Jake VanderPlas</a></span>
</div>
    
          <p class="dek">Python Data Science Handbook: Early Release</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/the-machine-learning-paradox"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/impossibletriangleeastperth_edit_gobeirne_crop-eaa19599485d1444ddf98eed00443afb.jpg" alt="&#34;Impossible Triangle,&#34; sculpture by Brian MacKay and Ahmad Abas, Claisebrook roundabout, East Perth, Western Australia." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/impossibletriangleeastperth_edit_gobeirne_crop-eaa19599485d1444ddf98eed00443afb.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/impossibletriangleeastperth_edit_gobeirne_crop-eaa19599485d1444ddf98eed00443afb.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/impossibletriangleeastperth_edit_gobeirne_crop-eaa19599485d1444ddf98eed00443afb.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-data--before">
  
            <a href="/topics/data-science" >Data science</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/the-machine-learning-paradox">The machine learning paradox</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1b7da-mike-loukides" itemprop="name">Mike Loukides</a></span>
</div>
    
          <p class="dek">Nothing says machine learning can't outperform humans, but it's important to realize perfect machine learning doesn't, and won't, exist.</p>

    
    
  </div>
</article>

      
  	</section>
    

</section>
  
</aside>

  </article>
</main>








  <footer role="contentinfo">
  <div class="footer-inner">

    <div class="about-us">
      <h3 class="title">About Us</h3>
      <ul>
        <li><a href="http://oreilly.com/about/">Our Company</a></li>
        <li><a href="http://oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
        <li><a href="http://oreilly.com/careers/">Careers</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Contact Us</a></li>
      </ul>
    </div>
    <div class="site-map">
      <h3 class="title">Site Map</h3>
      <ul>
        <li><a href="/ideas">Ideas</a></li>
        <li><a href="/learning">Learning</a></li>
        <li><a href="/topics">Topics</a></li>
        <li><a href="/all">All</a></li>
      </ul>
    </div>
    <div class="social">
      <ul>
        <li><a   class="icon-link " href="http://fb.co/OReilly"><span class="icon icon-facebook t-fill icon--white icon--large">
  <svg role="img">
    <title>facebook</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#facebook"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="http://twitter.com/oreillymedia"><span class="icon icon-twitter t-fill icon--white icon--large">
  <svg role="img">
    <title>twitter</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#twitter"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.youtube.com/user/OreillyMedia"><span class="icon icon-youtube-large t-fill icon--white icon--large">
  <svg role="img">
    <title>youtube-large</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#youtube-large"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://plus.google.com/+oreillymedia"><span class="icon icon-google t-fill icon--white icon--large">
  <svg role="img">
    <title>google</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#google"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.linkedin.com/company/oreilly-media"><span class="icon icon-linkedin t-fill icon--white icon--large">
  <svg role="img">
    <title>linkedin</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#linkedin"></use>
  </svg>
</span></a>
</li>
      </ul>
    </div>
  </div>
  <div class="legal">
	  <a href="/" class="logo logo-block t-bkg logo--medium">
<svg>
   <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
</svg>
</a>
  	<p class="copyright">&copy; 2017 O'Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><br>
  <a class="t-c" href="http://oreilly.com/terms/">Terms of Service</a>  <span class="bullet">&bull;</span>	<a class="t-c" href="http://oreilly.com/privacy.html">Privacy Policy</a> <span class="bullet">&bull;</span> <a class="t-c" href="http://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a>
	</div>
	<figure class="animal"><img src="https://d3ebicv0uqgr7t.cloudfront.net/images/tarsier.png" class="animal-img" alt="Animal"></figure>
</footer>



  
  

    <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5P4V6Z"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
  

    <!-- Start Adobe Digital Tag Manager -->
  <script type="text/javascript">_satellite && _satellite.pageBottom();</script>
  <!-- End Adobe Digital Tag Manager -->
  
</body>
</html>
