<!DOCTYPE html>
<html lang="en">
<head>
  <title>Damon Feldman on combining a data hub and data lake - O&#39;Reilly Media</title>

  <!-- Meta -->
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
      <meta property="twitter:card" content="summary_large_image" />
      <meta property="twitter:site" content="@OReillyMedia" />
      <meta property="twitter:title" content="Damon Feldman on combining a data hub and data lake" />
      <meta property="twitter:description" content="The O’Reilly Podcast: Achieving greater reliability and security when integrating data." />
      <meta property="description:site" content="The O’Reilly Podcast: Achieving greater reliability and security when integrating data." />
      <meta property="twitter:url" content="https://www.oreilly.com/ideas/damon-feldman-on-combining-a-data-hub-and-data-lake" />
      <meta property="fb:pages" content="15137500430" />
      <meta property="og:type" content="article" />
      <meta property="og:site_name" content="O&#39;Reilly Media" />
      <meta property="og:title" content="Damon Feldman on combining a data hub and data lake" />
      <meta property="og:description" content="The O’Reilly Podcast: Achieving greater reliability and security when integrating data." />
      <meta property="og:url" content="https://www.oreilly.com/ideas/damon-feldman-on-combining-a-data-hub-and-data-lake" />
      <meta property="article:published_time" content="2017-10-12T11:10:00Z" />
      <meta property="article:author" content="Jeff Bleiel" />
      <meta name="description" content="The O’Reilly Podcast: Achieving greater reliability and security when integrating data." />
      <meta name="author" content="Jeff Bleiel" />
      <meta name="date" content="2017-10-12" />
      <meta property="og:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/water-funnel-164713_crop-3584991ac95e44360898545435c88ead.jpg" />
      <meta property="twitter:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/water-funnel-164713_crop-3584991ac95e44360898545435c88ead.jpg" />
      <meta name="thumbnail" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/water-funnel-164713_crop-3584991ac95e44360898545435c88ead.jpg" />
      <meta name="graphic_medium" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/water-funnel-164713_crop-3584991ac95e44360898545435c88ead.jpg" />
      <meta name="oreilly:topic" content="Data science" />
      <meta name="oreilly:parent_topic" content="Data" />
      <meta name="oreilly:keywords" content="data,big data,data lake,data security,data hub,integrating data" />
  
  

  <!-- Assets -->
  <script type="text/javascript" src="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-bb2079ffdc.js"></script>
  <link rel="stylesheet" type="text/css" href="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-9342c1e387.css">
    
  
  <!-- Extra Assets -->
  
  
  


  <!-- Start Adobe Digital Tag Manager Header-->
  <script type="text/javascript">
    dataLayer = [];
  </script>

    <script src="//assets.adobedtm.com/cdb881fdfcc417bad9035bdbc61f4a2b2135b110/satelliteLib-2d3d7e7aff56a08b02334ccd859df32171807210.js"></script>
  

  <!-- End Adobe Digital Tag Manager Header-->

  <script type="text/javascript">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</script>

  <!-- Start Visual Website Optimizer Asynchronous Code -->
  <script type='text/javascript'>
    var _vwo_code=(function(){
    var account_id=244658,
    settings_tolerance=2000,
    library_tolerance=2500,
    use_existing_jquery=false,
  // DO NOT EDIT BELOW THIS LINE
  f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
  </script>
  <!-- End Visual Website Optimizer Asynchronous Code -->

</head>
<body class="body t-data" data-section="ideas" >
  <div class="flashes"></div>
    <header id="page-header">
  <div id="header-bar" class="t-bkg">
    <h1 class="logo t-bkg" >
  <a href="/" class=" logo-white ">
  <svg role="heading" aria-label="O'Reilly">
    <title>O'Reilly</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
  </svg>
  </a>
</h1>
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>


    <div class="right invert">
      <div id="search" class="hide">
        <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
      </div>
      <div id="user">
        <!-- <a href="#feedback"  class="t-c--d feedback" id="feedback">Feedback</a> -->
        <a class="t-c--d login" id="log-in-loading">Loading...</a>
        <a href="?log-in" class="t-c--d login" id="log-in">Log in</a>
        <a href="?log-out" class="t-c--d capture_end_session login" id="log-out">Log out</a>
        <a href="/user/preferences"  class="t-c--d login" id="preferences"><span class="icon icon-configure icon--small t-fill ">
  <svg role="img">
    <title>configure</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#configure"></use>
  </svg>
</span></a>
      </div>
    </div>
    <a id="menu-toggle" class="invert" ><span class="icon icon-white icon-menu">
  <svg role="img" id="close" class="is-hidden">
    <title>Close Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#close"></use>
  </svg>
  <svg role="img" id="open">
    <title>Open Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#menu"></use>
  </svg>
</span></a>
  </div>
     <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

  
  <div id="mobile-menu">

    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
         <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

    
  </div>

</header>



  <!-- Linked In -->
  <script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
  
<!-- Load Facebook SDK for JavaScript -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<main aria-live="polite">
  <article class="article" itemscope itemtype="http://schema.org/Article">
              <header class="article-header">
        <div class="flag-follow " data-status="" id="">
      <div class="flag t-bkg--before bg-data--before flag--small">
  
            <a href="/topics/data-science" >Data science</a>
    
    
  
</div>
  
  <span class="cta">
    <span class="icons">
      
      
    </span>
    <span class="messages">
      
      
    </span>
</span>
</div>

  
  

  

  <h1 class="title t-c" itemprop="headline">Damon Feldman on combining a data hub and data lake</h1>

      <p class="dek" itemprop="alternativeHeadline">The O’Reilly Podcast: Achieving greater reliability and security when integrating data.</p>
  

  <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/jeff-bleiel" itemprop="name">Jeff Bleiel</a></span>
</div> <time class="date">October 12, 2017</time>

</header>

      

      <div class="article-body" itemprop="articleBody">
        
                              <figure class="article-image right">
  <img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/water-funnel-164713_crop-3584991ac95e44360898545435c88ead.jpg" alt="Vortex" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/water-funnel-164713_crop-3584991ac95e44360898545435c88ead.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/water-funnel-164713_crop-3584991ac95e44360898545435c88ead.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/water-funnel-164713_crop-3584991ac95e44360898545435c88ead.jpg 1440w" sizes="(min-width: 1390px) 420px, (min-width: 600px) 45vw, 100vw" class=""/>
  <figcaption>Vortex
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://pixabay.com/en/water-funnel-whirl-swirl-vortex-164713/">Pixabay</a>)
        
        
      </span>
    
    
  <figcaption>

</figure>
          
                      <aside data-type="note">
  <p>Register for the webcast "<a href="http://www.oreilly.com/pub/e/3913?intcmp=il-data-webcast-lp-webcast_20171011_new_site_oreilly_podcast_damon_feldman_top_cta_webcast_link">How to make your data lake more effective with an operational data hub</a>," presented by Damon Feldman on November 2, 2017.</p>
</aside>

          
        

        

        <p>In this podcast episode, O’Reilly’s Shannon Cutt talks with <a href="http://www.marklogic.com/blog/author/dfeldman/">Damon Feldman</a>, solutions director at MarkLogic, a company that has developed an operational and transactional NoSQL database that integrates data silos to give customers a single view of their data. They discuss data lakes, data hubs, integrating data in a lake format, data governance related to security, and more.</p>


<iframe src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/346407869&amp;auto_play=false&amp;hide_related=false&amp;show_artwork=true" height="166" width="100%" frameborder="no" scrolling="no"></iframe>

<p>Here are some highlights from the conversation:</p>



<h2>Why data lakes can easily turn into data swamps</h2>

<blockquote><p>The core or the underlying foundation of these lakes is the Hadoop distributed file system; it really is a big file system just like a file system on our laptops or home computers. You can put anything there, and make as many copies, and name it wrong, and lose track of it, and not know who put it there. There's not inherently a lot of governance to it. That flexibility is a little bit like the flexibility of the web and HTML. Anybody can throw up any kind of crazy web page and you can't necessarily tell what information in it is accurate. So, that flexibility does lead, in some cases, to chaos.</p></blockquote>



<h2>How a data hub can help clear up a data lake</h2>

<blockquote><p>A data hub is an extension of the data lake pattern. The primary thing that characterizes the data lake is that you’re moving data into one area. When you move data to one place, you gain a huge amount of power in your ability to access and control the data. The data analytics reporting and downstream uses of that can become much easier because you can access the data any time you want. A data hub goes beyond moving the data. It starts to organize, harmonize, add a little common structure, and secure the data.</p></blockquote>



<h2>Tracking and governing data</h2>

<blockquote><p>As you copy data around, whether you're doing it through a well-defined pipeline like an ETL or data processing pipeline or if you're doing it in a more ad hoc way, it’s important to keep track of the original version of the data—which all data lakes are pretty good at. Data lakes are very flexible, and they have the ability to take in an as-is copy of data that originated somewhere else and keep it in its native form.</p></blockquote>



<h2>How the cloud works with data lakes and data hubs</h2>

<blockquote><p>Historically, data lakes, coming from the Hadoop world, have an ability to run on physical hardware in an inexpensive way. However, cloud has become so powerful and so convenient to stand up large groups of servers, that all of the data lake and Hadoop vendors are now able to run on the cloud, even though you lose some of that cost benefit of cheap discs. It's not a huge difference in terms of setting up and running the systems. The main advantage and the difference is when you want to do fast elasticity. Other than that, it's not a huge difference how you run on the cloud or a physical hard drive.</p></blockquote>





<p><em>This post and podcast is a collaboration between O’Reilly and MarkLogic. </em><a href="http://www.oreilly.com/about/editorial_independence.html"><em>See our statement of editorial independence</em></a><em>.</em></p>

        
        
                  
        

                      <div class="image-credit">
  Article image: Vortex
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://pixabay.com/en/water-funnel-whirl-swirl-vortex-164713/">Pixabay</a>).
        
        
      </span>
    
    
</div>
          

          

        </div>
      </div>

        <div class="article-meta">

  <div class="article-share">
  <div class="article-share-text"> Share </div>
  <ol>
    <li><a href="https://twitter.com/share" class="twitter-share-button" data-via="oreillymedia" data-show-count="false">Tweet</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></li>
    <li>  <div class="fb-share-button" 
    data-href="https://www.oreilly.com/ideas/damon-feldman-on-combining-a-data-hub-and-data-lake" 
    data-layout="button_count">
  </div></li>
    <li><script type="IN/Share" data-url="https://www.oreilly.com/ideas/damon-feldman-on-combining-a-data-hub-and-data-lake" data-counter="right"></script></li>
  </ol>
  <hr>
</div>

  

      <article class="block block-common with-img person with-link">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/people/jeff-bleiel"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x360/jeff_bleiel-8762164b77ecdba194ec914a974644eb.jpg" alt="Jeff Bleiel" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x360/jeff_bleiel-8762164b77ecdba194ec914a974644eb.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x720/jeff_bleiel-8762164b77ecdba194ec914a974644eb.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x1440/jeff_bleiel-8762164b77ecdba194ec914a974644eb.jpg 1440w"  class=""/></a>
    
    
  </div>
  

  

  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/people/jeff-bleiel">Jeff Bleiel</a>
    
    
    </h2>
    

    
          <p class="dek">Jeff Bleiel is an editor at O’Reilly Media, and the host and producer of the O’Reilly Programming Podcast.
</p>

    
          <a class="btn btn--xsmall" style="float: right;" href="/people/jeff-bleiel">more</a>
    
  </div>
</article>

  

</div>


        <hr class="t-bkg section-divider" />


        <aside class="article-related">
      <section class="block-rows columns-4 ">

    

    <section class="block-group">
                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/how-intelligent-data-platforms-are-powering-smart-cities"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/marina_bay_and_the_singapore_skyline_at_dusk_-_20110311-be0e3734d4b48afd99e42cdd89e4157a.jpg" alt="Marina Bay and the skyline of the Central Business District of Singapore at dusk, by William Cho." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/marina_bay_and_the_singapore_skyline_at_dusk_-_20110311-be0e3734d4b48afd99e42cdd89e4157a.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/marina_bay_and_the_singapore_skyline_at_dusk_-_20110311-be0e3734d4b48afd99e42cdd89e4157a.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/marina_bay_and_the_singapore_skyline_at_dusk_-_20110311-be0e3734d4b48afd99e42cdd89e4157a.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-data--before">
  
            <a href="/topics/data-science" >Data science</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/how-intelligent-data-platforms-are-powering-smart-cities">How intelligent data platforms are powering smart cities</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/4e7ad-ben-lorica" itemprop="name">Ben Lorica</a></span>
</div>
    
          <p class="dek">Smart cities and smart nations run on data.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/beyond-algorithms-optimizing-the-search-experience"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/card_puncher_-_nara_-_513295-17a33e71f1a0f5d83ce3fd9b064d1f0b.jpg" alt="A woman posed with a Hollerith pantograph: the keyboard is for the 1920 population card, and a 1940 census form." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/card_puncher_-_nara_-_513295-17a33e71f1a0f5d83ce3fd9b064d1f0b.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/card_puncher_-_nara_-_513295-17a33e71f1a0f5d83ce3fd9b064d1f0b.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/card_puncher_-_nara_-_513295-17a33e71f1a0f5d83ce3fd9b064d1f0b.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-data--before">
  
            <a href="/topics/data-science" >Data science</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/beyond-algorithms-optimizing-the-search-experience">Beyond algorithms: Optimizing the search experience</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/e9a1c-daniel-tunkelang" itemprop="name">Daniel Tunkelang</a></span>
</div>
    
          <p class="dek">Making search smarter through better human-computer interaction.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Runnable code</span>
        <span class="icon icon-code t-fill">
  <svg role="img">
    <title>code</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#code"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/learning/introducing-pandas-objects"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/pandas_objects-95b49105fb69c49cb1c7a119d6e897c5.png" alt="Pandas table" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/pandas_objects-95b49105fb69c49cb1c7a119d6e897c5.png 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/pandas_objects-95b49105fb69c49cb1c7a119d6e897c5.png 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/pandas_objects-95b49105fb69c49cb1c7a119d6e897c5.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-data--before">
  
            <a href="/topics/data-science" >Data science</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/learning/introducing-pandas-objects">Introducing Pandas Objects</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/89c9c-jake-vanderplas" itemprop="name">Jake VanderPlas</a></span>
</div>
    
          <p class="dek">Python Data Science Handbook: Early Release</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/the-machine-learning-paradox"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/impossibletriangleeastperth_edit_gobeirne_crop-eaa19599485d1444ddf98eed00443afb.jpg" alt="&#34;Impossible Triangle,&#34; sculpture by Brian MacKay and Ahmad Abas, Claisebrook roundabout, East Perth, Western Australia." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/impossibletriangleeastperth_edit_gobeirne_crop-eaa19599485d1444ddf98eed00443afb.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/impossibletriangleeastperth_edit_gobeirne_crop-eaa19599485d1444ddf98eed00443afb.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/impossibletriangleeastperth_edit_gobeirne_crop-eaa19599485d1444ddf98eed00443afb.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-data--before">
  
            <a href="/topics/data-science" >Data science</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/the-machine-learning-paradox">The machine learning paradox</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1b7da-mike-loukides" itemprop="name">Mike Loukides</a></span>
</div>
    
          <p class="dek">Nothing says machine learning can't outperform humans, but it's important to realize perfect machine learning doesn't, and won't, exist.</p>

    
    
  </div>
</article>

      
  	</section>
    

</section>
  
</aside>

      </div>
    </div>
  </article>
</main>








  <footer role="contentinfo">
  <div class="footer-inner">

    <div class="about-us">
      <h3 class="title">About Us</h3>
      <ul>
        <li><a href="http://oreilly.com/about/">Our Company</a></li>
        <li><a href="http://oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
        <li><a href="http://oreilly.com/careers/">Careers</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Contact Us</a></li>
      </ul>
    </div>
    <div class="site-map">
      <h3 class="title">Site Map</h3>
      <ul>
        <li><a href="/ideas">Ideas</a></li>
        <li><a href="/learning">Learning</a></li>
        <li><a href="/topics">Topics</a></li>
        <li><a href="/all">All</a></li>
      </ul>
    </div>
    <div class="social">
      <ul>
        <li><a   class="icon-link " href="http://fb.co/OReilly"><span class="icon icon-facebook t-fill icon--white icon--large">
  <svg role="img">
    <title>facebook</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#facebook"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="http://twitter.com/oreillymedia"><span class="icon icon-twitter t-fill icon--white icon--large">
  <svg role="img">
    <title>twitter</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#twitter"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.youtube.com/user/OreillyMedia"><span class="icon icon-youtube-large t-fill icon--white icon--large">
  <svg role="img">
    <title>youtube-large</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#youtube-large"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://plus.google.com/+oreillymedia"><span class="icon icon-google t-fill icon--white icon--large">
  <svg role="img">
    <title>google</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#google"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.linkedin.com/company/oreilly-media"><span class="icon icon-linkedin t-fill icon--white icon--large">
  <svg role="img">
    <title>linkedin</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#linkedin"></use>
  </svg>
</span></a>
</li>
      </ul>
    </div>
  </div>
  <div class="legal">
	  <a href="/" class="logo logo-block t-bkg logo--medium">
<svg>
   <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
</svg>
</a>
  	<p class="copyright">&copy; 2017 O'Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><br>
  <a class="t-c" href="http://oreilly.com/terms/">Terms of Service</a>  <span class="bullet">&bull;</span>	<a class="t-c" href="http://oreilly.com/privacy.html">Privacy Policy</a> <span class="bullet">&bull;</span> <a class="t-c" href="http://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a>
	</div>
	<figure class="animal"><img src="https://d3ebicv0uqgr7t.cloudfront.net/images/tarsier.png" class="animal-img" alt="Animal"></figure>
</footer>



  
  
    <!-- Start Adobe Digital Tag Manager -->
  <script type="text/javascript">_satellite && _satellite.pageBottom();</script>
  <!-- End Adobe Digital Tag Manager -->
  
</body>
</html>
