<!DOCTYPE html>
<html lang="en">
<head>
  <title>Deep learning in the enterprise - O&#39;Reilly Media</title>

  <!-- Meta -->
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
      <meta property="twitter:card" content="summary_large_image" />
      <meta property="twitter:site" content="@OReillyMedia" />
      <meta property="twitter:title" content="Deep learning in the enterprise" />
      <meta property="twitter:description" content="Opportunities and challenges companies will face integrating and implementing deep learning frameworks." />
      <meta property="description:site" content="Opportunities and challenges companies will face integrating and implementing deep learning frameworks." />
      <meta property="twitter:url" content="https://www.oreilly.com/ideas/deep-learning-in-the-enterprise" />
      <meta property="fb:pages" content="15137500430" />
      <meta property="og:type" content="article" />
      <meta property="og:site_name" content="O&#39;Reilly Media" />
      <meta property="og:title" content="Deep learning in the enterprise" />
      <meta property="og:description" content="Opportunities and challenges companies will face integrating and implementing deep learning frameworks." />
      <meta property="og:url" content="https://www.oreilly.com/ideas/deep-learning-in-the-enterprise" />
      <meta property="article:published_time" content="2018-02-26T11:00:00Z" />
      <meta property="article:author" content="Emily Drevets" />
      <meta name="description" content="Opportunities and challenges companies will face integrating and implementing deep learning frameworks." />
      <meta name="author" content="Emily Drevets" />
      <meta name="date" content="2018-02-26" />
      <meta property="og:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/denys-nevozhai-154974_crop-d5620703573ea1aa5669ed3325e4c883.jpg" />
      <meta property="twitter:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/denys-nevozhai-154974_crop-d5620703573ea1aa5669ed3325e4c883.jpg" />
      <meta name="thumbnail" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/denys-nevozhai-154974_crop-d5620703573ea1aa5669ed3325e4c883.jpg" />
      <meta name="graphic_medium" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/denys-nevozhai-154974_crop-d5620703573ea1aa5669ed3325e4c883.jpg" />
      <meta name="oreilly:topic" content="AI" />
      <meta name="oreilly:keywords" content="ai,artificial intelligence,deep learning,enterprise,architectures,implementation" />
  
  

  <!-- Assets -->
  <script type="text/javascript" src="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-f9f828b1d3.js"></script>
  <link rel="stylesheet" type="text/css" href="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-52db91f102.css">
    
  
  <!-- Extra Assets -->
  
  
  

  <script type="text/javascript">
    dataLayer = [];
  </script>

    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5P4V6Z');</script>
  <!-- End Google Tag Manager -->
  

  <!-- Start Adobe Digital Tag Manager Header-->
  

  <!-- End Adobe Digital Tag Manager Header-->

  <script type="text/javascript">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</script>

  <!-- Start Visual Website Optimizer Asynchronous Code -->
  <script type='text/javascript'>
    var _vwo_code=(function(){
    var account_id=244658,
    settings_tolerance=2000,
    library_tolerance=2500,
    use_existing_jquery=false,
  // DO NOT EDIT BELOW THIS LINE
  f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
  </script>
  <!-- End Visual Website Optimizer Asynchronous Code -->

</head>
<body class="body t-ai" data-section="ideas" >
  <div class="flashes"></div>
    <header id="page-header">
  <div id="header-bar" class="t-bkg">
    <h1 class="logo t-bkg" >
  <a href="/" class=" logo-white ">
  <svg role="heading" aria-label="O'Reilly">
    <title>O'Reilly</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
  </svg>
  </a>
</h1>
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>


    <div class="right invert">
      <div id="search" class="hide">
        <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
      </div>
      <div id="user">
        <!-- <a href="#feedback"  class="t-c--d feedback" id="feedback">Feedback</a> -->
        <a class="t-c--d login" id="log-in-loading">Loading...</a>
        <a href="?log-in" class="t-c--d login" id="log-in">Log in</a>
        <a href="?log-out" class="t-c--d capture_end_session login" id="log-out">Log out</a>
        <a href="/user/preferences"  class="t-c--d login" id="preferences"><span class="icon icon-configure icon--small t-fill ">
  <svg role="img">
    <title>configure</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#configure"></use>
  </svg>
</span></a>
      </div>
    </div>
    <a id="menu-toggle" class="invert" ><span class="icon icon-white icon-menu">
  <svg role="img" id="close" class="is-hidden">
    <title>Close Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#close"></use>
  </svg>
  <svg role="img" id="open">
    <title>Open Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#menu"></use>
  </svg>
</span></a>
  </div>
     <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

  
  <div id="mobile-menu">

    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
         <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

    
  </div>

</header>



  <!-- Linked In -->
  <script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
  
<!-- Load Facebook SDK for JavaScript -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<main aria-live="polite">
  <article class="article" itemscope itemtype="http://schema.org/Article">
              <header class="article-header">
        <div class="flag-follow " data-status="" id="">
      <div class="flag t-bkg--before bg-ai--before flag--small">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  
  <span class="cta">
    <span class="icons">
      
      
    </span>
    <span class="messages">
      
      
    </span>
</span>
</div>

  
  

  

  <h1 class="title t-c" itemprop="headline">Deep learning in the enterprise</h1>

      <p class="dek" itemprop="alternativeHeadline">Opportunities and challenges companies will face integrating and implementing deep learning frameworks.</p>
  

  <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/emily-drevets" itemprop="name">Emily Drevets</a></span>
</div> <time class="date">February 26, 2018</time>

</header>

      

      <div class="article-body" itemprop="articleBody">
        
                              <figure class="article-image right">
  <img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/denys-nevozhai-154974_crop-d5620703573ea1aa5669ed3325e4c883.jpg" alt="Network structure" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/denys-nevozhai-154974_crop-d5620703573ea1aa5669ed3325e4c883.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/denys-nevozhai-154974_crop-d5620703573ea1aa5669ed3325e4c883.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/denys-nevozhai-154974_crop-d5620703573ea1aa5669ed3325e4c883.jpg 1440w" sizes="(min-width: 1390px) 420px, (min-width: 600px) 45vw, 100vw" class=""/>
  <figcaption>Network structure
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://unsplash.com/photos/_QoAuZGAoPY">Denys Nevozhai on Unsplash</a>)
        
        
      </span>
    
    
  <figcaption>

</figure>
          
                      <aside data-type="note">
  <p><a href="http://www.oreilly.com/pub/e/3930?intcmp=il-data-webcast-lp-na_20180208_new_site_deep_learning_in_enterprise_top_cta_webcast_link">Attend the webcast "Using artificial intelligence to fight financial crimes"</a> on February 27, 2018.</p>
</aside>

          
        

        

        <p>Deep learning is a class of machine learning (ML) algorithms inspired by the human brain. Also called neural networks, these algorithms are especially good at detecting patterns across both noisy data and data that was once completely opaque to machines. While the technical details of neural nets may thrill mathematics and computer science Ph.D.s, the technology’s real significance has a much broader appeal. It represents one more step toward truly self-learning machines.</p>



<p>Not surprisingly, this new wave of algorithms has captured attention with applications that range from machine translation to self-driving cars. Enterprises—and not just web-scale digital giants—have begun to use it to solve a wide variety of problems. Early adopters are demonstrating high-impact business outcomes in fraud detection, manufacturing performance optimization, preventative maintenance, and recommendation engines. It’s becoming clear that these new machine-intelligence-powered initiatives have the potential to redefine industries and establish new winners and losers in the next five years.</p>



<p>Though a custom deep learning framework can provide significant value, building one does come with unique challenges. This article will address some of the hurdles that enterprises will face as they develop this technology, approaches to overcoming them, and other considerations for building and maintaining a deep learning program. Specifically we will explore:</p>


<ul>
<li>Deep learning’s specialized hardware and software needs (e.g., GPUs)</li>

<li>New approaches to model interpretability</li>

<li>Considerations for building a data platform that can service deep learning</li>

<li>Automation while choosing, testing, and promoting deep learning models</li>

<li>Challenges and requirements for deep learning in production</li>

<li>The need for enterprise-grade expertise</li>

</ul>

<h2>Deep learning requires powerful processing</h2>

<p>One of the challenges of using deep learning is the fact that the models—which sometimes run on a scale of millions of nodes—are computationally intensive, and training them efficiently requires specialized hardware and software resources.</p>



<p>Currently, the best-in-class option for training deep learning models are GPUs, or graphical processing units. These specialized electronic circuits were developed in the gaming industry and are particularly well-suited for doing the floating point parallel computations that deep learning requires.</p>



<p>This hardware is a significant step forward from CPUs, with models training in weeks on GPUs that would take months to train otherwise. However, working with GPUs can be challenging, as their architectures and compute frameworks are much different from those that are CPU only.</p>



<p>GPUs require significant engineering to optimize the software and ensure efficient parallelism, manageability, reliability, and portability. They must also be integrated with the rest of the analytical ecosystem, as some learning will happen within both the CPU and the GPU architectures. Scaling models over GPUs can be tricky, and doing so requires a blueprint that intelligently routes traffic so the architecture is used efficiently.</p>





<h2>Approaching model interpretability with LIME</h2>

<p>Aside from their intensive computational needs, another unique challenge of using neural nets is their occasional inscrutability. Neural nets use hidden layers that squirrel away information the machine uses to make decisions. Deep learning models are functionally black boxes, as it is nearly impossible to get a feeling for their inner workings. This raises the question of trust. In some industries, however, interpretability is not negotiable.</p>



<p>For example, financial institutions in Europe must remain in compliance with the EU’s <a href="https://www.eugdpr.org/">General Data Protection Regulation (GDPR)</a>, which levies heavy financial penalties for companies that cannot explain how a customer’s data was used. In this case, it is not possible—nor is it legal—to tell a customer that their financial transaction was declined simply because the model said so. Even beyond matters of regulatory compliance, stakeholders often need to be told how a decision was reached in order to support their actions.</p>



<p>Though far from solved, there are several approaches that enterprises are using to address the problem of model interpretability. One is through a method called <a href="https://github.com/marcotcr/lime">Local Interpretable Model-Agnostic Explanations (LIME)</a>, an open source body of research produced at the University of Washington. LIME sheds light on the specific variables that triggered the algorithm at the point of its decision and produces that information in a human-readable way. In the case of fraud, knowing this information can provide security from a regulatory standpoint as well as help the business understand how and why fraud is happening.</p>



<p>New innovations are occurring at a rapid pace as researchers attempt to address the interpretability issues and hardware necessities of working with deep learning. But even with these drawbacks, the gains of using this technology in the enterprise can be significant. Before deploying models, however, your organization must have the right data platform in place.</p>

<h2>Building a data foundation that can service deep learning</h2>

<p>Investing in a robust data and analytics foundation is the first step of a deep learning project. In fact, the project’s success is dependent on the data, which must be clean as well as highly available and reliable. Stale, incomplete, or inaccurate data leads to incorrect model predictions, which can get expensive and could derail an entire project.</p>



<p>Though not as exciting as other parts of deep learning, the majority of a deep learning project’s work will be done here—getting access to the data, making sure it’s the right kind, fixing any problems with accuracy, and developing the systems that will facilitate the models in the live environment.</p>



<p>Once models are in production, you will need to solve the problem of data integration in real time. Feeds of streaming data must be highly available and reliable, and have low latency for feature calculations. At the same time, batch feeds will require massive scale support, integration with data pipelines, and storage.</p>



<p>The system must also be able to iterate rapidly. Feature preparation needs to be in sync with the model training, including the same logic, latency, and forward compatibility. And for all data feeds and features, you must ensure visibility and traceability, integrating data quality and governance with monitoring.</p>



<p>Increasingly, enterprise data is spread across a hybrid cloud environment and different storage formats. Connections must be made between data residing in public clouds, on-premises data, and data that persists in different kinds of object and file storage.</p>



<p>Though the challenges are many, you can manage them by developing systems to monitor the data continuously so the teams that are working on the project know where the data came from, how to recreate it, and whether or not it’s current. Once this data foundation and its monitoring systems are in place, you’ll be able to leverage it for deep learning as well as extend its use to other domains.</p>



<h2>Automation while choosing and training deep learning models</h2>

<p>Most—if not all—of the software frameworks that are used in deep learning are open source projects, free for anyone to download and experiment with. Of these, TensorFlow is the market leader, open-sourced by Google in 2015.</p>



<p>Many different <a href="http://www.asimovinstitute.org/neural-network-zoo/">neural net taxonomies</a> can be run on top of these deep learning frameworks, such as <a href="https://en.wikipedia.org/wiki/Feedforward_neural_network">feedforward networks</a>, <a href="https://en.wikipedia.org/wiki/Generative_adversarial_network">generative adversarial networks</a>, <a href="https://en.wikipedia.org/wiki/Deep_belief_network">deep belief networks</a>, and <a href="https://en.wikipedia.org/wiki/Convolutional_neural_network">deep convolutional networks</a>. It’s nearly impossible to keep an updated list since new types of deep learning models continue to appear at a stunning pace. Depending on your use case, there may be best practices for choosing specific architectures. However, there is no substitute for testing. Deep learning is an experimental science, not a theoretical one.</p>



<p>Once trained and proven via an automatic process (analytic ops), the models should be promoted to a shadow production environment where they can be adjusted or retrained. Leveraging the analytic ops process methodology also gives stakeholders a chance to become familiar with the models before they operate autonomously in a live environment.</p>



<h2>Considerations for deep learning models in production</h2>

<p>Similar to all other types of machine learning models, the lifecycle of a model—from development to testing to pre-production and finally to production—requires monitoring and automatic retraining. In some cases, you should also be able to have gradual deployment from pre-production to production (often done via A/B testing frameworks).</p>



<p>Some considerations should also be given to re-training strategies. In some cases, traditional machine learning may be able to re-train more quickly compared to several deep learning fields, specifically when the deep learning model has been trained in vast amounts of data and new data will not provide much variance, (e.g., a model trained on billions of images of people and cars). It’s also important to recognize—via live testing—when the model’s predictions match expectations based on human domain knowledge. When that’s not the case, an auto-retrain job should start, again via the analytic ops process.</p>



<p>For example, as a recommendation engine presents shoppers with different options, there needs to be a mechanism in place to monitor it to make sure shoppers are responding positively. At the same time, you should also be able to deploy a new engine over a percentage of the total data and compare its performance with that of the other one in real time.</p>



<p>None of this is easy. In fact, production is where many deep learning projects die as data science experiments due to unforeseen complexities in scaling and management. Because there are so many pitfalls, it’s important to have a team that is familiar with the challenges of working with deep learning in production. Unfortunately, people with that kind of knowledge are (currently) hard to find outside of places like Google and Facebook.</p>



<h2>The talent deficit</h2>

<p>Deep learning expertise is scarce and expensive. While many smart people have been able to educate themselves on neural networks and experiment with models using cloud APIs, it is difficult to find engineers who have experience with deploying deep learning at scale in an enterprise setting. In a <a href="http://assets.teradata.com/pdf/microsites/products/AI-The-Killer-App-for-Your-Business.pdf">recent Forbes article on AI</a>, Diego Klabjan put it well when he said, “AI development has a very small talent pool, and it would be difficult to get that kind of brain trust in one organization at an affordable, sustainable rate.”</p>



<p>This will change as the field advances and as deep learning proves its value across more industries and use cases. In the meantime, however, one way to overcome this knowledge gap is by working with an experienced partner who knows what kinds of errors to look for. Though it might be tempting to wait until the field matures, doing so may result in falling behind.</p>

<h2>Leveraging deep learning for transformational change</h2>

<p>Deploying deep learning is different from adopting other kinds of software. It potentially involves the automation of decision-making at scale, and it can be disruptive, requiring you to rethink processes that were engineered prior to its deployment.</p>



<p>This is as it should be, as deep learning is much more than an analytic add-on to business as usual. These data products must become integral parts of the business, allowing companies to drive organizational change by harnessing the power of their data and acting on it automatically.</p>



<p>Enterprises that successfully deploy deep learning will see dividends in safer products, happier customers, more efficient operations, and in dozens of other use cases as the field continues to mature. Deploying it takes thoughtful (and significant) investment, cross-functional collaboration, and plenty of testing, but the results are worth it. If the enterprise is ready, deep learning can be transformative.</p>



<p><em>This post is a collaboration between Teradata and O’Reilly. See our </em><a href="http://www.oreilly.com/about/editorial_independence.html"><em>statement of editorial independence</em></a><em>.</em></p>


        
                  
        

                  <div class="image-credit">
  Article image: Network structure
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://unsplash.com/photos/_QoAuZGAoPY">Denys Nevozhai on Unsplash</a>).
        
        
      </span>
    
    
</div>
        

        

      </div>

      <div class="article-meta">

  <div class="article-share">
  <div class="article-share-text"> Share </div>
  <ol>
    <li><a href="https://twitter.com/share" class="twitter-share-button" data-via="oreillymedia" data-show-count="false">Tweet</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></li>
    <li>  <div class="fb-share-button" 
    data-href="https://www.oreilly.com/ideas/deep-learning-in-the-enterprise" 
    data-layout="button_count">
  </div></li>
    <li><script type="IN/Share" data-url="https://www.oreilly.com/ideas/deep-learning-in-the-enterprise" data-counter="right"></script></li>
  </ol>
  <hr>
</div>

  

      <article class="block block-common with-img person with-link">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/people/emily-drevets"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x360/emily_drevets_headshot-a1584068a9c6508b70affad2643752eb.jpg" alt="Emily Drevets" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x360/emily_drevets_headshot-a1584068a9c6508b70affad2643752eb.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x720/emily_drevets_headshot-a1584068a9c6508b70affad2643752eb.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x1440/emily_drevets_headshot-a1584068a9c6508b70affad2643752eb.jpg 1440w"  class=""/></a>
    
    
  </div>
  

  

  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/people/emily-drevets">Emily Drevets</a>
    
    
    </h2>
    

    
          <p class="dek">Emily Drevets is the former curator of data science and big data content at BrightTALK. She is currently based in Chicago where she works as a writer and turns into her improv alter ego at night. She has had a Chicago-style hot dog exactly twice.
</p>

    
          <a class="btn btn--xsmall" style="float: right;" href="/people/emily-drevets">more</a>
    
  </div>
</article>

  

</div>


      <hr class="t-bkg section-divider" />


      <aside class="article-related">
      <section class="block-rows columns-4 ">

    

    <section class="block-group">
                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/keynotes-from-ai-new-york-2016"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg" alt="Welcome sign at O&#39;Reilly AI Conference 2016" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/keynotes-from-ai-new-york-2016">Highlights from the O&#39;Reilly AI Conference in New York 2016</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/0d2c1-mac-slocum" itemprop="name">Mac Slocum</a></span>
</div>
    
          <p class="dek">Watch highlights covering artificial intelligence, machine learning, intelligence engineering, and more. From the O'Reilly AI Conference in New York 2016.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/ideas/how-ai-is-propelling-driverless-cars-the-future-of-surface-transport"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg" alt="Close up of Uber&#39;s Self Driving Car in Pittsburgh." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/how-ai-is-propelling-driverless-cars-the-future-of-surface-transport">How AI is propelling driverless cars, the future of surface transport</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/c7521-shahin-farshchi" itemprop="name">Shahin Farshchi</a></span>
</div>
    
          <p class="dek">Shahin Farshchi examines role artificial intelligence will play in driverless cars.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/untapped-opportunities-in-ai"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/timaeus_trans_calcidius_med_manuscript-d9d6fd54691fcdb2dcf16580cc7c3c72.jpg" alt="Latin translation of Plato&#39;s Timaeus" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/timaeus_trans_calcidius_med_manuscript-d9d6fd54691fcdb2dcf16580cc7c3c72.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/timaeus_trans_calcidius_med_manuscript-d9d6fd54691fcdb2dcf16580cc7c3c72.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/timaeus_trans_calcidius_med_manuscript-d9d6fd54691fcdb2dcf16580cc7c3c72.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/untapped-opportunities-in-ai">Untapped opportunities in AI</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/89289-beau-cronin" itemprop="name">Beau Cronin</a></span>
</div>
    
          <p class="dek">Some of AI's viable approaches lie outside the organizational boundaries of Google and other large Internet companies.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/small-brains-big-data"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/16585641410_65f3489ebd_o-93cfdd984c69a50c6a6d97c5cc903f69.jpg" alt="Addresses and papers" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/16585641410_65f3489ebd_o-93cfdd984c69a50c6a6d97c5cc903f69.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/16585641410_65f3489ebd_o-93cfdd984c69a50c6a6d97c5cc903f69.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/16585641410_65f3489ebd_o-93cfdd984c69a50c6a6d97c5cc903f69.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/small-brains-big-data">Small brains, big data</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/476ef-jeremey-freeman" itemprop="name">Jeremy Freeman</a></span>
</div>
    
          <p class="dek">How neuroscience is benefiting from distributed computing, and how computing might learn from neuroscience.</p>

    
    
  </div>
</article>

      
  	</section>
    

</section>
  
</aside>

  </article>
</main>








  <footer role="contentinfo">
  <div class="footer-inner">

    <div class="about-us">
      <h3 class="title">About Us</h3>
      <ul>
        <li><a href="http://oreilly.com/about/">Our Company</a></li>
        <li><a href="http://oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
        <li><a href="http://oreilly.com/careers/">Careers</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Contact Us</a></li>
      </ul>
    </div>
    <div class="site-map">
      <h3 class="title">Site Map</h3>
      <ul>
        <li><a href="/ideas">Ideas</a></li>
        <li><a href="/learning">Learning</a></li>
        <li><a href="/topics">Topics</a></li>
        <li><a href="/all">All</a></li>
      </ul>
    </div>
    <div class="social">
      <ul>
        <li><a   class="icon-link " href="http://fb.co/OReilly"><span class="icon icon-facebook t-fill icon--white icon--large">
  <svg role="img">
    <title>facebook</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#facebook"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="http://twitter.com/oreillymedia"><span class="icon icon-twitter t-fill icon--white icon--large">
  <svg role="img">
    <title>twitter</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#twitter"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.youtube.com/user/OreillyMedia"><span class="icon icon-youtube-large t-fill icon--white icon--large">
  <svg role="img">
    <title>youtube-large</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#youtube-large"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://plus.google.com/+oreillymedia"><span class="icon icon-google t-fill icon--white icon--large">
  <svg role="img">
    <title>google</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#google"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.linkedin.com/company/oreilly-media"><span class="icon icon-linkedin t-fill icon--white icon--large">
  <svg role="img">
    <title>linkedin</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#linkedin"></use>
  </svg>
</span></a>
</li>
      </ul>
    </div>
  </div>
  <div class="legal">
	  <a href="/" class="logo logo-block t-bkg logo--medium">
<svg>
   <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
</svg>
</a>
  	<p class="copyright">&copy; 2018 O'Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><br>
  <a class="t-c" href="http://oreilly.com/terms/">Terms of Service</a>  <span class="bullet">&bull;</span>	<a class="t-c" href="http://oreilly.com/privacy.html">Privacy Policy</a> <span class="bullet">&bull;</span> <a class="t-c" href="http://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a>
	</div>
	<figure class="animal"><img src="https://d3ebicv0uqgr7t.cloudfront.net/images/tarsier.png" class="animal-img" alt="Animal"></figure>
</footer>



  
  

    <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5P4V6Z"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
  

  
</body>
</html>
