<!DOCTYPE html>
<html lang="en">
<head>
  <title>Four short links: 10 April 2019 - O&#39;Reilly Media</title>

  <!-- Meta -->
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
      <meta property="twitter:card" content="summary_large_image" />
      <meta property="twitter:site" content="@OReillyMedia" />
      <meta property="twitter:title" content="Four short links: 10 April 2019" />
      <meta property="twitter:description" content="iPhone Dominance, Security Keys, Embedded Systems Course, and Better Slack Client" />
      <meta property="description:site" content="iPhone Dominance, Security Keys, Embedded Systems Course, and Better Slack Client" />
      <meta property="twitter:url" content="https://www.oreilly.com/ideas/four-short-links-10-april-2019" />
      <meta property="fb:pages" content="15137500430" />
      <meta property="og:type" content="article" />
      <meta property="og:site_name" content="O&#39;Reilly Media" />
      <meta property="og:title" content="Four short links: 10 April 2019" />
      <meta property="og:description" content="iPhone Dominance, Security Keys, Embedded Systems Course, and Better Slack Client" />
      <meta property="og:url" content="https://www.oreilly.com/ideas/four-short-links-10-april-2019" />
      <meta property="article:published_time" content="2019-04-10T11:10:00Z" />
      <meta property="article:author" content="Nat Torkington" />
      <meta name="description" content="iPhone Dominance, Security Keys, Embedded Systems Course, and Better Slack Client" />
      <meta name="author" content="Nat Torkington" />
      <meta name="date" content="2019-04-10" />
      <meta property="og:image" content="https://d3ucjech6zwjp8.cloudfront.net/1400x933/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" />
      <meta property="twitter:image" content="https://d3ucjech6zwjp8.cloudfront.net/1400x933/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" />
      <meta name="thumbnail" content="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" />
      <meta name="graphic_medium" content="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" />
      <meta name="oreilly:topic" content="Four Short Links" />
      <meta name="oreilly:keywords" content="iPhone Dominance,Security Keys,Embedded Systems Course,and Better Slack Client" />
      <meta name="oreilly:content_type" content="text" />
  
  

  <!-- Assets -->
  <script type="text/javascript" src="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-85c07f5db6.js"></script>
  <link rel="stylesheet" type="text/css" href="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-d3b85b5665.css">
    
  
  <!-- Extra Assets -->
  
  
  

  <link rel="stylesheet" type="text/css" href="https://cdn.oreillystatic.com/assets/css/mkto-multiform-subscribe-20180320.css">

  <script type="text/javascript">
    dataLayer = [{"content.author":"Nat Torkington","content.formatType":"article","content.free":"yes","content.identifier":"none","content.parentTopic":"four short links","content.publisher":"O'Reilly Media Inc.","content.releaseDate":"2019-04-10","content.subTopic":"four short links","content.subdirectory":"ideas","content.title":"Four short links: 10 April 2019","keywords":["iPhone Dominance","Security Keys","Embedded Systems Course","and Better Slack Client"],"path":"/ideas/four-short-links-10-april-2019","product.identifier":"none","product.title":"none","product.type":"none"}];
  </script>

  <script type="text/javascript">
    // init app.events for all communication
    app.events = new orm.Events();

    var tempData = {"content_type":"text","flag":{"flag-slug":"four-short-links","flag-title":"Four Short Links","flag-url":"/topics/four-short-links","parent-topic-slug":"four-short-links"},"gateway_api_url":"https://gateway.oreilly.com","icons-svg":"/assets/icons-8812ab3f83.svg","post_info":{"byline":{"authors":[{"first-name":"Nat","last-name":"Torkington","url":"/people/1f103-nathan-torkington"}]},"excerpt":"\u003col\u003e\r\n\u003cli\u003e\r\n\u003ca href=\"https://www.ped30.com/2019/04/08/apple-piper-jaffray-genz/\"\u003e83% U.S. College Students Have an iPhone\u003c/a\u003e -- from Piper Jaffray research. Android: 9%. Presumably 8% of U.S. college teens love their Nokia 3310s.\u003c/li\u003e\r\n\u003cli\u003e\r\n\u003ca href=\"https://medium.com/@mrisher_2499/phishing-and-security-keys-b5c8e8e26931\"\u003ePhishing and Security Keys\u003c/a\u003e -- \u003ci\u003eSecurity Keys flip this on its head, trading something humans are bad at (noticing subtle differences) for something computers are good at (identifying exact matches). With Security Keys, instead of the user verifying the site, the site has to prove itself to the key.\u003c/i\u003e 💻🔐💪Is this useful for convincing people who need to be convinced that security keys are the way and the light? I don't know, but every bit of ammunition has to help.\u003c/li\u003e\r\n\u003cli\u003e\r\n\u003ca href=\"https://www.archive.ece.cmu.edu/~ece642/\"\u003eEmbedded Systems Software Engineering\u003c/a\u003e -- a CMU course with notes, exercises, etc.\u003c/li\u003e\r\n\u003cli\u003e\r\n\u003ca href=\"https://cancel.fm/ripcord/\"\u003eRipcord\u003c/a\u003e -- Slack (and Discord) client that is not built on browser tech, so it's zippy compared to Slack's own client.\u003c/li\u003e\r\n\u003c/ol\u003e\r\n","title":"Four short links: 10 April 2019"},"post_slug":"four-short-links-10-april-2019","production":true,"segment_write":"c1bqZBPpSt05Stv3bKthxtFmC2etfgEK"};

    var kalturaVideoId = "";
    var kalturaAccount = "";
    var kalturaPlayer = "";

    // This should be genetated on the API directly.
    tempData.allTopics = [{"flag-title":"Money","flag-slug":"money"},{"flag-title":"Internet of Things","flag-slug":"internet-of-things","parent-topic-slug":"data"},{"flag-title":"Open Source","flag-slug":"open-source","parent-topic-slug":"software-engineering"},{"flag-title":"Data marketplace","flag-slug":"data-marketplace","parent-topic-slug":"data"},{"flag-title":"Cognitive augmentation","flag-slug":"cognitive-augmentation","parent-topic-slug":"data"},{"flag-title":"Software Architecture","flag-slug":"software-architecture","parent-topic-slug":"software-engineering"},{"flag-title":"Economy","flag-slug":"economy"},{"flag-title":"Data science","flag-slug":"data-science","parent-topic-slug":"data"},{"flag-title":"Design and Business","flag-slug":"design-and-business","parent-topic-slug":"design"},{"flag-title":"Data perils","flag-slug":"data-perils","parent-topic-slug":"data"},{"flag-title":"Data design","flag-slug":"data-design","parent-topic-slug":"data"},{"flag-title":"Data","flag-slug":"data"},{"flag-title":"Data culture","flag-slug":"data-culture","parent-topic-slug":"data"},{"flag-title":"Software Engineering","flag-slug":"software-engineering"},{"flag-title":"Data Tools","flag-slug":"data-tools","parent-topic-slug":"data"},{"flag-title":"Design","flag-slug":"design"},{"flag-title":"Artificial intelligence","flag-slug":"artificial-intelligence","parent-topic-slug":"data"}];

    // Push segement track requests to dataLayer
    window.analytics = { track: function(eventName, data){
      dataLayer.push({
        eventName: data
      });
    }};


    $(function() {
      app.metrics = new orm.Metrics();
      app.metrics.pageView();

      app.pageInit(tempData);

      // load data into events so it dispatched 'data:loaded'
      app.events.addData(tempData);
    })
  </script>

    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5P4V6Z');</script>
  <!-- End Google Tag Manager -->
  

  

    <script type="text/javascript">
    function createKeenWebAutoCollector(){window.keenWebAutoCollector=window.KeenWebAutoCollector.create({projectId:'551456c8672e6c2f4f5ee426',writeKey:'e737a463e3a57a914ddf707a34ad2c319c2e1c52999fe5f8087e41a71676675f90298cfd1a4e30ecf3f25e337db4b579c28c2bf784b26bdd6e9b7cc595b045098b94483dea878b17a65a56b5307b97ac3834670c2484fb8effa01cbacd55dba355850b97cad116b4b0e434dc64bc359c',onloadCallbacks:window.keenWebAutoCollector.onloadCallbacks}),window.keenWebAutoCollector.loaded()}function initKeenWebAutoCollector(){window.keenWebAutoCollector.domReady()?window.createKeenWebAutoCollector():document.addEventListener("readystatechange",function(){window.keenWebAutoCollector.domReady()&&window.createKeenWebAutoCollector()})}window.keenWebAutoCollector={onloadCallbacks:[],onload:function(a){this.onloadCallbacks.push(a)},domReady:function(){return["ready","complete"].indexOf(document.readyState)>-1}};
  </script>
  <script async type="text/javascript" src="https://d26b395fwzu5fz.cloudfront.net/keen-web-autocollector-1.0.8.min.js" onload="initKeenWebAutoCollector()"></script>
  

  <!-- Start Visual Website Optimizer Asynchronous Code -->
  <script type='text/javascript'>
    var _vwo_code=(function(){
    var account_id=244658,
    settings_tolerance=2000,
    library_tolerance=2500,
    use_existing_jquery=false,
  // DO NOT EDIT BELOW THIS LINE
  f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
  </script>
  <!-- End Visual Website Optimizer Asynchronous Code -->

  <!-- Marketo -->
  <script src="https://app-ab24.marketo.com/js/forms2/js/forms2.min.js" type="text/javascript"></script>

</head>
<body class="body t-four-short-links" data-section="ideas" >
  <div class="flashes"></div>
    <header id="page-header">
  <div id="header-bar" class="t-bkg">
    <h1 class="logo t-bkg" >
  <a href="/" class=" logo-white ">
  <svg role="heading" aria-label="O'Reilly">
    <title>O'Reilly</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
  </svg>
  </a>
</h1>
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://learning.oreilly.com">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>


    <div class="right">
      <div id="search" class="hide">
        <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
      </div>
      <div id="user">
        <a href="https://www.oreilly.com/sign-in.html" class="t-c--d">Sign In</a>
      </div>
    </div>
    <a id="menu-toggle" class="invert" ><span class="icon icon-white icon-menu">
  <svg role="img" id="close" class="is-hidden">
    <title>Close Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#close"></use>
  </svg>
  <svg role="img" id="open">
    <title>Open Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#menu"></use>
  </svg>
</span></a>
  </div>
     <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

  
  <div id="mobile-menu">

    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://learning.oreilly.com">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
         <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

    
  </div>

</header>



  <!-- Linked In -->
  <script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
  
<!-- Load Facebook SDK for JavaScript -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<main aria-live="polite">
  <article class="article" itemscope itemtype="http://schema.org/Article">
              <header class="article-header">
      <div class="flag t-bkg--before bg-four-short-links--before flag--small">
  
            <a href="/topics/four-short-links" >Four Short Links</a>
    
    
  
</div>
  
  

  <h1 class="title t-c" itemprop="headline">Four short links: 10 April 2019</h1>

      <p class="dek" itemprop="alternativeHeadline">iPhone Dominance, Security Keys, Embedded Systems Course, and Better Slack Client</p>
  

  <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1f103-nathan-torkington" itemprop="name">Nat Torkington</a></span>
</div> <time class="date">April 10, 2019</time>

</header>

      

      <div class="article-body" itemprop="articleBody">
        
                              <figure class="article-image right">
  <img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" alt="Four short links" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 1440w" sizes="(min-width: 1390px) 420px, (min-width: 600px) 45vw, 100vw" class=""/>
  <figcaption>Four short links
    
    
  <figcaption>

</figure>
          
          
        

        

        <ol>
<li>
<a href="https://www.ped30.com/2019/04/08/apple-piper-jaffray-genz/">83% U.S. College Students Have an iPhone</a> -- from Piper Jaffray research. Android: 9%. Presumably 8% of U.S. college teens love their Nokia 3310s.</li>
<li>
<a href="https://medium.com/@mrisher_2499/phishing-and-security-keys-b5c8e8e26931">Phishing and Security Keys</a> -- <i>Security Keys flip this on its head, trading something humans are bad at (noticing subtle differences) for something computers are good at (identifying exact matches). With Security Keys, instead of the user verifying the site, the site has to prove itself to the key.</i> 💻🔐💪Is this useful for convincing people who need to be convinced that security keys are the way and the light? I don't know, but every bit of ammunition has to help.</li>
<li>
<a href="https://www.archive.ece.cmu.edu/~ece642/">Embedded Systems Software Engineering</a> -- a CMU course with notes, exercises, etc.</li>
<li>
<a href="https://cancel.fm/ripcord/">Ripcord</a> -- Slack (and Discord) client that is not built on browser tech, so it's zippy compared to Slack's own client.</li>
</ol>


        
                  
        

                  <div class="image-credit">
  Article image: Four short links
    
    
</div>
        

        

      </div>

      <div class="article-meta">

  <div class="article-share">
  <div class="article-share-text"> Share </div>
  <ol>
    <li><a href="https://twitter.com/share" class="twitter-share-button" data-via="oreillymedia" data-show-count="false">Tweet</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></li>
    <li>  <div class="fb-share-button" 
    data-href="https://www.oreilly.com/ideas/four-short-links-10-april-2019" 
    data-layout="button_count">
  </div></li>
    <li><script type="IN/Share" data-url="https://www.oreilly.com/ideas/four-short-links-10-april-2019" data-counter="right"></script></li>
  </ol>
  <hr>
</div>

  

      <article class="block block-common with-img person with-link">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/people/1f103-nathan-torkington"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x360/nat-torkington-crop-c417a5acf583f8af99e316f6a043258a.jpg" alt="Nat Torkington" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x360/nat-torkington-crop-c417a5acf583f8af99e316f6a043258a.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x720/nat-torkington-crop-c417a5acf583f8af99e316f6a043258a.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x1440/nat-torkington-crop-c417a5acf583f8af99e316f6a043258a.jpg 1440w"  class=""/></a>
    
    
  </div>
  

  

  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/people/1f103-nathan-torkington">Nat Torkington</a>
    
    
    </h2>
    

    
          <p class="dek">Nat Torkington has been active in web development since the early days of the web.  He wrote the bestselling Perl Cookbook, and chaired conferences for O'Reilly Media for a decade.  During his time at O'Reilly Media, Nat was an editor and then became a trend-spotter for the O'Reilly Radar group, identifying the topics to build events and books around.  He has worked in areas as diverse as networking, publishing, science, edtech, and NLP.  He now lives in New Zealand, where he runs Kiwi Foo Camp and helps startups grow.  
</p>

    
          <a class="btn btn--xsmall" style="float: right;" href="/people/1f103-nathan-torkington">more</a>
    
  </div>
</article>

  

</div>


      <hr class="t-bkg section-divider" />


      <aside class="article-related">
      <section class="block-rows columns-4 ">

    

    <section class="block-group">
                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/four-short-links-1-july-2016"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" alt="Four Short Links" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-four-short-links--before">
  
            <a href="/topics/four-short-links" >Four Short Links</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/four-short-links-1-july-2016">Four short links: 1 July 2016</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1f103-nathan-torkington" itemprop="name">Nat Torkington</a></span>
</div>
    
          <p class="dek">Interactive Machine Learning, Pattern Recognition Tutorials, AI Safety, and Decentralised Web</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/four-short-links-8-november-2016"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" alt="Four short links" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-four-short-links--before">
  
            <a href="/topics/four-short-links" >Four Short Links</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/four-short-links-8-november-2016">Four short links: 8 November 2016</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1f103-nathan-torkington" itemprop="name">Nat Torkington</a></span>
</div>
    
          <p class="dek">Photoshop for Speech, Magic Leap, Someone Else's Problem, COBOL Microframework</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/four-short-links-24-january-2017"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" alt="Four short links." srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-four-short-links--before">
  
            <a href="/topics/four-short-links" >Four Short Links</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/four-short-links-24-january-2017">Four short links: 24 January 2017</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1f103-nathan-torkington" itemprop="name">Nat Torkington</a></span>
</div>
    
          <p class="dek">Doomsday Prep, Printing Skin, Autonomous Skepticism, and Slow Wifi</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/four-short-links-25-january-2018"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" alt="Four short links" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-four-short-links--before">
  
            <a href="/topics/four-short-links" >Four Short Links</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/four-short-links-25-january-2018">Four short links: 25 January 2018</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1f103-nathan-torkington" itemprop="name">Nat Torkington</a></span>
</div>
    
          <p class="dek">Young Developers Coding Later, Algorithmic Fairness, Google Goss, and Deep Learned Folk Music</p>

    
    
  </div>
</article>

      
  	</section>
    

</section>
  
</aside>

  </article>
</main>








  <footer role="contentinfo">
  <div class="footer-inner">

    <div class="about-us">
      <h3 class="title">About Us</h3>
      <ul>
        <li><a href="http://oreilly.com/about/">Our Company</a></li>
        <li><a href="http://oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
        <li><a href="http://oreilly.com/careers/">Careers</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Contact Us</a></li>
      </ul>
    </div>
    <div class="site-map">
      <h3 class="title">Site Map</h3>
      <ul>
        <li><a href="/ideas">Ideas</a></li>
        <li><a href="/topics/oreilly-learning">Learning</a></li>
        <li><a href="/topics">Topics</a></li>
        <li><a href="/all">All</a></li>
      </ul>
    </div>
    <div class="social">
      <ul>
        <li><a   class="icon-link " href="https://www.facebook.com/OReilly/"><span class="icon icon-facebook t-fill icon--white icon--large">
  <svg role="img">
    <title>facebook</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#facebook"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://twitter.com/oreillymedia"><span class="icon icon-twitter t-fill icon--white icon--large">
  <svg role="img">
    <title>twitter</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#twitter"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.youtube.com/user/OreillyMedia"><span class="icon icon-youtube-large t-fill icon--white icon--large">
  <svg role="img">
    <title>youtube-large</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#youtube-large"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://plus.google.com/+oreillymedia"><span class="icon icon-google t-fill icon--white icon--large">
  <svg role="img">
    <title>google</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#google"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.linkedin.com/company/oreilly-media"><span class="icon icon-linkedin t-fill icon--white icon--large">
  <svg role="img">
    <title>linkedin</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#linkedin"></use>
  </svg>
</span></a>
</li>
      </ul>
    </div>
  </div>
  <div class="legal">
	  <a href="/" class="logo logo-block t-bkg logo--medium">
<svg>
   <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
</svg>
</a>
  	<p class="copyright">&copy; 2019 O'Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><br>
  <a class="t-c" href="http://oreilly.com/terms/">Terms of Service</a>  <span class="bullet">&bull;</span>	<a class="t-c" href="http://oreilly.com/privacy.html">Privacy Policy</a> <span class="bullet">&bull;</span> <a class="t-c" href="http://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a>
	</div>
	<figure class="animal"><img src="https://d3ebicv0uqgr7t.cloudfront.net/images/tarsier.png" class="animal-img" alt="Animal"></figure>
</footer>



  
  

    <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5P4V6Z"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
  

  
</body>
</html>
