<!DOCTYPE html>
<html lang="en">
<head>
  <title>Four short links: 25 August 2017 - O&#39;Reilly Media</title>

  <!-- Meta -->
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
      <meta property="twitter:card" content="summary_large_image" />
      <meta property="twitter:site" content="@OReillyMedia" />
      <meta property="twitter:title" content="Four short links: 25 August 2017" />
      <meta property="twitter:description" content="Mobile Clusters, Practicing Code, Speech Commands Data Set, and Robogami" />
      <meta property="description:site" content="Mobile Clusters, Practicing Code, Speech Commands Data Set, and Robogami" />
      <meta property="twitter:url" content="https://www.oreilly.com/ideas/four-short-links-25-august-2017" />
      <meta property="fb:pages" content="15137500430" />
      <meta property="og:type" content="article" />
      <meta property="og:site_name" content="O&#39;Reilly Media" />
      <meta property="og:title" content="Four short links: 25 August 2017" />
      <meta property="og:description" content="Mobile Clusters, Practicing Code, Speech Commands Data Set, and Robogami" />
      <meta property="og:url" content="https://www.oreilly.com/ideas/four-short-links-25-august-2017" />
      <meta property="article:published_time" content="2017-08-25T09:00:00Z" />
      <meta property="article:author" content="Nat Torkington" />
      <meta name="description" content="Mobile Clusters, Practicing Code, Speech Commands Data Set, and Robogami" />
      <meta name="author" content="Nat Torkington" />
      <meta name="date" content="2017-08-25" />
      <meta property="og:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" />
      <meta property="twitter:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" />
      <meta name="thumbnail" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" />
      <meta name="graphic_medium" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" />
      <meta name="oreilly:topic" content="Four Short Links" />
      <meta name="oreilly:keywords" content="Mobile Clusters,Practicing Code,Speech Commands Data Set,and Robogami" />
  
  

  <!-- Assets -->
  <script type="text/javascript" src="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-3167096fd7.js"></script>
  <link rel="stylesheet" type="text/css" href="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-7fbee17137.css">
    
  
  <!-- Extra Assets -->
  
  
  


  <!-- Start Adobe Digital Tag Manager Header-->
  <script type="text/javascript">
    dataLayer = [];
  </script>

    <script src="//assets.adobedtm.com/cdb881fdfcc417bad9035bdbc61f4a2b2135b110/satelliteLib-2d3d7e7aff56a08b02334ccd859df32171807210.js"></script>
  

  <!-- End Adobe Digital Tag Manager Header-->

  <script type="text/javascript">
    // init app.events for all communication
    app.events = new orm.Events();

    var tempData = {"content_type":"text","flag":{"flag-slug":"four-short-links","flag-title":"Four Short Links","flag-url":"/topics/four-short-links","parent-topic-slug":"four-short-links"},"gateway_api_url":"https://gateway.oreilly.com","icons-svg":"/assets/icons-8812ab3f83.svg","post_info":{"byline":{"authors":[{"first-name":"Nat","last-name":"Torkington","url":"/people/1f103-nathan-torkington"}]},"excerpt":"\u003col\u003e\r\n\u003cli\u003e\r\n\u003ca href=\"https://www.usenix.org/conference/hotcloud17/program/presentation/shahrad\"\u003eTowards Deploying Decommissioned Mobile Devices as Cheap Energy-Efficient Compute Nodes\u003c/a\u003e -- clever!  \u003ci\u003eThe average number of CPU cores per device for the 350 mobile devices we studied is about 5.6 (M=5.55, SD=1.97). This means our 2U server could fit around 470 cores and the core density would be 235 cores/1U.\u003c/i\u003e (via \u003ca href=\"https://blog.acolyer.org/2017/08/25/towards-deploying-decommissioned-mobile-devices-as-cheap-energy-efficient-compute-nodes/\"\u003ePaper a Day\u003c/a\u003e)\u003c/li\u003e\r\n\u003cli\u003e\r\n\u003ca href=\"https://ericdouglas.github.io/2017/08/24/practicing-the-elixir-language/\"\u003ePracticing Any Programming Language\u003c/a\u003e -- share with the learner in your life.\u003c/li\u003e\r\n\u003cli\u003e\r\n\u003ca href=\"https://research.googleblog.com/2017/08/launching-speech-commands-dataset.html\"\u003eSpeech Commands Data Set\u003c/a\u003e -- Google releasing \u003ci\u003e65,000 one-second long utterances of 30 short words, by thousands of different people\u003c/i\u003e under a CC license.\u003c/li\u003e\r\n\u003cli\u003e\r\n\u003ca href=\"http://cfg.mit.edu/sites/cfg.mit.edu/files/robogami.pdf\"\u003eInteractive Robogami : An End-to-End System for Design of Robots with Ground Locomotion\u003c/a\u003e -- \u003ci\u003eUsing Interactive Robogami, designers can compose new robot designs from a database of print and fold parts. The designs are tested for the users’ functional specifications via simulation and fabricated upon user satisfaction. We present six robots designed and fabricated using a 3D printing based approach, as well as a larger robot cut from sheet metal. We have also conducted a user study that demonstrates our tool is intuitive for novice designers and expressive enough to create a wide variety of ground robot designs.\u003c/i\u003e\r\n\u003c/li\u003e\r\n\u003c/ol\u003e\r\n","title":"Four short links: 25 August 2017"},"post_slug":"four-short-links-25-august-2017","production":true,"segment_write":"c1bqZBPpSt05Stv3bKthxtFmC2etfgEK"};

    var kalturaVideoId = "";
    var kalturaAccount = "";
    var kalturaPlayer = "";

    // This should be genetated on the API directly.
    tempData.allTopics = [{"flag-title":"Money","flag-slug":"money"},{"flag-title":"Internet of Things","flag-slug":"internet-of-things","parent-topic-slug":"data"},{"flag-title":"Open Source","flag-slug":"open-source","parent-topic-slug":"software-engineering"},{"flag-title":"Data marketplace","flag-slug":"data-marketplace","parent-topic-slug":"data"},{"flag-title":"Cognitive augmentation","flag-slug":"cognitive-augmentation","parent-topic-slug":"data"},{"flag-title":"Software Architecture","flag-slug":"software-architecture","parent-topic-slug":"software-engineering"},{"flag-title":"Economy","flag-slug":"economy"},{"flag-title":"Data science","flag-slug":"data-science","parent-topic-slug":"data"},{"flag-title":"Design and Business","flag-slug":"design-and-business","parent-topic-slug":"design"},{"flag-title":"Data perils","flag-slug":"data-perils","parent-topic-slug":"data"},{"flag-title":"Data design","flag-slug":"data-design","parent-topic-slug":"data"},{"flag-title":"Data","flag-slug":"data"},{"flag-title":"Data culture","flag-slug":"data-culture","parent-topic-slug":"data"},{"flag-title":"Software Engineering","flag-slug":"software-engineering"},{"flag-title":"Data Tools","flag-slug":"data-tools","parent-topic-slug":"data"},{"flag-title":"Design","flag-slug":"design"},{"flag-title":"Artificial intelligence","flag-slug":"artificial-intelligence","parent-topic-slug":"data"}];

    // Add metrics, using a different write key for dev than for prod
    injectSegment(tempData.segment_write)

    $(function() {
      app.metrics = new orm.Metrics();
      app.metrics.pageView();

      app.pageInit(tempData);

      // load data into events so it dispatched 'data:loaded'
      app.events.addData(tempData);
    })
  </script>

  <!-- Start Visual Website Optimizer Asynchronous Code -->
  <script type='text/javascript'>
    var _vwo_code=(function(){
    var account_id=244658,
    settings_tolerance=2000,
    library_tolerance=2500,
    use_existing_jquery=false,
  // DO NOT EDIT BELOW THIS LINE
  f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
  </script>
  <!-- End Visual Website Optimizer Asynchronous Code -->

</head>
<body class="body t-four-short-links" data-section="ideas" >
  <div class="flashes"></div>
    <header id="page-header">
  <div id="header-bar" class="t-bkg">
    <h1 class="logo t-bkg" >
  <a href="/" class=" logo-white ">
  <svg role="heading" aria-label="O'Reilly">
    <title>O'Reilly</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
  </svg>
  </a>
</h1>
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    
    
    <div class="right invert">
      <div id="search" class="hide">
        <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
      </div>
      <div id="user">
        <a href="#feedback"  class="t-c--d feedback" id="feedback">Feedback</a>
        <a class="t-c--d login" id="log-in-loading">Loading...</a>
        <a href="?log-in" class="t-c--d login" id="log-in">Log in</a>
        <a href="?log-out" class="t-c--d capture_end_session login" id="log-out">Log out</a>
        <a href="/user/preferences"  class="t-c--d login" id="preferences"><span class="icon icon-configure icon--small t-fill ">
  <svg role="img">
    <title>configure</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#configure"></use>
  </svg>
</span></a>
      </div>
    </div>
    <a id="menu-toggle" class="invert" ><span class="icon icon-white icon-menu">
  <svg role="img" id="close" class="is-hidden">
    <title>Close Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#close"></use>
  </svg>
  <svg role="img" id="open">
    <title>Open Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#menu"></use>
  </svg>
</span></a>
  </div>
     <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

  
  <div id="mobile-menu">
    
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
         <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

    
  </div>

</header>


  <!-- Linked In -->
  <script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
  
<!-- Load Facebook SDK for JavaScript -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<main aria-live="polite">
  <article class="article" itemscope itemtype="http://schema.org/Article">
              <header class="article-header">
        <div class="flag-follow " data-status="" id="">
      <div class="flag t-bkg--before bg-four-short-links--before flag--small">
  
            <a href="/topics/four-short-links" >Four Short Links</a>
    
    
  
</div>
  
  <span class="cta">
    <span class="icons">
      
      
    </span>
    <span class="messages">
      
      
    </span>
</span>
</div>

  
  

  

  <h1 class="title t-c" itemprop="headline">Four short links: 25 August 2017</h1>

      <p class="dek" itemprop="alternativeHeadline">Mobile Clusters, Practicing Code, Speech Commands Data Set, and Robogami</p>
  

  <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1f103-nathan-torkington" itemprop="name">Nat Torkington</a></span>
</div> <time class="date">August 25, 2017</time>

</header>

      

      <div class="article-body" itemprop="articleBody">
        
                              <figure class="article-image right">
  <img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" alt="Four short links." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 1440w" sizes="(min-width: 1390px) 420px, (min-width: 600px) 45vw, 100vw" class=""/>
  <figcaption>Four short links.
    
    
  <figcaption>

</figure>
          
          
        

        

        <ol>
<li>
<a href="https://www.usenix.org/conference/hotcloud17/program/presentation/shahrad">Towards Deploying Decommissioned Mobile Devices as Cheap Energy-Efficient Compute Nodes</a> -- clever!  <i>The average number of CPU cores per device for the 350 mobile devices we studied is about 5.6 (M=5.55, SD=1.97). This means our 2U server could fit around 470 cores and the core density would be 235 cores/1U.</i> (via <a href="https://blog.acolyer.org/2017/08/25/towards-deploying-decommissioned-mobile-devices-as-cheap-energy-efficient-compute-nodes/">Paper a Day</a>)</li>
<li>
<a href="https://ericdouglas.github.io/2017/08/24/practicing-the-elixir-language/">Practicing Any Programming Language</a> -- share with the learner in your life.</li>
<li>
<a href="https://research.googleblog.com/2017/08/launching-speech-commands-dataset.html">Speech Commands Data Set</a> -- Google releasing <i>65,000 one-second long utterances of 30 short words, by thousands of different people</i> under a CC license.</li>
<li>
<a href="http://cfg.mit.edu/sites/cfg.mit.edu/files/robogami.pdf">Interactive Robogami : An End-to-End System for Design of Robots with Ground Locomotion</a> -- <i>Using Interactive Robogami, designers can compose new robot designs from a database of print and fold parts. The designs are tested for the users’ functional specifications via simulation and fabricated upon user satisfaction. We present six robots designed and fabricated using a 3D printing based approach, as well as a larger robot cut from sheet metal. We have also conducted a user study that demonstrates our tool is intuitive for novice designers and expressive enough to create a wide variety of ground robot designs.</i>
</li>
</ol>

        
        
                  
        

                      <div class="image-credit">
  Article image: Four short links.
    
    
</div>
          

          

        </div>
      </div>

        <div class="article-meta">

  <div class="article-share">
  <div class="article-share-text"> Share </div>
  <ol>
    <li><a href="https://twitter.com/share" class="twitter-share-button" data-via="oreillymedia" data-show-count="false">Tweet</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></li>
    <li>  <div class="fb-share-button" 
    data-href="https://www.oreilly.com/ideas/four-short-links-25-august-2017" 
    data-layout="button_count">
  </div></li>
    <li><script type="IN/Share" data-url="https://www.oreilly.com/ideas/four-short-links-25-august-2017" data-counter="right"></script></li>
  </ol>
  <hr>
</div>

  

      <article class="block block-common with-img person with-link">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/people/1f103-nathan-torkington"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x360/nat-torkington-crop-c417a5acf583f8af99e316f6a043258a.jpg" alt="Nat Torkington" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x360/nat-torkington-crop-c417a5acf583f8af99e316f6a043258a.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x720/nat-torkington-crop-c417a5acf583f8af99e316f6a043258a.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x1440/nat-torkington-crop-c417a5acf583f8af99e316f6a043258a.jpg 1440w"  class=""/></a>
    
    
  </div>
  

  

  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/people/1f103-nathan-torkington">Nat Torkington</a>
    
    
    </h2>
    

    
          <p class="dek">Nat Torkington has been active in web development since the early days of the web.  He wrote the bestselling Perl Cookbook, and chaired conferences for O'Reilly Media for a decade.  During his time at O'Reilly Media, Nat was an editor and then became a trend-spotter for the O'Reilly Radar group, identifying the topics to build events and books around.  He has worked in areas as diverse as networking, publishing, science, edtech, and NLP.  He now lives in New Zealand, where he runs Kiwi Foo Camp and helps startups grow.  
</p>

    
          <a class="btn btn--xsmall" style="float: right;" href="/people/1f103-nathan-torkington">more</a>
    
  </div>
</article>

  

</div>


        <hr class="t-bkg section-divider" />


        <aside class="article-related">
      <section class="block-rows columns-4 ">

    

    <section class="block-group">
                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/four-short-links-1-july-2016"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" alt="Four Short Links" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-four-short-links--before">
  
            <a href="/topics/four-short-links" >Four Short Links</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/four-short-links-1-july-2016">Four short links: 1 July 2016</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1f103-nathan-torkington" itemprop="name">Nat Torkington</a></span>
</div>
    
          <p class="dek">Interactive Machine Learning, Pattern Recognition Tutorials, AI Safety, and Decentralised Web</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/four-short-links-8-november-2016"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" alt="Four short links" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-four-short-links--before">
  
            <a href="/topics/four-short-links" >Four Short Links</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/four-short-links-8-november-2016">Four short links: 8 November 2016</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1f103-nathan-torkington" itemprop="name">Nat Torkington</a></span>
</div>
    
          <p class="dek">Photoshop for Speech, Magic Leap, Someone Else's Problem, COBOL Microframework</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/four-short-links-24-january-2017"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" alt="Four short links." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-four-short-links--before">
  
            <a href="/topics/four-short-links" >Four Short Links</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/four-short-links-24-january-2017">Four short links: 24 January 2017</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1f103-nathan-torkington" itemprop="name">Nat Torkington</a></span>
</div>
    
          <p class="dek">Doomsday Prep, Printing Skin, Autonomous Skepticism, and Slow Wifi</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/four-short-links-27-june-2016"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" alt="Four short links" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-four-short-links--before">
  
            <a href="/topics/four-short-links" >Four Short Links</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/four-short-links-27-june-2016">Four short links: 27 June 2016</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1f103-nathan-torkington" itemprop="name">Nat Torkington</a></span>
</div>
    
          <p class="dek">Tracking Sports, Structural Mapping at Scale, Systems that Don't Suck, and Yak-Shaving-First Development</p>

    
    
  </div>
</article>

      
  	</section>
    

</section>
  
</aside>

      </div>
    </div>
  </article>
</main>








  <footer role="contentinfo">
  <div class="footer-inner">

    <div class="about-us">
      <h3 class="title">About Us</h3>
      <ul>
        <li><a href="http://oreilly.com/about/">Our Company</a></li>
        <li><a href="http://oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
        <li><a href="http://oreilly.com/careers/">Careers</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Contact Us</a></li>
      </ul>
    </div>
    <div class="site-map">
      <h3 class="title">Site Map</h3>
      <ul>
        <li><a href="/ideas">Ideas</a></li>
        <li><a href="/learning">Learning</a></li>
        <li><a href="/topics">Topics</a></li>
        <li><a href="/all">All</a></li>
      </ul>
    </div>
    <div class="social">
      <ul>
        <li><a   class="icon-link " href="http://fb.co/OReilly"><span class="icon icon-facebook t-fill icon--white icon--large">
  <svg role="img">
    <title>facebook</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#facebook"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="http://twitter.com/oreillymedia"><span class="icon icon-twitter t-fill icon--white icon--large">
  <svg role="img">
    <title>twitter</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#twitter"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.youtube.com/user/OreillyMedia"><span class="icon icon-youtube-large t-fill icon--white icon--large">
  <svg role="img">
    <title>youtube-large</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#youtube-large"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://plus.google.com/+oreillymedia"><span class="icon icon-google t-fill icon--white icon--large">
  <svg role="img">
    <title>google</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#google"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.linkedin.com/company/oreilly-media"><span class="icon icon-linkedin t-fill icon--white icon--large">
  <svg role="img">
    <title>linkedin</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#linkedin"></use>
  </svg>
</span></a>
</li>
      </ul>
    </div>
  </div>
  <div class="legal">
	  <a href="/" class="logo logo-block t-bkg logo--medium">
<svg>
   <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
</svg>
</a>
  	<p class="copyright">&copy; 2017 O'Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><br>
  <a class="t-c" href="http://oreilly.com/terms/">Terms of Service</a>  <span class="bullet">&bull;</span>	<a class="t-c" href="http://oreilly.com/privacy.html">Privacy Policy</a> <span class="bullet">&bull;</span> <a class="t-c" href="http://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a>
	</div>
	<figure class="animal"><img src="https://d3ebicv0uqgr7t.cloudfront.net/images/tarsier.png" class="animal-img" alt="Animal"></figure>
</footer>



  
  
    <!-- Start Adobe Digital Tag Manager -->
  <script type="text/javascript">_satellite && _satellite.pageBottom();</script>
  <!-- End Adobe Digital Tag Manager -->
  
</body>
</html>
