<!DOCTYPE html>
<html lang="en">
<head>
  <title>Four short links: 6 December 2018 - O&#39;Reilly Media</title>

  <!-- Meta -->
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
      <meta property="twitter:card" content="summary_large_image" />
      <meta property="twitter:site" content="@OReillyMedia" />
      <meta property="twitter:title" content="Four short links: 6 December 2018" />
      <meta property="twitter:description" content="Public Domain, Optimistic Sci-Fi, C64 Defrag, and Quantum Computing" />
      <meta property="description:site" content="Public Domain, Optimistic Sci-Fi, C64 Defrag, and Quantum Computing" />
      <meta property="twitter:url" content="https://www.oreilly.com/ideas/four-short-links-6-december-2018" />
      <meta property="fb:pages" content="15137500430" />
      <meta property="og:type" content="article" />
      <meta property="og:site_name" content="O&#39;Reilly Media" />
      <meta property="og:title" content="Four short links: 6 December 2018" />
      <meta property="og:description" content="Public Domain, Optimistic Sci-Fi, C64 Defrag, and Quantum Computing" />
      <meta property="og:url" content="https://www.oreilly.com/ideas/four-short-links-6-december-2018" />
      <meta property="article:published_time" content="2018-12-06T12:15:00Z" />
      <meta property="article:author" content="Nat Torkington" />
      <meta name="description" content="Public Domain, Optimistic Sci-Fi, C64 Defrag, and Quantum Computing" />
      <meta name="author" content="Nat Torkington" />
      <meta name="date" content="2018-12-06" />
      <meta property="og:image" content="https://d3ucjech6zwjp8.cloudfront.net/1400x933/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" />
      <meta property="twitter:image" content="https://d3ucjech6zwjp8.cloudfront.net/1400x933/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" />
      <meta name="thumbnail" content="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" />
      <meta name="graphic_medium" content="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" />
      <meta name="oreilly:topic" content="Four Short Links" />
      <meta name="oreilly:keywords" content="Public Domain,Optimistic Sci-Fi,C64 Defrag,and Quantum Computing" />
  
  

  <!-- Assets -->
  <script type="text/javascript" src="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-f09526a22a.js"></script>
  <link rel="stylesheet" type="text/css" href="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-e83b91017e.css">
    
  
  <!-- Extra Assets -->
  
  
  

  <link rel="stylesheet" type="text/css" href="https://cdn.oreillystatic.com/assets/css/mkto-multiform-subscribe-20180320.css">

  <script type="text/javascript">
    dataLayer = [];
  </script>

    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5P4V6Z');</script>
  <!-- End Google Tag Manager -->
  

  

    <script type="text/javascript">
    function createKeenWebAutoCollector(){window.keenWebAutoCollector=window.KeenWebAutoCollector.create({projectId:'551456c8672e6c2f4f5ee426',writeKey:'e737a463e3a57a914ddf707a34ad2c319c2e1c52999fe5f8087e41a71676675f90298cfd1a4e30ecf3f25e337db4b579c28c2bf784b26bdd6e9b7cc595b045098b94483dea878b17a65a56b5307b97ac3834670c2484fb8effa01cbacd55dba355850b97cad116b4b0e434dc64bc359c',onloadCallbacks:window.keenWebAutoCollector.onloadCallbacks}),window.keenWebAutoCollector.loaded()}function initKeenWebAutoCollector(){window.keenWebAutoCollector.domReady()?window.createKeenWebAutoCollector():document.addEventListener("readystatechange",function(){window.keenWebAutoCollector.domReady()&&window.createKeenWebAutoCollector()})}window.keenWebAutoCollector={onloadCallbacks:[],onload:function(a){this.onloadCallbacks.push(a)},domReady:function(){return["ready","complete"].indexOf(document.readyState)>-1}};
  </script>
  <script async type="text/javascript" src="https://d26b395fwzu5fz.cloudfront.net/keen-web-autocollector-1.0.8.min.js" onload="initKeenWebAutoCollector()"></script>
  

  <script type="text/javascript">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</script>

  <!-- Start Visual Website Optimizer Asynchronous Code -->
  <script type='text/javascript'>
    var _vwo_code=(function(){
    var account_id=244658,
    settings_tolerance=2000,
    library_tolerance=2500,
    use_existing_jquery=false,
  // DO NOT EDIT BELOW THIS LINE
  f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
  </script>
  <!-- End Visual Website Optimizer Asynchronous Code -->

  <!-- Marketo -->
  <script src="https://app-ab24.marketo.com/js/forms2/js/forms2.min.js" type="text/javascript"></script>

</head>
<body class="body t-four-short-links" data-section="ideas" >
  <div class="flashes"></div>
    <header id="page-header">
  <div id="header-bar" class="t-bkg">
    <h1 class="logo t-bkg" >
  <a href="/" class=" logo-white ">
  <svg role="heading" aria-label="O'Reilly">
    <title>O'Reilly</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
  </svg>
  </a>
</h1>
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>


    <div class="right">
      <div id="search" class="hide">
        <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
      </div>
      <div id="user">
        <a href="https://www.oreilly.com/sign-in.html" class="t-c--d">Sign In</a>
      </div>
    </div>
    <a id="menu-toggle" class="invert" ><span class="icon icon-white icon-menu">
  <svg role="img" id="close" class="is-hidden">
    <title>Close Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#close"></use>
  </svg>
  <svg role="img" id="open">
    <title>Open Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#menu"></use>
  </svg>
</span></a>
  </div>
     <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/jupyter" >Jupyter</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

  
  <div id="mobile-menu">

    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
         <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/jupyter" >Jupyter</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

    
  </div>

</header>



  <!-- Linked In -->
  <script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
  
<!-- Load Facebook SDK for JavaScript -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<main aria-live="polite">
  <article class="article" itemscope itemtype="http://schema.org/Article">
              <header class="article-header">
      <div class="flag t-bkg--before bg-four-short-links--before flag--small">
  
            <a href="/topics/four-short-links" >Four Short Links</a>
    
    
  
</div>
  
  

  <h1 class="title t-c" itemprop="headline">Four short links: 6 December 2018</h1>

      <p class="dek" itemprop="alternativeHeadline">Public Domain, Optimistic Sci-Fi, C64 Defrag, and Quantum Computing</p>
  

  <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1f103-nathan-torkington" itemprop="name">Nat Torkington</a></span>
</div> <time class="date">December 6, 2018</time>

</header>

      

      <div class="article-body" itemprop="articleBody">
        
                              <figure class="article-image right">
  <img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" alt="Four short links" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 1440w" sizes="(min-width: 1390px) 420px, (min-width: 600px) 45vw, 100vw" class=""/>
  <figcaption>Four short links
    
    
  <figcaption>

</figure>
          
          
        

        

        <ol>
<li>
<a href="https://creativecommons.org/2018/12/05/join-us-for-a-grand-re-opening-of-the-public-domain/">Re-Opening of the Public Domain</a> (Creative Commons) -- after years of legal extension of copyright terms, 2019 will be the first year in which new materials fall into the American public domain, and Creative Commons is throwing a bash at the Internet Archive.</li>
<li>
<a href="https://www.theverge.com/2018/12/5/18055980/better-worlds-science-fiction-short-stories-video">Better Worlds</a> (The Verge) -- <i>starting on January 14th, we’ll be publishing Better Worlds: 10 original fiction stories, five animated adaptations, and five audio adaptations by a diverse roster of science fiction authors who take a more optimistic view of what lies ahead in ways both large and small, fantastical and everyday.</i> Necessary! I heard a great interview with <a href="https://medium.com/conversations-with-tyler/tyler-cowen-robert-wiblin-stubborn-attachments-80000-hours-podcast-359aa62aa8ab">Tyler Cowen</a> where he said, <i>"you cannot live with pessimism, right? There’s also a notion that more optimism is a partially self-fulfilling prophecy. Believing pessimistic views might make them more likely to come about."</i> It is a fallacy to conflate optimism with naivete.</li>
<li>
<a href="https://www.pagetable.com/?p=978">A Disk Defragmenter for the Commodore 64</a> -- I don't know what's more insane: watching a great 40x25 homage to the classic Windows defrag progress screen or reading the bonkers BASIC code behind it.</li>
<li>
<a href="https://www.nap.edu/catalog/25196/quantum-computing-progress-and-prospects">Quantum Computing Progress and Prospects</a>  -- <i>an introduction to the field, including the unique characteristics and constraints of the technology, and assesses the feasibility and implications of creating a functional quantum computer capable of addressing real-world problems. This report considers hardware and software requirements, quantum algorithms, drivers of advances in quantum computing and quantum devices, benchmarks associated with relevant use cases, the time and resources required, and how to assess the probability of success.</i> Separate the hype from the reality and develop a sense of the probability of different possible evolutionary paths for the technology.</li>
</ol>


        
                  
        

                  <div class="image-credit">
  Article image: Four short links
    
    
</div>
        

        

      </div>

      <div class="article-meta">

  <div class="article-share">
  <div class="article-share-text"> Share </div>
  <ol>
    <li><a href="https://twitter.com/share" class="twitter-share-button" data-via="oreillymedia" data-show-count="false">Tweet</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></li>
    <li>  <div class="fb-share-button" 
    data-href="https://www.oreilly.com/ideas/four-short-links-6-december-2018" 
    data-layout="button_count">
  </div></li>
    <li><script type="IN/Share" data-url="https://www.oreilly.com/ideas/four-short-links-6-december-2018" data-counter="right"></script></li>
  </ol>
  <hr>
</div>

  

      <article class="block block-common with-img person with-link">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/people/1f103-nathan-torkington"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x360/nat-torkington-crop-c417a5acf583f8af99e316f6a043258a.jpg" alt="Nat Torkington" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x360/nat-torkington-crop-c417a5acf583f8af99e316f6a043258a.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x720/nat-torkington-crop-c417a5acf583f8af99e316f6a043258a.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x1440/nat-torkington-crop-c417a5acf583f8af99e316f6a043258a.jpg 1440w"  class=""/></a>
    
    
  </div>
  

  

  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/people/1f103-nathan-torkington">Nat Torkington</a>
    
    
    </h2>
    

    
          <p class="dek">Nat Torkington has been active in web development since the early days of the web.  He wrote the bestselling Perl Cookbook, and chaired conferences for O'Reilly Media for a decade.  During his time at O'Reilly Media, Nat was an editor and then became a trend-spotter for the O'Reilly Radar group, identifying the topics to build events and books around.  He has worked in areas as diverse as networking, publishing, science, edtech, and NLP.  He now lives in New Zealand, where he runs Kiwi Foo Camp and helps startups grow.  
</p>

    
          <a class="btn btn--xsmall" style="float: right;" href="/people/1f103-nathan-torkington">more</a>
    
  </div>
</article>

  

</div>


      <hr class="t-bkg section-divider" />


      <aside class="article-related">
      <section class="block-rows columns-4 ">

    

    <section class="block-group">
                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/four-short-links-1-july-2016"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" alt="Four Short Links" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-four-short-links--before">
  
            <a href="/topics/four-short-links" >Four Short Links</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/four-short-links-1-july-2016">Four short links: 1 July 2016</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1f103-nathan-torkington" itemprop="name">Nat Torkington</a></span>
</div>
    
          <p class="dek">Interactive Machine Learning, Pattern Recognition Tutorials, AI Safety, and Decentralised Web</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/four-short-links-8-november-2016"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" alt="Four short links" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-four-short-links--before">
  
            <a href="/topics/four-short-links" >Four Short Links</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/four-short-links-8-november-2016">Four short links: 8 November 2016</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1f103-nathan-torkington" itemprop="name">Nat Torkington</a></span>
</div>
    
          <p class="dek">Photoshop for Speech, Magic Leap, Someone Else's Problem, COBOL Microframework</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/four-short-links-24-january-2017"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" alt="Four short links." srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-four-short-links--before">
  
            <a href="/topics/four-short-links" >Four Short Links</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/four-short-links-24-january-2017">Four short links: 24 January 2017</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1f103-nathan-torkington" itemprop="name">Nat Torkington</a></span>
</div>
    
          <p class="dek">Doomsday Prep, Printing Skin, Autonomous Skepticism, and Slow Wifi</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/four-short-links-25-january-2018"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png" alt="Four short links" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/4-short-links-logo-1400x750-9403d1b09c631442afebfc33c385755e.png 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-four-short-links--before">
  
            <a href="/topics/four-short-links" >Four Short Links</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/four-short-links-25-january-2018">Four short links: 25 January 2018</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1f103-nathan-torkington" itemprop="name">Nat Torkington</a></span>
</div>
    
          <p class="dek">Young Developers Coding Later, Algorithmic Fairness, Google Goss, and Deep Learned Folk Music</p>

    
    
  </div>
</article>

      
  	</section>
    

</section>
  
</aside>

  </article>
</main>








  <footer role="contentinfo">
  <div class="footer-inner">

    <div class="about-us">
      <h3 class="title">About Us</h3>
      <ul>
        <li><a href="http://oreilly.com/about/">Our Company</a></li>
        <li><a href="http://oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
        <li><a href="http://oreilly.com/careers/">Careers</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Contact Us</a></li>
      </ul>
    </div>
    <div class="site-map">
      <h3 class="title">Site Map</h3>
      <ul>
        <li><a href="/ideas">Ideas</a></li>
        <li><a href="/topics/oreilly-learning">Learning</a></li>
        <li><a href="/topics">Topics</a></li>
        <li><a href="/all">All</a></li>
      </ul>
    </div>
    <div class="social">
      <ul>
        <li><a   class="icon-link " href="https://www.facebook.com/OReilly/"><span class="icon icon-facebook t-fill icon--white icon--large">
  <svg role="img">
    <title>facebook</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#facebook"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://twitter.com/oreillymedia"><span class="icon icon-twitter t-fill icon--white icon--large">
  <svg role="img">
    <title>twitter</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#twitter"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.youtube.com/user/OreillyMedia"><span class="icon icon-youtube-large t-fill icon--white icon--large">
  <svg role="img">
    <title>youtube-large</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#youtube-large"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://plus.google.com/+oreillymedia"><span class="icon icon-google t-fill icon--white icon--large">
  <svg role="img">
    <title>google</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#google"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.linkedin.com/company/oreilly-media"><span class="icon icon-linkedin t-fill icon--white icon--large">
  <svg role="img">
    <title>linkedin</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#linkedin"></use>
  </svg>
</span></a>
</li>
      </ul>
    </div>
  </div>
  <div class="legal">
	  <a href="/" class="logo logo-block t-bkg logo--medium">
<svg>
   <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
</svg>
</a>
  	<p class="copyright">&copy; 2018 O'Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><br>
  <a class="t-c" href="http://oreilly.com/terms/">Terms of Service</a>  <span class="bullet">&bull;</span>	<a class="t-c" href="http://oreilly.com/privacy.html">Privacy Policy</a> <span class="bullet">&bull;</span> <a class="t-c" href="http://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a>
	</div>
	<figure class="animal"><img src="https://d3ebicv0uqgr7t.cloudfront.net/images/tarsier.png" class="animal-img" alt="Animal"></figure>
</footer>



  
  

    <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5P4V6Z"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
  

  
</body>
</html>
