<!DOCTYPE html>
<html lang="en">
<head>
  <title>Integrating Agile and UX design - O&#39;Reilly Media</title>

  <!-- Meta -->
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
      <meta property="twitter:card" content="summary_large_image" />
      <meta property="twitter:site" content="@OReillyMedia" />
      <meta property="twitter:title" content="Integrating Agile and UX design" />
      <meta property="twitter:description" content="Evolving the process of digital product creation." />
      <meta property="description:site" content="Evolving the process of digital product creation." />
      <meta property="twitter:url" content="https://www.oreilly.com/ideas/integrating-agile-and-ux-design" />
      <meta property="og:type" content="article" />
      <meta property="og:site_name" content="O&#39;Reilly Media" />
      <meta property="og:title" content="Integrating Agile and UX design" />
      <meta property="og:description" content="Evolving the process of digital product creation." />
      <meta property="og:url" content="https://www.oreilly.com/ideas/integrating-agile-and-ux-design" />
      <meta property="article:published_time" content="2017-05-02T13:15:00Z" />
      <meta property="article:author" content="Jonathan Follett" />
      <meta name="description" content="Evolving the process of digital product creation." />
      <meta name="author" content="Jonathan Follett" />
      <meta name="date" content="2017-05-02" />
      <meta property="og:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/its_raining_umbrellas_again_-_panoramio_crop-2894d508ce68b7b2ac166093fb343bf2.jpg" />
      <meta property="twitter:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/its_raining_umbrellas_again_-_panoramio_crop-2894d508ce68b7b2ac166093fb343bf2.jpg" />
      <meta name="thumbnail" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/its_raining_umbrellas_again_-_panoramio_crop-2894d508ce68b7b2ac166093fb343bf2.jpg" />
      <meta name="graphic_medium" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/its_raining_umbrellas_again_-_panoramio_crop-2894d508ce68b7b2ac166093fb343bf2.jpg" />
      <meta name="oreilly:topic" content="Design" />
      <meta name="oreilly:keywords" content="design,ux,lean startup,lean ux,agile,digital product creation" />
  
  

  <!-- Assets -->
  <script type="text/javascript" src="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-8f2cd28b01.js"></script>
  <link rel="stylesheet" type="text/css" href="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-6a8f319913.css">
    
  
  <!-- Extra Assets -->
  
  
  


  <!-- Start Adobe Digital Tag Manager Header-->
  <script type="text/javascript">
    dataLayer = [];
  </script>

    <script src="//assets.adobedtm.com/cdb881fdfcc417bad9035bdbc61f4a2b2135b110/satelliteLib-2d3d7e7aff56a08b02334ccd859df32171807210.js"></script>
  

  <!-- End Adobe Digital Tag Manager Header-->

  <script type="text/javascript">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</script>

  <!-- Start Visual Website Optimizer Asynchronous Code -->
  <script type='text/javascript'>
    var _vwo_code=(function(){
    var account_id=244658,
    settings_tolerance=2000,
    library_tolerance=2500,
    use_existing_jquery=false,
  // DO NOT EDIT BELOW THIS LINE
  f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
  </script>
  <!-- End Visual Website Optimizer Asynchronous Code -->

</head>
<body class="body t-design" data-section="ideas" >
  <div class="flashes"></div>
    <header id="page-header">
  <div id="header-bar" class="t-bkg">
    <h1 class="logo t-bkg" >
  <a href="/" class=" logo-white ">
  <svg role="heading" aria-label="O'Reilly">
    <title>O'Reilly</title>
    <use xlink:href="/assets/icons-b21895638b.svg#oreilly-logo"></use>
  </svg>
  </a>
</h1>
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="/learning">Learning</a>
              <a href="http://www.oreilly.com/conferences/">Events</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    
    
    <div class="right invert">
      <div id="search" class="hide">
        <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-b21895638b.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
      </div>
      <div id="user">
        <a href="#feedback"  class="t-c--d feedback" id="feedback">Feedback</a>
        <a class="t-c--d login" id="log-in-loading">Loading...</a>
        <a href="?log-in" class="t-c--d login" id="log-in">Log in</a>
        <a href="?log-out" class="t-c--d capture_end_session login" id="log-out">Log out</a>
        <a href="/user/preferences"  class="t-c--d login" id="preferences"><span class="icon icon-configure icon--small t-fill ">
  <svg role="img">
    <title>configure</title>
    <use xlink:href="/assets/icons-b21895638b.svg#configure"></use>
  </svg>
</span></a>
      </div>
    </div>
    <a id="menu-toggle" class="invert" ><span class="icon icon-white icon-menu">
  <svg role="img" id="close" class="is-hidden">
    <title>Close Menu</title>
    <use xlink:href="/assets/icons-b21895638b.svg#close"></use>
  </svg>
  <svg role="img" id="open">
    <title>Open Menu</title>
    <use xlink:href="/assets/icons-b21895638b.svg#menu"></use>
  </svg>
</span></a>
  </div>
     <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

  
  <div id="mobile-menu">
    
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="/learning">Learning</a>
              <a href="http://www.oreilly.com/conferences/">Events</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-b21895638b.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
         <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

    
  </div>

</header>


  <main aria-live="polite">
  <article class="article" itemscope itemtype="http://schema.org/Article">
              <header class="article-header">
        <div class="flag-follow " data-status="" id="">
      <div class="flag t-bkg--before bg-design--before flag--small">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
  
  <span class="cta">
    <span class="icons">
      
      
    </span>
    <span class="messages">
      
      
    </span>
</span>
</div>

  
  

  

  <h1 class="title t-c" itemprop="headline">Integrating Agile and UX design</h1>

      <p class="dek" itemprop="alternativeHeadline">Evolving the process of digital product creation.</p>
  

  <div class="byline">
  
  By
  <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/7a496-jon-follett" itemprop="name">Jonathan Follett</a></span></div> <time class="date">May 2, 2017</time>

</header>
      

      <div class="article-body" itemprop="articleBody">
        
                              <figure class="article-image right">
  <img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/its_raining_umbrellas_again_-_panoramio_crop-2894d508ce68b7b2ac166093fb343bf2.jpg" alt="Its raining umbrellas again." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/its_raining_umbrellas_again_-_panoramio_crop-2894d508ce68b7b2ac166093fb343bf2.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/its_raining_umbrellas_again_-_panoramio_crop-2894d508ce68b7b2ac166093fb343bf2.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/its_raining_umbrellas_again_-_panoramio_crop-2894d508ce68b7b2ac166093fb343bf2.jpg 1440w" sizes="(min-width: 1390px) 420px, (min-width: 600px) 45vw, 100vw" class=""/>
  <figcaption>Its raining umbrellas again.
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://commons.wikimedia.org/wiki/File:Its_raining_umbrellas_again_-_panoramio.jpg">Robert Dimov on Wikimedia Commons</a>).
        
        
      </span>
    
    
  <figcaption>
</figure>
          
                      <aside data-type="note">
  <p>To learn why Agile and Lean methodologies have transformed the way product teams work, check out the live online training <a href="https://www.safaribooksonline.com/live-training/courses/agile-for-everybody/0636920084389/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=20170501_follett_integrating_agile_ux_post_top_cta_agile_for_everybody_online_training">Agile for Everybody</a>, led by Matt LeMay.</p>
</aside>

          
        

        

        <p>Of all the modern methodologies for software development, perhaps none is so important, impactful, challenging, and rewarding as Agile. Much ink and many pixels have been devoted to documenting its various permutations—from Scrum to extreme programming (XP), feature-driven development (FDD) to Kanban, and everything in between. Suffice it to say, this article will not cover such a scope. It will, however, attempt to highlight Agile’s most basic tenets and discuss how it fits—or does not fit—with UX design.</p>

<h2>What is Agile?</h2>

<p>Agile is an umbrella term encompassing a variety of development methodologies that have at their core a commitment to highly collaborative, multi-functional, self-organizing teams. Agile’s minimal overhead and focus upon working software as a measure of progress contrasts with the heavy requirements and upfront documentation of waterfall development. Waterfall gets its name from the sequential tasks that drive the process: discovery and requirements gathering lead to design and detailed documentation, which lead to development and testing, and so on, each one cascading down into the other. However, it is rare that the fluidity and adaptability suggested by the waterfall metaphor is maintained. Those traits are actually more appropriately associated with the philosophy that underpins Agile.</p>

<p>In 2001, a group of 17 software engineers wrote the now famous <a href="http://agilemanifesto.org">Agile Manifesto</a>, which describes, in four simple statements, the overall approach:</p>

<blockquote>
<p>We are uncovering better ways of developing software by doing it and helping others do it. Through this work, we have come to value:</p>

<ul>
	<li>
<em>Individuals and interactions</em> over processes and tools</li>
	<li>
<em>Working software</em> over comprehensive documentation</li>
	<li>
<em>Customer collaboration</em> over contract negotiation</li>
	<li>
<em>Responding to change</em> over following a plan</li>
</ul>
</blockquote>

<h3>What does Agile development look like in practice?</h3>

<p>In Scrum, one of the most popular Agile product management frameworks, the team breaks down a digital product’s features and functions to create a backlog of user stories. User stories describe, from a user’s perspective, a particular function of the software and the benefit of that function. For instance, a story for a Dropbox user might be, “As a power user, I can use keyboard shortcuts to quickly navigate my files.” A select group of these stories is then built in a short development cycle, usually in a two-week increment, also known as a sprint. <a href="http://www.scrumguides.org/docs/scrumguide/v2016/2016-Scrum-Guide-US.pdf">The Scrum team,</a> which consists of a product owner, Scrum master, and development team—ideally 6-9 engineers—uses daily stand-up meetings to stay coordinated and focused. At the conclusion of a sprint, the team produces working software that’s demonstrated to stakeholders in a review meeting.</p>

<p>Importantly, the team also holds a retrospective to go over what went well, and what did not, so they can continually improve. Then, as needed, the process starts again with the next set of stories and the next sprint. To be successful, Scrum requires a high level of transparency, trust, and commitment between team members. Agile methods, like Scrum, work well for developing digital products because they provide adaptive, iterative methods for handling the complexity that comes with the infinitely malleable material that is software. But, at the same time, Agile is not necessarily all encompassing when it comes to product creation. Because it eschews upfront planning for learning as you go, it can create software that lacks cohesiveness from a user perspective.</p>

<ul>
	<li><em>To learn more about Agile methodologies, read <a href="https://www.safaribooksonline.com/library/view/learning-agile/9781449363819/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=20170501_follett_integrating_agile_ux_post_learning_agile_book">Learning Agile</a>, by Jennifer Greene and Andrew Stellman.</em></li>
</ul>

<h3>UX and Agile</h3>

<p>Of course, on the other side of the digital product creation equation is UX design—that intuitive, empathetic, and human-centered practice with its focus on the user experience as the driver. There’s no question that design-driven innovation has produced great value for companies in recent years. From Apple to IBM, Kaiser Permanente to Nike, market leaders have used design to innovate their products and services. And design-led companies like these have outperformed the overall market by a significant margin—beating the S&amp;P 500 by 211% over a ten-year period, according to the <a href="http://www.dmi.org/?page=2015DVIandOTW">Design Management Institute’s Design Value Index Study</a>.</p>

<p>There can be a tension between design and Agile delivery. In his foreword to Jeff Patton’s book on <a href="https://www.safaribooksonline.com/library/view/user-story-mapping/9781491904893/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=20170501_follett_integrating_agile_ux_post_body_text_user_story_mapping_book_link"><em>User Story Mapping</em></a><em>,</em> interaction design pioneer Alan Cooper writes: “In Mary Shelley’s famous science-fiction novel, <em>Frankenstein,</em> the mad Doctor Frankenstein builds a creature from the disparate pieces of dead humans and brings the creature to life with the then-new technology of electricity. Of course, we know this is not actually possible. You cannot create life by sewing together random body parts.”</p>

<p>“Yet this is what software developers attempt to do all the time,” Cooper continues. “They add good features to software, one at a time, and then wonder why few users love their product. The heart of the conundrum is that developers are using their construction method as design tool, but the two are not interchangeable.”</p>

<p>So, should software creation be design-driven or Agile-driven? Does design need to adapt to a world that is increasingly Agile, or does design’s strong value proposition—typified by the outsized valuations of design-centric companies—make it a natural product lead? “The premise that design has to…kneel beneath this juggernaut that is Agile, I’m not sure that's necessarily the right framing,” says designer, author, and speaker, Cennydd Bowles. It’s probably incorrect to suppose that one of these powerful methods has to conform to the other. For effective, successful software creation, we need to figure out how the two can work side-by-side. But how does this adaptation take place? How do UX design and Agile fit together in an effective way?</p>

<ul>
	<li><em>To learn how to integrate Lean UX and Agile, read <a href="https://www.safaribooksonline.com/library/view/lean-ux-2nd/9781491953594/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=20170501_follett_integrating_agile_ux_post_lean_ux_book">Lean UX, 2nd edition</a>, by Jeff Gothelf and Josh Seiden.</em></li>
</ul>

<h2>The miracles of iteration</h2>

<p>As you might expect, the relationship between Agile and user experience is continually evolving, as designers and developers find ways to adapt and better work together. Where the two approaches intersect, there are many areas in which they can complement one another. “They’re both desperately iterative,” says Bowles. “They both recognize you’re not going to get it right the first time. Designers are very comfortable with it. We know that. That's part of the design process. That’s why you have critique. That's why you have prototyping, and so on.” For designers, making ideas tangible is absolutely crucial, as are the iteration cycles needed for testing and refining those ideas. Design has a bias toward making things, and prototyping is where this all begins. It’s important that designers see how something is working and how users are reacting to it. Through the act of prototyping, designers can view the evidence and see where they got it right and where they got it wrong. Then, based on that learning, they can refine and hone the design. This same iterative philosophy is hardwired into the Agile approach. We learn by testing usage in the real world by real people, and through iteration based on that learning, we progress toward a solution.</p>

<p>But while an iterative approach to software creation is a shared value, transparency throughout that process is much less so. Agile developers are very comfortable externalizing their work-in-progress and revealing solutions early in the process. They prefer to ship code as soon as possible, in order to test assumptions, get feedback from real users, and learn from that feedback. Designers, in contrast, are usually less inclined to reveal work-in-progress. In this respect, design is changing and adapting. “Designers have to become a bit more comfortable with releasing things,” says Bowles. “Releasing, I mean now in the delivery-of-products sense, but also just conceptually, releasing control of things they may not be 100% happy with. That’s tough for designers. That’s kind of an ego check for a lot of designers. But that’s probably an OK thing.”</p>

<p>Designers have to be mindful and willing to take feedback as part of the process. How does this design actually perform in the real world? Does this actually meet the user need the team anticipated? Designers need to have the flexibility to learn. “So, it’s a relaxation of control on both sides,” says Bowles, “but then also being willing to absorb what you learn from that in the design process. I think designers sometimes have been not great at either of those. I think Agile is a nice balance, a nice way of sort of forcing that humility, to an extent.” While designers can learn much from Agile development’s focus on transparency, there are elements of software creation that designers can champion in an Agile environment: one of these is research.</p>

<ul>
	<li><em>To learn how to create and iterate on designing interfaces in Agile environments, watch <a href="https://www.safaribooksonline.com/library/view/effective-ux-design/9781491950623/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=20170501_follett_integrating_agile_ux_post_effective_ux_video">Effective UX Design with Patterns: Build and Leverage a Pattern Library for Rapid Iteration and Prototyping</a>, from Dani Nordin.</em></li>
</ul>

<h2>Research’s last stand?</h2>

<p>Is user research something we do before, during, or after creating a digital product? The Agile process does not favor much in the way of upfront research or discovery, preferring learning through continuous experimentation. Design, in contrast, has a preference for research at the very start—establishing a basic understanding of users and the target market—for informing product strategy and ongoing decision-making. Of course, there’s no reason a product team can’t insert design research upfront, ahead of embarking on the product development. This can allow for some ethnographic study, interviews, and other pre-development activities that can help inform digital product strategy and ideation. But this can be firmly at odds with an Agile approach. The trick is doing enough research, talking to users, etc., to inform the decision-making, but not so much that it wastes valuable time.</p>

<h3>Going Lean</h3>

<p>Another, complementary approach involves integrating user research into the iterative production process, which is the tactic taken by the increasingly popular Lean UX. This Agile-friendly design approach takes key ingredients from the <a href="https://www.safaribooksonline.com/library/view/continuous-delivery-expert/9780133412246/CDEI_er_part_1.html?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=20170501_follett_integrating_agile_ux_post_body_text_lean_startup">Lean Startup</a> method and is driven by core principles focused on maximizing value and minimizing waste. Ongoing research gives designers the opportunity to check hypothesis quickly, and test a Minimum Viable Product (MVP) with customers to validate, or invalidate it, as the case may be. Since Lean UX research is collaborative and distributed across the entire team, everyone can have exposure to it and develop a shared understanding. Ideally, the team will talk with customers at regularly scheduled intervals, perhaps once a week, and receive feedback. The formal research process and method is considered scope that can and should be altered as needed. In this way, Lean UX is pragmatic and utilitarian when it comes to soliciting customer and user feedback. However, in order for such an approach to succeed, team collaboration and shared understanding is critical.</p>

<h2>Collaboration and co-design</h2>

<p>Integrating UX design and Agile requires that user experience practice not be limited just to the designers, but rather that it become a responsibility of the team as a whole. Successfully making this happen requires a collaborative balance: a designer should remain the point person for the output, but many team members help shape and implement. “It’s important that designers retain control over the design process … [You need] someone accountable and someone actually trained and literate to make those decisions,” says Bowles. “Ultimately, the principle is that any problem is a team problem. If code review is proving to be an enormous backlog and choke point for the process, it’s everyone’s problem to fix that, including design [and] product management. It’s not just an engineering problem. Likewise, if we’re not able to get enough [design] research to validate that this is actually the right thing to be building, that’s for the team to solve. That’s not just on the design manager to figure it out.”</p>

<p>“It’s that sharing of responsibility that then, in turn, creates a feeling of shared accountability for the quality of the product. No team should be happy if they’re pumping out 70 points of Agile delivery every week on complete BS that doesn’t matter to the user. ... No engineering team should be happy about that. They should be concerned. I think having that kind of shared accountability and shared responsibility is probably the closest thing I've got to a golden shining key for how to design in those situations,” says Bowles.</p>

<h3>Increasing design literacy</h3>

<p>Even on a collaborative, co-located team, designers won’t be involved in all UX decisions. Ultimately, engineers will make design-related choices every day as they construct the product. So, a great way to improve the quality of the product is to increase the design literacy of the engineering team. Designers need to expose developers to and create a shared understanding of design principles. This goal can be achieved via any number of informal methods—from giving lunchtime tech talks to actively discussing design decisions to creating a design resource library. A tech talk at lunch can be accompanied by a lightweight presentation or a group discussion about a targeted design topic. While it’s great to have a design reference library, it’s not necessary to have a dedicated reading area. You might just buy some books to leave in the team’s shared space.</p>

<h3>Welcoming input</h3>

<p>The design process should be inclusive of everyone on the team. Designers should welcome input, even if (especially if) it’s input with which we disagree. “Probably the best question I [could] ever ask as a designer is ‘what do you think’?” says Bowles. “That draws your developers and your [product managers] into the conversation. Through that, they have buy-in to the solution, if they like it. But also, they’re exposed to the design process a little bit more.” The question is an excellent entry point from which you can draw the team into design discussions. “The minute you shut down, you say, ‘Well, I’m a designer. You’re an engineer. Go back to your work and leave this to me.’ Then you shut off those avenues for a potential benefit,” says Bowles. “So, it’s about retaining that openness and curiosity to accept ideas from wherever they may be.” This method of welcoming design input follows Agile’s primary axioms, valuing individual relationships over process, and conversation over documentation. We can take a similar approach in our attitude toward design deliverables, and emphasize communication rather than artifacts, which, unsurprisingly, is core to Lean UX.</p>

<ul>
	<li><em>To learn how to collaborate and design better together, read <a href="https://www.safaribooksonline.com/library/view/collaborative-product-design/9781491975022/body3.xhtml?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=20170501_follett_integrating_agile_ux_post_ch_2_collaborative_product_design">Chapter 2</a> of <a href="https://www.safaribooksonline.com/library/view/collaborative-product-design/9781491975022/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=20170501_follett_integrating_agile_ux_post_collaborative_product_design_book">Collaborative Product Design</a>, by Austin Govella.</em></li>
</ul>

<h2>Waste not, want not?</h2>

<p>Design processes tend to favor the creation of a discrete set of deliverables—whether it’s research, information architecture, interaction design, user interface mockups, or even prototyping—prior to engaging engineering in a substantial way. But maintaining this approach can be difficult, if not impossible, when collaborating in an Agile environment. “How do you take all those [design] tools and apply the most relevant ones at the most appropriate time at the appropriate level of effort?” says Jeff Gothelf, an organizational designer and co-author of <a href="https://www.safaribooksonline.com/library/view/lean-ux-2nd/9781491953594/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=20170501_follett_integrating_agile_ux_post_body_text_lean_ux"><em>Lean UX: Designing Great Products with Agile Teams</em></a>. “You’re eliminating the waste in your design process, and you’re moving away from being in the deliverables business.” By focusing on the communication of design ideas rather than specific deliverables, Lean UX streamlines the process to better match the flexible Agile environment. “I think, probably, the most important [tenet of Lean UX] is the minimum viable conversation,” says Gothelf. “What I mean by that is, as a designer, what’s the most important thing you need to communicate next? Who do you need to communicate it to? Then, what’s the least amount of work that you need to do to make that communication take place? I think if there were a Lean UX commandment, that’s really it.”</p>

<p>Of course, this doesn't mean that a Lean UX process is devoid of deliverables. It means you only create the design artifacts that are required to move the conversation forward—this might be a quick sketch, a whiteboarding session, or even a prototype, depending on whom you’re talking to. While favoring conversations over deliverables for the sake of themselves is a great example of design adapting to an Agile world, it does raise the question: just how lean do we need to get?</p>

<h3>In praise of inefficiency</h3>

<p>The flip side of the coin is that sometimes it can be difficult to identify what’s wasteful in the design process. Sometimes inefficiency can be a good thing. As valuable as communication of work-in-progress can be, there’s also value in creating artifacts and products that set the right conditions for design insight and inspiration. Just as deep upfront research and ethnographic techniques of study and observation can reveal previously unknown aspects of user behavior, so, too, can seemingly superfluous exploratory design activities set the stage for an “aha” moment. It’s a balance, of course, and in our quest to be Agile compatible, designers might be careful not to remove the elements of practice that inspire and invoke our intuition—providing the opportunity to play with ideas irrespective of the march to production.</p>

<h2>Bring the vision</h2>

<p>Because the Agile development process favors incremental building, engineering teams can focus overly so on short-term output. It’s all too common for a holistic product vision to disappear in the rhythm of sprints, in which the team creates discrete components, moving the product forward in releasable chunks. What can designers do to help ensure the value of an overall product vision is not lost? Having a strong design vision can bring additional clarity to product teams. “You absolutely need that in conjunction with the Agile process. ... Without that vision, that North Star, you do get that soulless kind of product. It doesn’t hang together. It doesn’t have that coherence,” says Bowles.</p>

<p>Developing and preserving a design vision is critical to the creation of excellent software. But product managers can easily get drawn into managing backlogs and Agile throughputs. And a singular focus on delivery can result in punting potential UX problems down the road—putting these decisions off because delivery is the primary concern—and finding no sensible resolution when you reach the end. Without a coherent vision for the end state of the product, we risk creating the isolated pieces of a final product that does not work in its totality. It’s tricky to balance between vision, figuring out those elements upfront, and incorporating what you’re learning through the delivery process. You may find that your initial assumptions are incorrect. And, in that case, it makes sense to revisit your strategy process. Expect that teams will have to take some time out on a regular basis to check the product vision and strategy.</p>

<h2>Agile / UX in action: TweetDeck</h2>

<p>In May 2011, <a href="http://money.cnn.com/2011/05/23/technology/twitter_acquires_tweetdeck/">Twitter acquired TweetDeck for more than $40 million in cash and stock</a> in a defensive acquisition that kept the aforementioned application—popular with Twitter power users—out of the hands of third-party app developer UberMedia, and brought the product under Twitter’s control. But it was not immediately clear what Twitter would do with the team. Cennydd Bowles was hired as a senior designer to work on TweetDeck. “My job was to try and bring design into that scenario and help kick-start that project again,” says Bowles. “I actually think we did a great job. ... That was easily the best Agile team I’ve been in. What really mattered there, I think, was that division of responsibilities, but also, again, that shared responsibility between engineering, product, and design.”</p>

<p>Collaboration and a team responsibility for design enabled the Tweetdeck team to operate closely together. “One of the developers who was inputting the most into the design process was actually a back-end engineer. ... He was very interested in UI, and he had a feel for it. So, he was always chipping in things. They may not [all] have been great suggestions, but even if five of his ideas would not work, one of them [might] actually be really promising.”</p>

<p>In his blog post <a href="https://blog.twitter.com/2012/designing-the-new-tweetdeck">“Designing the new TweetDeck,”</a> Bowles describes how the team’s iterative design process worked hand-in-hand with Twitter’s Agile development, using prototyping to test the software quickly. “After an extensive design review of the app, we sketched dozens of new interface ideas, iterating quickly toward stronger solutions. We then created Photoshop mockups to fill in the detail, before moving into our final design platform, a high-fidelity prototype. This prototype (built from scratch using HTML, Sass, JavaScript, Mustache, JSON, and our internal prototyping tool Protobird) allowed us to tweak the final important details in the browser. With this new prototyping platform in place, we could quickly test out ways to improve the app and ship future improvements faster.”</p>

<p>TweetDeck’s improvements were well received by users, and the application’s reviews improved measurably on the Mac App Store. The combination of user experience and Agile delivery enabled them to create a great product. “That worked really well, to be honest, and I look back at that as sort of a high point in my career in terms of delivering real product turnaround in an Agile environment,” says Bowles.</p>

<h2>What’s next?</h2>

<p>In the near future, we’ll continue to see a greater level of Agile / UX design integration maturity. This will, no doubt, vary based on company size, type of product, etc. Areas of particular challenge will include scaling these methods for the enterprise, where the sheer size and complexity of software can be difficult to manage.</p>

<p>Bowles sees push back against the empiricism of Lean Startup and Lean UX. “There’s going to be some kind of backlash against Lean Startup. I mean that's already begun, to be honest,” says Bowles. “Lean Startup has become this dominant ideology, and every company now thinks they’re unique in operating under Lean Startup principles. There’s going to be some kind of reaction against that. Probably a move to slightly more upfront planning, and designers are going to be central to doing that. ... There’s going to be something there around repositioning things, like prediction and intuition and deep research into that process, which I think is good news for designers.”</p>

<p>Agile and UX Design are not just ways of creating software, but also, cultural mores—the customs and conventions of work life. And, as these methods converge and mature together, they are establishing new ways of working.</p>

<h2>Additional resources</h2>

<p><a href="https://www.safaribooksonline.com/library/view/lean-ux-2nd/9781491953594/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=20170501_follett_integrating_agile_ux_post_resources_lean_ux"><em>Lean UX: Designing Great Products with Agile Teams</em></a>, by Jeff Gothelf and Josh Seiden</p>

<p><a href="https://www.safaribooksonline.com/library/view/learning-agile/9781449363819/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=20170501_follett_integrating_agile_ux_post_resources_learning_agile"><em>Learning Agile: Understanding Scrum, XP, Lean, and Kanban</em></a>, by Andrew Stellman and Jennifer Greene</p>

<p><a href="https://www.safaribooksonline.com/library/view/user-story-mapping/9781491904893/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=20170501_follett_integrating_agile_ux_post_resources_user_story_mapping"><em>User Story Mapping</em></a><em>, </em>by Jeff Patton</p>

<p>“<a href="https://www.cennydd.com/writing/agile-and-the-horizon-effect">Agile and the Horizon Effect</a>,” by Cennydd Bowles</p>


        
                  
        

                      <div class="image-credit">
  Article image: Its raining umbrellas again.
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://commons.wikimedia.org/wiki/File:Its_raining_umbrellas_again_-_panoramio.jpg">Robert Dimov on Wikimedia Commons</a>).
        
        
      </span>
    
    
</div>
          

          

        </div>
      </div>

        <div class="article-meta">

  

  <ol class="article-share">
  
</ol>


      <article class="block block-common with-img person">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/people/7a496-jon-follett"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x360/jon_follett-cb9b8511c93f9aa7dddf35f2bbb2013a.jpg" alt="Jon Follett" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x360/jon_follett-cb9b8511c93f9aa7dddf35f2bbb2013a.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x720/jon_follett-cb9b8511c93f9aa7dddf35f2bbb2013a.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x1440/jon_follett-cb9b8511c93f9aa7dddf35f2bbb2013a.jpg 1440w"  class=""/></a>
    
    
  </div>
  

  

  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/people/7a496-jon-follett">Jonathan Follett</a>
    
    
    </h2>
    

    
          <p class="dek">Jonathan Follett is a Principal at Involution Studios where he is a leader of the firm’s emerging technologies practice, working with clients like Partners HealthCare, the Personal Genome Project, and Walgreens. His work has been featured in the Atlantic, Forbes, the Huffington Post, and Wired. Jon is an author of four books including “Designing for Emerging Technologies” (O’Reilly Media, 2014), which offers a glimpse into what future interactions and user experiences may look like for rapidly developing technologies — from genomics t...</p>

    
  </div>
</article>

  

</div>


        <hr class="t-bkg section-divider" />


        <aside class="article-related">
      <section class="block-rows columns-4 ">

    

    <section class="block-group">
                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/information-architecture-4th-edition-contest"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/street_poetry_alex_cheek_flickr-8f52aede175832fdbfe903a85c39079e.jpg" alt="Street poetry" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/street_poetry_alex_cheek_flickr-8f52aede175832fdbfe903a85c39079e.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/street_poetry_alex_cheek_flickr-8f52aede175832fdbfe903a85c39079e.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/street_poetry_alex_cheek_flickr-8f52aede175832fdbfe903a85c39079e.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-design--before">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/information-architecture-4th-edition-contest">&#34;Information Architecture&#34;: 4th edition contest</a>
    
    
    </h2>
    

          <div class="byline">
  
  By
  <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/cef5c-mary-treseler" itemprop="name">Mary Treseler</a></span></div>
    
          <p class="dek">Enter to win a complimentary pass to the O’Reilly Design Conference</p>

    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/every-successful-company-is-a-service-company"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/waldorf-astoria-169387_1280-482b37e95271755980b7feaa8b4affed.jpg" alt="Waldorf-Astoria construction" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/waldorf-astoria-169387_1280-482b37e95271755980b7feaa8b4affed.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/waldorf-astoria-169387_1280-482b37e95271755980b7feaa8b4affed.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/waldorf-astoria-169387_1280-482b37e95271755980b7feaa8b4affed.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-design--before">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/every-successful-company-is-a-service-company">Every (successful) company is a service company</a>
    
    
    </h2>
    

          <div class="byline">
  
  By
  <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/cef5c-mary-treseler" itemprop="name">Mary Treseler</a></span></div>
    
          <p class="dek">Designers are helping to shape the businesses, products, and services in our changing economy.</p>

    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-b21895638b.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/learning/design-user-research-fundamental-usability-testing"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/rp-p-bi-5324-0bb915f51cdc93e0a326c77c4ec3df21.jpg" alt="Bezoekers in het natuurhistorisch kabinet van Levinus Vincent in Haarlem, Andries van Buysen (Sr.)," srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/rp-p-bi-5324-0bb915f51cdc93e0a326c77c4ec3df21.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/rp-p-bi-5324-0bb915f51cdc93e0a326c77c4ec3df21.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/rp-p-bi-5324-0bb915f51cdc93e0a326c77c4ec3df21.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-design--before">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/learning/design-user-research-fundamental-usability-testing">User research fundamentals for designers: Usability testing</a>
    
    
    </h2>
    

          <div class="byline">
  
  By
  <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/christine-perfetti" itemprop="name">Christine Perfetti</a></span></div>
    
          <p class="dek">How designers can apply usability testing to collecting insights and feedback.</p>

    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-b21895638b.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/ideas/design-user-research-fundamental-diary-studies"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/rp-p-2009-1471-62b4fbd9c14b7da4b9643daf4cc7b67e.jpg" alt="Modes et Manières du Jour, Philibert-Louis Debucourt" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/rp-p-2009-1471-62b4fbd9c14b7da4b9643daf4cc7b67e.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/rp-p-2009-1471-62b4fbd9c14b7da4b9643daf4cc7b67e.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/rp-p-2009-1471-62b4fbd9c14b7da4b9643daf4cc7b67e.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-design--before">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/design-user-research-fundamental-diary-studies">User research fundamentals for designers: Diary studies</a>
    
    
    </h2>
    

          <div class="byline">
  
  By
  <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/christine-perfetti" itemprop="name">Christine Perfetti</a></span></div>
    
          <p class="dek">Designers can use diary studies to evaluate user behavior over a period of time.</p>

    
  </div>
</article>

      
  	</section>
    

</section>
  
</aside>

      </div>
    </div>
  </article>
</main>








  <footer role="contentinfo">
  <div class="footer-inner">

    <div class="about-us">
      <h3 class="title">About Us</h3>
      <ul>
        <li><a href="http://oreilly.com/about/">Our Company</a></li>
        <li><a href="http://oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
        <li><a href="http://oreilly.com/careers/">Careers</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Contact Us</a></li>
      </ul>
    </div>
    <div class="site-map">
      <h3 class="title">Site Map</h3>
      <ul>
        <li><a href="/ideas">Ideas</a></li>
        <li><a href="/learning">Learning</a></li>
        <li><a href="/topics">Topics</a></li>
        <li><a href="/all">All</a></li>
      </ul>
    </div>
    <div class="social">
      <ul>
        <li><a   class="icon-link " href="http://fb.co/OReilly"><span class="icon icon-facebook t-fill icon--white icon--large">
  <svg role="img">
    <title>facebook</title>
    <use xlink:href="/assets/icons-b21895638b.svg#facebook"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="http://twitter.com/oreillymedia"><span class="icon icon-twitter t-fill icon--white icon--large">
  <svg role="img">
    <title>twitter</title>
    <use xlink:href="/assets/icons-b21895638b.svg#twitter"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.youtube.com/user/OreillyMedia"><span class="icon icon-youtube-large t-fill icon--white icon--large">
  <svg role="img">
    <title>youtube-large</title>
    <use xlink:href="/assets/icons-b21895638b.svg#youtube-large"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://plus.google.com/+oreillymedia"><span class="icon icon-google t-fill icon--white icon--large">
  <svg role="img">
    <title>google</title>
    <use xlink:href="/assets/icons-b21895638b.svg#google"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.linkedin.com/company/o%27reilly-media"><span class="icon icon-linkedin t-fill icon--white icon--large">
  <svg role="img">
    <title>linkedin</title>
    <use xlink:href="/assets/icons-b21895638b.svg#linkedin"></use>
  </svg>
</span></a>
</li>
      </ul>
    </div>
  </div>
  <div class="legal">
	  <a href="/" class="logo logo-block t-bkg logo--medium">
<svg>
   <use xlink:href="/assets/icons-b21895638b.svg#oreilly-logo"></use>
</svg>
</a>
  	<p class="copyright">&copy; 2017 O'Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><br>
  <a class="t-c" href="http://oreilly.com/terms/">Terms of Service</a>  <span class="bullet">&bull;</span>	<a class="t-c" href="http://oreilly.com/privacy.html">Privacy Policy</a> <span class="bullet">&bull;</span> <a class="t-c" href="http://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a>
	</div>
	<figure class="animal"><img src="https://d3ebicv0uqgr7t.cloudfront.net/images/tarsier.png" class="animal-img" alt="Animal"></figure>
</footer>



  
  
    <!-- Start Adobe Digital Tag Manager -->
  <script type="text/javascript">_satellite && _satellite.pageBottom();</script>
  <!-- End Adobe Digital Tag Manager -->
  
</body>
</html>
