<!DOCTYPE html>
<html lang="en">
<head>
  <title>Kubernetes and containers for enterprise developers - O&#39;Reilly Media</title>

  <!-- Meta -->
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
      <meta property="twitter:card" content="summary_large_image" />
      <meta property="twitter:site" content="@OReillyMedia" />
      <meta property="twitter:title" content="Kubernetes and containers for enterprise developers" />
      <meta property="twitter:description" content="O’Reilly Media Podcast: JP Phillips, platform engineer at IBM Cloud, on problem solving with containers and Kubernetes, and how developers can get started." />
      <meta property="description:site" content="O’Reilly Media Podcast: JP Phillips, platform engineer at IBM Cloud, on problem solving with containers and Kubernetes, and how developers can get started." />
      <meta property="twitter:url" content="https://www.oreilly.com/ideas/kubernetes-and-containers-for-enterprise-developers" />
      <meta property="fb:pages" content="15137500430" />
      <meta property="og:type" content="article" />
      <meta property="og:site_name" content="O&#39;Reilly Media" />
      <meta property="og:title" content="Kubernetes and containers for enterprise developers" />
      <meta property="og:description" content="O’Reilly Media Podcast: JP Phillips, platform engineer at IBM Cloud, on problem solving with containers and Kubernetes, and how developers can get started." />
      <meta property="og:url" content="https://www.oreilly.com/ideas/kubernetes-and-containers-for-enterprise-developers" />
      <meta property="article:published_time" content="2018-05-15T16:20:00Z" />
      <meta property="article:author" content="Nicole Tache" />
      <meta name="description" content="O’Reilly Media Podcast: JP Phillips, platform engineer at IBM Cloud, on problem solving with containers and Kubernetes, and how developers can get started." />
      <meta name="author" content="Nicole Tache" />
      <meta name="date" content="2018-05-15" />
      <meta property="og:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/14638567322_08e7585033_o_crop-322243ddd8ea98e043bc385702d22903.jpg" />
      <meta property="twitter:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/14638567322_08e7585033_o_crop-322243ddd8ea98e043bc385702d22903.jpg" />
      <meta name="thumbnail" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/14638567322_08e7585033_o_crop-322243ddd8ea98e043bc385702d22903.jpg" />
      <meta name="graphic_medium" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/14638567322_08e7585033_o_crop-322243ddd8ea98e043bc385702d22903.jpg" />
      <meta name="oreilly:topic" content="Software Architecture" />
      <meta name="oreilly:parent_topic" content="Software Engineering" />
      <meta name="oreilly:keywords" content="programming,software architecture,kubernetes,containers,enterprise,enterprise developers,platform engineering" />
  
  

  <!-- Assets -->
  <script type="text/javascript" src="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-9ecedd83fa.js"></script>
  <link rel="stylesheet" type="text/css" href="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-d38fc9c222.css">
    
  
  <!-- Extra Assets -->
  
  
  

  <script type="text/javascript">
    dataLayer = [];
  </script>

    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5P4V6Z');</script>
  <!-- End Google Tag Manager -->
  

  

    <script type="text/javascript">
    function createKeenWebAutoCollector(){window.keenWebAutoCollector=window.KeenWebAutoCollector.create({projectId:'551456c8672e6c2f4f5ee426',writeKey:'e737a463e3a57a914ddf707a34ad2c319c2e1c52999fe5f8087e41a71676675f90298cfd1a4e30ecf3f25e337db4b579c28c2bf784b26bdd6e9b7cc595b045098b94483dea878b17a65a56b5307b97ac3834670c2484fb8effa01cbacd55dba355850b97cad116b4b0e434dc64bc359c',onloadCallbacks:window.keenWebAutoCollector.onloadCallbacks}),window.keenWebAutoCollector.loaded()}function initKeenWebAutoCollector(){window.keenWebAutoCollector.domReady()?window.createKeenWebAutoCollector():document.addEventListener("readystatechange",function(){window.keenWebAutoCollector.domReady()&&window.createKeenWebAutoCollector()})}window.keenWebAutoCollector={onloadCallbacks:[],onload:function(a){this.onloadCallbacks.push(a)},domReady:function(){return["ready","complete"].indexOf(document.readyState)>-1}};
  </script>
  <script async type="text/javascript" src="https://d26b395fwzu5fz.cloudfront.net/keen-web-autocollector-1.0.8.min.js" onload="initKeenWebAutoCollector()"></script>
  

  <script type="text/javascript">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</script>

  <!-- Start Visual Website Optimizer Asynchronous Code -->
  <script type='text/javascript'>
    var _vwo_code=(function(){
    var account_id=244658,
    settings_tolerance=2000,
    library_tolerance=2500,
    use_existing_jquery=false,
  // DO NOT EDIT BELOW THIS LINE
  f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
  </script>
  <!-- End Visual Website Optimizer Asynchronous Code -->

  <!-- Marketo -->
  <script src="https://app-ab24.marketo.com/js/forms2/js/forms2.min.js" type="text/javascript"></script>

</head>
<body class="body t-software-engineering" data-section="ideas" >
  <div class="flashes"></div>
    <header id="page-header">
  <div id="header-bar" class="t-bkg">
    <h1 class="logo t-bkg" >
  <a href="/" class=" logo-white ">
  <svg role="heading" aria-label="O'Reilly">
    <title>O'Reilly</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
  </svg>
  </a>
</h1>
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>


    <div class="right invert">
      <div id="search" class="hide">
        <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
      </div>
    </div>
    <a id="menu-toggle" class="invert" ><span class="icon icon-white icon-menu">
  <svg role="img" id="close" class="is-hidden">
    <title>Close Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#close"></use>
  </svg>
  <svg role="img" id="open">
    <title>Open Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#menu"></use>
  </svg>
</span></a>
  </div>
     <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/jupyter" >Jupyter</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

  
  <div id="mobile-menu">

    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
         <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/jupyter" >Jupyter</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

    
  </div>

</header>



  <!-- Linked In -->
  <script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
  
<!-- Load Facebook SDK for JavaScript -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<main aria-live="polite">
  <article class="article" itemscope itemtype="http://schema.org/Article">
              <header class="article-header">
      <div class="flag t-bkg--before bg-software-engineering--before flag--small">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
  
  

  <h1 class="title t-c" itemprop="headline">Kubernetes and containers for enterprise developers</h1>

      <p class="dek" itemprop="alternativeHeadline">O’Reilly Media Podcast: JP Phillips, platform engineer at IBM Cloud, on problem solving with containers and Kubernetes, and how developers can get started.</p>
  

  <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/nicole-tache" itemprop="name">Nicole Tache</a></span>
</div> <time class="date">May 15, 2018</time>

</header>

      

      <div class="article-body" itemprop="articleBody">
        
                              <figure class="article-image right">
  <img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/14638567322_08e7585033_o_crop-322243ddd8ea98e043bc385702d22903.jpg" alt="Cubes" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/14638567322_08e7585033_o_crop-322243ddd8ea98e043bc385702d22903.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/14638567322_08e7585033_o_crop-322243ddd8ea98e043bc385702d22903.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/14638567322_08e7585033_o_crop-322243ddd8ea98e043bc385702d22903.jpg 1440w" sizes="(min-width: 1390px) 420px, (min-width: 600px) 45vw, 100vw" class=""/>
  <figcaption>Cubes
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://www.flickr.com/photos/blizzy/14638567322">Maik on Flickr</a>)
        
        
      </span>
    
    
  <figcaption>

</figure>
          
                      <aside data-type="note">
  <p>Check out the sessions <a href="https://conferences.oreilly.com/oscon/oscon-or/public/schedule/detail/66984?intcmp=il-prog-confreg-lp-osor18_20180221_new_site_kubernetes-and-containers-bring-confidence-and-efficiency-to-enterprise-developers_top_cta">"Istio&mdash;Weaving, securing, and observing the microservices"</a> and <a href="https://conferences.oreilly.com/oscon/oscon-or/public/schedule/detail/67649?intcmp=il-prog-confreg-lp-osor18_20180221_new_site_kubernetes-and-containers-bring-confidence-and-efficiency-to-enterprise-developers_top_cta">"Leveraging Istio's pilot adapters for non-Kubernetes platforms"</a> at the O'Reilly OSCON Conference, July 16-19, 2018, in Portland. Hurry&mdash;early price ends June 8.</p>
</aside>

          
        

        

        <p>There has been a surge of interest in containers, microservices, and Kubernetes in recent years, fueled by the need for developers to share apps that will scale and run in a consistent manner across many different environments. Whether it’s dev, staging, testing, or production, developers need assurance that the code they deploy to one environment is going to work in another. Containers, microservices, and Kubernetes provide such assurance.</p>
<p>In this episode of the O’Reilly Media Podcast, I talk with JP Phillips, platform engineer at <a href="https://www.ibm.com/cloud/compose?cm_mmc=Display_OReilly-_-Developer_Innovation-_-WW_WW-_-DataScienceBlogPost&amp;cm_mmca1=000019RT&amp;cm_mmca2=10004795">IBM Cloud</a>. IBM is driving development in the container space, as shown through last year’s launch of <a href="https://www.ibm.com/cloud/info/istio?cm_mmc=Display_OReilly-_-Developer_Innovation-_-WW_WW-_-DataScienceBlogPost&amp;cm_mmca1=000019RT&amp;cm_mmca2=10004795">Istio</a>, an open cloud service that allows developers to connect, manage, and secure networks of different microservices. Istio, a joint collaboration between IBM, Google, and Lyft, (in conjunction with the Cloud Native Computing Foundation), is platform agnostic and runs on Kubernetes platforms, such as <a href="https://www.ibm.com/cloud/container-service?cm_mmc=Display_OReilly-_-Developer_Innovation-_-WW_WW-_-DataScienceBlogPost&amp;cm_mmca1=000019RT&amp;cm_mmca2=10004795">IBM’s Cloud Container Service</a>. Interest in the platform is growing. IBM's Daniel Berg, who is <a href="https://conferences.oreilly.com/oscon/oscon-or/public/schedule/detail/66984?intcmp=il-prog-confreg-lp-osor18_20180221_new_site_kubernetes-and-containers-for-enterprise-developers_text_body_link">giving a talk on Istio at the upcoming OSCON conference in Portland</a>, recently led a hands-on workshop at KubeCon in Copenhagen to help developers learn how Istio can solve common challenges with microservices deployed within Kubernetes.</p>

<figure class="center" id="id-6YOix"><img alt="istio workshop" width="60%" src="https://d3ansictanv2wj.cloudfront.net/Figure1-070e8e2ffb4a41ccf4f5cfbe6b4150ab.jpg"><figcaption><span class="label">Figure 1. </span>Developers at the "Istio Hands-on Workshop" at KubeCon in Copenhagen. Image courtesy of IBM.</figcaption></figure>

<p>Phillips explains that containers enable a “consistent delivery mechanism” for applications, and Kubernetes extends that capability by creating a “unified language” that everyone can speak. This, in turn, helps teams fully utilize all available capacity to consistently run systems at scale. In our talk, Phillips and I also discuss how enterprise developers can get started using these tools, and some of the reasons behind their rapid adoption.</p>



<iframe src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/444424344&amp;auto_play=false&amp;hide_related=false&amp;show_artwork=true" height="166" width="100%" frameborder="no" scrolling="no"></iframe>





<p>Here are some highlights from our discussion:</p>





<h2>Bring team confidence to enterprise developers</h2>

<blockquote><p>The way they’ve designed Kubernetes and its use of containers to actually run apps has become very powerful. It really gives team confidence that the process of moving an app from a laptop through all the different environments and into production is going to be successful at the end of the day...[developers] are not going to run into a lot of issues where ‘it worked on my laptop, why doesn’t it work in production?’</p></blockquote>



<h2>Automated monitoring a key use case of Kubernetes for the enterprise</h2>

<blockquote><p>In Kubernetes, there’s the concept of a cluster autoscaler so you can configure it such that if you’re at a certain capacity or you’re hitting certain levels of CPU, it will automatically add another node to your cluster. The newer project is the <a href="https://kubernetes.io/docs/tasks/run-application/horizontal-pod-autoscale/">horizontal pod autoscaler</a>, which lets you capture custom metrics such that you can tell the queuing system ‘if I hit a certain threshold, then I need more workers; scale my workers up by X amount.’ It’s this notion of being able to put the system on autopilot so you’re not having to constantly monitor it, and it’s being more proactive. The more legacy approach is, ‘let’s create alerts and let’s create monitoring.’ Well, in that case, you have to have people looking at the dashboards, you have to have an individual responding to an alert.</p></blockquote>



<h2>The future of containers and Kubernetes</h2>

<blockquote><p>To me, the most exciting work is taking place in the extended ecosystem. So, you have projects like <a href="https://helm.sh/">Helm</a>, which is all about packaging your app and being able to configure it the same way across environments. <a href="https://istio.io/">Istio</a>, which was a project co-developed by Google, IBM, and Lyft, essentially gives you a network control plan for your microservices, and it's using the on-board proxy technology developed by Lyft. <a href="https://cilium.io/">Cilium</a> is a very new project; it's a network and security API, so it sort of has ties into projects like Istio. And then there's <a href="https://github.com/jaegertracing/jaeger">Jaeger</a>, which is distributed tracing. ... Tracing is the one where it's sort of like the third leg that is becoming more and more popular. So, having a system like Jaeger be easily deployed into your Kubernetes environment really gives you more insight into your microservices. I think that's going to play a huge role.</p></blockquote>


<h2>Plethora of resources to learn how to become productive with containers and Kubernetes</h2>

<p>Phillips recommends the following resources, which he visits regularly, for those looking to better understand containers and Kubernetes, and where it can provide value to their work:</p>


<ul>
<li><a href="https://developer.ibm.com/code/technologies/containers/?cm_mmc=Display_OReilly-_-Developer_Innovation-_-WW_WW-_-DataScienceBlogPost&amp;cm_mmca1=000019RT&amp;cm_mmca2=10004795">Containers Code Patterns</a></li>
<li>
<a href="https://www.youtube.com/watch?v=McwwWhCXMxc">TGI Kubernetes</a> (weekly YouTube series hosted by Joe Beda, one of the Kubernetes creators)</li>

<li>
<a href="https://www.safaribooksonline.com/library/view/kubernetes-up-and/9781491935668/?utm_source=oreilly&amp;utm_medium=newsite&amp;utm_campaign=kubernetes-and-containers-bring-confidence-and-efficiency-to-enterprise-developers_resource_list_kubernetes_up_and_running_book_link"><em>Kubernetes: Up and Running</em></a> (O’Reilly book)</li>

<li>
<a href="https://github.com/kelseyhightower/kubernetes-the-hard-way">Kubernetes The Hard Way</a> (GitHub tutorial by Kelsey Hightower)</li>

<li>
<a href="https://kubeweekly.com/">KubeWeekly</a> (newsletter with links to posts, articles, podcasts, YouTube videos)</li>

<li>
<a href="https://github.com/lachie83">Lachlan Evenson</a> (GitHub repo where he takes projects for a spin)</li>

<li>
<a href="https://www.cncf.io/">CNCF</a> (offers Kubernetes certification for administrators and, soon, app developers)</li>

<li>
<a href="https://www.katacoda.com/">Katacoda</a> (offers tasks and a playground in which to learn Kubernetes)</li>
</ul>




<p><em>This post is part of a collaboration between O'Reilly and IBM. </em><a href="http://www.oreilly.com/about/editorial_independence.html"><em>See our statement of editorial independence</em></a><em>.</em></p>


        
                  
        

                  <div class="image-credit">
  Article image: Cubes
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://www.flickr.com/photos/blizzy/14638567322">Maik on Flickr</a>).
        
        
      </span>
    
    
</div>
        

        

      </div>

      <div class="article-meta">

  <div class="article-share">
  <div class="article-share-text"> Share </div>
  <ol>
    <li><a href="https://twitter.com/share" class="twitter-share-button" data-via="oreillymedia" data-show-count="false">Tweet</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></li>
    <li>  <div class="fb-share-button" 
    data-href="https://www.oreilly.com/ideas/kubernetes-and-containers-for-enterprise-developers" 
    data-layout="button_count">
  </div></li>
    <li><script type="IN/Share" data-url="https://www.oreilly.com/ideas/kubernetes-and-containers-for-enterprise-developers" data-counter="right"></script></li>
  </ol>
  <hr>
</div>

  

      <article class="block block-common with-img person with-link">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/people/nicole-tache"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x360/nicole-tache-003cbec8d54fd78ef9878578c5d9e711.jpg" alt="nicole-tache" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x360/nicole-tache-003cbec8d54fd78ef9878578c5d9e711.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x720/nicole-tache-003cbec8d54fd78ef9878578c5d9e711.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x1440/nicole-tache-003cbec8d54fd78ef9878578c5d9e711.jpg 1440w"  class=""/></a>
    
    
  </div>
  

  

  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/people/nicole-tache">Nicole Tache</a>
    
    
    </h2>
    

    
          <p class="dek">Nicole Tache is an O'Reilly Data editor. She has 10 years of experience in academic and technical publishing, and is passionate about collaborating with authors to build products that are instructive, innovative, and that satisfy new or emerging market needs. When not working, Nicole enjoys kayaking, snowboarding, cooking, and writing silly children’s books for her daughter and nieces.
</p>

    
          <a class="btn btn--xsmall" style="float: right;" href="/people/nicole-tache">more</a>
    
  </div>
</article>

  

</div>


      <hr class="t-bkg section-divider" />


      <aside class="article-related">
      <section class="block-rows columns-4 ">

    

    <section class="block-group">
                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/ideas/walking-the-tightrope-balancing-bias-to-action-and-planning"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/1902_wright_glider_fly_crop-f4bb736dc0c311d88ccc346a010ca5cd.jpg" alt="The 1902 Wright Glider on one of its more than 700 flights." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/1902_wright_glider_fly_crop-f4bb736dc0c311d88ccc346a010ca5cd.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/1902_wright_glider_fly_crop-f4bb736dc0c311d88ccc346a010ca5cd.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/1902_wright_glider_fly_crop-f4bb736dc0c311d88ccc346a010ca5cd.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-software-engineering--before">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/walking-the-tightrope-balancing-bias-to-action-and-planning">Walking the tightrope: Balancing bias to action and planning</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/4a34a-dianne-marsh" itemprop="name">Dianne Marsh</a></span>
</div>
    
          <p class="dek">Dianne Marsh explains how microservices paved the way for traffic steering at Netflix, and she highlights current challenges. </p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/ideas/confessions-of-an-enterprise-architect"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/artgate_fondazione_cariplo_-_molteni_giuseppe,_la_confessione_crop-7d71e479a53b75c3ed13c47d59219a2b.jpg" alt="&#34;The Confession,&#34; by Giuseppe Molteni, 1838." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/artgate_fondazione_cariplo_-_molteni_giuseppe,_la_confessione_crop-7d71e479a53b75c3ed13c47d59219a2b.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/artgate_fondazione_cariplo_-_molteni_giuseppe,_la_confessione_crop-7d71e479a53b75c3ed13c47d59219a2b.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/artgate_fondazione_cariplo_-_molteni_giuseppe,_la_confessione_crop-7d71e479a53b75c3ed13c47d59219a2b.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-software-engineering--before">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/confessions-of-an-enterprise-architect">Confessions of an enterprise architect</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/dd9b0-scott-shaw" itemprop="name">Scott Shaw</a></span>
</div>
    
          <p class="dek">Faced with business and regulatory complexity, Scott Shaw found himself committing some of the software development acts he once condemned. He confesses those sins and explains why they’re sometimes necessary.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/ideas/listening-to-the-design-pressures-software-architecture-san-francisco-2016"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/7646172924_21751d1df6_o_crop-dcb6a2398267b3a8e315a9426ae53a01.jpg" alt="Listening in." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/7646172924_21751d1df6_o_crop-dcb6a2398267b3a8e315a9426ae53a01.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/7646172924_21751d1df6_o_crop-dcb6a2398267b3a8e315a9426ae53a01.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/7646172924_21751d1df6_o_crop-dcb6a2398267b3a8e315a9426ae53a01.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-software-engineering--before">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/listening-to-the-design-pressures-software-architecture-san-francisco-2016">Listening to the design pressures</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/9280b-martin-thompson" itemprop="name">Martin Thompson</a></span>
</div>
    
          <p class="dek">Martin Thompson explores the architectures that emerge from applying design patterns required for high performance, resilience, security, usability, and other quality-of-services measures.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/ideas/microservices-at-netflix-teams-and-services-are-tightly-aligned-and-loosely-coupled"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/soft-eng-hooks-on-fence-crop-33f7e78e18898d8966b72c330080f6b6.jpg" alt="Hooks on a fence." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/soft-eng-hooks-on-fence-crop-33f7e78e18898d8966b72c330080f6b6.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/soft-eng-hooks-on-fence-crop-33f7e78e18898d8966b72c330080f6b6.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/soft-eng-hooks-on-fence-crop-33f7e78e18898d8966b72c330080f6b6.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-software-engineering--before">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/microservices-at-netflix-teams-and-services-are-tightly-aligned-and-loosely-coupled">Microservices at Netflix: Teams and services are tightly aligned and loosely coupled</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/0d2c1-mac-slocum" itemprop="name">Mac Slocum</a></span>
</div>
    
          <p class="dek">An interview with Dianne Marsh, Director of Engineering, Cloud Tools, at Netflix.</p>

    
    
  </div>
</article>

      
  	</section>
    

</section>
  
</aside>

  </article>
</main>








  <footer role="contentinfo">
  <div class="footer-inner">

    <div class="about-us">
      <h3 class="title">About Us</h3>
      <ul>
        <li><a href="http://oreilly.com/about/">Our Company</a></li>
        <li><a href="http://oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
        <li><a href="http://oreilly.com/careers/">Careers</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Contact Us</a></li>
      </ul>
    </div>
    <div class="site-map">
      <h3 class="title">Site Map</h3>
      <ul>
        <li><a href="/ideas">Ideas</a></li>
        <li><a href="/learning">Learning</a></li>
        <li><a href="/topics">Topics</a></li>
        <li><a href="/all">All</a></li>
      </ul>
    </div>
    <div class="social">
      <ul>
        <li><a   class="icon-link " href="https://www.facebook.com/OReilly/"><span class="icon icon-facebook t-fill icon--white icon--large">
  <svg role="img">
    <title>facebook</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#facebook"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://twitter.com/oreillymedia"><span class="icon icon-twitter t-fill icon--white icon--large">
  <svg role="img">
    <title>twitter</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#twitter"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.youtube.com/user/OreillyMedia"><span class="icon icon-youtube-large t-fill icon--white icon--large">
  <svg role="img">
    <title>youtube-large</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#youtube-large"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://plus.google.com/+oreillymedia"><span class="icon icon-google t-fill icon--white icon--large">
  <svg role="img">
    <title>google</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#google"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.linkedin.com/company/oreilly-media"><span class="icon icon-linkedin t-fill icon--white icon--large">
  <svg role="img">
    <title>linkedin</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#linkedin"></use>
  </svg>
</span></a>
</li>
      </ul>
    </div>
  </div>
  <div class="legal">
	  <a href="/" class="logo logo-block t-bkg logo--medium">
<svg>
   <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
</svg>
</a>
  	<p class="copyright">&copy; 2018 O'Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><br>
  <a class="t-c" href="http://oreilly.com/terms/">Terms of Service</a>  <span class="bullet">&bull;</span>	<a class="t-c" href="http://oreilly.com/privacy.html">Privacy Policy</a> <span class="bullet">&bull;</span> <a class="t-c" href="http://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a>
	</div>
	<figure class="animal"><img src="https://d3ebicv0uqgr7t.cloudfront.net/images/tarsier.png" class="animal-img" alt="Animal"></figure>
</footer>



  
  

    <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5P4V6Z"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
  

  
</body>
</html>
