<!DOCTYPE html>
<html lang="en">
<head>
  <title>On computational ethics - O&#39;Reilly Media</title>

  <!-- Meta -->
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
      <meta property="twitter:card" content="summary_large_image" />
      <meta property="twitter:site" content="@OReillyMedia" />
      <meta property="twitter:title" content="On computational ethics" />
      <meta property="twitter:description" content="Is it possible to imagine an AI that can compute ethics?" />
      <meta property="description:site" content="Is it possible to imagine an AI that can compute ethics?" />
      <meta property="twitter:url" content="https://www.oreilly.com/ideas/on-computational-ethics" />
      <meta property="og:type" content="article" />
      <meta property="og:site_name" content="O&#39;Reilly Media" />
      <meta property="og:title" content="On computational ethics" />
      <meta property="og:description" content="Is it possible to imagine an AI that can compute ethics?" />
      <meta property="og:url" content="https://www.oreilly.com/ideas/on-computational-ethics" />
      <meta property="article:published_time" content="2017-03-20T11:00:00Z" />
      <meta property="article:author" content="Mike Loukides" />
      <meta name="description" content="Is it possible to imagine an AI that can compute ethics?" />
      <meta name="author" content="Mike Loukides" />
      <meta name="date" content="2017-03-20" />
      <meta property="og:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/stuttgart_friedrichsbau_denkpartner_crop-3ee43a7651e70cdf92645defd56b2215.jpg" />
      <meta property="twitter:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/stuttgart_friedrichsbau_denkpartner_crop-3ee43a7651e70cdf92645defd56b2215.jpg" />
      <meta name="thumbnail" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/stuttgart_friedrichsbau_denkpartner_crop-3ee43a7651e70cdf92645defd56b2215.jpg" />
      <meta name="graphic_medium" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/stuttgart_friedrichsbau_denkpartner_crop-3ee43a7651e70cdf92645defd56b2215.jpg" />
      <meta name="oreilly:topic" content="AI" />
      <meta name="oreilly:keywords" content="AI,artificial intelligence,ethics,philosophy,tragedy of the commons,computational ethics" />
  
  

  <!-- Assets -->
  <script type="text/javascript" src="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-7eba9a9879.js"></script>
  <link rel="stylesheet" type="text/css" href="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-a9c244cd4f.css">
    
  
  <!-- Extra Assets -->
  
  
  

  <!-- Start Adobe Digital Tag Manager Header-->
  <script type="text/javascript">
    dataLayer = [];
  </script>
  <script src="//assets.adobedtm.com/cdb881fdfcc417bad9035bdbc61f4a2b2135b110/satelliteLib-2d3d7e7aff56a08b02334ccd859df32171807210-staging.js"></script>
  <!-- End Adobe Digital Tag Manager Header-->

  <script type="text/javascript">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</script>

  <!-- Start Visual Website Optimizer Asynchronous Code -->
  <script type='text/javascript'>
    var _vwo_code=(function(){
    var account_id=244658,
    settings_tolerance=2000,
    library_tolerance=2500,
    use_existing_jquery=false,
  // DO NOT EDIT BELOW THIS LINE
  f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
  </script>
  <!-- End Visual Website Optimizer Asynchronous Code -->

</head>
<body class="body t-ai" data-section="ideas" >
  <div class="flashes"></div>
    <header id="page-header">
  <div id="header-bar" class="t-bkg">
    <h1 class="logo t-bkg" >
  <a href="/" class=" logo-white ">
  <svg role="heading" aria-label="O'Reilly">
    <title>O'Reilly</title>
    <use xlink:href="/assets/icons-b21895638b.svg#oreilly-logo"></use>
  </svg>
  </a>
</h1>
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="/learning">Learning</a>
              <a href="http://www.oreilly.com/conferences/">Events</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    
    
    <div class="right invert">
      <div id="search" class="hide">
        <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-b21895638b.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
      </div>
      <div id="user">
        <a href="#feedback"  class="t-c--d feedback" id="feedback">Feedback</a>
        <a class="t-c--d login" id="log-in-loading">Loading...</a>
        <a href="?log-in" class="t-c--d login" id="log-in">Log in</a>
        <a href="?log-out" class="t-c--d capture_end_session login" id="log-out">Log out</a>
        <a href="/user/preferences"  class="t-c--d login" id="preferences"><span class="icon icon-configure icon--small t-fill ">
  <svg role="img">
    <title>configure</title>
    <use xlink:href="/assets/icons-b21895638b.svg#configure"></use>
  </svg>
</span></a>
      </div>
    </div>
    <a id="menu-toggle" class="invert" ><span class="icon icon-white icon-menu">
  <svg role="img" id="close" class="is-hidden">
    <title>Close Menu</title>
    <use xlink:href="/assets/icons-b21895638b.svg#close"></use>
  </svg>
  <svg role="img" id="open">
    <title>Open Menu</title>
    <use xlink:href="/assets/icons-b21895638b.svg#menu"></use>
  </svg>
</span></a>
  </div>
     <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

  
  <div id="mobile-menu">
    
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="/learning">Learning</a>
              <a href="http://www.oreilly.com/conferences/">Events</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-b21895638b.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
         <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

    
  </div>

</header>


  <main aria-live="polite">
  <article class="article" itemscope itemtype="http://schema.org/Article">
              <header class="article-header">
        <div class="flag-follow " data-status="" id="">
      <div class="flag t-bkg--before bg-ai--before flag--small">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  
  <span class="cta">
    <span class="icons">
      
      
    </span>
    <span class="messages">
      
      
    </span>
</span>
</div>

  
  

  

  <h1 class="title t-c" itemprop="headline">On computational ethics</h1>

      <p class="dek" itemprop="alternativeHeadline">Is it possible to imagine an AI that can compute ethics?</p>
  

  <div class="byline">
  
  By
  <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/1b7da-mike-loukides" itemprop="name">Mike Loukides</a></span></div> <time class="date">March 20, 2017</time>

</header>
      

      <div class="article-body" itemprop="articleBody">
        
                              <figure class="article-image right">
  <img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/stuttgart_friedrichsbau_denkpartner_crop-3ee43a7651e70cdf92645defd56b2215.jpg" alt="Bronze-Skulptur &#34;Denkpartner&#34; von Hans-Jörg Limbach, 1980." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/stuttgart_friedrichsbau_denkpartner_crop-3ee43a7651e70cdf92645defd56b2215.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/stuttgart_friedrichsbau_denkpartner_crop-3ee43a7651e70cdf92645defd56b2215.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/stuttgart_friedrichsbau_denkpartner_crop-3ee43a7651e70cdf92645defd56b2215.jpg 1440w" sizes="(min-width: 1390px) 420px, (min-width: 600px) 45vw, 100vw" class=""/>
  <figcaption>Bronze-Skulptur &#34;Denkpartner&#34; von Hans-Jörg Limbach, 1980.
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://commons.wikimedia.org/wiki/File:Stuttgart_Friedrichsbau_Denkpartner.jpg">Andreas Praefcke on Wikimedia Commons</a>).
        
        
      </span>
    
    
  <figcaption>
</figure>
          
                      <aside data-type="note">
  <p>Registration for the <a href="https://conferences.oreilly.com/artificial-intelligence/ai-ny?intcmp=il-data-confreg-lp-ainy17_20170314_new_site_mike_loukides_computational_ethics_post_top_cta">O'Reilly Artificial Intelligence Conference, June 26-29, 2017, in New York is now open</a>.</p>
</aside>

          
        

        

        <p>While I was writing my post about <a href="https://www.oreilly.com/ideas/artificial-intelligence-cooperation-vs-aggression">artificial intelligence and aggression</a>, an odd thought occurred to me. When we discuss the <a href="https://www.oreilly.com/ideas/the-ethics-of-artificial-intelligence">ethics of artificial intelligence</a>, we're typically discussing the act of creating (programming, training, and deploying) AI systems. But there's another way to look at this. What kind of ethics is amenable to computation? Can ethical decision-making be computable?</p>
<p>I wasn't quite serious when I wrote about AIs deriving <a href="http://www.auburn.edu/~vestmon/robotics.html">Asimov's Laws of Robotics</a> from first principles—I really doubt that's possible. In particular, I doubt that AIs will ever be able to "learn" the difference between humans and other things: dogs, rocks, or, for that matter, computer-generated images of humans. There's a big difference between shooting a human and shooting an image of a human in Overwatch. How is a poor AI, which only sees patterns of bits, supposed to tell the difference?</p>
<p>But for the sake of argument and fantasy, let's engage in a thought experiment where we assume that AIs can tell the difference. And that the AI has unlimited computational power and memory. After all, Asimov was writing about precisely predicting human actions centuries in the future based on data and statistics. Big data indeed—and any computers he knew were infinitesimally small compared to ours. So, with computers that have more computational power than we can imagine today: is it possible to imagine an AI that can compute ethics?</p>
<p><a href="https://en.wikiquote.org/wiki/Jeremy_Bentham">Jeremy Bentham</a> summarized his moral philosophy, which came to be known as utilitarianism, by saying "the greatest happiness of the greatest number is the foundation of morals and legislation." That sounds like an optimization problem: figure out a utility function, some sort of computational version of <a href="https://en.wikipedia.org/wiki/Maslow's_hierarchy_of_needs">Maslow's hierarchy of needs</a>. Apply it to every person in the world, figure out how to combine the results, and optimize: use gradient ascent to find the maximum total utility. Many problems would need solutions along the way: what is that utility function in the first place, how do you know you have the right one, is the utility function the same for every person, and how do you combine the results? Is it simply additive? And there are problems with utilitarianism itself. It's been used to justify eugenics, ethnic cleansing, and all sorts of abominations: "the world would really be a better place without ..." Formally, this could be viewed simply as choosing the wrong utility function. But the problem isn't that simple: how do you know you have the right utility function, particularly if it can vary from person to person? So, utilitarianism might, in theory, be computable, but choosing appropriate utility functions would be subject to all sorts of prejudices and biases.</p>
<p><a href="https://en.wikipedia.org/wiki/Kantian_ethics">Immanual Kant's ethics</a> might also be computable. The primary idea, "act according to the principle which you would want to be a universal law" (the "categorical imperative"), can also be rephrased as an optimization problem. If I want to eat ice cream every day, I should first think about whether the world would be a tolerable place if everyone ate ice cream every day. It probably would (though that might conceivably push us up against some boundary conditions in the milk supply). If I want to dump my industrial waste on my neighbors' lawns, I have to think about whether the world would be acceptable if everyone did that. It probably wouldn't be. Computationally, this isn't all that different from utilitarianism: I have to apply my rule to everyone, sum the results, and decide whether they're acceptable. Instead of finding a maximum, we're avoiding a minimum, and computationally, that's just about the same thing. Kant would insist on something much more than avoiding a minimum, but I'll let that go. Kant would also insist that all rational actors would reach the same conclusion—which also makes it sound like a computational problem. If two programs use the same algorithm on the same data, they should get the same result. The difficulty would again be in finding the utility function. What are the global consequences, both positive and negative, of eating ice cream? Of pouring sewage? Like the utilitarian's utility function, this utility function would also be prone to prejudices and biases, both human and statistical.</p>
<p>You see a different optimization problem in <a href="https://plato.stanford.edu/entries/aristotle-ethics/">Aristotle's ethics</a>. One of Aristotle's principles is that the good is always situated between two extremes. When you see injustice, you ought to be angry, but not so angry that you lose control. It's equally unethical to have no anger, not to care about injustice. So, ethical action is a matter of dynamic balance, finding the appropriate operating point between unacceptable extremes. Maintaining that balance sounds a lot like control theory to me. Although Aristotle doesn't have the language to say this, it's a feedback loop. It's learned, it comes from experience, it's something people can get better at. But Aristotle has surprisingly little to say about the virtues on which ethical behavior is based. He assumes that he's speaking to someone who already understands what these mean, and wants to get better at living a good life. Computationally, that doesn't help. Humans can observe that acting justly satisfies them in a way that acting unjustly doesn't, and use this satisfaction as a signal that helps them learn how to lead a good life. It's not clear what satisfaction or pleasure would mean to an algorithm, and if we don't know what we're optimizing, we're not likely to achieve it. To an algorithm, this initial sense of right, of virtue or duty, is an input from outside the system, not something derived by the system.</p>
<p>Maybe there's a fourth approach. Are we limiting ourselves by casting computational ethics in terms defined by the history of philosophy? Maybe we can treat the whole world as a gigantic optimization problem and build an ethical software platform that learns its way toward ethics by observing actions and their outcomes, and tries to maximize total good. But that still begs the question: what are we optimizing? What's the utility function? Are we observing smiles and gestures, and interpreting them as signs of positive or negative outcomes? And what about long-range consequences? And if so, what sort of time frame are we looking at? To what extent are we willing to trade off short-term cost against long-term benefit? This is essentially utilitarian, in that we're solving for the "greatest good for the greatest number," so it's not surprising that we end up with the same problem. Even if we can use AI to distinguish good outcomes from bad outcomes, we still need some kind of function that tells how to value those outcomes. If a present good has bad consequences 10 years out, do we care? What if it's 100 years? 1,000 years? That's not a decision artificial intelligence can make for us.</p>
<p>We could go a step further by eliminating optimization altogether. That approach turns our problem into finding a <a href="https://en.wikipedia.org/wiki/Nash_equilibrium">Nash equilibrium</a>: you find everyone's preference function and evaluate the individual preference functions under all possible courses of action. Then you pick the action for each individual so that no individual can do better without convincing another player to change his or her action. The problem is that Nash equilibria aren't really optimal in any sense of the word. There is no such thing as cooperation; you can't go to the other players and say "if we work together, we will all be better off." A Nash equilibrium represents the <a href="https://en.wikipedia.org/wiki/Tragedy_of_the_commons">tragedy of the commons</a>, rendered in mathematical terms.</p>
<p>It isn't surprising that computational ethics looks like an optimization problem. Whether you're human or an AI, ethics is about finding the good, deciding the best way to live your life. That includes the possibility that you will sacrifice your own interest for someone else's good. If "living a good life" isn't a difficult optimization problem, I don't know what is. But I don't see how ethics based on <em>a priori</em> considerations, like Aristotle's ideas of duty or virtue, the Ten Commandments, or Asimov's laws, could be computed. These are all external inputs to the system, whether handed down on stone tablets or learned and handed down through many generations of human experience. I doubt that an AI could derive the idea that it must not harm a human—if we want AIs to behave according to anyone's laws, they'll have to be built into the system, including systems that have the ability to write their own code.</p>
<p>Or maybe not. If our ethics arose over millenia of shared experience and "supervised learning," could AIs do the same? Human learning is almost always supervised: we don't, on our own, learn how to act toward other humans. And our traditions are ancient enough that they can easily appear to be imposed from outside the system, even if they were derived within it.</p>
<p>That notion of <em>a priori</em> law was precisely what Kant and utilitarians were trying to avoid: can ethics be developed from the world, as opposed to imposed on it? But looking at the computational problems I've posed, I see a similar problem. Both utilitarians and Kantians need some kind of utility function. And those functions are either imposed from the outside or (to stay computational) derived from some futuristic sort of deep learning. In the first case, they're nothing more than the external laws we were trying to avoid, though possibly much more complex. In the latter case, where the functions are themselves the result of machine learning, they're still subject to bias, in both the rigorous statistical sense, and the less rigorous (but ultimately more important) human sense of "fairness." As <a href="https://www.bloomberg.com/view/articles/2017-03-08/how-data-can-turn-immigrants-into-criminals">Cathy O'Neil has observed</a>, people will create the data sets they need to confirm their biases. Who watches those who create the data sets?</p>
<p>Don't take this too seriously; I'm not really suggesting that any one try to code up the <a href="http://classics.mit.edu/Aristotle/nicomachaen.html">Nichomachean Ethics</a> or the <em><a href="http://philosophy.eserver.org/kant/critique-of-practical-reaso.txt">Critique of Practical Reason</a></em>. I'm skeptical of computational ethics, but skepticism comes easily. If you want to solve the problem of ethical computing, be my guest—but make sure you really solve it, and don't just sneak a holocaust's worth of human prejudices in through the back door.</p>


        
                  
        

                      <div class="image-credit">
  Article image: Bronze-Skulptur &#34;Denkpartner&#34; von Hans-Jörg Limbach, 1980.
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://commons.wikimedia.org/wiki/File:Stuttgart_Friedrichsbau_Denkpartner.jpg">Andreas Praefcke on Wikimedia Commons</a>).
        
        
      </span>
    
    
</div>
          

          

        </div>
      </div>

        <div class="article-meta">

  

  <ol class="article-share">
  
</ol>


      <article class="block block-common with-img person">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/people/1b7da-mike-loukides"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x360/mike-loukides-crop-b7719fefe24cc1ed26919575bde11961.jpg" alt="Mike Loukides" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x360/mike-loukides-crop-b7719fefe24cc1ed26919575bde11961.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x720/mike-loukides-crop-b7719fefe24cc1ed26919575bde11961.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x1440/mike-loukides-crop-b7719fefe24cc1ed26919575bde11961.jpg 1440w"  class=""/></a>
    
    
  </div>
  

  

  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/people/1b7da-mike-loukides">Mike Loukides</a>
    
    
    </h2>
    

    
          <p class="dek">Mike Loukides is Vice President of Content Strategy for O'Reilly Media, Inc. He's edited many highly regarded books on technical subjects that don't involve Windows programming. He's particularly interested in programming languages, Unix and what passes for Unix these days, and system and network administration. Mike is the author of System Performance Tuning and a coauthor of Unix Power Tools. Most recently, he's been fooling around with data and data analysis, languages like R, Mathematica, and Octave, and thinking about how to make books soc...</p>

    
  </div>
</article>

  

</div>


        <hr class="t-bkg section-divider" />


        <aside class="article-related">
      <section class="block-rows columns-4 ">

    

    <section class="block-group">
                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/keynotes-from-ai-new-york-2016"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg" alt="Welcome sign at O&#39;Reilly AI Conference 2016" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/keynotes-from-ai-new-york-2016">Highlights from the O&#39;Reilly AI Conference in New York 2016</a>
    
    
    </h2>
    

          <div class="byline">
  
  By
  <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/0d2c1-mac-slocum" itemprop="name">Mac Slocum</a></span></div>
    
          <p class="dek">Watch highlights covering artificial intelligence, machine learning, intelligence engineering, and more. From the O'Reilly AI Conference in New York 2016.</p>

    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-b21895638b.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/ideas/how-ai-is-propelling-driverless-cars-the-future-of-surface-transport"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg" alt="Close up of Uber&#39;s Self Driving Car in Pittsburgh." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/how-ai-is-propelling-driverless-cars-the-future-of-surface-transport">How AI is propelling driverless cars, the future of surface transport</a>
    
    
    </h2>
    

          <div class="byline">
  
  By
  <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/c7521-shahin-farshchi" itemprop="name">Shahin Farshchi</a></span></div>
    
          <p class="dek">Shahin Farshchi examines role artificial intelligence will play in driverless cars.</p>

    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/untapped-opportunities-in-ai"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/timaeus_trans_calcidius_med_manuscript-d9d6fd54691fcdb2dcf16580cc7c3c72.jpg" alt="Latin translation of Plato&#39;s Timaeus" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/timaeus_trans_calcidius_med_manuscript-d9d6fd54691fcdb2dcf16580cc7c3c72.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/timaeus_trans_calcidius_med_manuscript-d9d6fd54691fcdb2dcf16580cc7c3c72.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/timaeus_trans_calcidius_med_manuscript-d9d6fd54691fcdb2dcf16580cc7c3c72.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/untapped-opportunities-in-ai">Untapped opportunities in AI</a>
    
    
    </h2>
    

          <div class="byline">
  
  By
  <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/89289-beau-cronin" itemprop="name">Beau Cronin</a></span></div>
    
          <p class="dek">Some of AI's viable approaches lie outside the organizational boundaries of Google and other large Internet companies.</p>

    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/small-brains-big-data"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/16585641410_65f3489ebd_o-93cfdd984c69a50c6a6d97c5cc903f69.jpg" alt="Addresses and papers" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/16585641410_65f3489ebd_o-93cfdd984c69a50c6a6d97c5cc903f69.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/16585641410_65f3489ebd_o-93cfdd984c69a50c6a6d97c5cc903f69.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/16585641410_65f3489ebd_o-93cfdd984c69a50c6a6d97c5cc903f69.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/small-brains-big-data">Small brains, big data</a>
    
    
    </h2>
    

          <div class="byline">
  
  By
  <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/476ef-jeremey-freeman" itemprop="name">Jeremy Freeman</a></span></div>
    
          <p class="dek">How neuroscience is benefiting from distributed computing, and how computing might learn from neuroscience.</p>

    
  </div>
</article>

      
  	</section>
    

</section>
  
</aside>

      </div>
    </div>
  </article>
</main>








  <footer role="contentinfo">
  <div class="footer-inner">
    
    <div class="about-us">
      <h3 class="title">About Us</h3>
      <ul>
        <li><a href="http://oreilly.com/about/">Our Company</a></li>
        <li><a href="http://oreilly.com/work-with-us.html">Work with Us</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Contact Us</a></li>
      </ul>
    </div>
    <div class="site-map">
      <h3 class="title">Site Map</h3>
      <ul>
        <li><a href="/ideas">Ideas</a></li>
        <li><a href="/learning">Learning</a></li>
        <li><a href="/topics">Topics</a></li>
        <li><a href="/all">All</a></li>
      </ul>
    </div>
    <div class="social">
      <ul>
        <li><a   class="icon-link " href="http://fb.co/OReilly"><span class="icon icon-facebook t-fill icon--white icon--large">
  <svg role="img">
    <title>facebook</title>
    <use xlink:href="/assets/icons-b21895638b.svg#facebook"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="http://twitter.com/oreillymedia"><span class="icon icon-twitter t-fill icon--white icon--large">
  <svg role="img">
    <title>twitter</title>
    <use xlink:href="/assets/icons-b21895638b.svg#twitter"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.youtube.com/user/OreillyMedia"><span class="icon icon-youtube-large t-fill icon--white icon--large">
  <svg role="img">
    <title>youtube-large</title>
    <use xlink:href="/assets/icons-b21895638b.svg#youtube-large"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://plus.google.com/+oreillymedia"><span class="icon icon-google t-fill icon--white icon--large">
  <svg role="img">
    <title>google</title>
    <use xlink:href="/assets/icons-b21895638b.svg#google"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.linkedin.com/company/o%27reilly-media"><span class="icon icon-linkedin t-fill icon--white icon--large">
  <svg role="img">
    <title>linkedin</title>
    <use xlink:href="/assets/icons-b21895638b.svg#linkedin"></use>
  </svg>
</span></a>
</li>
      </ul>
    </div>
  </div>
  <div class="legal">
	  <a href="/" class="logo logo-block t-bkg logo--medium">
<svg>
   <use xlink:href="/assets/icons-b21895638b.svg#oreilly-logo"></use>
</svg>
</a>
  	<p class="copyright">&copy; 2017 O'Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><br>
  <a class="t-c" href="http://oreilly.com/terms/">Terms of Service</a>  <span class="bullet">&bull;</span>	<a class="t-c" href="http://oreilly.com/privacy.html">Privacy Policy</a> <span class="bullet">&bull;</span> <a class="t-c" href="http://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a>
	</div>
	<figure class="animal"><img src="https://d3ebicv0uqgr7t.cloudfront.net/images/tarsier.png" class="animal-img" alt="Animal"></figure>
</footer>



  
  
  <!-- Start Adobe Digital Tag Manager -->
  <script type="text/javascript">_satellite.pageBottom();</script>
  <!-- End Adobe Digital Tag Manager -->
</body>
</html>
