<!DOCTYPE html>
<html lang="en">
<head>
  <title>The future of machine learning is tiny - O&#39;Reilly Media</title>

  <!-- Meta -->
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
      <meta property="twitter:card" content="summary_large_image" />
      <meta property="twitter:site" content="@OReillyMedia" />
      <meta property="twitter:title" content="The future of machine learning is tiny" />
      <meta property="twitter:description" content="Pete Warden digs into why embedded machine learning is so important, how to implement it on existing chips, and shares new use cases it will unlock." />
      <meta property="description:site" content="Pete Warden digs into why embedded machine learning is so important, how to implement it on existing chips, and shares new use cases it will unlock." />
      <meta property="twitter:url" content="https://www.oreilly.com/ideas/the-future-of-machine-learning-is-tiny" />
      <meta property="fb:pages" content="15137500430" />
      <meta property="og:type" content="article" />
      <meta property="og:site_name" content="O&#39;Reilly Media" />
      <meta property="og:title" content="The future of machine learning is tiny" />
      <meta property="og:description" content="Pete Warden digs into why embedded machine learning is so important, how to implement it on existing chips, and shares new use cases it will unlock." />
      <meta property="og:url" content="https://www.oreilly.com/ideas/the-future-of-machine-learning-is-tiny" />
      <meta property="article:published_time" content="2019-07-08T15:50:00Z" />
      <meta property="article:author" content="Pete Warden" />
      <meta name="description" content="Pete Warden digs into why embedded machine learning is so important, how to implement it on existing chips, and shares new use cases it will unlock." />
      <meta name="author" content="Pete Warden" />
      <meta name="date" content="2019-07-08" />
      <meta property="og:image" content="https://d3ucjech6zwjp8.cloudfront.net/1400x933/kiwi-2539135_1920_crop-27fd0f1d2a07e4b53930755daf707ba5.jpg" />
      <meta property="twitter:image" content="https://d3ucjech6zwjp8.cloudfront.net/1400x933/kiwi-2539135_1920_crop-27fd0f1d2a07e4b53930755daf707ba5.jpg" />
      <meta name="thumbnail" content="https://d3ucjech6zwjp8.cloudfront.net/360x240/kiwi-2539135_1920_crop-27fd0f1d2a07e4b53930755daf707ba5.jpg" />
      <meta name="graphic_medium" content="https://d3ucjech6zwjp8.cloudfront.net/360x240/kiwi-2539135_1920_crop-27fd0f1d2a07e4b53930755daf707ba5.jpg" />
      <meta name="oreilly:topic" content="AI" />
      <meta name="oreilly:keywords" content="AI,machine learning,embedded machine learning" />
      <meta name="oreilly:content_type" content="video" />
  
  

  <!-- Assets -->
  <script type="text/javascript" src="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-85c07f5db6.js"></script>
  <link rel="stylesheet" type="text/css" href="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-d3cac3d885.css">
    
  
  <!-- Extra Assets -->
  
  
  

  <link rel="stylesheet" type="text/css" href="https://cdn.oreillystatic.com/assets/css/mkto-multiform-subscribe-20180320.css">

  <script type="text/javascript">
    dataLayer = [{"content.author":"Pete Warden","content.formatType":"video","content.free":"yes","content.identifier":"none","content.parentTopic":"ai","content.publisher":"O'Reilly Media Inc.","content.releaseDate":"2019-07-08","content.subTopic":"ai","content.subdirectory":"ideas","content.title":"The future of machine learning is tiny","keywords":["AI","machine learning","embedded machine learning"],"path":"/ideas/the-future-of-machine-learning-is-tiny","product.identifier":"none","product.title":"none","product.type":"none"}];
  </script>

  <script type="text/javascript">
    // init app.events for all communication
    app.events = new orm.Events();

    var tempData = {"content_type":"video","flag":{"flag-slug":"ai","flag-title":"AI","flag-url":"/topics/ai","parent-topic-slug":"ai"},"gateway_api_url":"https://gateway.oreilly.com","icons-svg":"/assets/icons-8812ab3f83.svg","post_info":{"byline":{"authors":[{"first-name":"Pete","last-name":"Warden","url":"/talent/b1e52-pete-warden"}],"content-type":"Video"},"title":"The future of machine learning is tiny"},"post_slug":"the-future-of-machine-learning-is-tiny","production":true,"segment_write":"c1bqZBPpSt05Stv3bKthxtFmC2etfgEK"};

    var kalturaVideoId = "";
    var kalturaAccount = "";
    var kalturaPlayer = "";

    // This should be genetated on the API directly.
    tempData.allTopics = [{"flag-title":"Money","flag-slug":"money"},{"flag-title":"Internet of Things","flag-slug":"internet-of-things","parent-topic-slug":"data"},{"flag-title":"Open Source","flag-slug":"open-source","parent-topic-slug":"software-engineering"},{"flag-title":"Data marketplace","flag-slug":"data-marketplace","parent-topic-slug":"data"},{"flag-title":"Cognitive augmentation","flag-slug":"cognitive-augmentation","parent-topic-slug":"data"},{"flag-title":"Software Architecture","flag-slug":"software-architecture","parent-topic-slug":"software-engineering"},{"flag-title":"Economy","flag-slug":"economy"},{"flag-title":"Data science","flag-slug":"data-science","parent-topic-slug":"data"},{"flag-title":"Design and Business","flag-slug":"design-and-business","parent-topic-slug":"design"},{"flag-title":"Data perils","flag-slug":"data-perils","parent-topic-slug":"data"},{"flag-title":"Data design","flag-slug":"data-design","parent-topic-slug":"data"},{"flag-title":"Data","flag-slug":"data"},{"flag-title":"Data culture","flag-slug":"data-culture","parent-topic-slug":"data"},{"flag-title":"Software Engineering","flag-slug":"software-engineering"},{"flag-title":"Data Tools","flag-slug":"data-tools","parent-topic-slug":"data"},{"flag-title":"Design","flag-slug":"design"},{"flag-title":"Artificial intelligence","flag-slug":"artificial-intelligence","parent-topic-slug":"data"}];

    // Push segement track requests to dataLayer
    window.analytics = { track: function(eventName, data){
      dataLayer.push({
        eventName: data
      });
    }};


    $(function() {
      app.metrics = new orm.Metrics();
      app.metrics.pageView();

      app.pageInit(tempData);

      // load data into events so it dispatched 'data:loaded'
      app.events.addData(tempData);
    })
  </script>

    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5P4V6Z');</script>
  <!-- End Google Tag Manager -->
  

  

    <script type="text/javascript">
    function createKeenWebAutoCollector(){window.keenWebAutoCollector=window.KeenWebAutoCollector.create({projectId:'551456c8672e6c2f4f5ee426',writeKey:'e737a463e3a57a914ddf707a34ad2c319c2e1c52999fe5f8087e41a71676675f90298cfd1a4e30ecf3f25e337db4b579c28c2bf784b26bdd6e9b7cc595b045098b94483dea878b17a65a56b5307b97ac3834670c2484fb8effa01cbacd55dba355850b97cad116b4b0e434dc64bc359c',onloadCallbacks:window.keenWebAutoCollector.onloadCallbacks}),window.keenWebAutoCollector.loaded()}function initKeenWebAutoCollector(){window.keenWebAutoCollector.domReady()?window.createKeenWebAutoCollector():document.addEventListener("readystatechange",function(){window.keenWebAutoCollector.domReady()&&window.createKeenWebAutoCollector()})}window.keenWebAutoCollector={onloadCallbacks:[],onload:function(a){this.onloadCallbacks.push(a)},domReady:function(){return["ready","complete"].indexOf(document.readyState)>-1}};
  </script>
  <script async type="text/javascript" src="https://d26b395fwzu5fz.cloudfront.net/keen-web-autocollector-1.0.8.min.js" onload="initKeenWebAutoCollector()"></script>
  

  <!-- Start Visual Website Optimizer Asynchronous Code -->
  <script type='text/javascript'>
    var _vwo_code=(function(){
    var account_id=244658,
    settings_tolerance=2000,
    library_tolerance=2500,
    use_existing_jquery=false,
  // DO NOT EDIT BELOW THIS LINE
  f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
  </script>
  <!-- End Visual Website Optimizer Asynchronous Code -->

  <!-- Marketo -->
  <script src="https://app-ab24.marketo.com/js/forms2/js/forms2.min.js" type="text/javascript"></script>

</head>
<body class="body t-ai" data-section="ideas" >
  <div class="flashes"></div>
    <header id="page-header">
  <div id="header-bar" class="t-bkg">
    <h1 class="logo t-bkg" >
  <a href="/" class=" logo-white ">
  <svg role="heading" aria-label="O'Reilly">
    <title>O'Reilly</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
  </svg>
  </a>
</h1>
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://learning.oreilly.com">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>


    <div class="right">
      <div id="search" class="hide">
        <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
      </div>
      <div id="user">
        <a href="https://www.oreilly.com/sign-in.html" class="t-c--d">Sign In</a>
      </div>
    </div>
    <a id="menu-toggle" class="invert" ><span class="icon icon-white icon-menu">
  <svg role="img" id="close" class="is-hidden">
    <title>Close Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#close"></use>
  </svg>
  <svg role="img" id="open">
    <title>Open Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#menu"></use>
  </svg>
</span></a>
  </div>
     <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

  
  <div id="mobile-menu">

    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://learning.oreilly.com">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
         <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

    
  </div>

</header>





  <!-- Linked In -->
  <script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
  
<!-- Load Facebook SDK for JavaScript -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<main aria-live="polite">
  <article class="article" itemscope itemtype="http://schema.org/Article">

              <header class="article-header">
      <div class="flag t-bkg--before bg-ai--before flag--small">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  
  

  <h1 class="title t-c" itemprop="headline">The future of machine learning is tiny</h1>

      <p class="dek" itemprop="alternativeHeadline">Pete Warden digs into why embedded machine learning is so important, how to implement it on existing chips, and shares new use cases it will unlock.</p>
  

  <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/talent/b1e52-pete-warden" itemprop="name">Pete Warden</a></span>
</div> <time class="date">July 8, 2019</time>

</header>

      

      <section class="video-body" itemprop="articleBody">

                    <div class="video-player">
            <div class="responsive-video">

    <iframe src="https://www.youtube.com/embed/0fLvCezGMko?rel=0&amp;autohide=1&amp;controls=1&amp;showinfo=0&amp;modestbranding=1" frameborder="0" allowfullscreen></iframe>
  

  

  

</div>

          </div>
          
          <div class="video-content article-body">
            

                          <p>This is a keynote highlight from the O'Reilly Artificial Intelligence Conference in Beijing 2019. <a href="https://learning.oreilly.com/videos/artificial-intelligence-conference/9781492050629/9781492050629-video325735">Watch the full version of this keynote on the O'Reilly online learning platform</a>.</p>

<p>You can also <a href="https://www.oreilly.com/ideas/highlights-from-ai-beijing-2019">see other highlights from the event</a>.</p>
            

            

                          <div class="image-credit">
  Article image: Bubbles
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://pixabay.com/photos/kiwi-kiwi-under-water-close-up-2539135/">Pixabay</a>).
        
        
      </span>
    
    
</div>
            

                          <div class="article-tags">
Tags:
  <a href="https://www.oreilly.com/tags/radar">O&#39;Reilly Radar Analysis</a>&nbsp;

</div>
            

            <div class="video-meta"></div>

          </div>

          <div class="article-meta">

  <div class="article-share">
  <div class="article-share-text"> Share </div>
  <ol>
    <li><a href="https://twitter.com/share" class="twitter-share-button" data-via="oreillymedia" data-show-count="false">Tweet</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></li>
    <li>  <div class="fb-share-button" 
    data-href="https://www.oreilly.com/ideas/the-future-of-machine-learning-is-tiny" 
    data-layout="button_count">
  </div></li>
    <li><script type="IN/Share" data-url="https://www.oreilly.com/ideas/the-future-of-machine-learning-is-tiny" data-counter="right"></script></li>
  </ol>
  <hr>
</div>

  

      <article class="block block-common person with-link">
  

  

  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/talent/b1e52-pete-warden">Pete Warden</a>
    
    
    </h2>
    

    
          <p class="dek">Pete Warden is the technical lead of the mobile and embedded TensorFlow group, in Google's Brain team.</p>

    
          <a class="btn btn--xsmall" style="float: right;" href="/talent/b1e52-pete-warden">more</a>
    
  </div>
</article>

  

</div>


      </section>

      <hr class="t-bkg section-divider" />


      <aside class="article-related">
      <section class="block-rows columns-4 ">

    

    <section class="block-group">
                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/infographic-the-bot-platform-ecosystem"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/crop_bots-landscape-1400-747150421594bbc537f4043fb0aa4dca.jpg" alt="Bots landscape." srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/crop_bots-landscape-1400-747150421594bbc537f4043fb0aa4dca.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/crop_bots-landscape-1400-747150421594bbc537f4043fb0aa4dca.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/crop_bots-landscape-1400-747150421594bbc537f4043fb0aa4dca.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/infographic-the-bot-platform-ecosystem">Infographic: The bot platform ecosystem</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/talent/b1d73-jon-bruner" itemprop="name">Jon Bruner</a></span>
</div>
    
          <p class="dek">A look at the artificial intelligence and messaging platforms behind the fast-growing chatbot community</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/ideas/evolve-ai"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/7155293377_9c276139df_o_crop-b30d7090c0e18da65e1c139d2d4d64f3.jpg" alt="Vertical forest, Milan." srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/7155293377_9c276139df_o_crop-b30d7090c0e18da65e1c139d2d4d64f3.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/7155293377_9c276139df_o_crop-b30d7090c0e18da65e1c139d2d4d64f3.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/7155293377_9c276139df_o_crop-b30d7090c0e18da65e1c139d2d4d64f3.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/evolve-ai">Evolve AI</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/talent/14d38-naveen-rao" itemprop="name">Naveen Rao</a></span>
</div>
    
          <p class="dek">Naveen Rao explains how Intel Nervana is evolving the AI stack from silicon to the cloud.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/keynotes-from-ai-new-york-2016"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg" alt="Welcome sign at O&#39;Reilly AI Conference 2016" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/keynotes-from-ai-new-york-2016">Highlights from the O&#39;Reilly AI Conference in New York 2016</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/talent/0d2c1-mac-slocum" itemprop="name">Mac Slocum</a></span>
</div>
    
          <p class="dek">Watch highlights covering artificial intelligence, machine learning, intelligence engineering, and more. From the O'Reilly AI Conference in New York 2016.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/ideas/how-ai-is-propelling-driverless-cars-the-future-of-surface-transport"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg" alt="Close up of Uber&#39;s Self Driving Car in Pittsburgh." srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/how-ai-is-propelling-driverless-cars-the-future-of-surface-transport">How AI is propelling driverless cars, the future of surface transport</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/talent/c7521-shahin-farshchi" itemprop="name">Shahin Farshchi</a></span>
</div>
    
          <p class="dek">Shahin Farshchi examines role artificial intelligence will play in driverless cars.</p>

    
    
  </div>
</article>

      
  	</section>
    

</section>
  
</aside>

  </article>
</main>






  <footer role="contentinfo">
  <div class="footer-inner">

    <div class="about-us">
      <h3 class="title">About Us</h3>
      <ul>
        <li><a href="http://oreilly.com/about/">Our Company</a></li>
        <li><a href="http://oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
        <li><a href="http://oreilly.com/careers/">Careers</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Contact Us</a></li>
      </ul>
    </div>
    <div class="site-map">
      <h3 class="title">Site Map</h3>
      <ul>
        <li><a href="/ideas">Ideas</a></li>
        <li><a href="/topics/oreilly-learning">Learning</a></li>
        <li><a href="/topics">Topics</a></li>
        <li><a href="/all">All</a></li>
      </ul>
    </div>
    <div class="social">
      <ul>
        <li><a   class="icon-link " href="https://www.facebook.com/OReilly/"><span class="icon icon-facebook t-fill icon--white icon--large">
  <svg role="img">
    <title>facebook</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#facebook"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://twitter.com/oreillymedia"><span class="icon icon-twitter t-fill icon--white icon--large">
  <svg role="img">
    <title>twitter</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#twitter"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.youtube.com/user/OreillyMedia"><span class="icon icon-youtube-large t-fill icon--white icon--large">
  <svg role="img">
    <title>youtube-large</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#youtube-large"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://plus.google.com/+oreillymedia"><span class="icon icon-google t-fill icon--white icon--large">
  <svg role="img">
    <title>google</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#google"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.linkedin.com/company/oreilly-media"><span class="icon icon-linkedin t-fill icon--white icon--large">
  <svg role="img">
    <title>linkedin</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#linkedin"></use>
  </svg>
</span></a>
</li>
      </ul>
    </div>
  </div>
  <div class="legal">
	  <a href="/" class="logo logo-block t-bkg logo--medium">
<svg>
   <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
</svg>
</a>
  	<p class="copyright">&copy; 2019 O'Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><br>
  <a class="t-c" href="http://oreilly.com/terms/">Terms of Service</a>  <span class="bullet">&bull;</span>	<a class="t-c" href="http://oreilly.com/privacy.html">Privacy Policy</a> <span class="bullet">&bull;</span> <a class="t-c" href="http://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a>
	</div>
	<figure class="animal"><img src="https://d3ebicv0uqgr7t.cloudfront.net/images/tarsier.png" class="animal-img" alt="Animal"></figure>
</footer>



  
  

    <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5P4V6Z"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
  

  
</body>
</html>
