<!DOCTYPE html>
<html lang="en">
<head>
  <title>Toward the Jet Age of machine learning - O&#39;Reilly Media</title>

  <!-- Meta -->
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
      <meta property="twitter:card" content="summary_large_image" />
      <meta property="twitter:site" content="@OReillyMedia" />
      <meta property="twitter:title" content="Toward the Jet Age of machine learning" />
      <meta property="twitter:description" content="Solving the challenges of efficiency, automation, and safety will require cooperation between researchers and engineers spanning both academia and industry." />
      <meta property="description:site" content="Solving the challenges of efficiency, automation, and safety will require cooperation between researchers and engineers spanning both academia and industry." />
      <meta property="twitter:url" content="https://www.oreilly.com/ideas/toward-the-jet-age-of-machine-learning" />
      <meta property="fb:pages" content="15137500430" />
      <meta property="og:type" content="article" />
      <meta property="og:site_name" content="O&#39;Reilly Media" />
      <meta property="og:title" content="Toward the Jet Age of machine learning" />
      <meta property="og:description" content="Solving the challenges of efficiency, automation, and safety will require cooperation between researchers and engineers spanning both academia and industry." />
      <meta property="og:url" content="https://www.oreilly.com/ideas/toward-the-jet-age-of-machine-learning" />
      <meta property="article:published_time" content="2018-04-25T06:45:00Z" />
      <meta property="article:author" content="Ameet Talwalkar" />
      <meta name="description" content="Solving the challenges of efficiency, automation, and safety will require cooperation between researchers and engineers spanning both academia and industry." />
      <meta name="author" content="Ameet Talwalkar" />
      <meta name="date" content="2018-04-25" />
      <meta property="og:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/2558061651_27eec20312_o_crop-1f1b13334578ddd71b9841f3d250867d.jpg" />
      <meta property="twitter:image" content="https://d3tdunqjn7n0wj.cloudfront.net/1400x933/2558061651_27eec20312_o_crop-1f1b13334578ddd71b9841f3d250867d.jpg" />
      <meta name="thumbnail" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/2558061651_27eec20312_o_crop-1f1b13334578ddd71b9841f3d250867d.jpg" />
      <meta name="graphic_medium" content="https://d3tdunqjn7n0wj.cloudfront.net/360x240/2558061651_27eec20312_o_crop-1f1b13334578ddd71b9841f3d250867d.jpg" />
      <meta name="oreilly:topic" content="AI" />
      <meta name="oreilly:keywords" content="AI,artificial intelligence,conference,tutorials,machine learning,automation,safety" />
  
  

  <!-- Assets -->
  <script type="text/javascript" src="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-9ea27e5263.js"></script>
  <link rel="stylesheet" type="text/css" href="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-2418db9e95.css">
    
  
  <!-- Extra Assets -->
  
  
  

  <script type="text/javascript">
    dataLayer = [];
  </script>

    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5P4V6Z');</script>
  <!-- End Google Tag Manager -->
  

  

    <script type="text/javascript">
    function createKeenWebAutoCollector(){window.keenWebAutoCollector=window.KeenWebAutoCollector.create({projectId:'551456c8672e6c2f4f5ee426',writeKey:'e737a463e3a57a914ddf707a34ad2c319c2e1c52999fe5f8087e41a71676675f90298cfd1a4e30ecf3f25e337db4b579c28c2bf784b26bdd6e9b7cc595b045098b94483dea878b17a65a56b5307b97ac3834670c2484fb8effa01cbacd55dba355850b97cad116b4b0e434dc64bc359c',onloadCallbacks:window.keenWebAutoCollector.onloadCallbacks}),window.keenWebAutoCollector.loaded()}function initKeenWebAutoCollector(){window.keenWebAutoCollector.domReady()?window.createKeenWebAutoCollector():document.addEventListener("readystatechange",function(){window.keenWebAutoCollector.domReady()&&window.createKeenWebAutoCollector()})}window.keenWebAutoCollector={onloadCallbacks:[],onload:function(a){this.onloadCallbacks.push(a)},domReady:function(){return["ready","complete"].indexOf(document.readyState)>-1}};
  </script>
  <script async type="text/javascript" src="https://d26b395fwzu5fz.cloudfront.net/keen-web-autocollector-1.0.8.min.js" onload="initKeenWebAutoCollector()"></script>
  

  <script type="text/javascript">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</script>

  <!-- Start Visual Website Optimizer Asynchronous Code -->
  <script type='text/javascript'>
    var _vwo_code=(function(){
    var account_id=244658,
    settings_tolerance=2000,
    library_tolerance=2500,
    use_existing_jquery=false,
  // DO NOT EDIT BELOW THIS LINE
  f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
  </script>
  <!-- End Visual Website Optimizer Asynchronous Code -->

  <!-- Marketo -->
  <script src="https://app-ab24.marketo.com/js/forms2/js/forms2.min.js" type="text/javascript"></script>

</head>
<body class="body t-ai" data-section="ideas" >
  <div class="flashes"></div>
    <header id="page-header">
  <div id="header-bar" class="t-bkg">
    <h1 class="logo t-bkg" >
  <a href="/" class=" logo-white ">
  <svg role="heading" aria-label="O'Reilly">
    <title>O'Reilly</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
  </svg>
  </a>
</h1>
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>


    <div class="right invert">
      <div id="search" class="hide">
        <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
      </div>
      <div id="user">
        <!-- <a href="#feedback"  class="t-c--d feedback" id="feedback">Feedback</a> -->
        <a class="t-c--d login" id="log-in-loading">Loading...</a>
        <a href="?log-in" class="t-c--d login" id="log-in">Log in</a>
        <a href="?log-out" class="t-c--d capture_end_session login" id="log-out">Log out</a>
        <a href="/user/preferences"  class="t-c--d login" id="preferences"><span class="icon icon-configure icon--small t-fill ">
  <svg role="img">
    <title>configure</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#configure"></use>
  </svg>
</span></a>
      </div>
    </div>
    <a id="menu-toggle" class="invert" ><span class="icon icon-white icon-menu">
  <svg role="img" id="close" class="is-hidden">
    <title>Close Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#close"></use>
  </svg>
  <svg role="img" id="open">
    <title>Open Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#menu"></use>
  </svg>
</span></a>
  </div>
     <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

  
  <div id="mobile-menu">

    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
         <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

    
  </div>

</header>



  <!-- Linked In -->
  <script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
  
<!-- Load Facebook SDK for JavaScript -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<main aria-live="polite">
  <article class="article" itemscope itemtype="http://schema.org/Article">
              <header class="article-header">
        <div class="flag-follow " data-status="" id="">
      <div class="flag t-bkg--before bg-ai--before flag--small">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  
  <span class="cta">
    <span class="icons">
      
      
    </span>
    <span class="messages">
      
      
    </span>
</span>
</div>

  
  

  

  <h1 class="title t-c" itemprop="headline">Toward the Jet Age of machine learning</h1>

      <p class="dek" itemprop="alternativeHeadline">Solving the challenges of efficiency, automation, and safety will require cooperation between researchers and engineers spanning both academia and industry.</p>
  

  <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/e25fb-ameet-talwalkar" itemprop="name">Ameet Talwalkar</a></span>
</div> <time class="date">April 25, 2018</time>

</header>

      

      <div class="article-body" itemprop="articleBody">
        
                              <figure class="article-image right">
  <img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/2558061651_27eec20312_o_crop-1f1b13334578ddd71b9841f3d250867d.jpg" alt="Pan Am L-049 Constellation at London" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/2558061651_27eec20312_o_crop-1f1b13334578ddd71b9841f3d250867d.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/2558061651_27eec20312_o_crop-1f1b13334578ddd71b9841f3d250867d.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/2558061651_27eec20312_o_crop-1f1b13334578ddd71b9841f3d250867d.jpg 1440w" sizes="(min-width: 1390px) 420px, (min-width: 600px) 45vw, 100vw" class=""/>
  <figcaption>Pan Am L-049 Constellation at London
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://www.flickr.com/photos/26652467@N00/2558061651">Greg and Cindy on Flickr</a>)
        
        
      </span>
    
    
  <figcaption>

</figure>
          
                      <aside data-type="note">
  <p><a href="https://conferences.oreilly.com/artificial-intelligence/ai-ca/public/schedule/detail/68727?intcmp=il-data-confreg-lp-ainy18_new_site_/toward-the-jet-age-of-machine-learning_top_cta">Check out the "Software Development in the Age of Deep Learning" session</a> at the AI Conference in San Francisco, September 4-7, 2018. Hurry&mdash;best price ends June 8.</p>
</aside>

          
        

        

        <p>Machine learning today resembles the dawn of aviation. In 1903, dramatic flights by the Wright brothers ushered in the Pioneer Age of aviation, and within a decade, there was widespread belief that powered flight would revolutionize transportation and society more generally. Machine learning (ML) today is also rapidly advancing. We have recently witnessed remarkable breakthroughs on important problems including image recognition, speech translation, and natural language processing, and major technology companies are investing billions of dollars to transform themselves into ML-centric organizations. There is a growing conviction that ML holds the key to some of society’s most pressing problems.</p>

<figure class="center" id="id-31Vik"><img alt="A new engineering discipline brought aviation into the Jet Age" width="65%" src="https://d3ansictanv2wj.cloudfront.net/talwalkar_figure1-fe8eb482f6c59f9910fdee1626f48eba.png"><figcaption><span class="label">Figure 1. </span>The Wright brothers’ first powered airplane traveled 120 feet during its initial 12 second flight on December 17, 1903, at Kitty Hawk. Credit <a href="https://www.pancakeandfranks.com/">Stacy Pancake</a>.</figcaption></figure>

<p>However, this excitement should also be met with caution. For all the enthusiasm that the Wright brothers generated, nearly half a century would pass before widespread commercial aviation finally became a reality. During the Pioneer Age, aviation was largely restricted to private, sport, and military use. Getting to the Jet Age required a series of fundamental innovations in aeronautical engineering—monoplane wings, aluminum designs, turbine engines, stress testing, jumbo jets, etc.</p>

<figure class="center" id="id-5vyir"><img alt="commercial Jet Age in the 1950s" width="75%" src="https://d3ansictanv2wj.cloudfront.net/talwalkar_figure2-8a9d02d8fdd388835e3be7265728f2c4.png"><figcaption><span class="label">Figure 2. </span>Decades of advances in aeronautical engineering led to the Jet Age in the 1950s, which fundamentally changed societal behavior and enabled us to tackle new challenges—e.g., space exploration. Credit: Stacy Pancake.</figcaption></figure>

<p>Simply put, we needed to invent aeronautical engineering before we could transform the aviation industry. Similarly, we need to invent a new kind of engineering to build ML applications. Data-driven software development is radically different from conventional software development, as it targets complex applications domains (e.g., vision, speech, language) and focuses on learned behaviors instead of rule-based operations (e.g., training deep neural networks on massive data sets versus hand-coded if-then-else statements). Currently, very few organizations have the expertise to do this kind of engineering, and we are just scratching the surface of the potential for ML-powered technology. We describe three key challenges of this new development paradigm below.</p>

<figure class="center" id="id-6nGie"><img alt="The turbine engine" width="40%" src="https://d3ansictanv2wj.cloudfront.net/talwalkar_figure3-aeb37da231f8248fb595f650abb4aa49.png"><figcaption><span class="label">Figure 3. </span>The turbine engine, developed over several decades, resulted in planes that were dramatically faster and more efficient, enabling travel around the world in less than a day. Credit: Stacy Pancake.</figcaption></figure>




<h2>Challenge 1: Efficiency</h2>



<p id="F1">Modern ML applications typically involve complex models and massive data sets, requiring significant computational and storage resources. For instance, engineers at Google Brain needed more than 250,000 GPU hours to train a neural translation model for a <em>single</em> pair of languages (English and German), which costs about $200,000 on Google Compute Engine.<a href="#_ftn1"><sup>[1]</sup></a> In response, a wide range of specialized hardware solutions are being developed (e.g., GPUs, TPUs, massively parallel CPUs, FPGAs) to improve the speed, energy efficiency, and cost of ML-powered applications.</p>



<p>However, effectively leveraging heterogenous hardware will require us to fundamentally redesign ML software itself. In particular, systems-aware algorithms and software are needed (i) to efficiently train models on massively parallel and heterogeneous hardware, and (ii) to satisfy service level agreements (SLAs) related to latency, power consumption, and memory footprint constraints for production deployments. Advances in hardware must be closely coupled with algorithmic and software innovation in order to develop and deploy ML-based applications in a timely and economical fashion.</p>

<figure class="center" id="id-5dEi7"><img alt="Automation in modern commercial aviation" width="40%" src="https://d3ansictanv2wj.cloudfront.net/talwalkar_figure4-41a732f201d6c773bb89e5267673a740.png"><figcaption><span class="label">Figure 4. </span>Automation is widespread in modern commercial aviation, including plane manufacturing / testing, air traffic control, and even operating planes. Credit: Stacy Pancake.</figcaption></figure>


<h2>Challenge 2: Automation</h2>



<p>In addition to being computationally intensive, ML-powered applications are incredibly labor-intensive for ML engineers to train, debug, and deploy. First, even selecting the appropriate computational platform is challenging, given the rapidly changing hardware landscape and diverse set of available cloud-based offerings. Second, the quality of an ML model is highly sensitive to hyperparameters; tuning these hyperparameters is crucial for accuracy but is often labor-intensive and expensive in computational cost. Third, utilizing parallel hardware at training time is highly non-trivial. Naively boosting computational power often does not result in meaningful speedups, and fair and effective sharing of cluster resources among users can be challenging.</p>



<p id="F2">To make things worse, developing ML applications is not a one-shot process: data changes over time, and therefore models and systems must adapt. Diagnosing and updating stale models is challenging, and exacerbated by the surprising difficulty (and sometimes impossibility<a href="#_ftn2"><sup>[2]</sup></a>) of reproducing the behavior of ML applications. These issues are due to many factors, including (i) the statistical or "fuzzy" nature of these applications; (ii) the complexity of ML applications (e.g., pipeline jungles<a href="#_ftn3"><sup>[3]</sup></a>); and (iii) ad-hoc development processes in which both code and data evolve over time with inadequate (and sometimes non-existent) controls. Given the shortage and cost of ML talent and the increased demands for ML technology, there is a pressing need to automate and simplify these development and deployment processes.</p>

<figure class="center" id="id-3EaiZ"><img alt="aviation safety" width="75%" src="https://d3ansictanv2wj.cloudfront.net/talwalkar_figure5-49fc42b4960df59f7af6155c63cdcc5a.png"><figcaption><span class="label">Figure 5. </span>The widespread adoption of commercial aviation hinged on dramatic advances in aviation safety, including advances in plane design and testing, as well as the creation of international and domestic regulatory bodies—e.g., the ICAO and FAA. Credit: Stacy Pancake.</figcaption></figure>

<h2>Challenge 3: Safety</h2>



<p>As ML applications become more ubiquitous and increasingly influence societal interactions (e.g., curating news, determining credit worthiness, influencing criminal sentencing, navigating vehicles autonomously), the safety risks associated with the misuse or misunderstanding of this technology are magnified. It is, thus, critical to understand and audit the behavior of ML applications: do we understand how models are making their decisions? What is the confidence / uncertainty associated with individual decisions? Do these predictions pose immediate threats to an individual or to society? What are the broader ethical ramifications of a given ML application? What information is being used to make decisions? Is individual privacy adequately being preserved?</p>



<p>Unfortunately, ML applications do not provide us with straightforward answers to these questions. They are inherently data-driven and not based on simple rules, and we have a fundamental lack of understanding as to why leading ML approaches (e.g., deep learning models) even work in the first place. In addition to advancing our basic scientific understanding, it is paramount that we develop robust ML-centric engineering processes to mitigate potential safety risks. These new processes must address the complexity and uncertainty inherent to ML applications.</p>



<h2>The interdisciplinary path forward</h2>



<p>These challenges—efficiency, automation, and safety—won’t be solved overnight. It is clear that they touch a broad set of disciplines, and consequently devising effective solutions will require cooperation between researchers and engineers spanning both academia and industry.</p>



<p id="F4">From an academic perspective, we are already witnessing encouraging signs of interdisciplinary progress, as these core challenges have spurred the development of new research communities. Two notable examples are: (i) the SysML<a href="#_ftn4"><sup>[4]</sup></a> research community that works at the intersection of systems and ML to design system-aware algorithms and identify best practices for learning systems; and (ii) the FatML<a href="#_ftn5"><sup>[5]</sup></a> research community that brings together a diverse set of social and quantitative researchers and practitioners concerned with fairness, accountability, and transparency in ML.</p>



<p>However, we ultimately want to move beyond academic research, and leverage cutting-edge theoretical advances in order to design and build increasingly robust and sophisticated engineering systems. To do so will require coordination between researchers working on more abstract and theoretical problems and engineers who understand industrial processes and real-world deployment requirements. While we have a long way to go before we arrive at the Jet Age of ML, continued collaborative efforts will truly enable ML to take flight.</p>

<aside data-type="sidebar" id="id-5qBSE">

<div id="_ftn1">
<p><sup>[1]</sup> Britz et al. Massive Exploration of Neural Machine Translation Architectures, Conference on Empirical Methods in Natural Language Processing, 2017. <a href="#F1">(Return)</a></p>
</div>

<div id="_ftn2">
<p><sup>[2]</sup> For instance, various TensorFlow operations on GPUs or multi-threaded CPUs are known to be non-deterministic; see <a href="https://github.com/tensorflow/tensorflow/issues/3103">https://github.com/tensorflow/tensorflow/issues/3103</a> for more details. <a href="#F2">(Return)</a></p>
</div>

<div id="_ftn3">
<p><sup>[3]</sup> Sculley et al. Hidden Technical Debt in Machine Learning Systems, Neural Information Processing Systems, 2015. <a href="#F2">(Return)</a></p>
</div>

<div id="_ftn4">
<p><sup>[4]</sup> <a href="http://www.sysml.cc">http://www.sysml.cc</a> <a href="#F4">(Return)</a></p>
</div>

<div id="_ftn5">
<p><sup>[5]</sup> <a href="https://fatconference.org">https://fatconference.org</a> <a href="#F4">(Return)</a></p>
</div>
</aside>

<p><strong>Related content:</strong></p>

<ul>
	<li>
<a href="https://www.oreilly.com/ideas/how-to-train-and-deploy-deep-learning-at-scale">"How to train and deploy deep learning at scale"</a>: Ameet Talwalkar on large-scale machine learning.</li>
</ul>


        
                  
        

                  <div class="image-credit">
  Article image: Pan Am L-049 Constellation at London
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://www.flickr.com/photos/26652467@N00/2558061651">Greg and Cindy on Flickr</a>).
        
        
      </span>
    
    
</div>
        

        

      </div>

      <div class="article-meta">

  <div class="article-share">
  <div class="article-share-text"> Share </div>
  <ol>
    <li><a href="https://twitter.com/share" class="twitter-share-button" data-via="oreillymedia" data-show-count="false">Tweet</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></li>
    <li>  <div class="fb-share-button" 
    data-href="https://www.oreilly.com/ideas/toward-the-jet-age-of-machine-learning" 
    data-layout="button_count">
  </div></li>
    <li><script type="IN/Share" data-url="https://www.oreilly.com/ideas/toward-the-jet-age-of-machine-learning" data-counter="right"></script></li>
  </ol>
  <hr>
</div>

  

      <article class="block block-common person with-link">
  

  

  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/people/e25fb-ameet-talwalkar">Ameet Talwalkar</a>
    
    
    </h2>
    

    
          <p class="dek">Ameet Talwalkar is an assistant professor in the Machine Learning Department at Carnegie Mellon University.  He is also co-founder and Chief Scientist at Determined AI, a software company that makes machine learning engineers and data scientists extraordinarily more productive.
</p>

    
          <a class="btn btn--xsmall" style="float: right;" href="/people/e25fb-ameet-talwalkar">more</a>
    
  </div>
</article>

  

</div>


      <hr class="t-bkg section-divider" />


      <aside class="article-related">
      <section class="block-rows columns-4 ">

    

    <section class="block-group">
                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/keynotes-from-ai-new-york-2016"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg" alt="Welcome sign at O&#39;Reilly AI Conference 2016" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/ai-oreilly-ai-16-welcome-crop-0c314e7dc94237143f57ec53bae638f2.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/keynotes-from-ai-new-york-2016">Highlights from the O&#39;Reilly AI Conference in New York 2016</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/0d2c1-mac-slocum" itemprop="name">Mac Slocum</a></span>
</div>
    
          <p class="dek">Watch highlights covering artificial intelligence, machine learning, intelligence engineering, and more. From the O'Reilly AI Conference in New York 2016.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/ideas/how-ai-is-propelling-driverless-cars-the-future-of-surface-transport"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg" alt="Close up of Uber&#39;s Self Driving Car in Pittsburgh." srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/27258726086_f1a468cf19_o_crop-3c8ae66a3a7b885793d08d0ae50c00ec.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/how-ai-is-propelling-driverless-cars-the-future-of-surface-transport">How AI is propelling driverless cars, the future of surface transport</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/c7521-shahin-farshchi" itemprop="name">Shahin Farshchi</a></span>
</div>
    
          <p class="dek">Shahin Farshchi examines role artificial intelligence will play in driverless cars.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/untapped-opportunities-in-ai"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/timaeus_trans_calcidius_med_manuscript-d9d6fd54691fcdb2dcf16580cc7c3c72.jpg" alt="Latin translation of Plato&#39;s Timaeus" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/timaeus_trans_calcidius_med_manuscript-d9d6fd54691fcdb2dcf16580cc7c3c72.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/timaeus_trans_calcidius_med_manuscript-d9d6fd54691fcdb2dcf16580cc7c3c72.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/timaeus_trans_calcidius_med_manuscript-d9d6fd54691fcdb2dcf16580cc7c3c72.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/untapped-opportunities-in-ai">Untapped opportunities in AI</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/89289-beau-cronin" itemprop="name">Beau Cronin</a></span>
</div>
    
          <p class="dek">Some of AI's viable approaches lie outside the organizational boundaries of Google and other large Internet companies.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/small-brains-big-data"><img src="https://d3tdunqjn7n0wj.cloudfront.net/360x240/16585641410_65f3489ebd_o-93cfdd984c69a50c6a6d97c5cc903f69.jpg" alt="Addresses and papers" srcset="https://d3tdunqjn7n0wj.cloudfront.net/360x240/16585641410_65f3489ebd_o-93cfdd984c69a50c6a6d97c5cc903f69.jpg 360w, https://d3tdunqjn7n0wj.cloudfront.net/720x480/16585641410_65f3489ebd_o-93cfdd984c69a50c6a6d97c5cc903f69.jpg 720w, https://d3tdunqjn7n0wj.cloudfront.net/1440x960/16585641410_65f3489ebd_o-93cfdd984c69a50c6a6d97c5cc903f69.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-ai--before">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/small-brains-big-data">Small brains, big data</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/476ef-jeremey-freeman" itemprop="name">Jeremy Freeman</a></span>
</div>
    
          <p class="dek">How neuroscience is benefiting from distributed computing, and how computing might learn from neuroscience.</p>

    
    
  </div>
</article>

      
  	</section>
    

</section>
  
</aside>

  </article>
</main>








  <footer role="contentinfo">
  <div class="footer-inner">

    <div class="about-us">
      <h3 class="title">About Us</h3>
      <ul>
        <li><a href="http://oreilly.com/about/">Our Company</a></li>
        <li><a href="http://oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
        <li><a href="http://oreilly.com/careers/">Careers</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Contact Us</a></li>
      </ul>
    </div>
    <div class="site-map">
      <h3 class="title">Site Map</h3>
      <ul>
        <li><a href="/ideas">Ideas</a></li>
        <li><a href="/learning">Learning</a></li>
        <li><a href="/topics">Topics</a></li>
        <li><a href="/all">All</a></li>
      </ul>
    </div>
    <div class="social">
      <ul>
        <li><a   class="icon-link " href="https://www.facebook.com/OReilly/"><span class="icon icon-facebook t-fill icon--white icon--large">
  <svg role="img">
    <title>facebook</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#facebook"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://twitter.com/oreillymedia"><span class="icon icon-twitter t-fill icon--white icon--large">
  <svg role="img">
    <title>twitter</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#twitter"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.youtube.com/user/OreillyMedia"><span class="icon icon-youtube-large t-fill icon--white icon--large">
  <svg role="img">
    <title>youtube-large</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#youtube-large"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://plus.google.com/+oreillymedia"><span class="icon icon-google t-fill icon--white icon--large">
  <svg role="img">
    <title>google</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#google"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.linkedin.com/company/oreilly-media"><span class="icon icon-linkedin t-fill icon--white icon--large">
  <svg role="img">
    <title>linkedin</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#linkedin"></use>
  </svg>
</span></a>
</li>
      </ul>
    </div>
  </div>
  <div class="legal">
	  <a href="/" class="logo logo-block t-bkg logo--medium">
<svg>
   <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
</svg>
</a>
  	<p class="copyright">&copy; 2018 O'Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><br>
  <a class="t-c" href="http://oreilly.com/terms/">Terms of Service</a>  <span class="bullet">&bull;</span>	<a class="t-c" href="http://oreilly.com/privacy.html">Privacy Policy</a> <span class="bullet">&bull;</span> <a class="t-c" href="http://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a>
	</div>
	<figure class="animal"><img src="https://d3ebicv0uqgr7t.cloudfront.net/images/tarsier.png" class="animal-img" alt="Animal"></figure>
</footer>



  
  

    <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5P4V6Z"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
  

  
</body>
</html>
