What you need for this book

We have used WildFly 8.1.0 in the book. Download WildFly 8.1.0 Final from http://wildfly.org/downloads/. In some of the chapters, we have used MySQL 5.6 Database-Community Edition, which can be downloaded from http://dev.mysql.com/downloads/mysql/. You also need to download and install the Eclipse IDE for Java EE Developers from http://www.eclipse.org/downloads/. Eclipse Luna 4.4.1 is used, but a later version can also be used. Also, install JBoss Tools (version 4.2.0 used) as a plugin to Eclipse. Apache Maven (version 3.05 or later) is also required to be installed and can be downloaded from http://maven.apache.org/download.cgi. We have used Windows OS, but if you have Linux installed, the book can still be used (though ...

Get Advanced Java® EE Development with WildFly® now with O’Reilly online learning.

O’Reilly members experience live online training, plus books, videos, and digital content from 200+ publishers.