What you need for this book

In order to get the best out of this book, you need to have Maven 3.0.5 installed on your system, as well as a JDK (Java Development Kit), version 6 or above.

Access to the Internet is strongly advised.

You should also set environment variables such as JAVA_HOME and MVN_HOME, pointing respectively to JDK and Maven install folders.

Any text editor (PS-Pad, NotePad++, or even VIm and XEmacs) is sufficient to deal with Maven; anyways, you have interest then install an IDE like Eclipse, NetBeans, or IntelliJ IDEA. From a personal viewpoint, I advise the latter, but all of them are pretty good.

Get Apache Maven Dependency Management now with O’Reilly online learning.

O’Reilly members experience live online training, plus books, videos, and digital content from 200+ publishers.