O'Reilly logo

Building job sites with Joomla! by Santonu Kumar Dhar

Stay ahead with the world's most comprehensive technology and business learning platform.

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, tutorials, and more.

Start Free Trial

No credit card required

Prerequisites for installation of Joomla! 1.5 and Jobs!

Joomla! is written in PHP and mainly uses MySQL database to store and manipulate information. Before installing Joomla! 1.5 and Jobs! extension, we need a server environment, that includes the following:

Software/Application

Minimum Requirement

Recommended Version

Website

PHP

5

5.2

http//php.net

MySQL

4.1 or above

5

http://dev.mysql.com/downloads/mysql/5.0.html

Apache

1.3 or above

http://httpd.apache.org

IIS

6

7

http://www.iis.net/

mod_mysql

mod_xml

mod_zlib

You must ensure that you have the MySQL, XML, and zlib functionality enabled within your PHP installation. This is controlled within the php.ini file.

Setting up a local server environment ...

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, interactive tutorials, and more.

Start Free Trial

No credit card required