<!DOCTYPE html>
<!--[if lt IE 10]><html class="no-js ie8 oldie" lang="en" prefix="og: http://ogp.me/ns/# og:book: http://ogp.me/ns/book# og:video: http://ogp.me/ns/video#"

  
    itemscope itemtype="http://schema.org/Book http://schema.org/CollectionPage" data-offline-url="/"
data-url="/library/view/building-machine-learning/9781492053187/"
data-reading-url="/library/view/building-machine-learning/9781492053187/ch01.html"
data-archive="9781492053187"
data-publishers="O&#x27;Reilly Media, Inc."

  
    data-book-overview="true"
  



data-federated-auth-enabled="true"
data-env="production"
data-debug="0" ><![endif]-->
<!--[if gt IE 9]><!--><html class="no-js" lang="en" prefix="og: http://ogp.me/ns/# og:book: http://ogp.me/ns/book# og:video: http://ogp.me/ns/video#"

  
    itemscope itemtype="http://schema.org/Book http://schema.org/CollectionPage" data-offline-url="/"
data-url="/library/view/building-machine-learning/9781492053187/"
data-reading-url="/library/view/building-machine-learning/9781492053187/ch01.html"
data-archive="9781492053187"
data-publishers="O&#x27;Reilly Media, Inc."

  
    data-book-overview="true"
  



data-federated-auth-enabled="true"
data-env="production"
data-debug="0" ><!--<![endif]-->
<head>
    <meta charset="UTF-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />
    <title>Building Machine Learning Pipelines [Book]</title>
    <meta name="viewport" content="width=device-width, initial-scale=1" />
    <link rel="stylesheet" href="/library/view/static/CACHE/css/output.2f5d8fc1cf92.css" type="text/css">
    <link href='//fonts.googleapis.com/css?family=Source+Sans+Pro' rel='stylesheet' type='text/css' />
    <link rel="stylesheet" type="text/css" href="https://cdn.oreillystatic.com/assets/css/2018_font_face.css" />
    

    <meta property="og:title" content="Building Machine Learning Pipelines" />
    <meta itemprop="name" content="Building Machine Learning Pipelines" />
    
    <meta property="og:url" itemprop="url" content="https://www.oreilly.com/library/view/building-machine-learning/9781492053187/" />
    <meta property="og:site_name" content="O’Reilly Online Learning" />
    <meta property="og:image" itemprop="thumbnailUrl" content="https://www.oreilly.com/library/cover/9781492053187/" />
    
    <meta property="og:image:secure_url" itemprop="thumbnailUrl" content="https://learning.oreilly.com/library/cover/9781492053187/360h/">
    <meta property="og:description" itemprop="description" name="description" content="Companies are spending billions on machine learning projects, but it’s money wasted if the models can’t be deployed effectively. In this practical guide, Hannes Hapke and Catherine Nelson walk you …  - Selection from Building Machine Learning Pipelines [Book]">
    
    <meta itemprop="inLanguage" content="en" />
    
    <meta itemprop="publisher" content="O&#x27;Reilly Media, Inc." />
    
    <meta property="og:type" content="article" />
    <meta property="og:book:isbn" itemprop="isbn" content="9781492053194" />
    
    <meta property="og:book:author" itemprop="author" content="Hannes Hapke" />
    <meta property="og:book:author" itemprop="author" content="Catherine Nelson" />
    
    
    
    
    <meta property="og:image:width" content="400">
    <meta property="og:image:height" content="400">
    <meta name="twitter:card" content="summary">
    <meta name="twitter:site" content="@OReillyMedia">

<!-- Start Visual Website Optimizer Asynchronous Code -->
<script type='text/javascript'>
var _vwo_code=(function(){
var account_id=291788,
settings_tolerance=2000,
library_tolerance=2500,
use_existing_jquery=false,
/* DO NOT EDIT BELOW THIS LINE */
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
</script>
<!-- End Visual Website Optimizer Asynchronous Code -->

    <link class="t-canonical-link" rel="canonical" href="https://www.oreilly.com/library/view/building-machine-learning/9781492053187/" />

    <link rel="shortcut icon" href="//www.oreilly.com/favicon.ico" type="image/vnd.microsoft.icon" />
    <link rel="apple-touch-icon" href="/library/view/static/images/apple-touch-icon.png" />
    

</head>
<body class="js-preview-content  ">


<div class="skipToMain" id="skipToMain"><a href="#maincontent"><span class="skipToMain-text">Skip to main content</span></a></div>
<header role="banner" class="global">
  <div class="global-nav">
    <div class="content">
      <nav role="navigation" aria-label="site sections">
        <a href="https://www.oreilly.com" class="logo" title="home page" aria-current="page"><img src="https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red.svg" onerror="this.src='https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red_@2x.png'; this.onerror=null;" alt="O'Reilly home"></a>

        <button id="mobileNavButton" class="mobileNavButton mobileNavButton--collapse mobileNavButton--3dx" type="button" aria-expanded="false" aria-controls="menuList">
          <span class="mobileNavButton-box">
            <span class="mobileNavButton-inner"></span>
          </span>
        </button>


        <ul id="menuList" class="menuList mobileHidden ">
          <li class="menuList-itemsP1">
            <ul>
              
  <li class="menuList-item menuList-signIn"><a class="t-sign-in" href="https://learning.oreilly.com/accounts/login/?next=/library/view/building-machine-learning/9781492053187/">Sign In</a></li>


              <li class="menuList-item menuList-tryNow"><a class="menuList-cta" href="https://learning.oreilly.com/register/">Try Now</a></li>
            </ul>
          </li>
          <li class="menuList-itemsP2">
            <ul>
              <li class="menuList-item menuList-itemWithSub"><a href="/online-learning/index.html">Online Learning</a>
                <ul class="menuList-subList">
                  <li class="menuList-subItem"><a href="/online-learning/individuals.html">Individuals</a></li>
                  <li class="menuList-subItem"><a href="/online-learning/teams.html">Teams</a></li>
                  <li class="menuList-subItem"><a href="/online-learning/enterprise.html">Enterprise</a></li>
                  <li class="menuList-subItem"><a href="/online-learning/government.html">Government</a></li>
                  <li class="menuList-subItem"><a href="/online-learning/academic.html">Academic</a></li>
                  <li class="menuList-subItem"><a href="/online-learning/features.html">Features</a></li>
                  <li class="menuList-subItem"><a href="/online-learning/custom-services.html">Custom Services</a></li>
                  <li class="menuList-subItem"><a href="/online-learning/pricing.html">Pricing</a></li>
                </ul>
              </li>

              <li class="menuList-item"><a href="/whats-new.html">What’s New</a></li>
            </ul>
          </li>
        </ul>
      </nav>
    </div>
  </div>


  <div class="global-search">
    <div class="content">
      <form id="js-search-form" class="t-navigation-form" action="https://learning.oreilly.com/search/">
        
        <script type="application/ld+json">
        {
          "@context": "http://schema.org",
          "@type": "WebSite",
          "url": "https://learning.oreilly.com",
          "potentialAction": {
            "@type": "SearchAction",
            "target": "https://learning.oreilly.com/search/?q={search_term_string}",
            "query-input": "required name=search_term_string"
          }
        }
        </script>
        <input data-search-text-focus= "See everything available through O’Reilly online learning and start a free trial. Explore now." data-search-text-idle = "See everything available through O’Reilly online learning and start a free trial. Explore now." id="search" type="search" name="query" placeholder="See everything available through O’Reilly online learning and start a free trial. Explore now." autocomplete="off" required />
        <input type="submit" value="Search" class="search-submit" />
      </form>
    </div>
  </div>
</header>

    
    


</header>


<section id="trial-overlay">
  <div class="trial-overlay-content">
    <p>Get <em>Building Machine Learning Pipelines</em> now with O’Reilly <span class="nowrap">online learning.</span></p>

    <p>O’Reilly members experience live online training, plus books, videos, and digital content from <span class="nowrap">200+ publishers.</span></p>

    <div class="controls">
      <a href="https://learning.oreilly.com/register/" class="button-primary" data-ga-label="Bottom CTA">Start your free trial</a>
    </div>
    <a class="modal-dismiss" aria-label="modal dismiss"></a>
  </div>
</section>

<main role="main" id="maincontent">
  <div role="document" class="document">
  	


<section id="sbo-reader" class="sbo-reader-title">
  <div class="title-info">
    <div class="content">
      <figure class="t-cover">
        <img class="t-cover-img" src="https://learning.oreilly.com/library/cover/9781492053187/250w/" alt="Building Machine Learning Pipelines"/>
      </figure>

      <div class="metadata">
        <h1 class="t-title">Building Machine Learning Pipelines</h1>
        

        <div class="t-authors">by <span class="author-name">Hannes Hapke</span>, <span class="author-name">Catherine Nelson</span></div>
        <div class="t-release-date">Released July 2020</div>
        <div class="t-publisher">Publisher(s): O&#x27;Reilly Media, Inc.</div>
        <div class="t-isbn">ISBN: 9781492053194</div>

        <p class="t-promo">Explore a preview version of <em>Building Machine Learning Pipelines</em> <span class="nowrap">right now.</span></p>

        <p class="t-promo">O’Reilly members get unlimited access to live online training experiences, plus books, videos, and digital content from <span class="nowrap">200+ publishers.</span></p>

        <div class="controls">
          <a href="https://learning.oreilly.com/register/" class="button-primary">Start your free trial</a>

          
            <div class="buy-button-group">
              <a href="https://www.amazon.com/_/dp/1492053198?tag=oreilly20-20" class="button-secondary">Buy on Amazon</a>
              <p>All of O’Reilly’s books are available for purchase in print on Amazon.com.</p>
            </div>
          
        </div>

        <div id="next-edition">
        
        </div>
      </div>
    </div>
  </div>

  <div class="title-description t-description sbo-reader-content">
    <div class="content">
      <h2 class="t-description-heading">Book Description</h2>
      <span><div><p>Companies are spending billions on machine learning projects, but it’s money wasted if the models can’t be deployed effectively. In this practical guide, Hannes Hapke and Catherine Nelson walk you through the steps of automating a machine learning pipeline using the TensorFlow ecosystem. You’ll learn the techniques and tools that will cut deployment time from days to minutes, so that you can focus on developing new models rather than maintaining legacy systems.</p><p>Data scientists, machine learning engineers, and DevOps engineers will discover how to go beyond model development to successfully productize their data science projects, while managers will better understand the role they play in helping to accelerate these projects.</p><ul><li>Understand the steps to build a machine learning pipeline</li><li>Build your pipeline using components from TensorFlow Extended</li><li>Orchestrate your machine learning pipeline with Apache Beam, Apache Airflow, and Kubeflow Pipelines</li><li>Work with data using TensorFlow Data Validation and TensorFlow Transform</li><li>Analyze a model in detail using TensorFlow Model Analysis</li><li>Examine fairness and bias in your model performance</li><li>Deploy models with TensorFlow Serving or TensorFlow Lite for mobile devices</li><li>Learn privacy-preserving machine learning techniques</li></ul></div></span>

      <div id="showMoreDescription" class="showMore hidden"><button class="more"><span class="screen-reader-text">Show and hide more</span></button></div>

      
      <div id="publisher_resources" class="publisher-resources">
        <h2 class="t-description-heading">Publisher Resources</h2>
          <p><a href="http://oreilly.com/catalog/0636920260912/errata">View/Submit Errata</a></p>
          <p><a href="https://oreil.ly/bmlp-git">Download Example Code</a></p>
      </div>
      

      <div id="toc-start"></div>
    </div>
  </div>

  <div id="title-tabs" class="title-tabs"><button id="title-tab-toc" class="title-tab title-tab-active" data-target="toc">Table of Contents</button><button id="title-tab-pi" class="title-tab" data-target="product-information">Product Information</button></div>

  <div class="title-toc" id="toc">
    <div class="content">
      <h2>Table of Contents</h2>

      <ol class="detail-toc">
          

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/foreword01.html#idm45129866148952" class="t-chapter js-chapter">Foreword</a>
      
    
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/preface01.html#idm45129866148392" class="t-chapter js-chapter">Preface</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/preface01.html#idm45129866161800" class="t-chapter js-chapter">What Are Machine Learning Pipelines?</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/preface01.html#idm45129866135672" class="t-chapter js-chapter">Who Is This Book For?</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/preface01.html#idm45129866196344" class="t-chapter js-chapter">Why TensorFlow and TensorFlow Extended?</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/preface01.html#idm45129866189416" class="t-chapter js-chapter">Overview of the Chapters</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/preface01.html#idm45129866188472" class="t-chapter js-chapter">Conventions Used in This Book</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/preface01.html#idm45129866233608" class="t-chapter js-chapter">Using Code Examples</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/preface01.html#idm45129866222632" class="t-chapter js-chapter">O’Reilly Online Learning</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/preface01.html#idm45129866216536" class="t-chapter js-chapter">How to Contact Us</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/preface01.html#idm45129866215912" class="t-chapter js-chapter">Acknowledgments</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#introduction" class="t-chapter js-chapter">1. Introduction</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129866397192" class="t-chapter js-chapter">Why Machine Learning Pipelines?</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129866375912" class="t-chapter js-chapter">When to Think About Machine Learning Pipelines</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129866371144" class="t-chapter js-chapter">Overview of the Steps in a Machine Learning Pipeline</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129866362648" class="t-chapter js-chapter">Data Ingestion and Data Versioning</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129866359000" class="t-chapter js-chapter">Data Validation</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129866353368" class="t-chapter js-chapter">Data Preprocessing</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129866346760" class="t-chapter js-chapter">Model Training and Tuning</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129866341256" class="t-chapter js-chapter">Model Analysis</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129866335592" class="t-chapter js-chapter">Model Versioning</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129866331448" class="t-chapter js-chapter">Model Deployment</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129866325992" class="t-chapter js-chapter">Feedback Loops</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129866321512" class="t-chapter js-chapter">Data Privacy</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129866370520" class="t-chapter js-chapter">Pipeline Orchestration</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129866303256" class="t-chapter js-chapter">Why Pipeline Orchestration?</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129866295400" class="t-chapter js-chapter">Directed Acyclic Graphs</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129871771016" class="t-chapter js-chapter">Our Example Project</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129871764536" class="t-chapter js-chapter">Project Structure</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129882439480" class="t-chapter js-chapter">Our Machine Learning Model</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129871072440" class="t-chapter js-chapter">Goal of the Example Project</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch01.html#idm45129870836344" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch02.html#tensorflow_extended" class="t-chapter js-chapter">2. Introduction to TensorFlow Extended</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch02.html#idm45129869332760" class="t-chapter js-chapter">What Is TFX?</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch02.html#idm45129868969480" class="t-chapter js-chapter">Installing TFX</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch02.html#idm45129867675912" class="t-chapter js-chapter">Overview of TFX Components</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch02.html#metadata_store_section" class="t-chapter js-chapter">What Is ML Metadata?</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch02.html#idm45129867606088" class="t-chapter js-chapter">Interactive Pipelines</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch02.html#idm45129867605464" class="t-chapter js-chapter">Alternatives to TFX</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch02.html#idm45129867368296" class="t-chapter js-chapter">Introduction to Apache Beam</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch02.html#idm45129867360840" class="t-chapter js-chapter">Setup</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch02.html#idm45129867339016" class="t-chapter js-chapter">Basic Data Pipeline</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch02.html#idm45129866557128" class="t-chapter js-chapter">Executing Your Basic Pipeline</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch02.html#idm45129866561592" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch03.html#data_ingestion" class="t-chapter js-chapter">3. Data Ingestion</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch03.html#idm45129866862312" class="t-chapter js-chapter">Concepts for Data Ingestion</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch03.html#idm45129866734696" class="t-chapter js-chapter">Ingesting Local Data Files</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch03.html#idm45129865588936" class="t-chapter js-chapter">Ingesting Remote Data Files</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch03.html#idm45129865134088" class="t-chapter js-chapter">Ingesting Data Directly from Databases</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch03.html#idm45129865037640" class="t-chapter js-chapter">Data Preparation</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch03.html#idm45129865030392" class="t-chapter js-chapter">Splitting Datasets</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch03.html#idm45129864289208" class="t-chapter js-chapter">Spanning Datasets</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch03.html#idm45129863958824" class="t-chapter js-chapter">Versioning Datasets</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch03.html#idm45129863925608" class="t-chapter js-chapter">Ingestion Strategies</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch03.html#idm45129863922200" class="t-chapter js-chapter">Structured Data</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch03.html#idm45129863916104" class="t-chapter js-chapter">Text Data for Natural Language Problems</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch03.html#image-data-section" class="t-chapter js-chapter">Image Data for Computer Vision Problems</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch03.html#idm45129863674712" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch04.html#data_validation" class="t-chapter js-chapter">4. Data Validation</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch04.html#idm45129863656792" class="t-chapter js-chapter">Why Data Validation?</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch04.html#idm45129863656232" class="t-chapter js-chapter">TFDV</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch04.html#idm45129863629576" class="t-chapter js-chapter">Installation</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch04.html#idm45129863601640" class="t-chapter js-chapter">Generating Statistics from Your Data</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch04.html#idm45129863601048" class="t-chapter js-chapter">Generating Schema from Your Data</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch04.html#idm45129863383496" class="t-chapter js-chapter">Recognizing Problems in Your Data</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch04.html#idm45129863284680" class="t-chapter js-chapter">Comparing Datasets</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch04.html#update_schema" class="t-chapter js-chapter">Updating the Schema</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch04.html#idm45129863027544" class="t-chapter js-chapter">Data Skew and Drift</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch04.html#idm45129862910664" class="t-chapter js-chapter">Biased Datasets</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch04.html#idm45129862695096" class="t-chapter js-chapter">Slicing Data in TFDV</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch04.html#Google_Cloud_Dataflow" class="t-chapter js-chapter">Processing Large Datasets with GCP</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch04.html#idm45129862368392" class="t-chapter js-chapter">Integrating TFDV into Your Machine Learning Pipeline</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch04.html#idm45129862116168" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch05.html#data_preprocessing" class="t-chapter js-chapter">5. Data Preprocessing</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch05.html#idm45129861899640" class="t-chapter js-chapter">Why Data Preprocessing?</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch05.html#idm45129861893160" class="t-chapter js-chapter">Preprocessing the Data in the Context of the Entire Dataset</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch05.html#idm45129861889512" class="t-chapter js-chapter">Scaling the Preprocessing Steps</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch05.html#idm45129861885304" class="t-chapter js-chapter">Avoiding a Training-Serving Skew</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch05.html#idm45129861845576" class="t-chapter js-chapter">Deploying Preprocessing Steps and the ML Model as One Artifact</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch05.html#idm45129861840600" class="t-chapter js-chapter">Checking Your Preprocessing Results in Your Pipeline</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch05.html#idm45129861828376" class="t-chapter js-chapter">Data Preprocessing with TFT</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch05.html#idm45129861802984" class="t-chapter js-chapter">Installation</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch05.html#idm45129861772632" class="t-chapter js-chapter">Preprocessing Strategies</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch05.html#idm45129861727480" class="t-chapter js-chapter">Best Practices</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch05.html#idm45129861684744" class="t-chapter js-chapter">TFT Functions</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch05.html#idm45129861441400" class="t-chapter js-chapter">Standalone Execution of TFT</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch05.html#preprocessing_pipeline_section" class="t-chapter js-chapter">Integrate TFT into Your Machine Learning Pipeline</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch05.html#idm45129861827784" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch06.html#training" class="t-chapter js-chapter">6. Model Training</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch06.html#idm45129860452072" class="t-chapter js-chapter">Defining the Model for Our Example Project</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch06.html#idm45129860451448" class="t-chapter js-chapter">The TFX Trainer Component</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch06.html#idm45129859515432" class="t-chapter js-chapter">run_fn() Function</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch06.html#running_trainer_component_section" class="t-chapter js-chapter">Running the Trainer Component</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch06.html#idm45129859014984" class="t-chapter js-chapter">Other Trainer Component Considerations</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch06.html#idm45129858593016" class="t-chapter js-chapter">Using TensorBoard in an Interactive Pipeline</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch06.html#idm45129858592504" class="t-chapter js-chapter">Distribution Strategies</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch06.html#model_tuning" class="t-chapter js-chapter">Model Tuning</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch06.html#idm45129858274856" class="t-chapter js-chapter">Strategies for Hyperparameter Tuning</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch06.html#idm45129858229960" class="t-chapter js-chapter">Hyperparameter Tuning in TFX Pipelines</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch06.html#idm45129858219528" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#model_analysis" class="t-chapter js-chapter">7. Model Analysis and Validation</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#metrics" class="t-chapter js-chapter">How to Analyze Your Model</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#idm45129858197928" class="t-chapter js-chapter">Classification Metrics</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#idm45129858197336" class="t-chapter js-chapter">Regression Metrics</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#idm45129858077192" class="t-chapter js-chapter">TensorFlow Model Analysis</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#idm45129858070696" class="t-chapter js-chapter">Analyzing a Single Model in TFMA</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#idm45129858069784" class="t-chapter js-chapter">Analyzing Multiple Models in TFMA</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#model_analysis_fairness" class="t-chapter js-chapter">Model Analysis for Fairness</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#idm45129857413384" class="t-chapter js-chapter">Slicing Model Predictions in TFMA</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#idm45129857412760" class="t-chapter js-chapter">Checking Decision Thresholds with Fairness Indicators</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#WIT" class="t-chapter js-chapter">Going Deeper with the What-If Tool</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#idm45129857523496" class="t-chapter js-chapter">Model Explainability</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#idm45129856714392" class="t-chapter js-chapter">Generating Explanations with the WIT</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#idm45129856690424" class="t-chapter js-chapter">Other Explainability Techniques</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#model-validation" class="t-chapter js-chapter">Analysis and Validation in TFX</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#idm45129856654040" class="t-chapter js-chapter">ResolverNode</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#evaluator_component" class="t-chapter js-chapter">Evaluator Component</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#idm45129856642424" class="t-chapter js-chapter">Validation in the Evaluator Component</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#pusher_component" class="t-chapter js-chapter">TFX Pusher Component</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch07.html#idm45129855961864" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#model_serving" class="t-chapter js-chapter">8. Model Deployment with TensorFlow Serving</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129855941656" class="t-chapter js-chapter">A Simple Model Server</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129855726264" class="t-chapter js-chapter">The Downside of Model Deployments with Python-Based APIs</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129855721448" class="t-chapter js-chapter">Lack of Code Separation</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129855839800" class="t-chapter js-chapter">Lack of Model Version Control</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129855835688" class="t-chapter js-chapter">Inefficient Model Inference</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#TF_Serving" class="t-chapter js-chapter">TensorFlow Serving</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129855824536" class="t-chapter js-chapter">TensorFlow Architecture Overview</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129855706680" class="t-chapter js-chapter">Exporting Models for TensorFlow Serving</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#Model_signature_section" class="t-chapter js-chapter">Model Signatures</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129855404952" class="t-chapter js-chapter">Inspecting Exported Models</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129854896888" class="t-chapter js-chapter">Setting Up TensorFlow Serving</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129854853112" class="t-chapter js-chapter">Docker Installation</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129854799304" class="t-chapter js-chapter">Native Ubuntu Installation</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129854755944" class="t-chapter js-chapter">Building TensorFlow Serving from Source</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129854722712" class="t-chapter js-chapter">Configuring a TensorFlow Server</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#REST_vs_gRPC" class="t-chapter js-chapter">REST Versus gRPC</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129854125816" class="t-chapter js-chapter">Making Predictions from the Model Server</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129854090712" class="t-chapter js-chapter">Getting Model Predictions via REST</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129853743448" class="t-chapter js-chapter">Using TensorFlow Serving via gRPC</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#ab_testing" class="t-chapter js-chapter">Model A/B Testing with TensorFlow Serving</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129852963048" class="t-chapter js-chapter">Requesting Model Metadata from the Model Server</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129852973880" class="t-chapter js-chapter">REST Requests for Model Metadata</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129853044216" class="t-chapter js-chapter">gRPC Requests for Model Metadata</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#batching_inferences" class="t-chapter js-chapter">Batching Inference Requests</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129852529896" class="t-chapter js-chapter">Configuring Batch Predictions</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129852529272" class="t-chapter js-chapter">Other TensorFlow Serving Optimizations</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129852357144" class="t-chapter js-chapter">TensorFlow Serving Alternatives</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129852351608" class="t-chapter js-chapter">BentoML</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129852348104" class="t-chapter js-chapter">Seldon</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129852342760" class="t-chapter js-chapter">GraphPipe</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129852337784" class="t-chapter js-chapter">Simple TensorFlow Serving</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129852333000" class="t-chapter js-chapter">MLflow</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129852329160" class="t-chapter js-chapter">Ray Serve</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129852294552" class="t-chapter js-chapter">Deploying with Cloud Providers</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129852287864" class="t-chapter js-chapter">Use Cases</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129852283400" class="t-chapter js-chapter">Example Deployment with GCP</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129852245240" class="t-chapter js-chapter">Model Deployment with TFX Pipelines</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch08.html#idm45129851997144" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#adv_model_deployments" class="t-chapter js-chapter">9. Advanced Model Deployments with TensorFlow Serving</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#idm45129851971048" class="t-chapter js-chapter">Decoupling Deployment Cycles</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#idm45129851961448" class="t-chapter js-chapter">Workflow Overview</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#idm45129851960856" class="t-chapter js-chapter">Optimization of Remote Model Loading</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#idm45129851657032" class="t-chapter js-chapter">Model Optimizations for Deployments</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#idm45129851650776" class="t-chapter js-chapter">Quantization</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#idm45129851612776" class="t-chapter js-chapter">Pruning</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#idm45129851603864" class="t-chapter js-chapter">Distillation</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#TensorRT" class="t-chapter js-chapter">Using TensorRT with TensorFlow Serving</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#TFLite_section" class="t-chapter js-chapter">TFLite</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#idm45129851561512" class="t-chapter js-chapter">Steps to Optimize Your Model with TFLite</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#idm45129851560888" class="t-chapter js-chapter">Serving TFLite Models with TensorFlow Serving</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#idm45129851263192" class="t-chapter js-chapter">Monitoring Your TensorFlow Serving Instances</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#idm45129851256840" class="t-chapter js-chapter">Prometheus Setup</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#idm45129851256216" class="t-chapter js-chapter">TensorFlow Serving Configuration</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#idm45129851015944" class="t-chapter js-chapter">Simple Scaling with TensorFlow Serving and Kubernetes</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch09.html#idm45129851015320" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch10.html#adv_tfx" class="t-chapter js-chapter">10. Advanced TensorFlow Extended</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch10.html#advanced_pipeline_concepts" class="t-chapter js-chapter">Advanced Pipeline Concepts</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch10.html#idm45129850667160" class="t-chapter js-chapter">Training Multiple Models Simultaneously</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch10.html#idm45129850666536" class="t-chapter js-chapter">Exporting TFLite Models</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch10.html#idm45129850461816" class="t-chapter js-chapter">Warm Starting Model Training</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch10.html#ch11_human_in_the_loop" class="t-chapter js-chapter">Human in the Loop</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch10.html#idm45129849840280" class="t-chapter js-chapter">Slack Component Setup</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch10.html#idm45129849833832" class="t-chapter js-chapter">How to Use the Slack Component</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch10.html#idm45129849860872" class="t-chapter js-chapter">Custom TFX Components</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch10.html#idm45129849603848" class="t-chapter js-chapter">Use Cases of Custom Components</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch10.html#idm45129849595064" class="t-chapter js-chapter">Writing a Custom Component from Scratch</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch10.html#Reusing_exisiting_component_section" class="t-chapter js-chapter">Reusing Existing Components</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch10.html#idm45129848094952" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#airflow_beam_pipelines" class="t-chapter js-chapter">11. Pipelines Part 1: Apache Beam and Apache Airflow</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129847407112" class="t-chapter js-chapter">Which Orchestration Tool to Choose?</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129847403304" class="t-chapter js-chapter">Apache Beam</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129847398568" class="t-chapter js-chapter">Apache Airflow</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129847394520" class="t-chapter js-chapter">Kubeflow Pipelines</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129847389576" class="t-chapter js-chapter">Kubeflow Pipelines on AI Platform</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129847382296" class="t-chapter js-chapter">Converting Your Interactive TFX Pipeline to a Production Pipeline</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129847381704" class="t-chapter js-chapter">Simple Interactive Pipeline Conversion for Beam and Airflow</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129847171080" class="t-chapter js-chapter">Introduction to Apache Beam</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129846913432" class="t-chapter js-chapter">Orchestrating TFX Pipelines with Apache Beam</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129846912808" class="t-chapter js-chapter">Introduction to Apache Airflow</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129846563224" class="t-chapter js-chapter">Installation and Initial Setup</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129846562600" class="t-chapter js-chapter">Basic Airflow Example</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129846131880" class="t-chapter js-chapter">Orchestrating TFX Pipelines with Apache Airflow</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129845464168" class="t-chapter js-chapter">Pipeline Setup</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129845463576" class="t-chapter js-chapter">Pipeline Execution</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch11.html#idm45129845579336" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch12.html#kubeflow_pipelines" class="t-chapter js-chapter">12. Pipelines Part 2: Kubeflow Pipelines</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch12.html#idm45129845285416" class="t-chapter js-chapter">Introduction to Kubeflow Pipelines</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch12.html#KFP_installation" class="t-chapter js-chapter">Installation and Initial Setup</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch12.html#CH02_Access_KFP" class="t-chapter js-chapter">Accessing Your Kubeflow Pipelines Installation</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch12.html#Pipelines_KFP" class="t-chapter js-chapter">Orchestrating TFX Pipelines with Kubeflow Pipelines</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch12.html#ch12_KFP_SETUP" class="t-chapter js-chapter">Pipeline Setup</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch12.html#idm45129845048616" class="t-chapter js-chapter">Executing the Pipeline</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch12.html#KFP_Features_section" class="t-chapter js-chapter">Useful Features of Kubeflow Pipelines</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch12.html#GCP_CLOUD_AI" class="t-chapter js-chapter">Pipelines Based on Google Cloud AI Platform</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch12.html#idm45129844257560" class="t-chapter js-chapter">Pipeline Setup</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch12.html#idm45129844256968" class="t-chapter js-chapter">TFX Pipeline Setup</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch12.html#idm45129843741240" class="t-chapter js-chapter">Pipeline Execution</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch12.html#idm45129843728936" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch13.html#feedback_loops" class="t-chapter js-chapter">13. Feedback Loops</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch13.html#idm45129843708328" class="t-chapter js-chapter">Explicit and Implicit Feedback</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch13.html#idm45129843700984" class="t-chapter js-chapter">The Data Flywheel</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch13.html#idm45129843663736" class="t-chapter js-chapter">Feedback Loops in the Real World</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch13.html#idm45129843636952" class="t-chapter js-chapter">Design Patterns for Collecting Feedback</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch13.html#user-action-sect" class="t-chapter js-chapter">Users Take Some Action as a Result of the Prediction</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch13.html#user-rate-sect" class="t-chapter js-chapter">Users Rate the Quality of the Prediction</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch13.html#user-correct-sect" class="t-chapter js-chapter">Users Correct the Prediction</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch13.html#user-annotate-sect" class="t-chapter js-chapter">Crowdsourcing the Annotations</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch13.html#expert-annotate-sect" class="t-chapter js-chapter">Expert Annotations</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch13.html#system-feedback-sect" class="t-chapter js-chapter">Producing Feedback Automatically</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch13.html#idm45129843636360" class="t-chapter js-chapter">How to Track Feedback Loops</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch13.html#idm45129843565208" class="t-chapter js-chapter">Tracking Explicit Feedback</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch13.html#idm45129843557352" class="t-chapter js-chapter">Tracking Implicit Feedback</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch13.html#idm45129843552920" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#ML_privacy" class="t-chapter js-chapter">14. Data Privacy for Machine Learning</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129843542104" class="t-chapter js-chapter">Data Privacy Issues</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129843535096" class="t-chapter js-chapter">Why Do We Care About Data Privacy?</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129843527912" class="t-chapter js-chapter">The Simplest Way to Increase Privacy</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129843523048" class="t-chapter js-chapter">What Data Needs to Be Kept Private?</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129843512888" class="t-chapter js-chapter">Differential Privacy</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129843493672" class="t-chapter js-chapter">Local and Global Differential Privacy</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129843486856" class="t-chapter js-chapter">Epsilon, Delta, and the Privacy Budget</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129843448088" class="t-chapter js-chapter">Differential Privacy for Machine Learning</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129843512296" class="t-chapter js-chapter">Introduction to TensorFlow Privacy</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129843426616" class="t-chapter js-chapter">Training with a Differentially Private Optimizer</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129843425960" class="t-chapter js-chapter">Calculating Epsilon</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#federated-learning" class="t-chapter js-chapter">Federated Learning</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129842976696" class="t-chapter js-chapter">Federated Learning in TensorFlow</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129843054248" class="t-chapter js-chapter">Encrypted Machine Learning</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129842955464" class="t-chapter js-chapter">Encrypted Model Training</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129842954840" class="t-chapter js-chapter">Converting a Trained Model to Serve Encrypted Predictions</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129842817832" class="t-chapter js-chapter">Other Methods for Data Privacy</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch14.html#idm45129842805496" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch15.html#next_steps" class="t-chapter js-chapter">15. The Future of Pipelines and Next Steps</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch15.html#idm45129842753528" class="t-chapter js-chapter">Model Experiment Tracking</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch15.html#idm45129842741528" class="t-chapter js-chapter">Thoughts on Model Release Management</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch15.html#idm45129842730728" class="t-chapter js-chapter">Future Pipeline Capabilities</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch15.html#idm45129842719256" class="t-chapter js-chapter">TFX with Other Machine Learning Frameworks</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch15.html#idm45129842713288" class="t-chapter js-chapter">Testing Machine Learning Models</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch15.html#idm45129842703192" class="t-chapter js-chapter">CI/CD Systems for Machine Learning</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch15.html#idm45129842699304" class="t-chapter js-chapter">Machine Learning Engineering Community</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ch15.html#idm45129842695384" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app01.html#appendix_1" class="t-chapter js-chapter">A. Introduction to Infrastructure for Machine Learning</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app01.html#idm45129842681768" class="t-chapter js-chapter">What Is a Container?</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app01.html#idm45129842675768" class="t-chapter js-chapter">Introduction to Docker</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app01.html#idm45129842667096" class="t-chapter js-chapter">Introduction to Docker Images</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app01.html#idm45129842650968" class="t-chapter js-chapter">Building Your First Docker Image</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app01.html#idm45129842593992" class="t-chapter js-chapter">Diving into the Docker CLI</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app01.html#idm45129842508456" class="t-chapter js-chapter">Introduction to Kubernetes</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app01.html#app_kubernetes_def_section" class="t-chapter js-chapter">Some Kubernetes Definitions</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app01.html#idm45129842456552" class="t-chapter js-chapter">Getting Started with Minikube and kubectl</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app01.html#idm45129842455960" class="t-chapter js-chapter">Interacting with the Kubernetes CLI</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app01.html#idm45129842180792" class="t-chapter js-chapter">Defining a Kubernetes Resource</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app01.html#idm45129842080536" class="t-chapter js-chapter">Deploying Applications to Kubernetes</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app02.html#appendix_2" class="t-chapter js-chapter">B. Setting Up a Kubernetes Cluster on Google Cloud</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app02.html#idm45129841653048" class="t-chapter js-chapter">Before You Get Started</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app02.html#idm45129841666104" class="t-chapter js-chapter">Kubernetes on Google Cloud</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app02.html#idm45129841661448" class="t-chapter js-chapter">Selecting a Google Cloud Project</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app02.html#idm45129841611672" class="t-chapter js-chapter">Setting Up Your Google Cloud Project</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app02.html#idm45129841517368" class="t-chapter js-chapter">Creating a Kubernetes Cluster</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app02.html#idm45129841516744" class="t-chapter js-chapter">Accessing Your Kubernetes Cluster with kubectl</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app02.html#idm45129841346680" class="t-chapter js-chapter">Using Your Kubernetes Cluster with kubectl</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app02.html#APP2_PVC_KFP" class="t-chapter js-chapter">Persistent Volume Setups for Kubeflow Pipelines</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app03.html#appendix_3" class="t-chapter js-chapter">C. Tips for Operating Kubeflow Pipelines</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app03.html#custom_tfx_image_section" class="t-chapter js-chapter">Custom TFX Images</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app03.html#chXX_persistent_volume" class="t-chapter js-chapter">Exchange Data Through Persistent Volumes</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app03.html#TFX_CLI_SECTION" class="t-chapter js-chapter">TFX Command-Line Interface</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app03.html#idm45129840649896" class="t-chapter js-chapter">TFX and Its Dependencies</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app03.html#idm45129840511208" class="t-chapter js-chapter">TFX Templates</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/app03.html#idm45129840439672" class="t-chapter js-chapter">Publishing Your Pipeline with TFX CLI</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/building-machine-learning/9781492053187/ix01.html#idm45129840159832" class="t-chapter js-chapter">Index</a>
      
    
    
  </li>


      </ol>

      <div id="showMoreTOC" class="showMore hidden"><button class="more"><span class="screen-reader-text">Show and hide more</span></button></div>
    </div>
  </div>

  <div id="product-information" class="title-product-information">
    <div class="content">
      <h2>Product Information</h2>

      <ul class="detail-product-information">
        <li><span class="name">Title:</span> <span class="value">Building Machine Learning Pipelines</span></li>
        <li><span class="name">Author(s):</span> <span class="value authors">Hannes Hapke, Catherine Nelson</span></li>
        <li><span class="name">Release date:</span> <span class="value">July 2020</span></li>
        <li><span class="name">Publisher(s):</span> <span class="value t-publishers">O&#x27;Reilly Media, Inc.</span></li>
        <li><span class="name">ISBN:</span> <span class="value t-isbn">9781492053194</span></li>
      </ul>
    </div>
  </div>
</section>

  </div>
</main>


  <footer id="footer" class="footer">
  <div class="content">
    <div class="footer-main" aria-label="company info">
      <div class="footer-mainLeft">
        <div class="footer-mainLeftOne">
          <div class="footer-approach">
            <h2 class="footer-header"><a href="/about/approach.html">The O'Reilly Approach</a></h2>
            <ul class="footer-links">
              <li><a href="/about/">Our Company</a></li>
              <li><a href="/work-with-us.html">Teach/Write/Train</a></li>
              <li><a href="/careers/">Careers</a></li>
              <li><a href="/partner/signup.csp">Community Partners</a></li>
              <li><a href="/diversity/">Diversity</a></li>
            </ul>
          </div>
        </div>
        <div class="footer-mainLeftTwo">
          <div class="footer-solutions">
            <h2 class="footer-header">Solutions</h2>
            <ul class="footer-links">
              <li><a href="/online-learning/teams.html">For Teams</a></li>
              <li><a href="/online-learning/enterprise.html">For Enterprise</a></li>
              <li><a href="/online-learning/individuals.html">For Individuals</a></li>
              <li><a href="/online-learning/government.html">For Government</a></li>
              <li><a href="/online-learning/academic.html">For Education</a></li>
              <li><a href="/content-marketing-solutions.html">Marketing Solutions</a></li>
            </ul>
          </div>
          
          <div class="footer-contact">
            <h2 class="footer-header"><a href="/online-learning/support/">Support</a></h2>

            <ul class="footer-links">
              <li><a href="/about/contact.html">Contact Us</a></li>
              <li><a href="/privacy.html">Privacy Policy</a></li>
            </ul>
          
            <a href="https://twitter.com/oreillymedia" target="_blank"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 400 400" style="enable-background:new 0 0 400 400;" xml:space="preserve"><style type="text/css">.st0{fill:#ee0000;}.st1{fill:#FFFFFF;}</style><g id="Red"><circle class="st0" cx="200" cy="200" r="200"/></g><g id="Logo__x2014__FIXED"><path class="st1" d="M163.4,305.5c88.7,0,137.2-73.5,137.2-137.2c0-2.1,0-4.2-0.1-6.2c9.4-6.8,17.6-15.3,24.1-25 c-8.6,3.8-17.9,6.4-27.7,7.6c10-6,17.6-15.4,21.2-26.7c-9.3,5.5-19.6,9.5-30.6,11.7c-8.8-9.4-21.3-15.2-35.2-15.2 c-26.6,0-48.2,21.6-48.2,48.2c0,3.8,0.4,7.5,1.3,11c-40.1-2-75.6-21.2-99.4-50.4c-4.1,7.1-6.5,15.4-6.5,24.2 c0,16.7,8.5,31.5,21.5,40.1c-7.9-0.2-15.3-2.4-21.8-6c0,0.2,0,0.4,0,0.6c0,23.4,16.6,42.8,38.7,47.3c-4,1.1-8.3,1.7-12.7,1.7 c-3.1,0-6.1-0.3-9.1-0.9c6.1,19.2,23.9,33.1,45,33.5c-16.5,12.9-37.3,20.6-59.9,20.6c-3.9,0-7.7-0.2-11.5-0.7 C110.8,297.5,136.2,305.5,163.4,305.5"/></g></svg></a>
            <a href="https://www.facebook.com/OReilly/" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>facebook-logo</title><path class="cls-1" d="M16.13,0A16.13,16.13,0,1,0,32.25,16.12,16.13,16.13,0,0,0,16.13,0Zm5.12,9.54H19.57a1.52,1.52,0,0,0-1.51,1.51v1.14h3.19v3.42H18.06V26.12H13.57V15.61H10.69V12.19h2.88v-2a4,4,0,0,1,4-4h3.65Z"/></svg></a>
            <a href="https://www.linkedin.com/company/oreilly-media" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>linkedin-logo</title><path class="cls-1" d="M17.43,13.53v0l0,0ZM16.12,0A16.13,16.13,0,1,0,32.25,16.12,16.12,16.12,0,0,0,16.12,0ZM11.77,22.92H8.12v-11h3.65ZM9.94,10.44h0a1.89,1.89,0,0,1-2-1.89A1.91,1.91,0,0,1,10,6.65a1.9,1.9,0,1,1,0,3.79Zm15,12.48H21.28V17.05c0-1.48-.53-2.49-1.85-2.49a2,2,0,0,0-1.88,1.34,2.63,2.63,0,0,0-.12.89v6.13H13.79s.05-10,0-11h3.64V13.5a3.63,3.63,0,0,1,3.29-1.82c2.4,0,4.21,1.57,4.21,4.95Z"/></svg></a>
            <a href="https://www.youtube.com/user/OreillyMedia" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>youtube-logo</title><path class="cls-1" d="M18.35,18.68a.89.89,0,0,0-.86.63V16.94h-1v7.59h1v-.59a.92.92,0,0,0,.89.74c.52,0,.86-.36,1-1.07a8.56,8.56,0,0,0,.14-1.9,10.47,10.47,0,0,0-.12-1.93C19.21,19.05,18.87,18.68,18.35,18.68Zm.09,4.14c-.05.52-.2.77-.45.77s-.43-.21-.49-.63a7.22,7.22,0,0,1,0-1c0-.72,0-1.14,0-1.26.07-.58.23-.88.51-.88s.4.27.46.79c0,.09,0,.47,0,1.13S18.46,22.71,18.44,22.82ZM8.61,18.19H9.86v6.34H11V18.19H12.2V16.94H8.61Zm7.71-6.12c.27,0,.43-.22.49-.66,0-.09,0-.45,0-1.07V9.78c0-.58,0-.93,0-1-.07-.43-.23-.65-.48-.65s-.41.19-.48.57a8.79,8.79,0,0,0,0,1v.53c0,.71,0,1.09,0,1.16C15.88,11.82,16.05,12.07,16.32,12.07Zm-1.74,10.4a2.92,2.92,0,0,1-.06.71c-.07.25-.2.37-.4.37s-.32-.11-.38-.34a2.63,2.63,0,0,1-.05-.66V18.83h-1v4.48c0,.91.33,1.37,1,1.37A1,1,0,0,0,14.6,24v.57h1v-5.7h-1Zm7.1-3.79a1.35,1.35,0,0,0-1.22.59,2.48,2.48,0,0,0-.3,1.07c0,.23,0,.61,0,1.16s0,1.13,0,1.37a2.93,2.93,0,0,0,.35,1.27,1.25,1.25,0,0,0,1.14.54,1.36,1.36,0,0,0,1.13-.45,2.29,2.29,0,0,0,.37-1.43s0-.07,0-.11v-.12h-1c0,.75-.17,1.12-.51,1.12s-.38-.18-.45-.56a4.68,4.68,0,0,1-.06-.9c0-.18,0-.31,0-.37h2v-.43a4.86,4.86,0,0,0-.3-2.11A1.28,1.28,0,0,0,21.68,18.68ZM22.15,21h-1c0-.05,0-.11,0-.16v-.08a1.64,1.64,0,0,1,.11-.8.39.39,0,0,1,.38-.23.42.42,0,0,1,.43.33,2.32,2.32,0,0,1,.07.7Zm-6-21A16.13,16.13,0,1,0,32.25,16.12,16.12,16.12,0,0,0,16.12,0Zm2.51,7.2h1V11a2.52,2.52,0,0,0,.06.66c.06.23.18.34.38.34s.34-.12.41-.37a3.76,3.76,0,0,0,.05-.71V7.2h1v5.74h-1v-.57a1,1,0,0,1-.93.72c-.66,0-1-.46-1-1.38ZM15,8a1.29,1.29,0,0,1,1.33-.92A1.3,1.3,0,0,1,17.65,8a6.77,6.77,0,0,1,.23,2.1,6.77,6.77,0,0,1-.23,2.1,1.3,1.3,0,0,1-1.32.92A1.29,1.29,0,0,1,15,12.17a6.77,6.77,0,0,1-.23-2.1A6.86,6.86,0,0,1,15,8ZM11.45,5.3l.89,2.87.88-2.87H14.4L12.88,9.7v3.24h-1.1V9.7L10.24,5.3ZM24.93,23.91a3,3,0,0,1-3,3h-12a3,3,0,0,1-3-3V18.05a3,3,0,0,1,3-3h12a3,3,0,0,1,3,3Z"/></svg></a>
            <a href="https://www.oreilly.com/emails/newsletters/" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.33 32.33"><defs><style>.cls-1{fill:#E00;}.cls-2{fill:#f0f1f1;}</style></defs><title>email-logo</title><circle class="cls-1" cx="16.17" cy="16.17" r="16.17"/><path class="cls-2" d="M6.66,13.32l.2.14c2.2,1.5,4.41,3,6.74,4.29.6.34,1.22.62,1.84.92a1.72,1.72,0,0,0,1.44,0,21,21,0,0,0,2.71-1.4c2-1.21,4-2.53,5.91-3.87l.18-.12v.21c0,2.77,0,5.54,0,8.31A1.51,1.51,0,0,1,24,23.33c-5.24,0-10.48,0-15.72,0a1.57,1.57,0,0,1-1.62-1.08,1.23,1.23,0,0,1,0-.19V13.47A.86.86,0,0,1,6.66,13.32Z"/><path class="cls-2" d="M16.15,9h7.9a1.5,1.5,0,0,1,1.56,1,4.81,4.81,0,0,1,.06,1.07s0,.08-.08.1a77.16,77.16,0,0,1-7.49,4.9c-.42.24-.87.43-1.31.63a1.41,1.41,0,0,1-1.28,0c-.65-.33-1.32-.64-1.95-1-2.37-1.4-4.59-3-6.81-4.55a.35.35,0,0,1-.1-.2c0-.2,0-.4,0-.6A1.45,1.45,0,0,1,8.05,9h8.1Z"/></svg></a>
          </div>
        </div>
      </div>

      <div class="footer-download" id="download-info">
        <h2 class="footer-header">Download the O&rsquo;Reilly App</h2>

        <div class="footer-downloadLinks">
          <a href="https://itunes.apple.com/us/app/safari-to-go/id881697395"><img src="https://cdn.oreillystatic.com/oreilly/images/app-store-logo.png" alt="Apple app store" /></a>
          <a href="https://play.google.com/store/apps/details?id=com.safariflow.queue"><img src="https://cdn.oreillystatic.com/oreilly/images/google-play-logo.png"  alt="Google play store" /></a>
        </div>

        <p>Take O&rsquo;Reilly online learning with you and learn anywhere, anytime on your phone or tablet. Download the app <span class="nowrap">today and:</span></p>

        <ul>
          <li>Get unlimited access to books, videos, and <span class="nowrap">live training</span></li>
          <li>Never lose your place&mdash;all your devices are synced</li>
          <li>Learn during your commute with online and <span class="nowrap">offline access</span></li>
        </ul>
      </div>
    </div>

    <div class="footer-subfooter">

      <a href="https://www.oreilly.com" title="home page" aria-current="page">
        <img 
        class="footer-subfooterLogo" 
        id="footer-subfooterLogo"
        src="https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red.svg" 
        onerror="this.src='https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red_@2x.png'; this.onerror=null;" 
        alt="O'Reilly home">
      </a>

      <p>&copy; 2020, O&rsquo;Reilly Media, Inc.  All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p>
      <p><a href="/terms/">Terms of Service</a> • <a href="/privacy.html">Privacy Policy</a> • <a href="/about/editorial_independence.html">Editorial Independence</a></p>
    </div>

  </div>
</footer>


<!--
<footer class="anybird-footer">
    <nav class="grid">
        <ul class="footer-nav col">
            <li><a href="https://learning.oreilly.com/explore/"><span>Explore</span></a></li>
            <li><a href="https://learning.oreilly.com/our-library/"><span>Tour</span></a></li>
            <li><a href="https://learning.oreilly.com/pricing/"><span>Pricing</span></a></li>
            <li><a href="https://learning.oreilly.com/enterprise/"><span>Enterprise</span></a></li>
            <li><a href="https://learning.oreilly.com/government/"><span>Government</span></a></li>
            <li><a href="https://learning.oreilly.com/academic-public-library/"><span>Education</span></a></li>
            <li><a href="https://learning.oreilly.com/your-experience/#queue"><span>Queue App</span></a></li>
        </ul>
        <ul class="footer-contact col">
            <li><a href="https://learning.oreilly.com/learn/"><span>Learn</span></a></li>
            <li><a href="https://learning.oreilly.com/blog/"><span>Blog</span></a></li>
            <li><a href="https://learning.oreilly.com/contact/"><span>Contact</span></a></li>
            <li><a href="https://learning.oreilly.com/careers/"><span>Careers</span></a></li>
            <li><a href="https://learning.oreilly.com/press-resources/"><span>Press Resources</span></a></li>
            <li><a href="https://www.oreilly.com/online-learning/support/"><span>Support</span></a></li>
        </ul>
        <ul class="footer-social col">
            <li id="footer-twitter"><a href="https://twitter.com/safari"><span>Twitter</span></a></li>
            <li id="footer-github"><a href="https://github.com/oreillymedia"><span>GitHub</span></a></li>
            <li id="footer-facebook"><a href="http://www.facebook.com/safaribooksonline"><span>Facebook</span></a></li>
            <li id="footer-linkedin"><a
                    href="https://www.linkedin.com/company/safari-books-online"><span>LinkedIn</span></a></li>
        </ul>
        <ul class="footer-legal col">
            <li><a href="https://learning.oreilly.com/terms/"><span>Terms of Service</span></a></li>
            <li><a href="https://learning.oreilly.com/membership-agreement/"><span>Membership Agreement</span></a></li>
            <li><a href="https://learning.oreilly.com/privacy/"><span>Privacy Policy</span></a></li>
        </ul>
    </nav>
    <div class="footer-copyright">
        Copyright &copy; 2020 Safari Books Online.
    </div>
</footer>
-->




<script>
  var g = {
    
  };
</script>
<script>
  window.dataLayer = window.dataLayer || [];
  window.dataLayer.push({
    'product.title': "Building Machine Learning Pipelines",
    'product.type': "book",
    'product.identifier': "9781492053187",
    'content.identifier': "9781492053187",
    'content.publisher': "O'Reilly Media, Inc.",
    'content.free': "no",
    'content.subdirectory': "none",
    'content.subTopic': "none",
    'content.parentTopic': "none",
    'content.formatType': "book",
    'content.author': "Hannes Hapke, Catherine Nelson",
    'content.releaseDate': "2020-07-20",
    'content.title': "Building Machine Learning Pipelines",
  });
</script>



<script src="/library/view/static/CACHE/js/output.d1c80552da2d.js"></script>


<noscript> 
  <iframe src="//www.googletagmanager.com/ns.html?id=GTM-5P4V6Z"
          height="0" width="0"
          style="display:none;visibility:hidden">
  </iframe>
</noscript>


<script async defer src="/library/view/pageview.js"></script>

<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.0/jquery.min.js"></script>

<script>
  jQuery(document).ready(function($) {
    //Toggle isActive and mobileHidden classes for mobileNavButton
    $('nav #mobileNavButton').on('click', function() {
      var expanded = $(this).attr('aria-expanded') === 'true' || false;
      $(this).attr('aria-expanded', !expanded);
      $(this).toggleClass("isActive");
      $(this).next().toggleClass("mobileHidden");
    });

    //Toggle isFocused class for keyboard navigation of submenus
    $('nav #menuList .menuList-subItem a').each(function(navItem) {
      $(this).on('focus', function() {
        $(this).parent().parent().toggleClass('isFocused');
      });
      $(this).on('blur', function() {
        $(this).parent().parent().toggleClass('isFocused');
      });
    });

    //Toggle mobileHidden class accordian elements
    $('.mobileAccordian').each(function() {
      var $btn = $(this).find('button');
      var $target =  $(this).next();
      $btn.on('click', function() {
        var expanded = $btn.attr('aria-expanded') === 'true' || false;

        $btn.attr('aria-expanded', !expanded);
        $target.toggleClass("mobileHidden");
      });
    });


    //Hide title page's long description behind disclosure button
    var titleDescriptionExtra = $('.title-description p:first-of-type').nextAll(':nth-child(3)').nextAll();
    titleDescriptionExtra.wrapAll('<div id="titleDescriptionExtra" />');
    if (titleDescriptionExtra.length > 0) {
      $('#titleDescriptionExtra').toggle();
      $('#showMoreDescription').removeClass('hidden');
      $('#showMoreDescription button').on('click', function() {
        $(this).toggleClass('more');
        $('#titleDescriptionExtra').slideToggle();
      });
    }

    //Hide title page's long TOC behind disclosure button
    var titleTOCShort = $('.sbo-reader-title .detail-toc').find('li').slice(0,4);
    var titleTOCExtra = $('.sbo-reader-title .detail-toc').find('li').not(titleTOCShort);
    if (titleTOCExtra.length > 0) {
      titleTOCExtra.toggle();
      $('#showMoreTOC').removeClass('hidden');
      $('#showMoreTOC button').on('click', function() {
        $(this).toggleClass('more');
        titleTOCExtra.toggle();
      });
    }

    //Hide product information on page load
    $('#product-information').toggle();
    $('#title-tabs button').on('click', function() {
      var $thisTab = $(this);
      if (!$thisTab.hasClass('title-tab-active')) {
        var lastTabTarget = $('#title-tabs .title-tab-active').removeClass('title-tab-active').attr('data-target');
        $('#' + lastTabTarget).toggle();

        $thisTab.addClass('title-tab-active');
        var $tabTarget = $(this).attr('data-target');
        $('#' + $tabTarget).toggle();
      }
    });

  });

</script>



<!-- MARC Intercept Support -->

<script src="https://service.seamlessaccess.org/thiss.js"></script>

<script src="/library/view/static/CACHE/js/output.8bff54f150f1.js"></script>


</body>
</html>
