<!DOCTYPE html>
<!--[if lt IE 10]><html class="no-js ie8 oldie" lang="en" prefix="og: http://ogp.me/ns/# og:book: http://ogp.me/ns/book# og:video: http://ogp.me/ns/video#"

  
    itemscope itemtype="http://schema.org/Book http://schema.org/CollectionPage" data-offline-url="/"
data-url="/library/view/deep-learning-for/9781492045519/"
data-reading-url="/library/view/deep-learning-for/9781492045519/ch01.html"
data-archive="9781492045519"
data-publishers="O&#x27;Reilly Media, Inc."

  
    data-book-overview="true"
  



data-federated-auth-enabled="true"
data-env="production"
data-debug="0" ><![endif]-->
<!--[if gt IE 9]><!--><html class="no-js" lang="en" prefix="og: http://ogp.me/ns/# og:book: http://ogp.me/ns/book# og:video: http://ogp.me/ns/video#"

  
    itemscope itemtype="http://schema.org/Book http://schema.org/CollectionPage" data-offline-url="/"
data-url="/library/view/deep-learning-for/9781492045519/"
data-reading-url="/library/view/deep-learning-for/9781492045519/ch01.html"
data-archive="9781492045519"
data-publishers="O&#x27;Reilly Media, Inc."

  
    data-book-overview="true"
  



data-federated-auth-enabled="true"
data-env="production"
data-debug="0" ><!--<![endif]-->
<head>
    <meta charset="UTF-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />
    <title>Deep Learning for Coders with fastai and PyTorch [Book]</title>
    <meta name="viewport" content="width=device-width, initial-scale=1" />
    <link rel="stylesheet" href="/library/view/static/CACHE/css/output.2f5d8fc1cf92.css" type="text/css">
    <link href='//fonts.googleapis.com/css?family=Source+Sans+Pro' rel='stylesheet' type='text/css' />
    <link rel="stylesheet" type="text/css" href="https://cdn.oreillystatic.com/assets/css/2018_font_face.css" />
    

    <meta property="og:title" content="Deep Learning for Coders with fastai and PyTorch" />
    <meta itemprop="name" content="Deep Learning for Coders with fastai and PyTorch" />
    
    <meta property="og:url" itemprop="url" content="https://www.oreilly.com/library/view/deep-learning-for/9781492045519/" />
    <meta property="og:site_name" content="O’Reilly Online Learning" />
    <meta property="og:image" itemprop="thumbnailUrl" content="https://www.oreilly.com/library/cover/9781492045519/" />
    
    <meta property="og:image:secure_url" itemprop="thumbnailUrl" content="https://learning.oreilly.com/library/cover/9781492045519/360h/">
    <meta property="og:description" itemprop="description" name="description" content="Deep learning is often viewed as the exclusive domain of math PhDs and big tech companies. But as this hands-on guide demonstrates, programmers comfortable with Python can achieve impressive results …  - Selection from Deep Learning for Coders with fastai and PyTorch [Book]">
    
    <meta itemprop="inLanguage" content="en" />
    
    <meta itemprop="publisher" content="O&#x27;Reilly Media, Inc." />
    
    <meta property="og:type" content="article" />
    <meta property="og:book:isbn" itemprop="isbn" content="9781492045526" />
    
    <meta property="og:book:author" itemprop="author" content="Jeremy Howard" />
    <meta property="og:book:author" itemprop="author" content="Sylvain Gugger" />
    
    
    
    
    <meta property="og:image:width" content="400">
    <meta property="og:image:height" content="400">
    <meta name="twitter:card" content="summary">
    <meta name="twitter:site" content="@OReillyMedia">

<!-- Start Visual Website Optimizer Asynchronous Code -->
<script type='text/javascript'>
var _vwo_code=(function(){
var account_id=291788,
settings_tolerance=2000,
library_tolerance=2500,
use_existing_jquery=false,
/* DO NOT EDIT BELOW THIS LINE */
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
</script>
<!-- End Visual Website Optimizer Asynchronous Code -->

    <link class="t-canonical-link" rel="canonical" href="https://www.oreilly.com/library/view/deep-learning-for/9781492045519/" />

    <link rel="shortcut icon" href="//www.oreilly.com/favicon.ico" type="image/vnd.microsoft.icon" />
    <link rel="apple-touch-icon" href="/library/view/static/images/apple-touch-icon.png" />
    

</head>
<body class="js-preview-content  ">


<div class="skipToMain" id="skipToMain"><a href="#maincontent"><span class="skipToMain-text">Skip to main content</span></a></div>
<header role="banner" class="global">
  <div class="global-nav">
    <div class="content">
      <nav role="navigation" aria-label="site sections">
        <a href="https://www.oreilly.com" class="logo" title="home page" aria-current="page"><img src="https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red.svg" onerror="this.src='https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red_@2x.png'; this.onerror=null;" alt="O'Reilly home"></a>

        <button id="mobileNavButton" class="mobileNavButton mobileNavButton--collapse mobileNavButton--3dx" type="button" aria-expanded="false" aria-controls="menuList">
          <span class="mobileNavButton-box">
            <span class="mobileNavButton-inner"></span>
          </span>
        </button>


        <ul id="menuList" class="menuList mobileHidden ">
          <li class="menuList-itemsP1">
            <ul>
              
  <li class="menuList-item menuList-signIn"><a class="t-sign-in" href="https://learning.oreilly.com/accounts/login/?next=/library/view/deep-learning-for/9781492045519/">Sign In</a></li>


              <li class="menuList-item menuList-tryNow"><a class="menuList-cta" href="https://learning.oreilly.com/register/">Try Now</a></li>
            </ul>
          </li>
          <li class="menuList-itemsP2">
            <ul>
              <li class="menuList-item menuList-itemWithSub"><a href="/online-learning/index.html">Online Learning</a>
                <ul class="menuList-subList">
                  <li class="menuList-subItem"><a href="/online-learning/individuals.html">Individuals</a></li>
                  <li class="menuList-subItem"><a href="/online-learning/teams.html">Teams</a></li>
                  <li class="menuList-subItem"><a href="/online-learning/enterprise.html">Enterprise</a></li>
                  <li class="menuList-subItem"><a href="/online-learning/government.html">Government</a></li>
                  <li class="menuList-subItem"><a href="/online-learning/academic.html">Academic</a></li>
                  <li class="menuList-subItem"><a href="/online-learning/features.html">Features</a></li>
                  <li class="menuList-subItem"><a href="/online-learning/custom-services.html">Custom Services</a></li>
                  <li class="menuList-subItem"><a href="/online-learning/pricing.html">Pricing</a></li>
                </ul>
              </li>

              <li class="menuList-item"><a href="/whats-new.html">What’s New</a></li>
            </ul>
          </li>
        </ul>
      </nav>
    </div>
  </div>


  <div class="global-search">
    <div class="content">
      <form id="js-search-form" class="t-navigation-form" action="https://learning.oreilly.com/search/">
        
        <script type="application/ld+json">
        {
          "@context": "http://schema.org",
          "@type": "WebSite",
          "url": "https://learning.oreilly.com",
          "potentialAction": {
            "@type": "SearchAction",
            "target": "https://learning.oreilly.com/search/?q={search_term_string}",
            "query-input": "required name=search_term_string"
          }
        }
        </script>
        <input data-search-text-focus= "See everything available through O’Reilly online learning and start a free trial. Explore now." data-search-text-idle = "See everything available through O’Reilly online learning and start a free trial. Explore now." id="search" type="search" name="query" placeholder="See everything available through O’Reilly online learning and start a free trial. Explore now." autocomplete="off" required />
        <input type="submit" value="Search" class="search-submit" />
      </form>
    </div>
  </div>
</header>

    
    


</header>


<section id="trial-overlay">
  <div class="trial-overlay-content">
    <p>Get <em>Deep Learning for Coders with fastai and PyTorch</em> now with O’Reilly <span class="nowrap">online learning.</span></p>

    <p>O’Reilly members experience live online training, plus books, videos, and digital content from <span class="nowrap">200+ publishers.</span></p>

    <div class="controls">
      <a href="https://learning.oreilly.com/register/" class="button-primary" data-ga-label="Bottom CTA">Start your free trial</a>
    </div>
    <a class="modal-dismiss" aria-label="modal dismiss"></a>
  </div>
</section>

<main role="main" id="maincontent">
  <div role="document" class="document">
  	


<section id="sbo-reader" class="sbo-reader-title">
  <div class="title-info">
    <div class="content">
      <figure class="t-cover">
        <img class="t-cover-img" src="https://learning.oreilly.com/library/cover/9781492045519/250w/" alt="Deep Learning for Coders with fastai and PyTorch"/>
      </figure>

      <div class="metadata">
        <h1 class="t-title">Deep Learning for Coders with fastai and PyTorch</h1>
        

        <div class="t-authors">by <span class="author-name">Jeremy Howard</span>, <span class="author-name">Sylvain Gugger</span></div>
        <div class="t-release-date">Released July 2020</div>
        <div class="t-publisher">Publisher(s): O&#x27;Reilly Media, Inc.</div>
        <div class="t-isbn">ISBN: 9781492045526</div>

        <p class="t-promo">Explore a preview version of <em>Deep Learning for Coders with fastai and PyTorch</em> <span class="nowrap">right now.</span></p>

        <p class="t-promo">O’Reilly members get unlimited access to live online training experiences, plus books, videos, and digital content from <span class="nowrap">200+ publishers.</span></p>

        <div class="controls">
          <a href="https://learning.oreilly.com/register/" class="button-primary">Start your free trial</a>

          
            <div class="buy-button-group">
              <a href="https://www.amazon.com/_/dp/1492045527?tag=oreilly20-20" class="button-secondary">Buy on Amazon</a>
              <p>All of O’Reilly’s books are available for purchase in print on Amazon.com.</p>
            </div>
          
        </div>

        <div id="next-edition">
        
        </div>
      </div>
    </div>
  </div>

  <div class="title-description t-description sbo-reader-content">
    <div class="content">
      <h2 class="t-description-heading">Book Description</h2>
      <span><div><p>Deep learning is often viewed as the exclusive domain of math PhDs and big tech companies. But as this hands-on guide demonstrates, programmers comfortable with Python can achieve impressive results in deep learning with little math background, small amounts of data, and minimal code. How? With fastai, the first library to provide a consistent interface to the most frequently used deep learning applications.</p><p>Authors Jeremy Howard and Sylvain Gugger, the creators of fastai, show you how to train a model on a wide range of tasks using fastai and PyTorch. You’ll also dive progressively further into deep learning theory to gain a complete understanding of the algorithms behind the scenes.</p><ul><li>Train models in computer vision, natural language processing, tabular data, and collaborative filtering</li><li>Learn the latest deep learning techniques that matter most in practice</li><li>Improve accuracy, speed, and reliability by understanding how deep learning models work</li><li>Discover how to turn your models into web applications</li><li>Implement deep learning algorithms from scratch</li><li>Consider the ethical implications of your work</li><li>Gain insight from the foreword by PyTorch cofounder, Soumith Chintala</li></ul></div></span>

      <div id="showMoreDescription" class="showMore hidden"><button class="more"><span class="screen-reader-text">Show and hide more</span></button></div>

      
      <div id="publisher_resources" class="publisher-resources">
        <h2 class="t-description-heading">Publisher Resources</h2>
          <p><a href="http://oreilly.com/catalog/0636920216391/errata">View/Submit Errata</a></p>
          <p><a href="https://book.fast.ai">Download Example Code</a></p>
      </div>
      

      <div id="toc-start"></div>
    </div>
  </div>

  <div id="title-tabs" class="title-tabs"><button id="title-tab-toc" class="title-tab title-tab-active" data-target="toc">Table of Contents</button><button id="title-tab-pi" class="title-tab" data-target="product-information">Product Information</button></div>

  <div class="title-toc" id="toc">
    <div class="content">
      <h2>Table of Contents</h2>

      <ol class="detail-toc">
          

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/preface01.html#idm46287176653768" class="t-chapter js-chapter">Preface</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/preface01.html#idm46287176650904" class="t-chapter js-chapter">Who This Book Is For</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/preface01.html#idm46287188555160" class="t-chapter js-chapter">What You Need to Know</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/preface01.html#idm46287176711832" class="t-chapter js-chapter">What You Will Learn</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/preface01.html#idm46287206094424" class="t-chapter js-chapter">O’Reilly Online Learning</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/preface01.html#idm46287176670504" class="t-chapter js-chapter">How to Contact Us</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/foreword01.html#idm46287176669880" class="t-chapter js-chapter">Foreword</a>
      
    
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/part01.html#part1" class="t-chapter js-chapter">I. Deep Learning in Practice</a>
      
    
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#chapter_intro" class="t-chapter js-chapter">1. Your Deep Learning Journey</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287176799592" class="t-chapter js-chapter">Deep Learning Is for Everyone</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287176848200" class="t-chapter js-chapter">Neural Networks: A Brief History</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287176847576" class="t-chapter js-chapter">Who We Are</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287188569160" class="t-chapter js-chapter">How to Learn Deep Learning</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287177015720" class="t-chapter js-chapter">Your Projects and Your Mindset</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287176832616" class="t-chapter js-chapter">The Software: PyTorch, fastai, and Jupyter (And Why It Doesn’t Matter)</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287176997640" class="t-chapter js-chapter">Your First Model</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287176867896" class="t-chapter js-chapter">Getting a GPU Deep Learning Server</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287176867432" class="t-chapter js-chapter">Running Your First Notebook</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287176947736" class="t-chapter js-chapter">What Is Machine Learning?</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287187870664" class="t-chapter js-chapter">What Is a Neural Network?</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287187431192" class="t-chapter js-chapter">A Bit of Deep Learning Jargon</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287187371752" class="t-chapter js-chapter">Limitations Inherent to Machine Learning</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287187371096" class="t-chapter js-chapter">How Our Image Recognizer Works</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287187336040" class="t-chapter js-chapter">What Our Image Recognizer Learned</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287187335448" class="t-chapter js-chapter">Image Recognizers Can Tackle Non-Image Tasks</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287186887224" class="t-chapter js-chapter">Jargon Recap</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287176881544" class="t-chapter js-chapter">Deep Learning Is Not Just for Image Classification</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287186766872" class="t-chapter js-chapter">Validation Sets and Test Sets</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287185926696" class="t-chapter js-chapter">Use Judgment in Defining Test Sets</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287186766376" class="t-chapter js-chapter">A Choose Your Own Adventure Moment</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287185873672" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch01.html#idm46287185869448" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#chapter_production" class="t-chapter js-chapter">2. From Model to Production</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287185816664" class="t-chapter js-chapter">The Practice of Deep Learning</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287185805496" class="t-chapter js-chapter">Starting Your Project</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287185804936" class="t-chapter js-chapter">The State of Deep Learning</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287185693208" class="t-chapter js-chapter">The Drivetrain Approach</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287185692616" class="t-chapter js-chapter">Gathering Data</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287185666248" class="t-chapter js-chapter">From Data to DataLoaders</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287184589112" class="t-chapter js-chapter">Data Augmentation</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287185195928" class="t-chapter js-chapter">Training Your Model, and Using It to Clean Your Data</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287184501240" class="t-chapter js-chapter">Turning Your Model into an Online Application</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287184146408" class="t-chapter js-chapter">Using the Model for Inference</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287184145816" class="t-chapter js-chapter">Creating a Notebook App from the Model</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287183968520" class="t-chapter js-chapter">Turning Your Notebook into a Real App</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287183600072" class="t-chapter js-chapter">Deploying Your App</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287183599448" class="t-chapter js-chapter">How to Avoid Disaster</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287183417816" class="t-chapter js-chapter">Unforeseen Consequences and Feedback Loops</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287183481592" class="t-chapter js-chapter">Get Writing!</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287183378216" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch02.html#idm46287183376376" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#chapter_ethics" class="t-chapter js-chapter">3. Data Ethics</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287183319736" class="t-chapter js-chapter">Key Examples for Data Ethics</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287183309816" class="t-chapter js-chapter">Bugs and Recourse: Buggy Algorithm Used for Healthcare Benefits</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287183301208" class="t-chapter js-chapter">Feedback Loops: YouTube’s Recommendation System</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287183285704" class="t-chapter js-chapter">Bias: Professor Latanya Sweeney “Arrested”</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287183272120" class="t-chapter js-chapter">Why Does This Matter?</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287183271496" class="t-chapter js-chapter">Integrating Machine Learning with Product Design</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287183218264" class="t-chapter js-chapter">Topics in Data Ethics</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287183211896" class="t-chapter js-chapter">Recourse and Accountability</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287183191800" class="t-chapter js-chapter">Feedback Loops</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287183191176" class="t-chapter js-chapter">Bias</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287183139992" class="t-chapter js-chapter">Disinformation</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287182956552" class="t-chapter js-chapter">Identifying and Addressing Ethical Issues</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#analzye_a_project" class="t-chapter js-chapter">Analyze a Project You Are Working On</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287182904776" class="t-chapter js-chapter">Processes to Implement</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287182867880" class="t-chapter js-chapter">The Power of Diversity</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287182867224" class="t-chapter js-chapter">Fairness, Accountability, and Transparency</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287182818504" class="t-chapter js-chapter">Role of Policy</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287182813448" class="t-chapter js-chapter">The Effectiveness of Regulation</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287182795256" class="t-chapter js-chapter">Rights and Policy</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287182788312" class="t-chapter js-chapter">Cars: A Historical Precedent</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287182776696" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287182765864" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287182764344" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch03.html#idm46287182731576" class="t-chapter js-chapter">Deep Learning in Practice: That’s a Wrap!</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/part02.html#part2" class="t-chapter js-chapter">II. Understanding fastai’s Applications</a>
      
    
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#chapter_mnist_basics" class="t-chapter js-chapter">4. Under the Hood: Training a Digit Classifier</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287182709240" class="t-chapter js-chapter">Pixels: The Foundations of Computer Vision</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287182708296" class="t-chapter js-chapter">First Try: Pixel Similarity</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287181786424" class="t-chapter js-chapter">NumPy Arrays and PyTorch Tensors</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287181785352" class="t-chapter js-chapter">Computing Metrics Using Broadcasting</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287181468216" class="t-chapter js-chapter">Stochastic Gradient Descent</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287180848504" class="t-chapter js-chapter">Calculating Gradients</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287180595384" class="t-chapter js-chapter">Stepping with a Learning Rate</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287180567368" class="t-chapter js-chapter">An End-to-End SGD Example</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287180531160" class="t-chapter js-chapter">Summarizing Gradient Descent</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287181003928" class="t-chapter js-chapter">The MNIST Loss Function</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287178917960" class="t-chapter js-chapter">Sigmoid</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287178915832" class="t-chapter js-chapter">SGD and Mini-Batches</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287179733256" class="t-chapter js-chapter">Putting It All Together</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287177745880" class="t-chapter js-chapter">Creating an Optimizer</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287177724408" class="t-chapter js-chapter">Adding a Nonlinearity</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287175974856" class="t-chapter js-chapter">Going Deeper</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287177095576" class="t-chapter js-chapter">Jargon Recap</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287175859224" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch04.html#idm46287175770872" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#chapter_pet_breeds" class="t-chapter js-chapter">5. Image Classification</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287175719720" class="t-chapter js-chapter">From Dogs and Cats to Pet Breeds</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287175718776" class="t-chapter js-chapter">Presizing</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287175324040" class="t-chapter js-chapter">Checking and Debugging a DataBlock</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287175407400" class="t-chapter js-chapter">Cross-Entropy Loss</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287175108328" class="t-chapter js-chapter">Viewing Activations and Labels</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287175107704" class="t-chapter js-chapter">Softmax</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287175016568" class="t-chapter js-chapter">Log Likelihood</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287174771928" class="t-chapter js-chapter">Taking the log</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287174480792" class="t-chapter js-chapter">Model Interpretation</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287174205160" class="t-chapter js-chapter">Improving Our Model</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287174191064" class="t-chapter js-chapter">The Learning Rate Finder</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287174190120" class="t-chapter js-chapter">Unfreezing and Transfer Learning</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287173954168" class="t-chapter js-chapter">Discriminative Learning Rates</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287173734408" class="t-chapter js-chapter">Selecting the Number of Epochs</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287173557560" class="t-chapter js-chapter">Deeper Architectures</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287173556936" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287173421432" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch05.html#idm46287173419208" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch06.html#chapter_multicat" class="t-chapter js-chapter">6. Other Computer Vision Problems</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch06.html#idm46287173384136" class="t-chapter js-chapter">Multi-Label Classification</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch06.html#idm46287173374856" class="t-chapter js-chapter">The Data</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch06.html#idm46287173374232" class="t-chapter js-chapter">Constructing a DataBlock</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch06.html#idm46287173092920" class="t-chapter js-chapter">Binary Cross Entropy</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch06.html#idm46287172447000" class="t-chapter js-chapter">Regression</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch06.html#idm46287171549304" class="t-chapter js-chapter">Assembling the Data</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch06.html#idm46287171548360" class="t-chapter js-chapter">Training a Model</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch06.html#idm46287170988584" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch06.html#idm46287170641032" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch06.html#idm46287170639400" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch07.html#chapter_sizing_and_tta" class="t-chapter js-chapter">7. Training a State-of-the-Art Model</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch07.html#idm46287170584296" class="t-chapter js-chapter">Imagenette</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch07.html#idm46287170583672" class="t-chapter js-chapter">Normalization</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch07.html#idm46287170423416" class="t-chapter js-chapter">Progressive Resizing</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch07.html#idm46287170025832" class="t-chapter js-chapter">Test Time Augmentation</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch07.html#idm46287169863672" class="t-chapter js-chapter">Mixup</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch07.html#idm46287169736248" class="t-chapter js-chapter">Label Smoothing</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch07.html#idm46287169715640" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch07.html#idm46287169596152" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch07.html#idm46287169594536" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch08.html#chapter_collab" class="t-chapter js-chapter">8. Collaborative Filtering Deep Dive</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch08.html#idm46287169530152" class="t-chapter js-chapter">A First Look at the Data</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch08.html#idm46287169529208" class="t-chapter js-chapter">Learning the Latent Factors</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch08.html#idm46287169228232" class="t-chapter js-chapter">Creating the DataLoaders</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch08.html#idm46287169227320" class="t-chapter js-chapter">Collaborative Filtering from Scratch</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch08.html#idm46287168079432" class="t-chapter js-chapter">Weight Decay</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch08.html#idm46287168078776" class="t-chapter js-chapter">Creating Our Own Embedding Module</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch08.html#idm46287167839256" class="t-chapter js-chapter">Interpreting Embeddings and Biases</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch08.html#idm46287167178616" class="t-chapter js-chapter">Using fastai.collab</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch08.html#idm46287167177992" class="t-chapter js-chapter">Embedding Distance</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch08.html#idm46287167250760" class="t-chapter js-chapter">Bootstrapping a Collaborative Filtering Model</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch08.html#idm46287166844616" class="t-chapter js-chapter">Deep Learning for Collaborative Filtering</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch08.html#idm46287166843704" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch08.html#idm46287166334456" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch08.html#idm46287166332472" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#chapter_tabular" class="t-chapter js-chapter">9. Tabular Modeling Deep Dive</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287166267144" class="t-chapter js-chapter">Categorical Embeddings</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287166266200" class="t-chapter js-chapter">Beyond Deep Learning</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287166186664" class="t-chapter js-chapter">The Dataset</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287166136008" class="t-chapter js-chapter">Kaggle Competitions</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287166135512" class="t-chapter js-chapter">Look at the Data</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287165961144" class="t-chapter js-chapter">Decision Trees</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287165644136" class="t-chapter js-chapter">Handling Dates</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287165643512" class="t-chapter js-chapter">Using TabularPandas and TabularProc</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287165563944" class="t-chapter js-chapter">Creating the Decision Tree</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287165123944" class="t-chapter js-chapter">Categorical Variables</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287165735128" class="t-chapter js-chapter">Random Forests</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#random_forest" class="t-chapter js-chapter">Creating a Random Forest</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287164353976" class="t-chapter js-chapter">Out-of-Bag Error</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287164422616" class="t-chapter js-chapter">Model Interpretation</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287164005064" class="t-chapter js-chapter">Tree Variance for Prediction Confidence</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287164004440" class="t-chapter js-chapter">Feature Importance</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287163883960" class="t-chapter js-chapter">Removing Low-Importance Variables</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287163693560" class="t-chapter js-chapter">Removing Redundant Features</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287163497768" class="t-chapter js-chapter">Partial Dependence</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287163041800" class="t-chapter js-chapter">Data Leakage</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287162854584" class="t-chapter js-chapter">Tree Interpreter</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287163995592" class="t-chapter js-chapter">Extrapolation and Neural Networks</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287162645832" class="t-chapter js-chapter">The Extrapolation Problem</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287162645240" class="t-chapter js-chapter">Finding Out-of-Domain Data</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287162414184" class="t-chapter js-chapter">Using a Neural Network</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287162003912" class="t-chapter js-chapter">Ensembling</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287161228040" class="t-chapter js-chapter">Boosting</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287161159960" class="t-chapter js-chapter">Combining Embeddings with Other Methods</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287162003256" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287161136088" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch09.html#idm46287161134104" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#chapter_nlp" class="t-chapter js-chapter">10. NLP Deep Dive: RNNs</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287161047416" class="t-chapter js-chapter">Text Preprocessing</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287161018664" class="t-chapter js-chapter">Tokenization</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287161004664" class="t-chapter js-chapter">Word Tokenization with fastai</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287161003752" class="t-chapter js-chapter">Subword Tokenization</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287160691000" class="t-chapter js-chapter">Numericalization with fastai</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287160497320" class="t-chapter js-chapter">Putting Our Texts into Batches for a Language Model</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287161046760" class="t-chapter js-chapter">Training a Text Classifier</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287159921192" class="t-chapter js-chapter">Language Model Using DataBlock</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287159920568" class="t-chapter js-chapter">Fine-Tuning the Language Model</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287159812728" class="t-chapter js-chapter">Saving and Loading Models</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287159649656" class="t-chapter js-chapter">Text Generation</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287159419448" class="t-chapter js-chapter">Creating the Classifier DataLoaders</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287159416120" class="t-chapter js-chapter">Fine-Tuning the Classifier</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287159154872" class="t-chapter js-chapter">Disinformation and Language Models</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287158885160" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287158838120" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch10.html#idm46287158836136" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch11.html#chapter_midlevel_data" class="t-chapter js-chapter">11. Data Munging with fastai’s Mid-Level API</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch11.html#idm46287158804408" class="t-chapter js-chapter">Going Deeper into fastai’s Layered API</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch11.html#idm46287158669688" class="t-chapter js-chapter">Transforms</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch11.html#idm46287158668744" class="t-chapter js-chapter">Writing Your Own Transform</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch11.html#idm46287158398984" class="t-chapter js-chapter">Pipeline</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch11.html#idm46287158803816" class="t-chapter js-chapter">TfmdLists and Datasets: Transformed Collections</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch11.html#idm46287158054856" class="t-chapter js-chapter">TfmdLists</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch11.html#idm46287158019128" class="t-chapter js-chapter">Datasets</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch11.html#idm46287157643336" class="t-chapter js-chapter">Applying the Mid-Level Data API: SiamesePair</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch11.html#idm46287157274552" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch11.html#idm46287156324360" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch11.html#idm46287156322696" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch11.html#idm46287156288776" class="t-chapter js-chapter">Understanding fastai’s Applications: Wrap Up</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/part03.html#part3" class="t-chapter js-chapter">III. Foundations of Deep Learning</a>
      
    
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#chapter_nlp_dive" class="t-chapter js-chapter">12. A Language Model from Scratch</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287156279896" class="t-chapter js-chapter">The Data</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287156278984" class="t-chapter js-chapter">Our First Language Model from Scratch</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287155788808" class="t-chapter js-chapter">Our Language Model in PyTorch</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287155787896" class="t-chapter js-chapter">Our First Recurrent Neural Network</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287155990824" class="t-chapter js-chapter">Improving the RNN</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287155107944" class="t-chapter js-chapter">Maintaining the State of an RNN</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287155107032" class="t-chapter js-chapter">Creating More Signal</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287154616008" class="t-chapter js-chapter">Multilayer RNNs</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287154021544" class="t-chapter js-chapter">The Model</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287153735480" class="t-chapter js-chapter">Exploding or Disappearing Activations</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287153716952" class="t-chapter js-chapter">LSTM</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287153703064" class="t-chapter js-chapter">Building an LSTM from Scratch</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287153702120" class="t-chapter js-chapter">Training a Language Model Using LSTMs</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287152952840" class="t-chapter js-chapter">Regularizing an LSTM</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287152824728" class="t-chapter js-chapter">Dropout</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#AR_and_TAR" class="t-chapter js-chapter">Activation Regularization and Temporal Activation Regularization</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287152649640" class="t-chapter js-chapter">Training a Weight-Tied Regularized LSTM</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287152649048" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287152124488" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch12.html#idm46287152122504" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#chapter_convolutions" class="t-chapter js-chapter">13. Convolutional Neural Networks</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287152022712" class="t-chapter js-chapter">The Magic of Convolutions</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287151534312" class="t-chapter js-chapter">Mapping a Convolutional Kernel</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287151533720" class="t-chapter js-chapter">Convolutions in PyTorch</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287151271816" class="t-chapter js-chapter">Strides and Padding</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287150858792" class="t-chapter js-chapter">Understanding the Convolution Equations</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287152021256" class="t-chapter js-chapter">Our First Convolutional Neural Network</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287150807496" class="t-chapter js-chapter">Creating the CNN</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287150806552" class="t-chapter js-chapter">Understanding Convolution Arithmetic</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287150322008" class="t-chapter js-chapter">Receptive Fields</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287150184760" class="t-chapter js-chapter">A Note About Twitter</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287150184168" class="t-chapter js-chapter">Color Images</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287150161176" class="t-chapter js-chapter">Improving Training Stability</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287149846072" class="t-chapter js-chapter">A Simple Baseline</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287149845128" class="t-chapter js-chapter">Increase Batch Size</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287149359000" class="t-chapter js-chapter">1cycle Training</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287149336376" class="t-chapter js-chapter">Batch Normalization</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287150013368" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287148728328" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch13.html#idm46287148725896" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch14.html#chapter_resnet" class="t-chapter js-chapter">14. ResNets</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch14.html#idm46287148671144" class="t-chapter js-chapter">Going Back to Imagenette</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch14.html#idm46287148670200" class="t-chapter js-chapter">Building a Modern CNN: ResNet</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch14.html#idm46287148164376" class="t-chapter js-chapter">Skip Connections</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch14.html#idm46287148162824" class="t-chapter js-chapter">A State-of-the-Art ResNet</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch14.html#idm46287147576376" class="t-chapter js-chapter">Bottleneck Layers</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch14.html#idm46287147166344" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch14.html#idm46287146792456" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch14.html#idm46287146790440" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch15.html#chapter_arch_details" class="t-chapter js-chapter">15. Application Architectures Deep Dive</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch15.html#idm46287146755256" class="t-chapter js-chapter">Computer Vision</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch15.html#idm46287146747544" class="t-chapter js-chapter">cnn_learner</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch15.html#idm46287146746920" class="t-chapter js-chapter">unet_learner</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch15.html#idm46287146684952" class="t-chapter js-chapter">A Siamese Network</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch15.html#idm46287146639704" class="t-chapter js-chapter">Natural Language Processing</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch15.html#idm46287146181240" class="t-chapter js-chapter">Tabular</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch15.html#idm46287146180328" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch15.html#idm46287145805832" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch15.html#idm46287145815288" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch16.html#chapter_accel_sgd" class="t-chapter js-chapter">16. The Training Process</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch16.html#idm46287145712280" class="t-chapter js-chapter">Establishing a Baseline</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch16.html#idm46287145704248" class="t-chapter js-chapter">A Generic Optimizer</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch16.html#idm46287145450136" class="t-chapter js-chapter">Momentum</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch16.html#idm46287145182520" class="t-chapter js-chapter">RMSProp</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch16.html#idm46287144852968" class="t-chapter js-chapter">Adam</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch16.html#idm46287144568136" class="t-chapter js-chapter">Decoupled Weight Decay</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch16.html#idm46287144362696" class="t-chapter js-chapter">Callbacks</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch16.html#idm46287144073560" class="t-chapter js-chapter">Creating a Callback</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch16.html#idm46287144072936" class="t-chapter js-chapter">Callback Ordering and Exceptions</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch16.html#idm46287144332856" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch16.html#idm46287143634568" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch16.html#idm46287143632584" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch16.html#idm46287143531688" class="t-chapter js-chapter">Foundations of Deep Learning: Wrap Up</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/part04.html#part4" class="t-chapter js-chapter">IV. Deep Learning from Scratch</a>
      
    
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch17.html#chapter_foundations" class="t-chapter js-chapter">17. A Neural Net from the Foundations</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch17.html#idm46287143522392" class="t-chapter js-chapter">Building a Neural Net Layer from Scratch</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch17.html#idm46287143518904" class="t-chapter js-chapter">Modeling a Neuron</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch17.html#matrix_multiplication" class="t-chapter js-chapter">Matrix Multiplication from Scratch</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch17.html#idm46287143274904" class="t-chapter js-chapter">Elementwise Arithmetic</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch17.html#idm46287143055784" class="t-chapter js-chapter">Broadcasting</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch17.html#idm46287142435256" class="t-chapter js-chapter">Einstein Summation</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch17.html#idm46287141653240" class="t-chapter js-chapter">The Forward and Backward Passes</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch17.html#idm46287141453512" class="t-chapter js-chapter">Defining and Initializing a Layer</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch17.html#idm46287141451960" class="t-chapter js-chapter">Gradients and the Backward Pass</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch17.html#idm46287140248216" class="t-chapter js-chapter">Refactoring the Model</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch17.html#idm46287139766376" class="t-chapter js-chapter">Going to PyTorch</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch17.html#idm46287139187896" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch17.html#idm46287138206904" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch17.html#idm46287138204280" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch18.html#chapter_cam" class="t-chapter js-chapter">18. CNN Interpretation with CAM</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch18.html#idm46287138126584" class="t-chapter js-chapter">CAM and Hooks</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch18.html#idm46287138125032" class="t-chapter js-chapter">Gradient CAM</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch18.html#idm46287138124440" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch18.html#idm46287136783144" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch18.html#idm46287136781528" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch19.html#learner_from_scratch" class="t-chapter js-chapter">19. A fastai Learner from Scratch</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch19.html#idm46287136755240" class="t-chapter js-chapter">Data</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch19.html#idm46287136465800" class="t-chapter js-chapter">Dataset</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch19.html#idm46287136464760" class="t-chapter js-chapter">Module and Parameter</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch19.html#idm46287134511912" class="t-chapter js-chapter">Simple CNN</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch19.html#idm46287134511320" class="t-chapter js-chapter">Loss</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch19.html#idm46287134126664" class="t-chapter js-chapter">Learner</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch19.html#idm46287133064536" class="t-chapter js-chapter">Callbacks</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch19.html#idm46287133063912" class="t-chapter js-chapter">Scheduling the Learning Rate</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch19.html#idm46287133617800" class="t-chapter js-chapter">Conclusion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch19.html#idm46287132121016" class="t-chapter js-chapter">Questionnaire</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch19.html#idm46287132134904" class="t-chapter js-chapter">Further Research</a>
      
    
    
  </li>


      </ol>
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ch20.html#chapter_conclusion" class="t-chapter js-chapter">20. Concluding Thoughts</a>
      
    
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/app01.html#creating_a_blog" class="t-chapter js-chapter">A. Creating a Blog</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/app01.html#idm46287131946280" class="t-chapter js-chapter">Blogging with GitHub Pages</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/app01.html#idm46287131936104" class="t-chapter js-chapter">Creating the Repository</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/app01.html#idm46287131924392" class="t-chapter js-chapter">Setting Up Your Home Page</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/app01.html#idm46287131923800" class="t-chapter js-chapter">Creating Posts</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/app01.html#idm46287131897688" class="t-chapter js-chapter">Synchronizing GitHub and Your Computer</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/app01.html#idm46287131845480" class="t-chapter js-chapter">Jupyter for Blogging</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/app02.html#data_project_checklist" class="t-chapter js-chapter">B. Data Project Checklist</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/app02.html#idm46287131819144" class="t-chapter js-chapter">Data Scientists</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/app02.html#idm46287131805912" class="t-chapter js-chapter">Strategy</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/app02.html#idm46287131786136" class="t-chapter js-chapter">Data</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/app02.html#idm46287131770584" class="t-chapter js-chapter">Analytics</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/app02.html#idm46287131757256" class="t-chapter js-chapter">Implementation</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/app02.html#idm46287131742664" class="t-chapter js-chapter">Maintenance</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/app02.html#idm46287131732872" class="t-chapter js-chapter">Constraints</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/deep-learning-for/9781492045519/ix01.html#idm46287131724424" class="t-chapter js-chapter">Index</a>
      
    
    
  </li>


      </ol>

      <div id="showMoreTOC" class="showMore hidden"><button class="more"><span class="screen-reader-text">Show and hide more</span></button></div>
    </div>
  </div>

  <div id="product-information" class="title-product-information">
    <div class="content">
      <h2>Product Information</h2>

      <ul class="detail-product-information">
        <li><span class="name">Title:</span> <span class="value">Deep Learning for Coders with fastai and PyTorch</span></li>
        <li><span class="name">Author(s):</span> <span class="value authors">Jeremy Howard, Sylvain Gugger</span></li>
        <li><span class="name">Release date:</span> <span class="value">July 2020</span></li>
        <li><span class="name">Publisher(s):</span> <span class="value t-publishers">O&#x27;Reilly Media, Inc.</span></li>
        <li><span class="name">ISBN:</span> <span class="value t-isbn">9781492045526</span></li>
      </ul>
    </div>
  </div>
</section>

  </div>
</main>


  <footer id="footer" class="footer">
  <div class="content">
    <div class="footer-main" aria-label="company info">
      <div class="footer-mainLeft">
        <div class="footer-mainLeftOne">
          <div class="footer-approach">
            <h2 class="footer-header"><a href="/about/approach.html">The O'Reilly Approach</a></h2>
            <ul class="footer-links">
              <li><a href="/about/">Our Company</a></li>
              <li><a href="/work-with-us.html">Teach/Write/Train</a></li>
              <li><a href="/careers/">Careers</a></li>
              <li><a href="/partner/signup.csp">Community Partners</a></li>
              <li><a href="/diversity/">Diversity</a></li>
            </ul>
          </div>
        </div>
        <div class="footer-mainLeftTwo">
          <div class="footer-solutions">
            <h2 class="footer-header">Solutions</h2>
            <ul class="footer-links">
              <li><a href="/online-learning/teams.html">For Teams</a></li>
              <li><a href="/online-learning/enterprise.html">For Enterprise</a></li>
              <li><a href="/online-learning/individuals.html">For Individuals</a></li>
              <li><a href="/online-learning/government.html">For Government</a></li>
              <li><a href="/online-learning/academic.html">For Education</a></li>
              <li><a href="/content-marketing-solutions.html">Marketing Solutions</a></li>
            </ul>
          </div>
          
          <div class="footer-contact">
            <h2 class="footer-header"><a href="/online-learning/support/">Support</a></h2>

            <ul class="footer-links">
              <li><a href="/about/contact.html">Contact Us</a></li>
              <li><a href="/privacy.html">Privacy Policy</a></li>
            </ul>
          
            <a href="https://twitter.com/oreillymedia" target="_blank"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 400 400" style="enable-background:new 0 0 400 400;" xml:space="preserve"><style type="text/css">.st0{fill:#ee0000;}.st1{fill:#FFFFFF;}</style><g id="Red"><circle class="st0" cx="200" cy="200" r="200"/></g><g id="Logo__x2014__FIXED"><path class="st1" d="M163.4,305.5c88.7,0,137.2-73.5,137.2-137.2c0-2.1,0-4.2-0.1-6.2c9.4-6.8,17.6-15.3,24.1-25 c-8.6,3.8-17.9,6.4-27.7,7.6c10-6,17.6-15.4,21.2-26.7c-9.3,5.5-19.6,9.5-30.6,11.7c-8.8-9.4-21.3-15.2-35.2-15.2 c-26.6,0-48.2,21.6-48.2,48.2c0,3.8,0.4,7.5,1.3,11c-40.1-2-75.6-21.2-99.4-50.4c-4.1,7.1-6.5,15.4-6.5,24.2 c0,16.7,8.5,31.5,21.5,40.1c-7.9-0.2-15.3-2.4-21.8-6c0,0.2,0,0.4,0,0.6c0,23.4,16.6,42.8,38.7,47.3c-4,1.1-8.3,1.7-12.7,1.7 c-3.1,0-6.1-0.3-9.1-0.9c6.1,19.2,23.9,33.1,45,33.5c-16.5,12.9-37.3,20.6-59.9,20.6c-3.9,0-7.7-0.2-11.5-0.7 C110.8,297.5,136.2,305.5,163.4,305.5"/></g></svg></a>
            <a href="https://www.facebook.com/OReilly/" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>facebook-logo</title><path class="cls-1" d="M16.13,0A16.13,16.13,0,1,0,32.25,16.12,16.13,16.13,0,0,0,16.13,0Zm5.12,9.54H19.57a1.52,1.52,0,0,0-1.51,1.51v1.14h3.19v3.42H18.06V26.12H13.57V15.61H10.69V12.19h2.88v-2a4,4,0,0,1,4-4h3.65Z"/></svg></a>
            <a href="https://www.linkedin.com/company/oreilly-media" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>linkedin-logo</title><path class="cls-1" d="M17.43,13.53v0l0,0ZM16.12,0A16.13,16.13,0,1,0,32.25,16.12,16.12,16.12,0,0,0,16.12,0ZM11.77,22.92H8.12v-11h3.65ZM9.94,10.44h0a1.89,1.89,0,0,1-2-1.89A1.91,1.91,0,0,1,10,6.65a1.9,1.9,0,1,1,0,3.79Zm15,12.48H21.28V17.05c0-1.48-.53-2.49-1.85-2.49a2,2,0,0,0-1.88,1.34,2.63,2.63,0,0,0-.12.89v6.13H13.79s.05-10,0-11h3.64V13.5a3.63,3.63,0,0,1,3.29-1.82c2.4,0,4.21,1.57,4.21,4.95Z"/></svg></a>
            <a href="https://www.youtube.com/user/OreillyMedia" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>youtube-logo</title><path class="cls-1" d="M18.35,18.68a.89.89,0,0,0-.86.63V16.94h-1v7.59h1v-.59a.92.92,0,0,0,.89.74c.52,0,.86-.36,1-1.07a8.56,8.56,0,0,0,.14-1.9,10.47,10.47,0,0,0-.12-1.93C19.21,19.05,18.87,18.68,18.35,18.68Zm.09,4.14c-.05.52-.2.77-.45.77s-.43-.21-.49-.63a7.22,7.22,0,0,1,0-1c0-.72,0-1.14,0-1.26.07-.58.23-.88.51-.88s.4.27.46.79c0,.09,0,.47,0,1.13S18.46,22.71,18.44,22.82ZM8.61,18.19H9.86v6.34H11V18.19H12.2V16.94H8.61Zm7.71-6.12c.27,0,.43-.22.49-.66,0-.09,0-.45,0-1.07V9.78c0-.58,0-.93,0-1-.07-.43-.23-.65-.48-.65s-.41.19-.48.57a8.79,8.79,0,0,0,0,1v.53c0,.71,0,1.09,0,1.16C15.88,11.82,16.05,12.07,16.32,12.07Zm-1.74,10.4a2.92,2.92,0,0,1-.06.71c-.07.25-.2.37-.4.37s-.32-.11-.38-.34a2.63,2.63,0,0,1-.05-.66V18.83h-1v4.48c0,.91.33,1.37,1,1.37A1,1,0,0,0,14.6,24v.57h1v-5.7h-1Zm7.1-3.79a1.35,1.35,0,0,0-1.22.59,2.48,2.48,0,0,0-.3,1.07c0,.23,0,.61,0,1.16s0,1.13,0,1.37a2.93,2.93,0,0,0,.35,1.27,1.25,1.25,0,0,0,1.14.54,1.36,1.36,0,0,0,1.13-.45,2.29,2.29,0,0,0,.37-1.43s0-.07,0-.11v-.12h-1c0,.75-.17,1.12-.51,1.12s-.38-.18-.45-.56a4.68,4.68,0,0,1-.06-.9c0-.18,0-.31,0-.37h2v-.43a4.86,4.86,0,0,0-.3-2.11A1.28,1.28,0,0,0,21.68,18.68ZM22.15,21h-1c0-.05,0-.11,0-.16v-.08a1.64,1.64,0,0,1,.11-.8.39.39,0,0,1,.38-.23.42.42,0,0,1,.43.33,2.32,2.32,0,0,1,.07.7Zm-6-21A16.13,16.13,0,1,0,32.25,16.12,16.12,16.12,0,0,0,16.12,0Zm2.51,7.2h1V11a2.52,2.52,0,0,0,.06.66c.06.23.18.34.38.34s.34-.12.41-.37a3.76,3.76,0,0,0,.05-.71V7.2h1v5.74h-1v-.57a1,1,0,0,1-.93.72c-.66,0-1-.46-1-1.38ZM15,8a1.29,1.29,0,0,1,1.33-.92A1.3,1.3,0,0,1,17.65,8a6.77,6.77,0,0,1,.23,2.1,6.77,6.77,0,0,1-.23,2.1,1.3,1.3,0,0,1-1.32.92A1.29,1.29,0,0,1,15,12.17a6.77,6.77,0,0,1-.23-2.1A6.86,6.86,0,0,1,15,8ZM11.45,5.3l.89,2.87.88-2.87H14.4L12.88,9.7v3.24h-1.1V9.7L10.24,5.3ZM24.93,23.91a3,3,0,0,1-3,3h-12a3,3,0,0,1-3-3V18.05a3,3,0,0,1,3-3h12a3,3,0,0,1,3,3Z"/></svg></a>
            <a href="https://www.oreilly.com/emails/newsletters/" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.33 32.33"><defs><style>.cls-1{fill:#E00;}.cls-2{fill:#f0f1f1;}</style></defs><title>email-logo</title><circle class="cls-1" cx="16.17" cy="16.17" r="16.17"/><path class="cls-2" d="M6.66,13.32l.2.14c2.2,1.5,4.41,3,6.74,4.29.6.34,1.22.62,1.84.92a1.72,1.72,0,0,0,1.44,0,21,21,0,0,0,2.71-1.4c2-1.21,4-2.53,5.91-3.87l.18-.12v.21c0,2.77,0,5.54,0,8.31A1.51,1.51,0,0,1,24,23.33c-5.24,0-10.48,0-15.72,0a1.57,1.57,0,0,1-1.62-1.08,1.23,1.23,0,0,1,0-.19V13.47A.86.86,0,0,1,6.66,13.32Z"/><path class="cls-2" d="M16.15,9h7.9a1.5,1.5,0,0,1,1.56,1,4.81,4.81,0,0,1,.06,1.07s0,.08-.08.1a77.16,77.16,0,0,1-7.49,4.9c-.42.24-.87.43-1.31.63a1.41,1.41,0,0,1-1.28,0c-.65-.33-1.32-.64-1.95-1-2.37-1.4-4.59-3-6.81-4.55a.35.35,0,0,1-.1-.2c0-.2,0-.4,0-.6A1.45,1.45,0,0,1,8.05,9h8.1Z"/></svg></a>
          </div>
        </div>
      </div>

      <div class="footer-download" id="download-info">
        <h2 class="footer-header">Download the O&rsquo;Reilly App</h2>

        <div class="footer-downloadLinks">
          <a href="https://itunes.apple.com/us/app/safari-to-go/id881697395"><img src="https://cdn.oreillystatic.com/oreilly/images/app-store-logo.png" alt="Apple app store" /></a>
          <a href="https://play.google.com/store/apps/details?id=com.safariflow.queue"><img src="https://cdn.oreillystatic.com/oreilly/images/google-play-logo.png"  alt="Google play store" /></a>
        </div>

        <p>Take O&rsquo;Reilly online learning with you and learn anywhere, anytime on your phone or tablet. Download the app <span class="nowrap">today and:</span></p>

        <ul>
          <li>Get unlimited access to books, videos, and <span class="nowrap">live training</span></li>
          <li>Never lose your place&mdash;all your devices are synced</li>
          <li>Learn during your commute with online and <span class="nowrap">offline access</span></li>
        </ul>
      </div>
    </div>

    <div class="footer-subfooter">

      <a href="https://www.oreilly.com" title="home page" aria-current="page">
        <img 
        class="footer-subfooterLogo" 
        id="footer-subfooterLogo"
        src="https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red.svg" 
        onerror="this.src='https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red_@2x.png'; this.onerror=null;" 
        alt="O'Reilly home">
      </a>

      <p>&copy; 2020, O&rsquo;Reilly Media, Inc.  All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p>
      <p><a href="/terms/">Terms of Service</a> • <a href="/privacy.html">Privacy Policy</a> • <a href="/about/editorial_independence.html">Editorial Independence</a></p>
    </div>

  </div>
</footer>


<!--
<footer class="anybird-footer">
    <nav class="grid">
        <ul class="footer-nav col">
            <li><a href="https://learning.oreilly.com/explore/"><span>Explore</span></a></li>
            <li><a href="https://learning.oreilly.com/our-library/"><span>Tour</span></a></li>
            <li><a href="https://learning.oreilly.com/pricing/"><span>Pricing</span></a></li>
            <li><a href="https://learning.oreilly.com/enterprise/"><span>Enterprise</span></a></li>
            <li><a href="https://learning.oreilly.com/government/"><span>Government</span></a></li>
            <li><a href="https://learning.oreilly.com/academic-public-library/"><span>Education</span></a></li>
            <li><a href="https://learning.oreilly.com/your-experience/#queue"><span>Queue App</span></a></li>
        </ul>
        <ul class="footer-contact col">
            <li><a href="https://learning.oreilly.com/learn/"><span>Learn</span></a></li>
            <li><a href="https://learning.oreilly.com/blog/"><span>Blog</span></a></li>
            <li><a href="https://learning.oreilly.com/contact/"><span>Contact</span></a></li>
            <li><a href="https://learning.oreilly.com/careers/"><span>Careers</span></a></li>
            <li><a href="https://learning.oreilly.com/press-resources/"><span>Press Resources</span></a></li>
            <li><a href="https://www.oreilly.com/online-learning/support/"><span>Support</span></a></li>
        </ul>
        <ul class="footer-social col">
            <li id="footer-twitter"><a href="https://twitter.com/safari"><span>Twitter</span></a></li>
            <li id="footer-github"><a href="https://github.com/oreillymedia"><span>GitHub</span></a></li>
            <li id="footer-facebook"><a href="http://www.facebook.com/safaribooksonline"><span>Facebook</span></a></li>
            <li id="footer-linkedin"><a
                    href="https://www.linkedin.com/company/safari-books-online"><span>LinkedIn</span></a></li>
        </ul>
        <ul class="footer-legal col">
            <li><a href="https://learning.oreilly.com/terms/"><span>Terms of Service</span></a></li>
            <li><a href="https://learning.oreilly.com/membership-agreement/"><span>Membership Agreement</span></a></li>
            <li><a href="https://learning.oreilly.com/privacy/"><span>Privacy Policy</span></a></li>
        </ul>
    </nav>
    <div class="footer-copyright">
        Copyright &copy; 2020 Safari Books Online.
    </div>
</footer>
-->




<script>
  var g = {
    
  };
</script>
<script>
  window.dataLayer = window.dataLayer || [];
  window.dataLayer.push({
    'product.title': "Deep Learning for Coders with fastai and PyTorch",
    'product.type': "book",
    'product.identifier': "9781492045519",
    'content.identifier': "9781492045519",
    'content.publisher': "O'Reilly Media, Inc.",
    'content.free': "no",
    'content.subdirectory': "none",
    'content.subTopic': "none",
    'content.parentTopic': "none",
    'content.formatType': "book",
    'content.author': "Jeremy Howard, Sylvain Gugger",
    'content.releaseDate': "2020-07-22",
    'content.title': "Deep Learning for Coders with fastai and PyTorch",
  });
</script>



<script src="/library/view/static/CACHE/js/output.d1c80552da2d.js"></script>


<noscript> 
  <iframe src="//www.googletagmanager.com/ns.html?id=GTM-5P4V6Z"
          height="0" width="0"
          style="display:none;visibility:hidden">
  </iframe>
</noscript>


<script async defer src="/library/view/pageview.js"></script>

<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.0/jquery.min.js"></script>

<script>
  jQuery(document).ready(function($) {
    //Toggle isActive and mobileHidden classes for mobileNavButton
    $('nav #mobileNavButton').on('click', function() {
      var expanded = $(this).attr('aria-expanded') === 'true' || false;
      $(this).attr('aria-expanded', !expanded);
      $(this).toggleClass("isActive");
      $(this).next().toggleClass("mobileHidden");
    });

    //Toggle isFocused class for keyboard navigation of submenus
    $('nav #menuList .menuList-subItem a').each(function(navItem) {
      $(this).on('focus', function() {
        $(this).parent().parent().toggleClass('isFocused');
      });
      $(this).on('blur', function() {
        $(this).parent().parent().toggleClass('isFocused');
      });
    });

    //Toggle mobileHidden class accordian elements
    $('.mobileAccordian').each(function() {
      var $btn = $(this).find('button');
      var $target =  $(this).next();
      $btn.on('click', function() {
        var expanded = $btn.attr('aria-expanded') === 'true' || false;

        $btn.attr('aria-expanded', !expanded);
        $target.toggleClass("mobileHidden");
      });
    });


    //Hide title page's long description behind disclosure button
    var titleDescriptionExtra = $('.title-description p:first-of-type').nextAll(':nth-child(3)').nextAll();
    titleDescriptionExtra.wrapAll('<div id="titleDescriptionExtra" />');
    if (titleDescriptionExtra.length > 0) {
      $('#titleDescriptionExtra').toggle();
      $('#showMoreDescription').removeClass('hidden');
      $('#showMoreDescription button').on('click', function() {
        $(this).toggleClass('more');
        $('#titleDescriptionExtra').slideToggle();
      });
    }

    //Hide title page's long TOC behind disclosure button
    var titleTOCShort = $('.sbo-reader-title .detail-toc').find('li').slice(0,4);
    var titleTOCExtra = $('.sbo-reader-title .detail-toc').find('li').not(titleTOCShort);
    if (titleTOCExtra.length > 0) {
      titleTOCExtra.toggle();
      $('#showMoreTOC').removeClass('hidden');
      $('#showMoreTOC button').on('click', function() {
        $(this).toggleClass('more');
        titleTOCExtra.toggle();
      });
    }

    //Hide product information on page load
    $('#product-information').toggle();
    $('#title-tabs button').on('click', function() {
      var $thisTab = $(this);
      if (!$thisTab.hasClass('title-tab-active')) {
        var lastTabTarget = $('#title-tabs .title-tab-active').removeClass('title-tab-active').attr('data-target');
        $('#' + lastTabTarget).toggle();

        $thisTab.addClass('title-tab-active');
        var $tabTarget = $(this).attr('data-target');
        $('#' + $tabTarget).toggle();
      }
    });

  });

</script>



<!-- MARC Intercept Support -->

<script src="https://service.seamlessaccess.org/thiss.js"></script>

<script src="/library/view/static/CACHE/js/output.8bff54f150f1.js"></script>


</body>
</html>
