What you need for this book

To run the examples in the book following software will be required:

Web Server:

Apache recommended (The Drupal installation recipe is specific to an Apache installation).

  • Apache 1.3 or Apache 2.x, Apache 2.x recommended
  • Microsoft IIS 7

#

Software Name

URL

1

Apache

http://httpd.apache.org/

2

Microsoft IIS

http://www.iis.net/

Database:

  • MySQL 5.0.15 or higher with PDO, SQLite 3.3.7 or higher

Microsoft SQL Server and Oracle are supported by an additional module

PHP:

  • PHP 5.2.5 or higher, PHP 5.3 recommended

#

Software Name

URL

1

PHP

http://php.net

FTP client:

There are a number of free FTP clients; this is the recommended, cross-platform client:

#

Software Name

URL

1

FileZilla

http://filezilla-project.org/

Text ...

Get Drupal 7 Cookbook now with O’Reilly online learning.

O’Reilly members experience live online training, plus books, videos, and digital content from 200+ publishers.