What you need for this book

Obviously, you will need Solr itself running on your system. This book relies on Solr Version 4.3.

As Solr is implemented in Java, you will also need a recent version of Java installed on your machine. Version 1.6 or later of either the runtime or development environment will work fine. You will also need a modern web browser to access the Admin WebUI.

Get Instant Apache Solr for Indexing Data How-to now with O’Reilly online learning.

O’Reilly members experience live online training, plus books, videos, and digital content from 200+ publishers.