O'Reilly logo

Moodle 1.9 for Design and Technology by Paul Taylor

Stay ahead with the world's most comprehensive technology and business learning platform.

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, tutorials, and more.

Start Free Trial

No credit card required

What you need for this book

For Moodle, you must have the following components up and running on your server:

  • Database: MySQL (version 4.1.6 or later), PostgreSQL (version 7.4 or later), Microsoft SQL Server (version 2005 or later), Oracle (version 8 or later).
  • Web server: Apache is the preferred web server though IIS 6 is also fine.
  • PHP: PHP 4.30 is required to run Moodle, but it might be advisable to use PHP 5.24 or higher as this will be necessary in the forthcoming 2.0 version of Moodle.
  • PHP extensions: Moodle makes use of a number of PHP extensions, most of which are compiled into PHP by default.

Depending on your specific setup, additional software or hardware might be required.

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, interactive tutorials, and more.

Start Free Trial

No credit card required