What you need for this book

To use this book, it is recommended you install your favorite IDE, which should support the following:

  • HTML
  • SASS
  • CSS

For better understanding of the code and its debugging, you will need a browser such as:

  • Google Chrome
  • Mozilla Firefox
  • Internet Explorer 9+

Additionally, you will need the following:

  • Ruby (to install SASS)
  • SASS
  • Node.js (to install Gulp.js)
  • Gulp.js

Get Professional CSS3 now with O’Reilly online learning.

O’Reilly members experience live online training, plus books, videos, and digital content from 200+ publishers.