2.4. Java 2 support

With support for JDK 1.2.2 (Java 2 SE) the following Java APIs are supported with WebSphere Advanced Edition (AE) V3.5 (specific support that exists only in the Enterprise Edition (EE) is noted):

  • EJB 1.0 (plus extensions to support RMI/IIOP, transactions, and CMP)

  • Java Servlet Specification 2.2

    - WAR files support for deployment

    - Multiple error page support

    - Request dispatchers by name and by relative path

  • JavaServer Pages (JSP) 1.1 including Tag Library support

  • JDBC 2.0

  • Java Naming and Directory Interface (JNDI)1.2

  • RMI/IIOP 1.0

  • Java Transaction Service (JTS)/Java Transaction API (JTA)1.0

  • Java Messaging Service (JMS)1.0 (in conjunction with MQSeries)

  • JavaIDL and CORBA (EE only)

Get WebSphere V3.5 Handbook now with O’Reilly online learning.

O’Reilly members experience live online training, plus books, videos, and digital content from 200+ publishers.