<!DOCTYPE html>
<html lang="en-US">
  <head>

    <meta charset="UTF-8">

    <title>
      Four short links: 9 March 2020 – O’Reilly     </title>

    <link rel="stylesheet" href="https://cdn.oreillystatic.com/assets/css/wp_sites/style-20200218a.css">

    
    <link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.oreilly.com\/radar\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.oreilly.com/radar/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='mo_saml_admin_settings_style-css'  href='https://www.oreilly.com/radar/wp-content/plugins/miniorange-saml-20-single-sign-on/includes/css/jquery.ui.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='ssp-frontend-player-css'  href='https://www.oreilly.com/radar/wp-content/plugins/seriously-simple-podcasting/assets/css/player.css?ver=1.20.10' type='text/css' media='all' />
<script type='text/javascript' src='https://www.oreilly.com/radar/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.oreilly.com/radar/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.oreilly.com/radar/wp-content/plugins/miniorange-saml-20-single-sign-on/includes/js/settings.js?ver=5.3.2'></script>
<link rel="canonical" href="https://www.oreilly.com/radar/four-short-links-9-march-2020/" />
<link rel='shortlink' href='https://www.oreilly.com/radar/?p=12360' />

<link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.oreilly.com/radar/feed/podcast" />


<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="language_name" content="English">
<meta name="native_language_name" content="English">
<meta name="format-detection" content="telephone=no">

<link rel="icon" type="image/png" href="//www.oreilly.com/favicon.ico">

<!--[if lte IE 9]>
<script>
  'article aside footer header main nav section time'.replace(/\w+/g,function(n){document.createElement(n)})
</script>
<![endif]-->

<!--[if IE 9]>
<style type="text/css">
  #menu-toggle:checked ~ .mobile-nav { display:block; }
  .mobile-nav { display: none; }
</style>
<![endif]-->

<meta property="twitter:card" content="summary_large_image" />
<meta property="twitter:site" content="@OReillyMedia" />
<meta property="twitter:title" content="Four short links: 9 March 2020" />
<meta property="twitter:description" content="Git for Geodata, Language Generation Bias, Online Conferences, and Multithreaded Gotchas" />
<meta property="twitter:url" content="https://www.oreilly.com/radar/four-short-links-9-march-2020" />
<meta property="twitter:image" content="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2019/06/4_short_links_logo-1400x750.png" />
<meta property="og:type" content="article" />
<meta property="og:site_name" content="O’Reilly Media" />
<meta property="og:title" content="Four short links: 9 March 2020" />
<meta property="og:description" content="Git for Geodata, Language Generation Bias, Online Conferences, and Multithreaded Gotchas" />
<meta property="og:url" content="https://www.oreilly.com/radar/four-short-links-9-march-2020/" />
<meta property="og:image" content="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2019/06/4_short_links_logo-1400x750.png" />
<meta name="description" content="Git for Geodata, Language Generation Bias, Online Conferences, and Multithreaded Gotchas" />
<meta name="author" content="Nat Torkington" />
<meta name="description:site" content="Git for Geodata, Language Generation Bias, Online Conferences, and Multithreaded Gotchas" />
<meta property="article:published_time" content="2020-03-09T00:01:00-04:00" />
<meta name="article:author" content="Nat Torkington" />
<meta name="date" content="2020-03-09" />
<meta name="thumbnail" content="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2019/06/4_short_links_logo-1400x750.png" />
<meta name="graphic_medium" content="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2019/06/4_short_links_logo-1400x750.png" />
<meta name="oreilly:content_type" content="text" />

<script>
  loggedInObject = new Object();
  var dataLayer = window.dataLayer || [];

  //Check for O'Reilly Unified logged-in status
  if (document.cookie.split(';').filter(function(item) {
    return item.indexOf('orm-jwt=') >= 0;
  }).length) {
    loggedInObject.loggedIn = 'yes';
    dataLayer.push(loggedInObject);
  }
</script>


  <script>
    dataLayer = [{"content.author":"Nat Torkington","content.formatType":"article","content.free":"yes","content.identifier":"none","content.parentTopic":"Four Short Links","content.publisher":"O'Reilly Media Inc.","content.releaseDate":"2020-03-09","content.subTopic":"none","content.subdirectory":"radar","content.title":"Four short links: 9 March 2020","product.identifier":"none","product.title":"none","product.type":"none"}];
  </script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5P4V6Z');</script>
<!-- End Google Tag Manager -->


<!-- Start Visual Website Optimizer Asynchronous Code -->
<script type='text/javascript'>
var _vwo_code=(function(){
var account_id=27087,
settings_tolerance=2000,
library_tolerance=2500,
use_existing_jquery=false,
// DO NOT EDIT BELOW THIS LINE
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
</script>
<!-- End Visual Website Optimizer Asynchronous Code -->


</head>
<body class="post-template-default single single-post postid-12360 single-format-standard multisite-radar">

<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5P4V6Z" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

<div class="skipToMain" id="skipToMain"><a href="#maincontent"><span class="skipToMain-text">Skip to main content</span></a></div>

<header role="banner">
  <nav role="navigation" aria-label="site sections">
    <a href="https://www.oreilly.com/" class="logo" title="home page"><img src="https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red.svg" onerror="this.src='https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red_@2x.png'; this.onerror=null;" alt="O'Reilly home"></a>

    <button id="mobileNavButton" class="mobileNavButton mobileNavButton--collapse mobileNavButton--3dx" type="button" aria-expanded="false" aria-controls="menuList">
      <span class="mobileNavButton-box">
        <span class="mobileNavButton-inner"></span>
      </span>
    </button>

    <ul id="menuList" class="menuList mobileHidden">
      <li class="menuList-itemsP1">
        <ul>
          <li class="menuList-item menuList-signIn"><a href="https://oreilly.com/sign-in.html">Sign In</a></li>
          <li class="menuList-item menuList-tryNow"><a class="menuList-cta" href="https://oreilly.com/online-learning/try-now.html">Try Now</a></li>
        </ul>
      </li>
      <li class="menuList-itemsP2">
        <ul>
          <li class="menuList-item menuList-itemWithSub"><a href="https://oreilly.com/online-learning/index.html">Online Learning</a>
            <ul class="menuList-subList">
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/individuals.html">Individuals</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/teams.html">Teams</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/enterprise.html">Enterprise</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/government.html">Government</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/academic.html">Academic</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/features.html">Features</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/custom-services.html">Custom Services</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/pricing.html">Pricing</a></li>
            </ul>
          </li>
          <li class="menuList-item menuList-itemWithSub"><a href="https://www.oreilly.com/conferences/">Conferences</a>
            <ul class="menuList-subList menuList-subList-conferences">
              <li class="menuList-subItem"><a href="https://conferences.oreilly.com/infrastructure-ops/io-ca">Infrastructure &amp; Ops Conference</a></li>
              <li class="menuList-subItem"><a href="https://conferences.oreilly.com/oscon">Open Source Software Conference</a></li>
              <li class="menuList-subItem"><a href="https://conferences.oreilly.com/software-architecture">Software Architecture Conference</a></li>
              <li class="menuList-subItem"><a href="https://conferences.oreilly.com/strata-data-ai">Strata Data &amp; AI Conference</a></li>
              <li class="menuList-subItem"><a href="https://conferences.oreilly.com/tensorflow">TensorFlow World</a></li>
              <li class="menuList-subItem"><a href="https://conferences.oreilly.com/velocity">Velocity Conference</a></li>
            </ul>
          </li>
          <li class="menuList-item menuList-itemWithSub"><a href="https://www.oreilly.com/radar/" aria-current="page"  >Radar</a>
          <!-- v2 -->
            <ul class="menuList-subList">
              <li class="menuList-subItem"><a href="https://www.oreilly.com/radar/topics/ai-ml/">AI/ML</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/radar/topics/future-of-the-firm/">Future of the Firm</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/radar/topics/innovation-and-disruption/" class="nowrap">Innovation &amp; Disruption</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/radar/topics/next-architecture/">Next Architecture</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/radar/topics/next-economy/">Next Economy</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/radar/posts/">All Articles</a></li>
            </ul>
          </li>
          <li class="menuList-item"><a href="https://www.oreilly.com/about/approach.html">Our Approach</a></li>
        </ul>
      </li>
    </ul>
  </nav>

  <!-- <div class="head-search-bar">

    <div class="content">
      <p>This is where the search bar goes</p>
    </div>
  </div> -->

</header>

<main role="main" id="maincontent">
      <section class="hero hero-wp">
      <div class="content">
        <div class="hero-textWrap">
          <div class="hero-breadcrumbs">
            <a href="https://www.oreilly.com/radar">Radar</a> / <a href="https://www.oreilly.com/radar/topics/four-short-links/">Four Short Links</a>          </div>
          <h1 class="radar-post-page-head">Four short links: 9 March 2020</h1>
                      <div class="radar-post-page-subhead">
              <p>Git for Geodata, Language Generation Bias, Online Conferences, and Multithreaded Gotchas</p>
            </div>
          	      </div>
      </div>
    </section>


    <section class="textSection post-radar ">
      <div class="content">

                              <div class="radar-post-page-meta">
              <span class="radar-post-page-author">
                By <a href="https://www.oreilly.com/people/nathan-torkington/">Nat Torkington</a>              </span>
            </div>
          
          <div class="radar-post-page-meta">
            <span class="radar-post-page-date">
              March 9, 2020            </span>
          </div>
        
        <div class="radar-post-flex-wrap">

          <div class="right-rail" id="right-rail">
            
              <div id="post-featured-image" class="post-featured-image">
                <img width="1400" height="750" src="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2019/06/4_short_links_logo-1400x750.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Four Short Links" srcset="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2019/06/4_short_links_logo-1400x750.png 1400w, https://www.oreilly.com/radar/wp-content/uploads/sites/3/2019/06/4_short_links_logo-1400x750-300x161.png 300w, https://www.oreilly.com/radar/wp-content/uploads/sites/3/2019/06/4_short_links_logo-1400x750-768x411.png 768w, https://www.oreilly.com/radar/wp-content/uploads/sites/3/2019/06/4_short_links_logo-1400x750-1048x561.png 1048w" sizes="(max-width: 1400px) 100vw, 1400px" />
                                </div>

                        </div>

          <div class="post-radar-content" id="post-radar-content">

            <div class="main-post-radar-content">

              
              
              
              
              
              <ol>
<li><a href="https://sno.earth/">Sno</a> &#8212; <i>Distributed version control<br />
for geospatial and tabular data</i>. Finally, git for (geo)data done right. Open source.</li>
<li><a href="https://arxiv.org/pdf/1909.01326.pdf">The Woman Worked as a Babysitter: On Biases in Language Generation</a> &#8212; plugging prompts like &#8220;the woman worked as&#8221; and &#8220;the white person worked as&#8221; into text generation systems, and the horrors you get back. (via <a href="https://twitter.com/VioletNPeng/status/1191982282011230213">Violent Peng</a>)</li><div class="JoQ1Xnry"><div itemscope="" itemtype="http://schema.org/Product" class="inline-cta trial-cta" id="trial-cta">
  <div class="thumb ">
    <a href="https://www.oreilly.com/online-learning/">
      <img itemprop="image" src="https://d3ansictanv2wj.cloudfront.net/safari-topic-cta-1f60e6f96856da19ba3cb25660472ca5.jpg" class="">
    </a>
  </div>
  <div class="title">
    <h2>
      Learn faster. Dig deeper. See farther.
    </h2>
  </div>
   <div class="meta">
    <p class="dek">Join the O'Reilly online learning platform. Get a free trial today and find answers on the fly, or master something new and useful.</p>
    <a href="https://www.oreilly.com/online-learning/" class="textCTA-small more">Learn more</a>
  </div>
</div></div>
<li><a href="https://docs.google.com/document/d/1EABkSzEdJk5cmMLETpSbXaeDXmFwcTz7SUXP_C3dN9k/edit?usp=sharing">How to Run a Free Online Academic Conference: A Workbook</a> &#8212; as f2f conferences are canceled left, right, and center, this might be of interest to folks. (via <a href="https://twitter.com/fdsayre/status/1236023757434580992">Franklin Sayre</a>)</li>
<li><a href="https://docs.microsoft.com/en-us/archive/msdn-magazine/2008/october/concurrency-hazards-solving-problems-in-your-multithreaded-code">Solving 11 Likely Problems in Your Multithreaded Code</a> &#8212; <i>There really is a fundamental set of concepts that you need to learn and become comfortable with. It&#8217;s likely that certain languages and libraries can hide some concepts over time, but if you&#8217;re doing concurrency today, you won&#8217;t have that luxury. This article describes some of the more common challenges to be aware of and presents advice for coping with them in your software.</i></li>
</ol>
</li>
                          </div>

                        
            <div class="post-radar-end">

              
                              <div class="radar-post-page-meta" >
      Post topics: <a href="https://www.oreilly.com/radar/topics/four-short-links/" title="Four Short Links">Four Short Links</a></div>              
                              <div class="radar-post-page-meta" >
      Post tags: <a href="https://www.oreilly.com/radar/tag/signals/" title="Signals">Signals</a></div>              
              <div class="radar-post-page-meta radar-post-page-meta-share">
                Share:
                <ul>
                  <li>
                    <a data-via="oreillymedia" class="twitter-share-button" href="https://twitter.com/intent/tweet?text=Four short links: 9 March 2020">Tweet</a>                  </li>
                  <li>
                    <div class="fb-share-button" data-href="https://www.oreilly.com/radar/four-short-links-9-march-2020" data-layout="button" data-size="small"><a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fdevelopers.facebook.com%2Fdocs%2Fplugins%2F&amp;src=sdkpreparse" class="fb-xfbml-parse-ignore">Share</a></div>                  </li>
                  <li>
                    <script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
    <script type="IN/Share"></script>                  </li>
                </ul>
              </div>

                              
              <script type="text/javascript" src="https://www.oreilly.com/radar/wp-content/themes/odot/files/cta-191118.js"></script>

            </div>
          </div>

        </div>

      </div>
    </section>


  
<!-- twitter button script  -->
<script>window.twttr = (function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0],
    t = window.twttr || {};
  if (d.getElementById(id)) return t;
  js = d.createElement(s);
  js.id = id;
  js.src = "https://platform.twitter.com/widgets.js";
  fjs.parentNode.insertBefore(js, fjs);
  t._e = [];
  t.ready = function(f) {
    t._e.push(f);
  };
  return t;
}(document, "script", "twitter-wjs"));</script>

<!-- Load Facebook SDK for JavaScript -->
<div id="fb-root"></div>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v5.0"></script>

  </main>

  <footer id="footer" class="footer">
    <div class="content">

      <div class="footer-main" aria-label="company info">
        <div class="footer-mainLeft">
          <div class="footer-mainLeftOne">
            <div class="footer-upcoming">

              <h2 class="footer-header"><a href="https://www.oreilly.com/conferences/">Upcoming Conferences</a></h2>
                <ul><!-- v2 --><li class="conf_event"><a href="https://oreilly.formulated.by/scme-phoenix-2020/"><span itemprop="summary" class="confName">Smart Cities & Mobility Ecosystems</span> <time itemprop="startDate"datetime="2020-04-15"><span class="confMonth">Apr</span>&nbsp;15</time>&ndash;16, Phoenix</a></li><li class="conf_event"><a href="https://oreilly.formulated.by/scme-miami-2020/"><span itemprop="summary" class="confName">Smart Cities & Mobility Ecosystems</span> <time itemprop="startDate"datetime="2020-06-03"><span class="confMonth">Jun</span>&nbsp;3</time>&ndash;4, Miami</a></li><li class="conf_event"><a href="https://conferences.oreilly.com/software-architecture/sa-ca"><span itemprop="summary" class="confName">Software Architecture</span> <time itemprop="startDate"datetime="2019-06-15"><span class="confMonth">Jun</span>&nbsp;15</time>&ndash;18, Santa Clara</a></li><li class="conf_event"><a href="https://conferences.oreilly.com/infrastructure-ops/io-ca"><span itemprop="summary" class="confName">Infrastructure & Ops</span> <time itemprop="startDate"datetime="2020-06-15"><span class="confMonth">Jun</span>&nbsp;15</time>&ndash;18, Santa Clara</a></li><li class="conf_event"><a href="https://conferences.oreilly.com/oscon/oscon-or"><span itemprop="summary" class="confName">OSCON</span> <time itemprop="startDate"datetime="2020-07-13"><span class="confMonth">Jul</span>&nbsp;13</time>&ndash;16, Portland</a></li><li class="conf_event"><a href="https://conferences.oreilly.com/strata-data-ai/stai-ny"><span itemprop="summary" class="confName">Strata & AI</span> <time itemprop="startDate"datetime="2020-09-14"><span class="confMonth">Sep</span>&nbsp;14</time>&ndash;17, New York</a></li></ul>            </div>
            <div class="footer-approach">
              <h2 class="footer-header"><a href="https://www.oreilly.com/about/approach.html">The O'Reilly Approach</a></h2>
              <ul class="footer-links">
                <li><a href="https://www.oreilly.com/about/">Our Company</a></li>
                <li><a href="https://www.oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
                <li><a href="https://www.oreilly.com/careers/">Careers</a></li>
                <li><a href="https://www.oreilly.com/partner/signup.csp">Community Partners</a></li>
              </ul>
            </div>
          </div>
          <div class="footer-mainLeftTwo">
            <div class="footer-solutions">
              <h2 class="footer-header">Solutions</h2>
              <ul class="footer-links">
                <li><a href="https://www.oreilly.com/online-learning/teams.html">For Teams</a></li>
                <li><a href="https://www.oreilly.com/online-learning/enterprise.html">For Enterprise</a></li>
                <li><a href="https://www.oreilly.com/online-learning/individuals.html">For Individuals</a></li>
                <li><a href="https://www.oreilly.com/online-learning/government.html">For Government</a></li>
                <li><a href="https://www.oreilly.com/online-learning/academic.html">For Education</a></li>
              </ul>
            </div>
            <div class="footer-contact">
              <h2 class="footer-header"><a href="http://shop.oreilly.com/category/customer-service.do">Support</a></h2>

              <ul class="footer-links">
                <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
                <li><a href="https://www.oreilly.com/about/contact.html">Contact Us</a></li>
                <li><a href="https://www.oreilly.com/privacy.html">Privacy Policy</a></li>
              </ul>
            
              <a href="https://twitter.com/oreillymedia" target="_blank"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 400 400" style="enable-background:new 0 0 400 400;" xml:space="preserve"><style type="text/css">.st0{fill:#ee0000;}.st1{fill:#FFFFFF;}</style><g id="Red"><circle class="st0" cx="200" cy="200" r="200"/></g><g id="Logo__x2014__FIXED"><path class="st1" d="M163.4,305.5c88.7,0,137.2-73.5,137.2-137.2c0-2.1,0-4.2-0.1-6.2c9.4-6.8,17.6-15.3,24.1-25 c-8.6,3.8-17.9,6.4-27.7,7.6c10-6,17.6-15.4,21.2-26.7c-9.3,5.5-19.6,9.5-30.6,11.7c-8.8-9.4-21.3-15.2-35.2-15.2 c-26.6,0-48.2,21.6-48.2,48.2c0,3.8,0.4,7.5,1.3,11c-40.1-2-75.6-21.2-99.4-50.4c-4.1,7.1-6.5,15.4-6.5,24.2 c0,16.7,8.5,31.5,21.5,40.1c-7.9-0.2-15.3-2.4-21.8-6c0,0.2,0,0.4,0,0.6c0,23.4,16.6,42.8,38.7,47.3c-4,1.1-8.3,1.7-12.7,1.7 c-3.1,0-6.1-0.3-9.1-0.9c6.1,19.2,23.9,33.1,45,33.5c-16.5,12.9-37.3,20.6-59.9,20.6c-3.9,0-7.7-0.2-11.5-0.7 C110.8,297.5,136.2,305.5,163.4,305.5"/></g></svg></a>
              <a href="https://www.facebook.com/OReilly/" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>facebook-logo</title><path class="cls-1" d="M16.13,0A16.13,16.13,0,1,0,32.25,16.12,16.13,16.13,0,0,0,16.13,0Zm5.12,9.54H19.57a1.52,1.52,0,0,0-1.51,1.51v1.14h3.19v3.42H18.06V26.12H13.57V15.61H10.69V12.19h2.88v-2a4,4,0,0,1,4-4h3.65Z"/></svg></a>
              <a href="https://www.linkedin.com/company/oreilly-media" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>linkedin-logo</title><path class="cls-1" d="M17.43,13.53v0l0,0ZM16.12,0A16.13,16.13,0,1,0,32.25,16.12,16.12,16.12,0,0,0,16.12,0ZM11.77,22.92H8.12v-11h3.65ZM9.94,10.44h0a1.89,1.89,0,0,1-2-1.89A1.91,1.91,0,0,1,10,6.65a1.9,1.9,0,1,1,0,3.79Zm15,12.48H21.28V17.05c0-1.48-.53-2.49-1.85-2.49a2,2,0,0,0-1.88,1.34,2.63,2.63,0,0,0-.12.89v6.13H13.79s.05-10,0-11h3.64V13.5a3.63,3.63,0,0,1,3.29-1.82c2.4,0,4.21,1.57,4.21,4.95Z"/></svg></a>
              <a href="https://www.youtube.com/user/OreillyMedia" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>youtube-logo</title><path class="cls-1" d="M18.35,18.68a.89.89,0,0,0-.86.63V16.94h-1v7.59h1v-.59a.92.92,0,0,0,.89.74c.52,0,.86-.36,1-1.07a8.56,8.56,0,0,0,.14-1.9,10.47,10.47,0,0,0-.12-1.93C19.21,19.05,18.87,18.68,18.35,18.68Zm.09,4.14c-.05.52-.2.77-.45.77s-.43-.21-.49-.63a7.22,7.22,0,0,1,0-1c0-.72,0-1.14,0-1.26.07-.58.23-.88.51-.88s.4.27.46.79c0,.09,0,.47,0,1.13S18.46,22.71,18.44,22.82ZM8.61,18.19H9.86v6.34H11V18.19H12.2V16.94H8.61Zm7.71-6.12c.27,0,.43-.22.49-.66,0-.09,0-.45,0-1.07V9.78c0-.58,0-.93,0-1-.07-.43-.23-.65-.48-.65s-.41.19-.48.57a8.79,8.79,0,0,0,0,1v.53c0,.71,0,1.09,0,1.16C15.88,11.82,16.05,12.07,16.32,12.07Zm-1.74,10.4a2.92,2.92,0,0,1-.06.71c-.07.25-.2.37-.4.37s-.32-.11-.38-.34a2.63,2.63,0,0,1-.05-.66V18.83h-1v4.48c0,.91.33,1.37,1,1.37A1,1,0,0,0,14.6,24v.57h1v-5.7h-1Zm7.1-3.79a1.35,1.35,0,0,0-1.22.59,2.48,2.48,0,0,0-.3,1.07c0,.23,0,.61,0,1.16s0,1.13,0,1.37a2.93,2.93,0,0,0,.35,1.27,1.25,1.25,0,0,0,1.14.54,1.36,1.36,0,0,0,1.13-.45,2.29,2.29,0,0,0,.37-1.43s0-.07,0-.11v-.12h-1c0,.75-.17,1.12-.51,1.12s-.38-.18-.45-.56a4.68,4.68,0,0,1-.06-.9c0-.18,0-.31,0-.37h2v-.43a4.86,4.86,0,0,0-.3-2.11A1.28,1.28,0,0,0,21.68,18.68ZM22.15,21h-1c0-.05,0-.11,0-.16v-.08a1.64,1.64,0,0,1,.11-.8.39.39,0,0,1,.38-.23.42.42,0,0,1,.43.33,2.32,2.32,0,0,1,.07.7Zm-6-21A16.13,16.13,0,1,0,32.25,16.12,16.12,16.12,0,0,0,16.12,0Zm2.51,7.2h1V11a2.52,2.52,0,0,0,.06.66c.06.23.18.34.38.34s.34-.12.41-.37a3.76,3.76,0,0,0,.05-.71V7.2h1v5.74h-1v-.57a1,1,0,0,1-.93.72c-.66,0-1-.46-1-1.38ZM15,8a1.29,1.29,0,0,1,1.33-.92A1.3,1.3,0,0,1,17.65,8a6.77,6.77,0,0,1,.23,2.1,6.77,6.77,0,0,1-.23,2.1,1.3,1.3,0,0,1-1.32.92A1.29,1.29,0,0,1,15,12.17a6.77,6.77,0,0,1-.23-2.1A6.86,6.86,0,0,1,15,8ZM11.45,5.3l.89,2.87.88-2.87H14.4L12.88,9.7v3.24h-1.1V9.7L10.24,5.3ZM24.93,23.91a3,3,0,0,1-3,3h-12a3,3,0,0,1-3-3V18.05a3,3,0,0,1,3-3h12a3,3,0,0,1,3,3Z"/></svg></a>
              <a href="https://www.oreilly.com/emails/newsletters/" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.33 32.33"><defs><style>.cls-1{fill:#E00;}.cls-2{fill:#f0f1f1;}</style></defs><title>email-logo</title><circle class="cls-1" cx="16.17" cy="16.17" r="16.17"/><path class="cls-2" d="M6.66,13.32l.2.14c2.2,1.5,4.41,3,6.74,4.29.6.34,1.22.62,1.84.92a1.72,1.72,0,0,0,1.44,0,21,21,0,0,0,2.71-1.4c2-1.21,4-2.53,5.91-3.87l.18-.12v.21c0,2.77,0,5.54,0,8.31A1.51,1.51,0,0,1,24,23.33c-5.24,0-10.48,0-15.72,0a1.57,1.57,0,0,1-1.62-1.08,1.23,1.23,0,0,1,0-.19V13.47A.86.86,0,0,1,6.66,13.32Z"/><path class="cls-2" d="M16.15,9h7.9a1.5,1.5,0,0,1,1.56,1,4.81,4.81,0,0,1,.06,1.07s0,.08-.08.1a77.16,77.16,0,0,1-7.49,4.9c-.42.24-.87.43-1.31.63a1.41,1.41,0,0,1-1.28,0c-.65-.33-1.32-.64-1.95-1-2.37-1.4-4.59-3-6.81-4.55a.35.35,0,0,1-.1-.2c0-.2,0-.4,0-.6A1.45,1.45,0,0,1,8.05,9h8.1Z"/></svg></a>
            </div>
          </div>
        </div>

        <div class="footer-download" id="download-info">
          <h2 class="footer-header">Download the O’Reilly App</h2>

          <div class="footer-downloadLinks">
            <a href="https://itunes.apple.com/us/app/safari-to-go/id881697395"><img src="https://cdn.oreillystatic.com/oreilly/images/app-store-logo.png" alt="Apple app store" /></a>
            <a href="https://play.google.com/store/apps/details?id=com.safariflow.queue"><img src="https://cdn.oreillystatic.com/oreilly/images/google-play-logo.png"  alt="Google play store" /></a>
          </div>

          <p>Take O’Reilly online learning with you and learn anywhere, anytime on your phone or tablet. Download the app <span class="nowrap">today and:</span></p>
          <ul>
            <li>Get unlimited access to books, videos, and <span class="nowrap">live training</span></li>
            <li>Never lose your place—all your devices are synced</li>
            <li>Learn during your commute with online and <span class="nowrap">offline access</span></li>
          </ul>
        </div>
      </div>

      <div class="footer-subfooter">

        <a href="https://www.oreilly.com" title="home page" aria-current="page">
          <img 
          class="footer-subfooterLogo" 
          id="footer-subfooterLogo"
          src="https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red.svg" 
          onerror="this.src='https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red_@2x.png'; this.onerror=null;" 
          alt="O'Reilly home">
        </a>

        <p>&copy; 2020, O&rsquo;Reilly Media, Inc.  All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p>
        <p><a href="https://www.oreilly.com/terms/">Terms of Service</a> • <a href="https://www.oreilly.com/privacy.html">Privacy Policy</a> • <a href="https://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a></p>
      </div>

    </div>
  </footer>

  <!-- <script src="https://cdn.oreillystatic.com/ajax/libs/jquery/3.3.1/jquery.min.js"></script> -->


  <script>
  (function($) {
    //Toggle isActive and mobileHidden classes for mobileNavButton
    $('nav #mobileNavButton').on('click', function() {
      var expanded = $(this).attr('aria-expanded') === 'true' || false;
      $(this).attr('aria-expanded', !expanded);
      $(this).toggleClass("isActive");
      $(this).next().toggleClass("mobileHidden");
    });

    //Toggle isFocused class for keyboard navigation of submenus
    $('nav #menuList .menuList-subItem a').each(function(navItem) {
      $(this).on('focus', function() {
        $(this).parent().parent().toggleClass('isFocused');
      });
      $(this).on('blur', function() {
        $(this).parent().parent().toggleClass('isFocused');
      });
    });


    //Toggle mobileHidden class accordian elements
    $('.mobileAccordian').each(function() {
      var $btn = $(this).find('button');
      var $target =  $(this).next();
      $btn.on('click', function() {
        var expanded = $btn.attr('aria-expanded') === 'true' || false;

        $btn.attr('aria-expanded', !expanded);
        $target.toggleClass("mobileHidden");  
      });
    });

    // truncate months in footer conf listings
    var months = $('.confMonth');
    months.each(function(){    
      var m = $(this).text();        
      if(m.length < 3 ) return;
      $(this).html(m.slice(0,3));
    });
  })(jQuery);
  </script>

  		<style type="text/css">
			.ssp-wave wave wave {
				background: #00d4f7 !important;
			}
		</style>
		<script type='text/javascript' src='https://www.oreilly.com/radar/wp-content/plugins/seriously-simple-podcasting/assets/js/media.player.js?ver=1.20.10'></script>
<script type='text/javascript' src='https://www.oreilly.com/radar/wp-content/plugins/seriously-simple-podcasting/assets/js/html5.player.js?ver=1.20.10'></script>
<script type='text/javascript' src='https://www.oreilly.com/radar/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>

  <script type="text/javascript" id="MathJax-script">

    var math = document.getElementsByClassName('math-tex');
    if (math.length > 0) includeMathJax();
    function includeMathJax() {
      var head = document.getElementsByTagName('head')[0];
      var script = document.createElement('script');
      script.src = "https://cdn.jsdelivr.net/npm/mathjax@3/es5/tex-mml-chtml.js";
      script.type = 'text/javascript';
      script.async = 'async';
      head.appendChild(script)
    }   
  </script>
  </body>
</html>
