<!DOCTYPE html>
<html lang="en-US">
  <head>

    <meta charset="UTF-8">

    <title>
      5 key areas for tech leaders to watch in 2020 – O’Reilly     </title>

    <link rel="stylesheet" href="https://www.oreilly.com/radar/wp-content/themes/odot/style.css">

    
    <link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.oreilly.com\/radar\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.oreilly.com/radar/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='mo_saml_admin_settings_style-css'  href='https://www.oreilly.com/radar/wp-content/plugins/miniorange-saml-20-single-sign-on/includes/css/jquery.ui.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='ssp-frontend-player-css'  href='https://www.oreilly.com/radar/wp-content/plugins/seriously-simple-podcasting/assets/css/player.css?ver=1.20.10' type='text/css' media='all' />
<script type='text/javascript' src='https://www.oreilly.com/radar/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.oreilly.com/radar/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.oreilly.com/radar/wp-content/plugins/miniorange-saml-20-single-sign-on/includes/js/settings.js?ver=5.3.2'></script>
<link rel="canonical" href="https://www.oreilly.com/radar/oreilly-2020-platform-analysis/" />
<link rel='shortlink' href='https://www.oreilly.com/radar/?p=11698' />

<link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.oreilly.com/radar/feed/podcast" />


<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="language_name" content="English">
<meta name="native_language_name" content="English">
<meta name="format-detection" content="telephone=no">

<link rel="icon" type="image/png" href="//www.oreilly.com/favicon.ico">

<!--[if lte IE 9]>
<script>
  'article aside footer header main nav section time'.replace(/\w+/g,function(n){document.createElement(n)})
</script>
<![endif]-->

<!--[if IE 9]>
<style type="text/css">
  #menu-toggle:checked ~ .mobile-nav { display:block; }
  .mobile-nav { display: none; }
</style>
<![endif]-->

<meta property="twitter:card" content="summary_large_image" />
<meta property="twitter:site" content="@OReillyMedia" />
<meta property="twitter:title" content="5 key areas for tech leaders to watch in 2020" />
<meta property="twitter:description" content="Our annual analysis of the O’Reilly online learning platform reveals Python’s continued dominance and important shifts in infrastructure, AI/ML, cloud, and security." />
<meta property="twitter:url" content="https://www.oreilly.com/radar/oreilly-2020-platform-analysis" />
<meta property="twitter:image" content="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/fotf-geo-data-4a-1400x950-1.jpg" />
<meta property="og:type" content="article" />
<meta property="og:site_name" content="O’Reilly Media" />
<meta property="og:title" content="5 key areas for tech leaders to watch in 2020" />
<meta property="og:description" content="Our annual analysis of the O’Reilly online learning platform reveals Python’s continued dominance and important shifts in infrastructure, AI/ML, cloud, and security." />
<meta property="og:url" content="https://www.oreilly.com/radar/oreilly-2020-platform-analysis/" />
<meta property="og:image" content="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/fotf-geo-data-4a-1400x950-1.jpg" />
<meta name="description" content="Our annual analysis of the O’Reilly online learning platform reveals Python’s continued dominance and important shifts in infrastructure, AI/ML, cloud, and security." />
<meta name="author" content="Roger Magoulas, Steve Swoyer" />
<meta name="description:site" content="Our annual analysis of the O’Reilly online learning platform reveals Python’s continued dominance and important shifts in infrastructure, AI/ML, cloud, and security." />
<meta property="article:published_time" content="2020-02-18T06:00:00-05:00" />
<meta name="article:author" content="Roger Magoulas, Steve Swoyer" />
<meta name="date" content="2020-02-18" />
<meta name="thumbnail" content="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/fotf-geo-data-4a-1400x950-1.jpg" />
<meta name="graphic_medium" content="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/fotf-geo-data-4a-1400x950-1.jpg" />
<meta name="oreilly:content_type" content="text" />

<script>
  loggedInObject = new Object();
  var dataLayer = window.dataLayer || [];

  //Check for O'Reilly Unified logged-in status
  if (document.cookie.split(';').filter(function(item) {
    return item.indexOf('orm-jwt=') >= 0;
  }).length) {
    loggedInObject.loggedIn = 'yes';
    dataLayer.push(loggedInObject);
  }
</script>


  <script>
    dataLayer = [{"content.author":"Roger Magoulas, Steve Swoyer","content.formatType":"article","content.free":"yes","content.identifier":"none","content.parentTopic":"AI & ML","content.publisher":"O'Reilly Media Inc.","content.releaseDate":"2020-02-18","content.subTopic":"none","content.subdirectory":"radar","content.title":"5 key areas for tech leaders to watch in 2020","product.identifier":"none","product.title":"none","product.type":"none"}];
  </script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5P4V6Z');</script>
<!-- End Google Tag Manager -->


<!-- Start Visual Website Optimizer Asynchronous Code -->
<script type='text/javascript'>
var _vwo_code=(function(){
var account_id=27087,
settings_tolerance=2000,
library_tolerance=2500,
use_existing_jquery=false,
// DO NOT EDIT BELOW THIS LINE
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
</script>
<!-- End Visual Website Optimizer Asynchronous Code -->


</head>
<body class="post-template-default single single-post postid-11698 single-format-standard multisite-radar">

<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5P4V6Z" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

<div class="skipToMain" id="skipToMain"><a href="#maincontent"><span class="skipToMain-text">Skip to main content</span></a></div>

<header role="banner">
  <nav role="navigation" aria-label="site sections">
    <a href="https://www.oreilly.com/" class="logo" title="home page"><img src="https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red.svg" onerror="this.src='https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red_@2x.png'; this.onerror=null;" alt="O'Reilly home"></a>

    <button id="mobileNavButton" class="mobileNavButton mobileNavButton--collapse mobileNavButton--3dx" type="button" aria-expanded="false" aria-controls="menuList">
      <span class="mobileNavButton-box">
        <span class="mobileNavButton-inner"></span>
      </span>
    </button>

    <ul id="menuList" class="menuList mobileHidden">
      <li class="menuList-itemsP1">
        <ul>
          <li class="menuList-item menuList-signIn"><a href="https://oreilly.com/sign-in.html">Sign In</a></li>
          <li class="menuList-item menuList-tryNow"><a class="menuList-cta" href="https://oreilly.com/online-learning/try-now.html">Try Now</a></li>
        </ul>
      </li>
      <li class="menuList-itemsP2">
        <ul>
          <li class="menuList-item menuList-itemWithSub"><a href="https://oreilly.com/online-learning/index.html">Online Learning</a>
            <ul class="menuList-subList">
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/individuals.html">Individuals</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/teams.html">Teams</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/enterprise.html">Enterprise</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/government.html">Government</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/academic.html">Academic</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/features.html">Features</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/custom-services.html">Custom Services</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/pricing.html">Pricing</a></li>
            </ul>
          </li>
          <li class="menuList-item menuList-itemWithSub"><a href="https://www.oreilly.com/conferences/">Conferences</a>
            <ul class="menuList-subList menuList-subList-conferences">
              <li class="menuList-subItem"><a href="https://conferences.oreilly.com/infrastructure-ops/io-ca">Infrastructure &amp; Ops Conference</a></li>
              <li class="menuList-subItem"><a href="https://conferences.oreilly.com/oscon">Open Source Software Conference</a></li>
              <li class="menuList-subItem"><a href="https://conferences.oreilly.com/software-architecture">Software Architecture Conference</a></li>
              <li class="menuList-subItem"><a href="https://conferences.oreilly.com/strata-data-ai">Strata Data &amp; AI Conference</a></li>
              <li class="menuList-subItem"><a href="https://conferences.oreilly.com/tensorflow">TensorFlow World</a></li>
              <li class="menuList-subItem"><a href="https://conferences.oreilly.com/velocity">Velocity Conference</a></li>
            </ul>
          </li>
          <li class="menuList-item menuList-itemWithSub"><a href="https://www.oreilly.com/radar/" aria-current="page"  >Radar</a>
          <!-- v2 -->
            <ul class="menuList-subList">
              <li class="menuList-subItem"><a href="https://www.oreilly.com/radar/topics/ai-ml/">AI/ML</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/radar/topics/future-of-the-firm/">Future of the Firm</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/radar/topics/innovation-and-disruption/" class="nowrap">Innovation &amp; Disruption</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/radar/topics/next-architecture/">Next Architecture</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/radar/topics/next-economy/">Next Economy</a></li>
              <li class="menuList-subItem"><a href="https://www.oreilly.com/radar/posts/">All Articles</a></li>
            </ul>
          </li>
          <li class="menuList-item"><a href="https://www.oreilly.com/about/approach.html">Our Approach</a></li>
        </ul>
      </li>
    </ul>
  </nav>

  <!-- <div class="head-search-bar">

    <div class="content">
      <p>This is where the search bar goes</p>
    </div>
  </div> -->

</header>

<main role="main" id="maincontent">
      <section class="hero hero-wp">
      <div class="content">
        <div class="hero-textWrap">
          <div class="hero-breadcrumbs">
            <a href="https://www.oreilly.com/radar">Radar</a> / <a href="https://www.oreilly.com/radar/topics/ai-ml/">AI & ML</a>          </div>
          <h1 class="radar-post-page-head">5 key areas for tech leaders to watch in 2020</h1>
                      <div class="radar-post-page-subhead">
              <p>Our annual analysis of the O’Reilly online learning platform reveals Python’s continued dominance and important shifts in infrastructure, AI/ML, cloud, and security.</p>
            </div>
          	      </div>
      </div>
    </section>


    <section class="textSection post-radar">
      <div class="content">

                              <div class="radar-post-page-meta">
              <span class="radar-post-page-author">
                By <a href="https://www.oreilly.com/people/roger-magoulas/">Roger Magoulas</a> and <a href="https://www.oreilly.com/people/steve-swoyer/">Steve Swoyer</a>              </span>
            </div>
          
          <div class="radar-post-page-meta">
            <span class="radar-post-page-date">
              February 18, 2020            </span>
          </div>
        
        <div class="radar-post-flex-wrap">

          <div class="right-rail" id="right-rail">
            
              <div id="post-featured-image" class="post-featured-image">
                <img width="1400" height="950" src="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/fotf-geo-data-4a-1400x950-1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Platform analysis report" srcset="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/fotf-geo-data-4a-1400x950-1.jpg 1400w, https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/fotf-geo-data-4a-1400x950-1-300x204.jpg 300w, https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/fotf-geo-data-4a-1400x950-1-1048x711.jpg 1048w, https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/fotf-geo-data-4a-1400x950-1-768x521.jpg 768w" sizes="(max-width: 1400px) 100vw, 1400px" />
                                  <span class="post-featured-image-caption">
                                      </span>
                                </div>

                        </div>

          <div class="post-radar-content" id="post-radar-content">

            <div class="main-post-radar-content">

              
              
              
              
              
              <p id="F1"><a href="https://www.oreilly.com/online-learning/">O’Reilly online learning</a> contains information about the trends, topics, and issues tech leaders need to watch and explore. It’s also the data source for our annual usage study, which examines the most-used topics and the top search terms.<a href="#_ftn1"><sup>[1]</sup></a></p>
<p>This combination of usage and search affords a contextual view that encompasses not only the tools, techniques, and technologies that members are actively using, but also the areas they’re gathering information about.</p><div class="7O7JZFfg"><div itemscope="" itemtype="http://schema.org/Product" class="inline-cta trial-cta" id="trial-cta">
  <div class="thumb">
    <a href="https://www.oreilly.com/online-learning/">
      <img itemprop="image" src="https://d3ansictanv2wj.cloudfront.net/safari-topic-cta-1f60e6f96856da19ba3cb25660472ca5.jpg" class="">
    </a>
  </div>
  <div class="title">
    <h2>
      Learn faster. Dig deeper. See farther.
    </h2>
  </div>
   <div class="meta">
    <p class="dek">Join the O'Reilly online learning platform. Get a free trial today and find answers on the fly, or master something new and useful.</p>
    <a href="https://www.oreilly.com/online-learning/" class="textCTA-small more">Learn more</a>
  </div>
</div></div>
<p>Current signals from usage on the O’Reilly online learning platform reveal:</p>
<ul>
<li><strong>Python is preeminent</strong>. It’s the single most popular programming language on O’Reilly, and it accounts for 10% of <em>all</em> usage. This year’s growth in Python usage was buoyed by its increasing popularity among data scientists and machine learning (ML) and artificial intelligence (AI) engineers.</li>
<li><strong>Software architecture, infrastructure, and operations are each changing rapidly</strong>. The shift to cloud native design is transforming both software architecture and infrastructure and operations. Also: <a href="https://conferences.oreilly.com/infrastructure-ops">infrastructure and operations</a> is trending up, while DevOps is trending down. Coincidence? Probably not, but only time will tell.</li>
<li><strong>ML + AI are up, but passions have cooled</strong>. Up until 2017, the ML+AI topic had been amongst the fastest growing topics on the platform. Growth is still strong for such a large topic, but usage slowed in 2018 (+13%) and cooled significantly in 2019, growing by just 7%. Within the data topic, however, ML+AI has gone from 22% of all usage to 26%.</li>
<li><strong>Still cloud-y, but with a possibility of migration</strong>. Strong usage in cloud platforms (+16%) accounted for most cloud-specific growth. But sustained interest in cloud migrations—usage was up almost 10% in 2019, on top of 30% in 2018—gets at another important emerging trend.</li>
<li><strong>Security is surging.</strong> Aggregate security usage spiked 26% last year, driven by increased usage for two security certifications: CompTIA Security (+50%) and CompTIA CySA+ (+59%). There’s plenty of security risks for business executives, sysadmins, DBAs, developers, etc., to be wary of.</li>
</ul>
<figure class="center"><img src="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/1-top-search-terms.png" alt="Normalized search frequency of top terms on the O’Reilly online learning platform in 2019 (left) and the rate of change for each term (right)."><figcaption>Figure 1 (above). Normalized search frequency of top terms on the O’Reilly online learning platform in 2019 (left) and the rate of change for each term (right).</figcaption></figure>
<figure class="center"><img src="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/2-high-level-topic-usage-e1581084720697.png" alt="High-level topics on the O’Reilly online learning platform with the most usage in 2019 (left) and the rate of change for each topic (right)."><figcaption>Figure 2. High-level topics on the O’Reilly online learning platform with the most usage in 2019 (left) and the rate of change for each topic (right).</figcaption></figure>
<h2>In programming, Python is preeminent</h2>
<p>In 2019, as in 2018, Python was the most popular language on O’Reilly online learning. Python-related usage grew at a solid 6% pace in 2019, a slight drop from 2018 (+10%). After several years of steady climbing—and after outstripping Java in 2017—Python-related interactions now comprise almost 10% of all usage.</p>
<p>But Python is a special case: this year, more than in year’s past, its growth was buoyed by interest in ML. Usage specific to Python as a programming language grew by just 4% in 2019; by contrast, usage that had to do with Python and ML—be it in the context of AI, deep learning, and natural language processing, or in combination with any of several popular ML/AI frameworks—grew by 9%. The laggard use case was Python-based web development frameworks, which grew by just 3% in usage, year over year.</p>
<figure class="center"><img src="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/3-top-languages-search.png" alt="Normalized search frequency of top programming languages on the O’Reilly online learning platform in 2019 (left) and the rate of change for each language (right)."><figcaption>Figure 3 (above). Normalized search frequency of top programming languages on the O’Reilly online learning platform in 2019 (left) and the rate of change for each language (right).</figcaption></figure>
<figure class="center"><img src="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/4-top-languages-usage.png" alt="Programming languages on the O’Reilly online learning platform with the most usage in 2019 (left) and the rate of change for each language (right)."><figcaption>Figure 4. Programming languages on the O’Reilly online learning platform with the most usage in 2019 (left) and the rate of change for each language (right).</figcaption></figure>
<p>This is consistent with <a href="https://www.oreilly.com/radar/whats-driving-open-source-software-in-2019/">what we’ve observed elsewhere</a>: Python has acquired new relevance amid strong interest in AI and ML. Along with <a href="https://en.wikipedia.org/wiki/R_(programming_language)">R</a>, Python is one of the most-used languages for data analysis. From pre-built libraries for linear or logistic regressions, decision trees, naïve Bayes, k-means, gradient-boosting, etc., there’s a Python library for virtually anything a developer or data scientist might need to do. (Python libraries are no less useful for manipulating or engineering data, too.)</p>
<p>Interestingly, <a href="https://trends.google.com/trends/explore?date=all&amp;geo=US&amp;q=%2Fm%2F0212jm">R itself continues to decline</a>. R-related usage on O’Reilly online learning fell by 8% between 2017-18 and by 6%, year-over-year, in 2019. It’s likely that R—much like Scala (-33% in usage in 2018-19; -19% in usage 2017-18)—is a casualty of Python. True, it might seem difficult to reconcile R’s decline with strong interest in AI and ML, but consider two factors: first, ML and statistics are not the same thing, and, second, R is not, primarily, a developer-oriented language. R was designed for use in academic, scientific, and, more recently, commercial use cases. As statistics and related techniques become more important in software development, more programmers are encountering stats in programming classes. In this context, they’re more likely to use Python than R.</p>
<p>Interest in some languages seems to be trending up, and interest in others, down. Exhibit A: Java-related usage dropped by a noteworthy 13% between 2018 and 2019. Is this the harbinger of a trend? Not necessarily: Java-related searches increased by 5% between 2017 and 2018. On the other hand, Java’s cousin, JavaScript, also appears to be in decline. True, theirs is only a conceptual relation, but interest in JavaScript, too, <a href="https://trends.google.com/trends/explore?date=all&amp;geo=US&amp;q=%2Fm%2F02p97">really does seem to be waning</a>: JS-related usage dropped on O’Reilly online learning by 4% between 2017-2018 and by 7% between 2018-19. It’s possible that microservices architecture is hastening the move to other languages (such as Go, Rust, and Python) for web properties.</p>
<p>Among the JavaScript-based web application frameworks, React gained in popularity (+4% in usage) as Angular (-12% in usage) slipped between 2018 and 2019. Vue.js—a competitor to both React and Angular—settled down to steady growth (+8% in usage) in 2018-19, after almost doubling in usage (+97%) between 2017-18.</p>
<p id="F2">One possible trend-in-the-making is that of a slowing Go, which—following several years of rapid growth in usage (including +14% from 2017 to 2018)—cooled down last year, with usage growing by a mere 2%. But Go is now the sixth most-used programming language, trailing only Python, Java, .NET, and C++. Drop .NET from the tally on methodological grounds<a href="#_ftn2"><sup>[2]</sup></a>, and Go cracks the top five.</p>
<h2>Trends in software architecture, infrastructure, and operations</h2>
<p><a href="https://www.oreilly.com/radar/how-companies-adopt-and-apply-cloud-native-infrastructure/">Cloud native</a><a href="https://www.oreilly.com/radar/how-companies-adopt-and-apply-cloud-native-infrastructure/"> design</a> is a new way of thinking about software and architecture. But the shift to cloud native has implications not only for <a href="https://www.oreilly.com/radar/the-topics-to-watch-in-software-architecture/">software architecture</a><u>,</u> but for <a href="https://conferences.oreilly.com/infrastructure-ops/io-ca">infrastructure and operations</a>, too. It exploits new design patterns (microservices) and adapts existing techniques (service orchestration) with the goal of achieving cloud-like elasticity and resilience in <em>all</em> environments, cloud or on-premises. O’Reilly Radar uses the term “<a href="https://www.oreilly.com/radar/what-is-next-architecture/">Next Architecture</a><u>”</u> to describe this shift.</p>
<p>It’s against this backdrop that what’s happening in both software architecture and infrastructure and ops must be understood. In the generic software architecture topic, usage in the containers topic increased in our 2019 analysis, growing by 17%. This was just a fraction of its 2018 growth rate (+56% in usage), but impressive nonetheless. Kubernetes has emerged as the <em>de facto</em> solution for orchestrating services and microservices in cloud native design patterns. Usage in Kubernetes surged by 211% in 2018—and grew at a 40% clip in 2019. Kubernetes’ parent topic, container orchestrators, also posted strong usage growth: 151% in 2018, 36% this year—almost all due to interest in Kubernetes itself.</p>
<figure class="center"><img src="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/5-software-architecture-usage-e1581084431270.png" alt="Software architecture topics on the O’Reilly online learning platform with the most usage in 2019 (left) and the rate of change for each topic (right)."><figcaption>Figure 5. Software architecture topics on the O’Reilly online learning platform with the most usage in 2019 (left) and the rate of change for each topic (right).</figcaption></figure>
<p>This also helps explain increased usage in the microservices topic, which grew at a 22% clip in 2019. True, you don’t necessarily <em>need</em> microservices to “do” cloud native design; at this point, however, it’s difficult to disentangle the two. Most cloud native design patterns involve microservices.</p>
<p>These trends are also implicated in the rise of infrastructure and ops, which reflects both the limitations of DevOps and the challenges posed by the shift to cloud native design. Infrastructure and ops usage was the fastest growing sub-topic under the generic systems administration topic. Surging interest in infrastructure and ops also explains declining usage in the configuration management (CM) and DevOps topic areas. The most popular CM tools are DevOps focused, and, like DevOps itself, they’re declining: usage in the CM topic dropped significantly (-18%) in 2019, as did virtually all CM tools. Ansible was least affected (-4% in usage), but Jenkins, Puppet, Chef, and Salt each dropped off by 25% or more in usage. It can’t be a coincidence that DevOps usage declined again (-5%) in 2019, following a 20% decline in 2018.</p>
<figure class="center"><img src="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/6-infrastructure-ops-usage-e1581084489821.png" alt="Infrastructure and operations topics on the O’Reilly online learning platform with the most usage in 2019 (left) and the rate of change for each topic (right)."><figcaption>Figure 6. Infrastructure and operations topics on the O’Reilly online learning platform with the most usage in 2019 (left) and the rate of change for each topic (right).</figcaption></figure>
<p>The emergence of infrastructure and ops suggests that organizations might be having trouble <em>scaling</em> DevOps. DevOps aims to produce programmers who can work competently in each of the layers in a system “<a href="https://www.facebook.com/note.php?note_id=461505383919">stack</a>.” In practice, however, developers tend to be less committed to DevOps’ operations component, a fact that gave birth to the idea of <a href="https://en.wikipedia.org/wiki/Site_Reliability_Engineering">site reliability engineering</a> (SRE). Even if the “full stack” developer isn’t a unicorn, she certainly isn’t commonplace. Organizations see infrastructure and ops as a pragmatic, ops-focused complement that picks up precisely where DevOps tends to fail.</p>
<h2>A drill-down into data, AI, and ML topics</h2>
<p>The results for data-related topics are both predictable and—there’s no other way to put it—confusing. Starting with data engineering, the backbone of all data work (the category includes titles covering data management, i.e., relational databases, Spark, Hadoop, SQL, NoSQL, etc.). In aggregate, data engineering usage declined 8% in 2019. This follows a 3% drop in 2018. Both years were driven by declining usage of data management titles.</p>
<p>When we look more specifically at data engineering topics, <em>excluding</em> data management, we see a small share, but solid growth in usage, up 7% in 2018 and 15% in 2019 (see Figure 7).</p>
<p>Within the broad “data” topic, data engineering (including data management) continues as the topic with the most share, garnering about one-twelfth of all usage on the platform. This is almost double the usage share of the data science topic, which recorded an uptick in usage (+5%) in 2019, following a decline (-2%) in 2018.</p>
<p>Elsewhere, interest in ML and AI keeps growing, albeit at a diminished rate. To wit: the combined ML/AI topic was up 7% in usage in 2019, about half its growth (+13%) in 2018.</p>
<figure class="center"><img src="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/7-data-usage-e1581084542209.png" alt="Data topics on the O’Reilly online learning platform with the most usage in 2019 (left) and the rate of change for each topic (right)."><figcaption>Figure 7. Data topics on the O’Reilly online learning platform with the most usage in 2019 (left) and the rate of change for each topic (right).</figcaption></figure>
<p>Ironically, the strength of ML/AI might be less evident in data-specific topics than in other topic areas, such as programming languages, where growing Python usage is—to a large degree—being driven by that language’s usefulness for and applicability to ML. But ML/AI-related topics such as natural language processing (NLP, +22% in 2019) and neural networks (+17%) recorded strong growth in usage, too.</p>
<p id="F3">Data engineering <em>as a task</em> certainly isn’t in decline. Interest in data engineering probably isn’t declining, either. If anything, data engineering <em>as a practice area</em> is being subsumed by both data science and ML/AI<a href="#_ftn3"><sup>[3]</sup></a>. We know from <a href="https://www.oreilly.com/radar/the-state-of-data-quality-in-2020/">other research</a> that data scientists, ML and AI engineers, etc., spend an outsized proportion of their time discovering, preparing, and engineering data for their work. We’ve seen that popular tools and frameworks usually incorporate data engineering capabilities, either in the form of automated/guided self-service features or (in the case of Jupyter and other notebooks) an ability to build and orchestrate data engineering pipelines that invoke Python, R (via Python), etc., libraries to run data engineering jobs concurrently or, if possible, in parallel.</p>
<p>Terms that correspond with old-school data engineering—e.g., “relational database,” “Oracle database solutions,” “Hive,” “database administration,” “data models,” “Spark”—declined in usage, year-over-year, in 2019. Some of this decline was a function of larger, market-driven factors. We know from our research that Hadoop and its ecosystem of related projects (such as Hive) <a href="https://www.oreilly.com/radar/topics-to-watch-at-the-strata-data-conference-in-new-york-2019/">are in the midst of a protracted, years-long decline</a>. This decline is borne out in our usage numbers: Hadoop (-34%), Hive (also -34%), and even Spark (-21%) were all down, significantly, year-over-year.</p>
<p>We discuss likely reasons for this decline in more detail <a href="https://www.oreilly.com/radar/topics-to-watch-at-the-strata-data-conference-in-new-york-2019/">in our analysis of O’Reilly Strata Conference speaker proposals</a>.</p>
<h2>Cloud continuing to climb</h2>
<p>Interest in cloud-related concepts and terms continues to increase on O’Reilly online learning, albeit at a slower rate. Cloud-related usage surged by 35% between 2017 and 2018; it grew at less than half that rate (17%) between 2018 and 2019. This slowdown suggests that cloud as a category has achieved such a large share that (mathematically) any additional growth <em>must</em> occur at a slower rate. In cloud’s case, while growth is slower, it’s still strong.</p>
<figure class="center"><img src="https://www.oreilly.com/radar/wp-content/uploads/sites/3/2020/02/8-cloud-usage-e1581084605868.png" alt="Cloud topics on the O’Reilly online learning platform with the most usage in 2019 (left) and the rate of change for each topic (right)."><figcaption>Figure 8. Cloud topics on the O’Reilly online learning platform with the most usage in 2019 (left) and the rate of change for each topic (right).</figcaption></figure>
<p>Interest in cloud service provider platforms mirrors that of the industry as a whole: Amazon and AWS-related usage increased by 14%, year-over-year; Azure usage, on the other hand, grew at a speedier 29% clip, while Google Compute Platform (GCP) surged by 39%. Amazon controls a little less than half (<a href="https://www.gartner.com/en/newsroom/press-releases/2019-07-29-gartner-says-worldwide-iaas-public-cloud-services-market-grew-31point3-percent-in-2018">per Gartner’s 2018 numbers</a>) of the overall market for cloud infrastructure-as-a-service (IaaS) offerings. It, too, has reached the point at which rapid growth becomes mathematically prohibitive. Both Azure and GCP are growing much faster than AWS, but they’re also much smaller: Azure notched nearly 61% growth in 2018 (per Gartner), good for more than 15% of the IaaS market; GCP, at around 60% growth, accounts for 4% of IaaS share.</p>
<p>Also intriguing: cloud-specific interest in microservices and <a href="https://en.wikipedia.org/wiki/Kubernetes">Kubernetes</a> grew significantly last year on O’Reilly. Microservices-related usage was up 22%, year over year, following a decline in 2018. Kubernetes usage was up by 38%, year over year, following a period of explosive growth (+190%) from 2017 to 2018. Both trends mirror what we’re seeing via user surveys and other <a href="https://www.oreilly.com/radar/tag/research/">research efforts</a>: namely, that microservices has emerged as an important component of cloud native design and development.</p>
<p>The bigger takeaway is that the essential tendency of modern software architecture—namely, the priority it gives to loose coupling in emphasizing abstraction, isolation, and atomicity—is eliding the boundaries between what we think of as “cloud” versus “on-premises” contexts. We see this via sustained interest in microservices and Kubernetes in both on-premises <em>and</em> cloud deployments.</p>
<p>This is the logic of cloud native design: specific deployment contexts will still matter, of course—which features or constraints do developers need to take into account when they’re developing for AWS? For Azure? For GCP? But the clear boundaries that used to demarcate the public cloud from the private cloud are starting to disappear, just as those that distinguish on-premises private clouds from conventional on-premises systems are falling away, too.</p>
<h2>Surging interest in security</h2>
<p>Security usage (+26%) grew significantly in 2019 (see Figure 2). Some of this was driven by increased usage in the CompTIA Security+ (50%) and CompTIA Cyber Security Analyst (CySA+, 59%) topics.</p>
<p>Security+ is an entry-level security certification, so its growth could be attributed to increased usage by sysadmins, DBAs, software developers, and other non-specialists. Whether it’s to flesh out their full-stack bona ides, address new job (or <a href="https://nvlpubs.nist.gov/nistpubs/SpecialPublications/NIST.SP.800-181.pdf?trackDocs=NIST.SP.800-181.pdf">regulatory</a>) requirements, or simply to make themselves more marketable, Security+ is a pretty straightforward certification process: pass the exam and you’re certified. CySA+, on the other hand, is relatively new. This <em>could</em> explain the explosion of CySA+-related usage in 2018 (+128%), as well as last year’s strong growth. Unlike <a href="https://en.wikipedia.org/wiki/List_of_computer_security_certifications">the CISSP and other popular certifications</a>, CySA+ recommends, but doesn’t require, real-world experience. Like Security+, it’s another certification sys admins, DBAs, developers, and others can pick up to burnish their bonafides.</p>
<p>Certifications weren’t the only thing driving security-related usage on O’Reilly in 2019. A rash of vulnerabilities and potential exploits, too, had some impact. If 2018 (+5% growth in security usage; +22% growth in search) gave us <a href="https://en.wikipedia.org/wiki/Meltdown_(security_vulnerability)">Meltdown</a> and <a href="https://en.wikipedia.org/wiki/Spectre_(security_vulnerability)">Spectre</a>, 2019 gave us sobering information about <a href="https://www.pandasecurity.com/mediacenter/security/spectre-making-comeback-processors/">the far-reaching </a><a href="https://www.pandasecurity.com/mediacenter/security/spectre-making-comeback-processors/"><em>implications</em></a><a href="https://www.pandasecurity.com/mediacenter/security/spectre-making-comeback-processors/"> of Meltdown</a> and, <a href="https://www.technologyreview.com/s/612989/chips-may-be-inherently-vulnerable-to-spectre-and-meltdown-attacks/">especially, Spectre</a>. For 2019, security-specific usage (+26%) and search (+25%) increased accordingly. System and database administrators, CSAs, CISSPs, and others were keen to acquire expert, detailed information specific to patching and hardening their vulnerable systems to protect against <a href="https://arxiv.org/pdf/1811.05441.pdf">no less than 13 different Spectre and 14 different Meltdown variants</a>, as well as to mitigate <a href="https://www.phoronix.com/scan.php?page=article&amp;item=spec-melt-8way&amp;num=1">the potentially huge performance impacts associated with these patches</a>. Developers and software architects had questions about rewriting, refactoring, or optimizing their code to address these same concerns. Against this backdrop, the spike in security-related usage makes sense.</p>
<p>There was a great deal going on with respect to information security and data privacy, too. After all, not only was 2019 the first full year for which the EU’s omnibus GDPR regime was binding, but—as of January 1, 2019—updates to Canada’s GDPR-like PIPEDA regime officially kicked in, too. The sweeping <a href="https://en.wikipedia.org/wiki/California_Consumer_Privacy_Act">California Consumer Privacy Act</a> (CCPA), which has been called California’s GDPR, went into effect on January 1, &nbsp;2020.</p>
<p>Taken together, an analysis of these trends seems to support a glass-half-full assessment of the state of security today. If the sustained growth in security usage on O’Reilly is a reliable indicator, it’s <em>possible</em> that security may, finally, be getting the attention it deserves in an increasingly digital world. It&#8217;s <em>possible</em> that organizations have accepted that the financial and reputational penalties entailed by a data breach or high-profile hack are just too costly to risk, and that money spent on information security is, on balance, money well spent.</p>
<p>The same analysis also lends itself to a glass-half-empty assessment, however: namely, that security spending is cyclical; that a confluence of circumstances has helped to boost security spending; and that—let’s be honest—<a href="https://www.varonis.com/blog/company-reputation-after-a-data-breach/">organizations tend to bounce back from high-profile security incidents</a>. Only time (or future installments of this survey) will tell.</p>
<h2>Concluding thoughts</h2>
<p>It’s hard to imagine that the hottest trends of 2019 won’t be reprising their roles, in more or less the same pecking order, in next year’s analysis. Programming languages come into and go out of vogue, but Python appears poised to keep growing at a steady rate because it’s at once protean, adaptable, and easy to use. We see this in the widespread use of Python in ML and AI, where it has supplanted R as the <em>lingua franca</em> of data engineering and analysis.</p>
<p>The same is true of ML and AI. Even if (as some naysayers warn) the next <a href="https://en.wikipedia.org/wiki/AI_winter">AI winter</a> <a href="https://www.ft.com/content/47111fce-d0a4-11e8-9a3c-5d5eac8f1ab4">is nigh upon us</a>, it’s hard to imagine interest in ML and AI petering out anytime soon. The same could be said about trends in software architecture and, especially, infrastructure and operations. They’re each sites of ceaseless innovation. Their practitioners will be hard-pressed to keep up with what’s happening.</p>
<p>It’s helpful to think of what’s hot and what’s not in terms of a modified “<a href="https://en.wikipedia.org/wiki/Overton_window">Overton Window</a>.” The Overton Window circumscribes the <em>human cognitive bandwidth</em> that’s available in a certain place at a certain time. No combination of policies—or issues, or trends—can exceed more than 100% of available bandwidth. This is true, to a degree, of the activity on O’Reilly online learning, too. A decline in usage doesn’t have to correlate with a decline in use (or usefulness) in practice. It’s just being crowded out by other, emergent trends.</p>
<p>This also underscores why the decline in a bellwether topic such as JavaScript might be hugely significant. Even if these topics are no longer sites of rapid and sustained innovation, they are likewise important for day-to-day use cases, especially with respect to general-purpose information-gathering or more specialized problem solving. It isn’t that JavaScript is less important than it used to be; after all, React, Angular, and Vue.js are sites of development and innovation, and all three are based on JavaScript. It’s that we’re coming to understand and relate to JavaScript—or data engineering, or Docker, or DevOps and change management—in a different way. We’re appropriating them differently.</p>
<p>It’s this difference that Radar aims to capture. Not the change that’s obvious for everyone to see, but the coalescence of change itself as it’s happening.</p>
<hr>
<aside data-type="sidebar">
<p id="_ftn1"><a href="#F1"><sup>[1]</sup></a> This article is based on non-personally-identifiable information about the top search terms and most-used topics on O’Reilly online learning. We compared aggregated data for the last three years; a full year of data for 2017 and 2018, and through the end of October for 2019.</p>
<p id="_ftn2"><a href="#F2"><sup>[2]</sup></a> A reasonable enough decision. .NET isn’t so much a language as a software framework: i.e., a superset of C# and a few related languages, including Visual Basic .NET, J#, and, C++/CLI, the latter of which is a .NET-specific implementation of C++.</p>
<p id="_ftn3"><a href="#F3"><sup>[3]</sup></a> ML and AI aren’t in any sense the same thing, either. We combine them here for simplicity’s sake.</p>
</aside>
</p>
                          </div>

                        
            <div class="post-radar-end">

              
                              <div class="radar-post-page-meta" >
      Post topics: <a href="https://www.oreilly.com/radar/topics/ai-ml/" title="AI &amp; ML">AI &amp; ML</a>, <a href="https://www.oreilly.com/radar/topics/innovation-and-disruption/" title="Innovation &amp; Disruption">Innovation &amp; Disruption</a>, <a href="https://www.oreilly.com/radar/topics/next-architecture/" title="Next Architecture">Next Architecture</a></div>              
                              <div class="radar-post-page-meta" >
      Post tags: <a href="https://www.oreilly.com/radar/tag/platform-analysis/" title="Platform Analysis">Platform Analysis</a>, <a href="https://www.oreilly.com/radar/tag/research/" title="Research">Research</a></div>              
              <div class="radar-post-page-meta radar-post-page-meta-share">
                Share:
                <ul>
                  <li>
                    <a data-via="oreillymedia" class="twitter-share-button" href="https://twitter.com/intent/tweet?text=5 key areas for tech leaders to watch in 2020">Tweet</a>                  </li>
                  <li>
                    <div class="fb-share-button" data-href="https://www.oreilly.com/radar/oreilly-2020-platform-analysis" data-layout="button" data-size="small"><a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fdevelopers.facebook.com%2Fdocs%2Fplugins%2F&amp;src=sdkpreparse" class="fb-xfbml-parse-ignore">Share</a></div>                  </li>
                  <li>
                    <script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
    <script type="IN/Share"></script>                  </li>
                </ul>
              </div>

              <!-- Marketo -->
<link rel="stylesheet" type="text/css" href="https://www.oreilly.com/radar/wp-content/themes/odot/files/mkto-multiform-subscribe-20190821.css">
<script src="https://get.oreilly.com/js/forms2/js/forms2.min.js" type="text/javascript"></script>
<div class="radar-newsletter inline-nls" id="newsletter">
	<h2>Get the O’Reilly Artificial Intelligence Newsletter</h2>
	<div class="newsletter-text">
		<p>Receive weekly insight from industry insiders—plus exclusive content, offers, and more on the topic of AI.</p>
		<a href="http://www.oreilly.com/emails/newsletters/?display=preview#ai" target="_blank" data-source="http://www.oreilly.com/emails/newsletters/?display=preview#ai">View sample newsletter</a>
		<div class="mktoForm-email large -medium -small smallContainer">
			<form class="mktoForm subscribe" data-formid="1114" data-forminstance="topicRow" data-formtopic="AI"></form>
		</div>
	</div>
	<div class="newsletter-quote">
		<blockquote>
			<p>We&rsquo;re just at the beginning of an explosion of intelligent software.</p>
			<footer>— <strong>Tim O&rsquo;Reilly</strong></footer>
		</blockquote>
	</div>
	</div>
<div class="radar-newsletter inline-nls" id="newsletter2">
	<h2>Get the O’Reilly Artificial Intelligence Newsletter</h2>
	<div class="newsletter-text">
		<p>Receive weekly insight from industry insiders—plus exclusive content, offers, and more on the topic of AI.</p>
		<a href="http://www.oreilly.com/emails/newsletters/?display=preview#ai" target="_blank" data-source="http://www.oreilly.com/emails/newsletters/?display=preview#ai">View sample newsletter</a>
		<div class="mktoForm-email large -medium -small smallContainer">
			<form class="mktoForm subscribe" data-formid="1114" data-forminstance="topicRow" data-formtopic="AI"></form>
		</div>
	</div>
	</div>
<script src="https://cdn.oreillystatic.com/assets/js/mkto-multiform-subscribe-20190814.js" type="text/javascript"></script>
                
              <script type="text/javascript" src="https://www.oreilly.com/radar/wp-content/themes/odot/files/cta-191118.js"></script>

            </div>
          </div>

        </div>

      </div>
    </section>


  
<!-- twitter button script  -->
<script>window.twttr = (function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0],
    t = window.twttr || {};
  if (d.getElementById(id)) return t;
  js = d.createElement(s);
  js.id = id;
  js.src = "https://platform.twitter.com/widgets.js";
  fjs.parentNode.insertBefore(js, fjs);
  t._e = [];
  t.ready = function(f) {
    t._e.push(f);
  };
  return t;
}(document, "script", "twitter-wjs"));</script>

<!-- Load Facebook SDK for JavaScript -->
<div id="fb-root"></div>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v5.0"></script>

  </main>

  <footer id="footer" class="footer">
    <div class="content">

      <div class="footer-main" aria-label="company info">
        <div class="footer-mainLeft">
          <div class="footer-mainLeftOne">
            <div class="footer-upcoming">

              <h2 class="footer-header"><a href="https://www.oreilly.com/conferences/">Upcoming Conferences</a></h2>
                <ul><li class="conf_event"><a href="https://conferences.oreilly.com/software-architecture/sa-ny"><span itemprop="summary" class="confName">Software Architecture</span> <time itemprop="startDate"><span class="confMonth">Feb</span>&nbsp;23</time>&ndash;26, New York</a></li><li class="conf_event"><a href="https://conferences.oreilly.com/strata-data-ai/stai-ca"><span itemprop="summary" class="confName">Strata & AI</span> <time itemprop="startDate"><span class="confMonth">Mar</span>&nbsp;15</time>&ndash;18, San Jose</a></li><li class="conf_event"><a href="https://oreilly.formulated.by/scme-phoenix-2020/"><span itemprop="summary" class="confName">Smart Cities & Mobility Ecosystems</span> <time itemprop="startDate"><span class="confMonth">Apr</span>&nbsp;15</time>&ndash;16, Phoenix</a></li><li class="conf_event"><a href="https://conferences.oreilly.com/strata-data-ai/stai-eu"><span itemprop="summary" class="confName">Strata & AI</span> <time itemprop="startDate"><span class="confMonth">Apr</span>&nbsp;20</time>&ndash;23, London</a></li><li class="conf_event"><a href="https://oreilly.formulated.by/scme-miami-2020/"><span itemprop="summary" class="confName">Smart Cities & Mobility Ecosystems</span> <time itemprop="startDate"><span class="confMonth">Jun</span>&nbsp;3</time>&ndash;4, Miami</a></li><li class="conf_event"><a href="https://conferences.oreilly.com/software-architecture/sa-ca"><span itemprop="summary" class="confName">Software Architecture</span> <time itemprop="startDate"><span class="confMonth">Jun</span>&nbsp;15</time>&ndash;18, Santa Clara</a></li></ul>            </div>
            <div class="footer-approach">
              <h2 class="footer-header"><a href="https://www.oreilly.com/about/approach.html">The O'Reilly Approach</a></h2>
              <ul class="footer-links">
                <li><a href="https://www.oreilly.com/about/">Our Company</a></li>
                <li><a href="https://www.oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
                <li><a href="https://www.oreilly.com/careers/">Careers</a></li>
                <li><a href="https://www.oreilly.com/partner/signup.csp">Community Partners</a></li>
              </ul>
            </div>
          </div>
          <div class="footer-mainLeftTwo">
            <div class="footer-solutions">
              <h2 class="footer-header">Solutions</h2>
              <ul class="footer-links">
                <li><a href="https://www.oreilly.com/online-learning/teams.html">For Teams</a></li>
                <li><a href="https://www.oreilly.com/online-learning/enterprise.html">For Enterprise</a></li>
                <li><a href="https://www.oreilly.com/online-learning/individuals.html">For Individuals</a></li>
                <li><a href="https://www.oreilly.com/online-learning/government.html">For Government</a></li>
                <li><a href="https://www.oreilly.com/online-learning/academic.html">For Education</a></li>
              </ul>
            </div>
            <div class="footer-contact">
              <h2 class="footer-header"><a href="http://shop.oreilly.com/category/customer-service.do">Support</a></h2>

              <ul class="footer-links">
                <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
                <li><a href="https://www.oreilly.com/about/contact.html">Contact Us</a></li>
                <li><a href="https://www.oreilly.com/privacy.html">Privacy Policy</a></li>
              </ul>
            
              <a href="https://twitter.com/oreillymedia" target="_blank"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewbox="0 0 400 400" style="enable-background:new 0 0 400 400;" xml:space="preserve"><style type="text/css">.st0{fill:#ee0000;}.st1{fill:#FFFFFF;}</style><g id="Red"><circle class="st0" cx="200" cy="200" r="200"/></g><g id="Logo__x2014__FIXED"><path class="st1" d="M163.4,305.5c88.7,0,137.2-73.5,137.2-137.2c0-2.1,0-4.2-0.1-6.2c9.4-6.8,17.6-15.3,24.1-25 c-8.6,3.8-17.9,6.4-27.7,7.6c10-6,17.6-15.4,21.2-26.7c-9.3,5.5-19.6,9.5-30.6,11.7c-8.8-9.4-21.3-15.2-35.2-15.2 c-26.6,0-48.2,21.6-48.2,48.2c0,3.8,0.4,7.5,1.3,11c-40.1-2-75.6-21.2-99.4-50.4c-4.1,7.1-6.5,15.4-6.5,24.2 c0,16.7,8.5,31.5,21.5,40.1c-7.9-0.2-15.3-2.4-21.8-6c0,0.2,0,0.4,0,0.6c0,23.4,16.6,42.8,38.7,47.3c-4,1.1-8.3,1.7-12.7,1.7 c-3.1,0-6.1-0.3-9.1-0.9c6.1,19.2,23.9,33.1,45,33.5c-16.5,12.9-37.3,20.6-59.9,20.6c-3.9,0-7.7-0.2-11.5-0.7 C110.8,297.5,136.2,305.5,163.4,305.5"/></g></svg></a>
              <a href="https://www.facebook.com/OReilly/" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>facebook-logo</title><path class="cls-1" d="M16.13,0A16.13,16.13,0,1,0,32.25,16.12,16.13,16.13,0,0,0,16.13,0Zm5.12,9.54H19.57a1.52,1.52,0,0,0-1.51,1.51v1.14h3.19v3.42H18.06V26.12H13.57V15.61H10.69V12.19h2.88v-2a4,4,0,0,1,4-4h3.65Z"/></svg></a>
              <a href="https://www.linkedin.com/company/oreilly-media" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>linkedin-logo</title><path class="cls-1" d="M17.43,13.53v0l0,0ZM16.12,0A16.13,16.13,0,1,0,32.25,16.12,16.12,16.12,0,0,0,16.12,0ZM11.77,22.92H8.12v-11h3.65ZM9.94,10.44h0a1.89,1.89,0,0,1-2-1.89A1.91,1.91,0,0,1,10,6.65a1.9,1.9,0,1,1,0,3.79Zm15,12.48H21.28V17.05c0-1.48-.53-2.49-1.85-2.49a2,2,0,0,0-1.88,1.34,2.63,2.63,0,0,0-.12.89v6.13H13.79s.05-10,0-11h3.64V13.5a3.63,3.63,0,0,1,3.29-1.82c2.4,0,4.21,1.57,4.21,4.95Z"/></svg></a>
              <a href="https://www.youtube.com/user/OreillyMedia" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>youtube-logo</title><path class="cls-1" d="M18.35,18.68a.89.89,0,0,0-.86.63V16.94h-1v7.59h1v-.59a.92.92,0,0,0,.89.74c.52,0,.86-.36,1-1.07a8.56,8.56,0,0,0,.14-1.9,10.47,10.47,0,0,0-.12-1.93C19.21,19.05,18.87,18.68,18.35,18.68Zm.09,4.14c-.05.52-.2.77-.45.77s-.43-.21-.49-.63a7.22,7.22,0,0,1,0-1c0-.72,0-1.14,0-1.26.07-.58.23-.88.51-.88s.4.27.46.79c0,.09,0,.47,0,1.13S18.46,22.71,18.44,22.82ZM8.61,18.19H9.86v6.34H11V18.19H12.2V16.94H8.61Zm7.71-6.12c.27,0,.43-.22.49-.66,0-.09,0-.45,0-1.07V9.78c0-.58,0-.93,0-1-.07-.43-.23-.65-.48-.65s-.41.19-.48.57a8.79,8.79,0,0,0,0,1v.53c0,.71,0,1.09,0,1.16C15.88,11.82,16.05,12.07,16.32,12.07Zm-1.74,10.4a2.92,2.92,0,0,1-.06.71c-.07.25-.2.37-.4.37s-.32-.11-.38-.34a2.63,2.63,0,0,1-.05-.66V18.83h-1v4.48c0,.91.33,1.37,1,1.37A1,1,0,0,0,14.6,24v.57h1v-5.7h-1Zm7.1-3.79a1.35,1.35,0,0,0-1.22.59,2.48,2.48,0,0,0-.3,1.07c0,.23,0,.61,0,1.16s0,1.13,0,1.37a2.93,2.93,0,0,0,.35,1.27,1.25,1.25,0,0,0,1.14.54,1.36,1.36,0,0,0,1.13-.45,2.29,2.29,0,0,0,.37-1.43s0-.07,0-.11v-.12h-1c0,.75-.17,1.12-.51,1.12s-.38-.18-.45-.56a4.68,4.68,0,0,1-.06-.9c0-.18,0-.31,0-.37h2v-.43a4.86,4.86,0,0,0-.3-2.11A1.28,1.28,0,0,0,21.68,18.68ZM22.15,21h-1c0-.05,0-.11,0-.16v-.08a1.64,1.64,0,0,1,.11-.8.39.39,0,0,1,.38-.23.42.42,0,0,1,.43.33,2.32,2.32,0,0,1,.07.7Zm-6-21A16.13,16.13,0,1,0,32.25,16.12,16.12,16.12,0,0,0,16.12,0Zm2.51,7.2h1V11a2.52,2.52,0,0,0,.06.66c.06.23.18.34.38.34s.34-.12.41-.37a3.76,3.76,0,0,0,.05-.71V7.2h1v5.74h-1v-.57a1,1,0,0,1-.93.72c-.66,0-1-.46-1-1.38ZM15,8a1.29,1.29,0,0,1,1.33-.92A1.3,1.3,0,0,1,17.65,8a6.77,6.77,0,0,1,.23,2.1,6.77,6.77,0,0,1-.23,2.1,1.3,1.3,0,0,1-1.32.92A1.29,1.29,0,0,1,15,12.17a6.77,6.77,0,0,1-.23-2.1A6.86,6.86,0,0,1,15,8ZM11.45,5.3l.89,2.87.88-2.87H14.4L12.88,9.7v3.24h-1.1V9.7L10.24,5.3ZM24.93,23.91a3,3,0,0,1-3,3h-12a3,3,0,0,1-3-3V18.05a3,3,0,0,1,3-3h12a3,3,0,0,1,3,3Z"/></svg></a>
              <a href="https://www.oreilly.com/emails/newsletters/" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 32.33 32.33"><defs><style>.cls-1{fill:#E00;}.cls-2{fill:#f0f1f1;}</style></defs><title>email-logo</title><circle class="cls-1" cx="16.17" cy="16.17" r="16.17"/><path class="cls-2" d="M6.66,13.32l.2.14c2.2,1.5,4.41,3,6.74,4.29.6.34,1.22.62,1.84.92a1.72,1.72,0,0,0,1.44,0,21,21,0,0,0,2.71-1.4c2-1.21,4-2.53,5.91-3.87l.18-.12v.21c0,2.77,0,5.54,0,8.31A1.51,1.51,0,0,1,24,23.33c-5.24,0-10.48,0-15.72,0a1.57,1.57,0,0,1-1.62-1.08,1.23,1.23,0,0,1,0-.19V13.47A.86.86,0,0,1,6.66,13.32Z"/><path class="cls-2" d="M16.15,9h7.9a1.5,1.5,0,0,1,1.56,1,4.81,4.81,0,0,1,.06,1.07s0,.08-.08.1a77.16,77.16,0,0,1-7.49,4.9c-.42.24-.87.43-1.31.63a1.41,1.41,0,0,1-1.28,0c-.65-.33-1.32-.64-1.95-1-2.37-1.4-4.59-3-6.81-4.55a.35.35,0,0,1-.1-.2c0-.2,0-.4,0-.6A1.45,1.45,0,0,1,8.05,9h8.1Z"/></svg></a>
            </div>
          </div>
        </div>

        <div class="footer-download" id="download-info">
          <h2 class="footer-header">Download the O’Reilly App</h2>

          <div class="footer-downloadLinks">
            <a href="https://itunes.apple.com/us/app/safari-to-go/id881697395"><img src="https://cdn.oreillystatic.com/oreilly/images/app-store-logo.png" alt="Apple app store" /></a>
            <a href="https://play.google.com/store/apps/details?id=com.safariflow.queue"><img src="https://cdn.oreillystatic.com/oreilly/images/google-play-logo.png"  alt="Google play store" /></a>
          </div>

          <p>Take O’Reilly online learning with you and learn anywhere, anytime on your phone or tablet. Download the app <span class="nowrap">today and:</span></p>
          <ul>
            <li>Get unlimited access to books, videos, and <span class="nowrap">live training</span></li>
            <li>Never lose your place—all your devices are synced</li>
            <li>Learn during your commute with online and <span class="nowrap">offline access</span></li>
          </ul>
        </div>
      </div>

      <div class="footer-subfooter">

        <a href="https://www.oreilly.com/" title="home page" aria-current="page">
          <img 
          class="footer-subfooterLogo" 
          id="footer-subfooterLogo"
          src="https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red.svg" 
          onerror="this.src='https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red_@2x.png'; this.onerror=null;" 
          alt="O'Reilly home">
        </a>

        <p>&copy; 2020, O&rsquo;Reilly Media, Inc.  All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p>
        <p><a href="https://www.oreilly.com/terms/">Terms of Service</a> • <a href="https://www.oreilly.com/privacy.html">Privacy Policy</a> • <a href="https://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a></p>
      </div>

    </div>
  </footer>

  <!-- <script src="https://cdn.oreillystatic.com/ajax/libs/jquery/3.3.1/jquery.min.js"></script> -->


  <script>
  (function($) {
    //Toggle isActive and mobileHidden classes for mobileNavButton
    $('nav #mobileNavButton').on('click', function() {
      var expanded = $(this).attr('aria-expanded') === 'true' || false;
      $(this).attr('aria-expanded', !expanded);
      $(this).toggleClass("isActive");
      $(this).next().toggleClass("mobileHidden");
    });

    //Toggle isFocused class for keyboard navigation of submenus
    $('nav #menuList .menuList-subItem a').each(function(navItem) {
      $(this).on('focus', function() {
        $(this).parent().parent().toggleClass('isFocused');
      });
      $(this).on('blur', function() {
        $(this).parent().parent().toggleClass('isFocused');
      });
    });


    //Toggle mobileHidden class accordian elements
    $('.mobileAccordian').each(function() {
      var $btn = $(this).find('button');
      var $target =  $(this).next();
      $btn.on('click', function() {
        var expanded = $btn.attr('aria-expanded') === 'true' || false;

        $btn.attr('aria-expanded', !expanded);
        $target.toggleClass("mobileHidden");  
      });
    });

    // truncate months in footer conf listings
    var months = $('.confMonth');
    months.each(function(){    
      var m = $(this).text();        
      if(m.length < 3 ) return;
      $(this).html(m.slice(0,3));
    });
  })(jQuery);
  </script>

  		<style type="text/css">
			.ssp-wave wave wave {
				background: #00d4f7 !important;
			}
		</style>
		<script type='text/javascript' src='https://www.oreilly.com/radar/wp-content/plugins/seriously-simple-podcasting/assets/js/media.player.js?ver=1.20.10'></script>
<script type='text/javascript' src='https://www.oreilly.com/radar/wp-content/plugins/seriously-simple-podcasting/assets/js/html5.player.js?ver=1.20.10'></script>
<script type='text/javascript' src='https://www.oreilly.com/radar/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>

  <script type="text/javascript" id="MathJax-script">

    var math = document.getElementsByClassName('math-tex');
    if (math.length > 0) includeMathJax();
    function includeMathJax() {
      var head = document.getElementsByTagName('head')[0];
      var script = document.createElement('script');
      script.src = "https://cdn.jsdelivr.net/npm/mathjax@3/es5/tex-mml-chtml.js";
      script.type = 'text/javascript';
      script.async = 'async';
      head.appendChild(script)
    }   
  </script>
  </body>
</html>
