<!DOCTYPE html>
<html lang="en">
<head>
  <title>5 things you should be monitoring - O&#39;Reilly Media</title>

  <!-- Meta -->
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
      <meta property="twitter:card" content="summary_large_image" />
      <meta property="twitter:site" content="@OReillyMedia" />
      <meta property="twitter:title" content="5 things you should be monitoring" />
      <meta property="twitter:description" content="Achieve high-impact systems monitoring by focusing on latency, errors, throughput, utilization, and blackbox monitoring.
" />
      <meta property="description:site" content="Achieve high-impact systems monitoring by focusing on latency, errors, throughput, utilization, and blackbox monitoring.
" />
      <meta property="twitter:url" content="https://www.oreilly.com/ideas/5-things-you-should-be-monitoring" />
      <meta property="fb:pages" content="15137500430" />
      <meta property="og:type" content="article" />
      <meta property="og:site_name" content="O&#39;Reilly Media" />
      <meta property="og:title" content="5 things you should be monitoring" />
      <meta property="og:description" content="Achieve high-impact systems monitoring by focusing on latency, errors, throughput, utilization, and blackbox monitoring.
" />
      <meta property="og:url" content="https://www.oreilly.com/ideas/5-things-you-should-be-monitoring" />
      <meta property="article:published_time" content="2018-08-06T10:00:00Z" />
      <meta property="article:author" content="Brian Brazil" />
      <meta name="description" content="Achieve high-impact systems monitoring by focusing on latency, errors, throughput, utilization, and blackbox monitoring.
" />
      <meta name="author" content="Brian Brazil" />
      <meta name="date" content="2018-08-06" />
      <meta property="og:image" content="https://d3ucjech6zwjp8.cloudfront.net/1400x933/operations-radar-station-crop-fb9af7e304dfb111145d2d8b8c3145cd.jpg" />
      <meta property="twitter:image" content="https://d3ucjech6zwjp8.cloudfront.net/1400x933/operations-radar-station-crop-fb9af7e304dfb111145d2d8b8c3145cd.jpg" />
      <meta name="thumbnail" content="https://d3ucjech6zwjp8.cloudfront.net/360x240/operations-radar-station-crop-fb9af7e304dfb111145d2d8b8c3145cd.jpg" />
      <meta name="graphic_medium" content="https://d3ucjech6zwjp8.cloudfront.net/360x240/operations-radar-station-crop-fb9af7e304dfb111145d2d8b8c3145cd.jpg" />
      <meta name="oreilly:topic" content="Operations" />
      <meta name="oreilly:keywords" content="monitoring,systems,latency,errors,throughput,utilization,blackbox" />
  
  

  <!-- Assets -->
  <script type="text/javascript" src="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-f09526a22a.js"></script>
  <link rel="stylesheet" type="text/css" href="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-e83b91017e.css">
    
  
  <!-- Extra Assets -->
  
  
  

  <link rel="stylesheet" type="text/css" href="https://cdn.oreillystatic.com/assets/css/mkto-multiform-subscribe-20180320.css">

  <script type="text/javascript">
    dataLayer = [];
  </script>

    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5P4V6Z');</script>
  <!-- End Google Tag Manager -->
  

  

    <script type="text/javascript">
    function createKeenWebAutoCollector(){window.keenWebAutoCollector=window.KeenWebAutoCollector.create({projectId:'551456c8672e6c2f4f5ee426',writeKey:'e737a463e3a57a914ddf707a34ad2c319c2e1c52999fe5f8087e41a71676675f90298cfd1a4e30ecf3f25e337db4b579c28c2bf784b26bdd6e9b7cc595b045098b94483dea878b17a65a56b5307b97ac3834670c2484fb8effa01cbacd55dba355850b97cad116b4b0e434dc64bc359c',onloadCallbacks:window.keenWebAutoCollector.onloadCallbacks}),window.keenWebAutoCollector.loaded()}function initKeenWebAutoCollector(){window.keenWebAutoCollector.domReady()?window.createKeenWebAutoCollector():document.addEventListener("readystatechange",function(){window.keenWebAutoCollector.domReady()&&window.createKeenWebAutoCollector()})}window.keenWebAutoCollector={onloadCallbacks:[],onload:function(a){this.onloadCallbacks.push(a)},domReady:function(){return["ready","complete"].indexOf(document.readyState)>-1}};
  </script>
  <script async type="text/javascript" src="https://d26b395fwzu5fz.cloudfront.net/keen-web-autocollector-1.0.8.min.js" onload="initKeenWebAutoCollector()"></script>
  

  <script type="text/javascript">
    // init app.events for all communication
    app.events = new orm.Events();

    var tempData = {"content_type":"text","flag":{"flag-slug":"operations","flag-title":"Operations","flag-url":"/topics/operations","parent-topic-slug":"operations"},"gateway_api_url":"https://gateway.oreilly.com","icons-svg":"/assets/icons-8812ab3f83.svg","post_info":{"byline":{"authors":[{"first-name":"Brian","last-name":"Brazil","url":"/people/brian-brazil"}]},"excerpt":"\u003cp\u003eSo you've deployed your brand new web application (now with blockchain!), and your users love it. Traffic is increasing, and you're getting great press. Then one morning you wake up to find that the site has been slow all night, and your users are complaining. How do you find the problem?\u003c/p\u003e\r\n\r\n\u003cp\u003eWhether you're a developer building websites or internal applications, or an administrator building the infrastructure to back them, your job doesn't stop once they're up and running. Machine failure, releases containing bugs, and growth in usage can all lead to problems that need to be dealt with. To detect them, you need monitoring.\u003c/p\u003e","title":"5 things you should be monitoring"},"post_slug":"5-things-you-should-be-monitoring","production":true,"segment_write":"c1bqZBPpSt05Stv3bKthxtFmC2etfgEK"};

    var kalturaVideoId = "";
    var kalturaAccount = "";
    var kalturaPlayer = "";

    // This should be genetated on the API directly.
    tempData.allTopics = [{"flag-title":"Money","flag-slug":"money"},{"flag-title":"Internet of Things","flag-slug":"internet-of-things","parent-topic-slug":"data"},{"flag-title":"Open Source","flag-slug":"open-source","parent-topic-slug":"software-engineering"},{"flag-title":"Data marketplace","flag-slug":"data-marketplace","parent-topic-slug":"data"},{"flag-title":"Cognitive augmentation","flag-slug":"cognitive-augmentation","parent-topic-slug":"data"},{"flag-title":"Software Architecture","flag-slug":"software-architecture","parent-topic-slug":"software-engineering"},{"flag-title":"Economy","flag-slug":"economy"},{"flag-title":"Data science","flag-slug":"data-science","parent-topic-slug":"data"},{"flag-title":"Design and Business","flag-slug":"design-and-business","parent-topic-slug":"design"},{"flag-title":"Data perils","flag-slug":"data-perils","parent-topic-slug":"data"},{"flag-title":"Data design","flag-slug":"data-design","parent-topic-slug":"data"},{"flag-title":"Data","flag-slug":"data"},{"flag-title":"Data culture","flag-slug":"data-culture","parent-topic-slug":"data"},{"flag-title":"Software Engineering","flag-slug":"software-engineering"},{"flag-title":"Data Tools","flag-slug":"data-tools","parent-topic-slug":"data"},{"flag-title":"Design","flag-slug":"design"},{"flag-title":"Artificial intelligence","flag-slug":"artificial-intelligence","parent-topic-slug":"data"}];

    // Add metrics, using a different write key for dev than for prod
    injectSegment(tempData.segment_write)

    $(function() {
      app.metrics = new orm.Metrics();
      app.metrics.pageView();

      app.pageInit(tempData);

      // load data into events so it dispatched 'data:loaded'
      app.events.addData(tempData);
    })
  </script>

  <!-- Start Visual Website Optimizer Asynchronous Code -->
  <script type='text/javascript'>
    var _vwo_code=(function(){
    var account_id=244658,
    settings_tolerance=2000,
    library_tolerance=2500,
    use_existing_jquery=false,
  // DO NOT EDIT BELOW THIS LINE
  f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
  </script>
  <!-- End Visual Website Optimizer Asynchronous Code -->

  <!-- Marketo -->
  <script src="https://app-ab24.marketo.com/js/forms2/js/forms2.min.js" type="text/javascript"></script>

</head>
<body class="body t-operations" data-section="ideas" >
  <div class="flashes"></div>
    <header id="page-header">
  <div id="header-bar" class="t-bkg">
    <h1 class="logo t-bkg" >
  <a href="/" class=" logo-white ">
  <svg role="heading" aria-label="O'Reilly">
    <title>O'Reilly</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
  </svg>
  </a>
</h1>
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>


    <div class="right">
      <div id="search" class="hide">
        <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
      </div>
      <div id="user">
        <a href="https://www.oreilly.com/sign-in.html" class="t-c--d">Sign In</a>
      </div>
    </div>
    <a id="menu-toggle" class="invert" ><span class="icon icon-white icon-menu">
  <svg role="img" id="close" class="is-hidden">
    <title>Close Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#close"></use>
  </svg>
  <svg role="img" id="open">
    <title>Open Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#menu"></use>
  </svg>
</span></a>
  </div>
     <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/jupyter" >Jupyter</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

  
  <div id="mobile-menu">

    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
         <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/jupyter" >Jupyter</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

    
  </div>

</header>



  <!-- Linked In -->
  <script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
  
<!-- Load Facebook SDK for JavaScript -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<main aria-live="polite">
  <article class="article" itemscope itemtype="http://schema.org/Article">
              <header class="article-header">
      <div class="flag t-bkg--before bg-operations--before flag--small">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
  
  

  <h1 class="title t-c" itemprop="headline">5 things you should be monitoring</h1>

      <p class="dek" itemprop="alternativeHeadline">Achieve high-impact systems monitoring by focusing on latency, errors, throughput, utilization, and blackbox monitoring.
</p>
  

  <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/brian-brazil" itemprop="name">Brian Brazil</a></span>
</div> <time class="date">August 6, 2018</time>

</header>

      

      <div class="article-body" itemprop="articleBody">
        
                              <figure class="article-image right">
  <img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/operations-radar-station-crop-fb9af7e304dfb111145d2d8b8c3145cd.jpg" alt="Radar station" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/operations-radar-station-crop-fb9af7e304dfb111145d2d8b8c3145cd.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/operations-radar-station-crop-fb9af7e304dfb111145d2d8b8c3145cd.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/operations-radar-station-crop-fb9af7e304dfb111145d2d8b8c3145cd.jpg 1440w" sizes="(min-width: 1390px) 420px, (min-width: 600px) 45vw, 100vw" class=""/>
  <figcaption>Radar station
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://pixabay.com/en/radar-station-stairs-radar-sky-3431258/">Paul_Henri via Pixabay</a>)
        
        
      </span>
    
    
  <figcaption>

</figure>
          
                      <aside data-type="note">
  <p>Check out Brian Brazil’s new book, <a href="https://www.safaribooksonline.com/library/view/prometheus-up/9781492034131/?utm_source=oreilly&utm_medium=newsite&utm_campaign=5-things-you-should-be-monitoring-text-cta">Prometheus: Up & Running</a>, to learn more about application monitoring.</p>
</aside>

          
        

        

        <p>So you've deployed your brand new web application (now with blockchain!), and your users love it. Traffic is increasing, and you're getting great press. Then one morning you wake up to find that the site has been slow all night, and your users are complaining. How do you find the problem?</p>

<p>Whether you're a developer building websites or internal applications, or an administrator building the infrastructure to back them, your job doesn't stop once they're up and running. Machine failure, releases containing bugs, and growth in usage can all lead to problems that need to be dealt with. To detect them, you need monitoring.</p>

<p>But monitoring can do more than just send you alerts about the things that are going wrong. It can also help you debug those problems and prevent them in the future. So what things should you be monitoring?</p>

<h2>1. Latency</h2>

<p>Faster web pages lead to happier users. The opposite is also true: increased latency leads to user dissatisfaction and could also be the first warning sign that your system is strained. Launching resource-intensive features often means more user requests being served. As servers die, latency can increase. In fact, latency tends to increase nonlinearly in response to load due to increased contention. Small latency increases today could indicate bigger latency increases in the future; early awareness gives you some time to fix any issues.</p>

<p>Latency is generally measured from two perspectives: your users and your system. Having instrumentation inside the user's browser can detect issues such as JavaScript and static assets getter larger slowing the user experience. This measurement will have a lot of variance due to users' specific hardware, their network environment, and their internet connection. Measuring from each of your own backend systems tends to be much less noisy but can never capture the entire user experience, so it's best to measure both. Browser latency monitoring will catch frontend issues due to a release, and backend monitoring will catch most of the rest.</p>

<p>But what do you do with your latency data once you've gathered it? You could alert every time latency increases by a millisecond, but that's not really a good reason to drag yourself out of bed at 3:00am. A better option is to set alert thresholds based on service-level agreements (SLA). If you don’t have SLAs, choose a threshold that indicates when things are significantly abnormal. For example, if your latency usually varies between 50ms and 100ms, 200ms might be a good threshold to start with.</p>

<p>Beyond alerts that require immediate human attention, it is also wise to review key metrics, such as latency, every week, month, or quarter depending on your development velocity and how dynamic your system is. Using a review process to notice trends in advance is better than burning engineers out with hair-trigger alerts.</p>

<h2>2. Errors</h2>

<p>While latency can make a system feel sluggish for your users, errors tend to cause more obvious problems. Error sources may include a bug in your system, a bad interaction with a new browser release, or a timeout due to increased load. These can lead to malfunctions or outright failure.</p>

<p>Ordinarily, you want to know about errors at every level of your stack, from the frontend all the way down to the backend data stores. But that doesn't mean you need an alert on every single error counter. For example, if database errors always cause application errors, an alert on application errors will suffice, because it will cover the database errors and more. However, you should still show both database and application errors on your dashboards to help you determine whether the application errors are due to the database. Conversely, if you have an optional backend whose errors don't cause upstream systems to hard fail, it makes sense to alert on the errors of the optional backend, since the application error alert won't catch them.</p>

<p>When creating dashboards and alerts related to errors, it's best to use the ratio of number of errors to total requests rather than just the number of errors. For example, one error per second might be typical during peak traffic but could be a bad sign during times of lower load. Knowing that the error ratio is 5% is more useful for comparison and doesn't require updating the alert threshold as your traffic grows.</p>

<p>Finally, remember that not all errors are equal. Say you have a system that accepts user uploads, processes them, and then serves them over HTTP. If the storage backend times out, your system is clearly at fault. But if a user makes a malformed request, you may choose to ignore the error unless you see enough malformed requests to prompt you to investigate a broken frontend. Similarly, you may choose to ignore requests made for things that don't exist because they could be caused by a number of things, from user error to lost uploads or uploads that haven't completed processing. However, as with malformed requests, a high level of these errors is likely worth alerting on.</p>

<h2>3. Throughput</h2>

<p>In order to learn your error ratio, you need to know the number of requests that you are serving (i.e., throughput). When debugging a performance issue, knowing your throughput can reveal whether traffic increased around the same time, which can indicate a capacity problem.</p>

<p>Beyond immediate debugging, monitoring throughput helps you understand how your traffic has been growing over the past few months or years. This is important for capacity planning, helping predict what traffic is likely to be in the future. You don't want to leave yourself short in terms of resources and finances, but neither do you want to overspend.</p>

<p>There's more to consider than raw request count. It's useful to track what the requests are for and whether they are cheap or expensive requests to serve. Expense might be quantified in terms of CPU or even network bandwidth. You may also want to know where your users are geographically so that you can plan your data center locations accordingly.</p>

<h2>4. Utilization</h2>

<p>Capacity planning should ensure that you have enough resources, but that isn't always the case. Growth may exceed expectations, feature launches may entail unforeseen expenses, and you may experience traffic spikes or a sudden loss of machines. That's where utilization comes in. Utilization is a measure of how close your service is to maximum capacity. This is usually determined by CPU, but some systems may be constrained by other resources, such as network bandwidth, storage space, or RAM.</p>

<p>Determining how utilization of your existing machines correlates with traffic enables you to use your traffic growth projections to predict your hardware/resource needs. For example, if serving 100 requests per second takes one CPU, and you need to serve 200 requests per second in the future, you know you'll need at least two CPUs to make that happen. Be aware that as traffic increases, your resource needs will increase faster than linear, as explained by models such as the <a href="http://www.perfdynamics.com/Manifesto/USLscalability.html">Universal Scalability </a><a href="http://www.perfdynamics.com/Manifesto/USLscalability.html">Law</a>.</p>

<h2>5. Blackbox monitoring</h2>

<p>Is this thing turned on? Monitoring whether your service is working as seen from the outside is known as blackbox monitoring. Everything might look fine at your backend servers from inside your network, but a broken load balancer or misconfigured internet routing could stop users from getting that far. Thus, it's wise to have some basic monitoring from outside your network confirming that traffic can get in. It's also useful to look for sudden dips in traffic to detect issues with users getting to your services, although this tends to be difficult to tune for a good signal-to-noise ratio.</p>

<p>You should also check whether key features, such as user login, are working. I recommend treating these as smoke tests rather than regression tests. The main purpose of blackbox monitoring is to tell you if your system is severely broken. But blackbox monitoring has a tendency to be flaky, particularly when using heavy, complex tests, and flaky monitoring will burn out the engineer on the receiving end of any alerts. More subtle failures, like users being unable to log in if their password is longer than 32 characters, are best caught in other ways, such as the above metrics, error logs, and user bug reports.</p>

<h2>Use monitoring to cover your bases</h2>

<p>With a combination of latency, errors, throughput, utilization, and blackbox monitoring, all of your main needs should be covered. Monitoring these five areas will not catch every possible problem (although you shouldn't try to catch every problem, as you'll quickly hit diminishing returns). However, it will offer enough information to give you confidence that your systems are running smoothly.</p>


        
                  
        

                  <div class="image-credit">
  Article image: Radar station
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://pixabay.com/en/radar-station-stairs-radar-sky-3431258/">Paul_Henri via Pixabay</a>).
        
        
      </span>
    
    
</div>
        

        

      </div>

      <div class="article-meta">

  <div class="article-share">
  <div class="article-share-text"> Share </div>
  <ol>
    <li><a href="https://twitter.com/share" class="twitter-share-button" data-via="oreillymedia" data-show-count="false">Tweet</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></li>
    <li>  <div class="fb-share-button" 
    data-href="https://www.oreilly.com/ideas/5-things-you-should-be-monitoring" 
    data-layout="button_count">
  </div></li>
    <li><script type="IN/Share" data-url="https://www.oreilly.com/ideas/5-things-you-should-be-monitoring" data-counter="right"></script></li>
  </ol>
  <hr>
</div>

  

      <article class="block block-common with-img person with-link">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/people/brian-brazil"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x360/brian-brazil-crop-65e70c6b2bf206c99626362cbfa4c1d7.jpg" alt="Brian Brazil" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x360/brian-brazil-crop-65e70c6b2bf206c99626362cbfa4c1d7.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x720/brian-brazil-crop-65e70c6b2bf206c99626362cbfa4c1d7.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x1440/brian-brazil-crop-65e70c6b2bf206c99626362cbfa4c1d7.jpg 1440w"  class=""/></a>
    
    
  </div>
  

  

  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/people/brian-brazil">Brian Brazil</a>
    
    
    </h2>
    

    
          <p class="dek">Brian Brazil is the founder of Robust Perception and a Prometheus developer. He is well known in the Prometheus community, has given countless presentations at conferences, and his blog is widely read within the community.
</p>

    
          <a class="btn btn--xsmall" style="float: right;" href="/people/brian-brazil">more</a>
    
  </div>
</article>

  

</div>


      <hr class="t-bkg section-divider" />


      <aside class="article-related">
      <section class="block-rows columns-4 ">

    

    <section class="block-group">
                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/ideas/javascript-security-and-the-case-for-feature-simplicity"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/iron-72129_crop-6d5cd20562177e8240d7834e3b114a95.jpg" alt="Chain link" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/iron-72129_crop-6d5cd20562177e8240d7834e3b114a95.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/iron-72129_crop-6d5cd20562177e8240d7834e3b114a95.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/iron-72129_crop-6d5cd20562177e8240d7834e3b114a95.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-operations--before">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/javascript-security-and-the-case-for-feature-simplicity">JavaScript, security, and the case for feature simplicity</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/e9dcd-natalie-silvanovich" itemprop="name">Natalie Silvanovich</a></span>
</div>
    
          <p class="dek">Natalie Silvanovich discusses the link between feature complexity, developer error, and security vulnerabilities.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/its-usability-all-the-way-down"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/2654032126_31dfed74b0_o-9b2b490e1a61dbfca6875db7206ecb64.jpg" alt="arne jacobsen, central steel staircase, rødovre town hall, 1952-1956" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/2654032126_31dfed74b0_o-9b2b490e1a61dbfca6875db7206ecb64.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/2654032126_31dfed74b0_o-9b2b490e1a61dbfca6875db7206ecb64.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/2654032126_31dfed74b0_o-9b2b490e1a61dbfca6875db7206ecb64.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-operations--before">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/its-usability-all-the-way-down">It’s usability all the way down</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/818a7-jeff-sussna" itemprop="name">Jeff Sussna</a></span>
</div>
    
          <p class="dek">Designing, building, and operating services from the perspective of customer goals helps improve quality.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/ideas/ghosts-in-the-machines"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/6432099557_bcb0630c3c_o-d762a9dae2918ed0c2a0462c788db0f6.jpg" alt="Favorittbilde #15. Ukas bilde" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/6432099557_bcb0630c3c_o-d762a9dae2918ed0c2a0462c788db0f6.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/6432099557_bcb0630c3c_o-d762a9dae2918ed0c2a0462c788db0f6.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/6432099557_bcb0630c3c_o-d762a9dae2918ed0c2a0462c788db0f6.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-operations--before">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/ghosts-in-the-machines">Ghosts in the machines</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/3f5d7-courtneyw-nash" itemprop="name">Courtney Nash</a></span>
</div>
    
          <p class="dek">The secret to successful infrastructure automation is people.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Runnable code</span>
        <span class="icon icon-code t-fill">
  <svg role="img">
    <title>code</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#code"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/learning/continuous-delivery-windows-dot-net"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/continuous_delivery_with_windows_and_dotnet-1-f4085b95bc81884d973421a125644a57.jpg" alt="Cans on production line" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/continuous_delivery_with_windows_and_dotnet-1-f4085b95bc81884d973421a125644a57.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/continuous_delivery_with_windows_and_dotnet-1-f4085b95bc81884d973421a125644a57.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/continuous_delivery_with_windows_and_dotnet-1-f4085b95bc81884d973421a125644a57.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-operations--before">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/learning/continuous-delivery-windows-dot-net">Continuous delivery with Windows and .NET</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/4a7b9-matthew-skelton" itemprop="name">Matthew Skelton</a></span><span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/chris-odell" itemprop="name">Chris O&#39;Dell</a></span>
</div>
    
          <p class="dek">Learn how to use modern Windows and .NET software with third-party and open source tools to automate the frequent software builds, testing, and deployments that CD prescribes. </p>

    
    
  </div>
</article>

      
  	</section>
    

</section>
  
</aside>

  </article>
</main>








  <footer role="contentinfo">
  <div class="footer-inner">

    <div class="about-us">
      <h3 class="title">About Us</h3>
      <ul>
        <li><a href="http://oreilly.com/about/">Our Company</a></li>
        <li><a href="http://oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
        <li><a href="http://oreilly.com/careers/">Careers</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Contact Us</a></li>
      </ul>
    </div>
    <div class="site-map">
      <h3 class="title">Site Map</h3>
      <ul>
        <li><a href="/ideas">Ideas</a></li>
        <li><a href="/topics/oreilly-learning">Learning</a></li>
        <li><a href="/topics">Topics</a></li>
        <li><a href="/all">All</a></li>
      </ul>
    </div>
    <div class="social">
      <ul>
        <li><a   class="icon-link " href="https://www.facebook.com/OReilly/"><span class="icon icon-facebook t-fill icon--white icon--large">
  <svg role="img">
    <title>facebook</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#facebook"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://twitter.com/oreillymedia"><span class="icon icon-twitter t-fill icon--white icon--large">
  <svg role="img">
    <title>twitter</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#twitter"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.youtube.com/user/OreillyMedia"><span class="icon icon-youtube-large t-fill icon--white icon--large">
  <svg role="img">
    <title>youtube-large</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#youtube-large"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://plus.google.com/+oreillymedia"><span class="icon icon-google t-fill icon--white icon--large">
  <svg role="img">
    <title>google</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#google"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.linkedin.com/company/oreilly-media"><span class="icon icon-linkedin t-fill icon--white icon--large">
  <svg role="img">
    <title>linkedin</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#linkedin"></use>
  </svg>
</span></a>
</li>
      </ul>
    </div>
  </div>
  <div class="legal">
	  <a href="/" class="logo logo-block t-bkg logo--medium">
<svg>
   <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
</svg>
</a>
  	<p class="copyright">&copy; 2018 O'Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><br>
  <a class="t-c" href="http://oreilly.com/terms/">Terms of Service</a>  <span class="bullet">&bull;</span>	<a class="t-c" href="http://oreilly.com/privacy.html">Privacy Policy</a> <span class="bullet">&bull;</span> <a class="t-c" href="http://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a>
	</div>
	<figure class="animal"><img src="https://d3ebicv0uqgr7t.cloudfront.net/images/tarsier.png" class="animal-img" alt="Animal"></figure>
</footer>



  
  

    <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5P4V6Z"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
  

  
</body>
</html>
