<!DOCTYPE html>
<html lang="en">
<head>
  <title>Kelsey Hightower and Chris Gaun on serverless and Kubernetes - O&#39;Reilly Media</title>

  <!-- Meta -->
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
      <meta property="twitter:card" content="summary_large_image" />
      <meta property="twitter:site" content="@OReillyMedia" />
      <meta property="twitter:title" content="Kelsey Hightower and Chris Gaun on serverless and Kubernetes" />
      <meta property="twitter:description" content="Exploring use cases for the two tools." />
      <meta property="description:site" content="Exploring use cases for the two tools." />
      <meta property="twitter:url" content="https://www.oreilly.com/ideas/kelsey-hightower-and-chris-gaun-on-serverless-and-kubernetes" />
      <meta property="fb:pages" content="15137500430" />
      <meta property="og:type" content="article" />
      <meta property="og:site_name" content="O&#39;Reilly Media" />
      <meta property="og:title" content="Kelsey Hightower and Chris Gaun on serverless and Kubernetes" />
      <meta property="og:description" content="Exploring use cases for the two tools." />
      <meta property="og:url" content="https://www.oreilly.com/ideas/kelsey-hightower-and-chris-gaun-on-serverless-and-kubernetes" />
      <meta property="article:published_time" content="2018-09-13T11:05:00Z" />
      <meta property="article:author" content="Jeff Bleiel" />
      <meta name="description" content="Exploring use cases for the two tools." />
      <meta name="author" content="Jeff Bleiel" />
      <meta name="date" content="2018-09-13" />
      <meta property="og:image" content="https://d3ucjech6zwjp8.cloudfront.net/1400x933/cube-3457851_1920_crop-c1b9fbabaefa96d2fcec9ea219dfefc4.jpg" />
      <meta property="twitter:image" content="https://d3ucjech6zwjp8.cloudfront.net/1400x933/cube-3457851_1920_crop-c1b9fbabaefa96d2fcec9ea219dfefc4.jpg" />
      <meta name="thumbnail" content="https://d3ucjech6zwjp8.cloudfront.net/360x240/cube-3457851_1920_crop-c1b9fbabaefa96d2fcec9ea219dfefc4.jpg" />
      <meta name="graphic_medium" content="https://d3ucjech6zwjp8.cloudfront.net/360x240/cube-3457851_1920_crop-c1b9fbabaefa96d2fcec9ea219dfefc4.jpg" />
      <meta name="oreilly:topic" content="Software Architecture" />
      <meta name="oreilly:parent_topic" content="Software Engineering" />
      <meta name="oreilly:keywords" content="Kubernetes,serverless,architecture,security,tools" />
  
  

  <!-- Assets -->
  <script type="text/javascript" src="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-f09526a22a.js"></script>
  <link rel="stylesheet" type="text/css" href="https://d3ebicv0uqgr7t.cloudfront.net/assets/application-e83b91017e.css">
    
  
  <!-- Extra Assets -->
  
  
  

  <link rel="stylesheet" type="text/css" href="https://cdn.oreillystatic.com/assets/css/mkto-multiform-subscribe-20180320.css">

  <script type="text/javascript">
    dataLayer = [];
  </script>

    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5P4V6Z');</script>
  <!-- End Google Tag Manager -->
  

  

    <script type="text/javascript">
    function createKeenWebAutoCollector(){window.keenWebAutoCollector=window.KeenWebAutoCollector.create({projectId:'551456c8672e6c2f4f5ee426',writeKey:'e737a463e3a57a914ddf707a34ad2c319c2e1c52999fe5f8087e41a71676675f90298cfd1a4e30ecf3f25e337db4b579c28c2bf784b26bdd6e9b7cc595b045098b94483dea878b17a65a56b5307b97ac3834670c2484fb8effa01cbacd55dba355850b97cad116b4b0e434dc64bc359c',onloadCallbacks:window.keenWebAutoCollector.onloadCallbacks}),window.keenWebAutoCollector.loaded()}function initKeenWebAutoCollector(){window.keenWebAutoCollector.domReady()?window.createKeenWebAutoCollector():document.addEventListener("readystatechange",function(){window.keenWebAutoCollector.domReady()&&window.createKeenWebAutoCollector()})}window.keenWebAutoCollector={onloadCallbacks:[],onload:function(a){this.onloadCallbacks.push(a)},domReady:function(){return["ready","complete"].indexOf(document.readyState)>-1}};
  </script>
  <script async type="text/javascript" src="https://d26b395fwzu5fz.cloudfront.net/keen-web-autocollector-1.0.8.min.js" onload="initKeenWebAutoCollector()"></script>
  

  <script type="text/javascript">
    // init app.events for all communication
    app.events = new orm.Events();

    var tempData = {"content_type":"text","flag":{"flag-slug":"software-architecture","flag-title":"Software Architecture","flag-url":"/topics/software-architecture","parent-topic-slug":"software-engineering"},"gateway_api_url":"https://gateway.oreilly.com","icons-svg":"/assets/icons-8812ab3f83.svg","post_info":{"byline":{"authors":[{"first-name":"Jeff","last-name":"Bleiel","url":"/people/jeff-bleiel"}]},"excerpt":"\u003cp\u003eThis episode of the O’Reilly Podcast, features a conversation on serverless and Kubernetes, with \u003ca href=\"https://twitter.com/kelseyhightower\"\u003eKelsey Hightower\u003c/a\u003e, developer advocate for Google Cloud Platform at Google (and co-author of \u003ca href=\"https://www.safaribooksonline.com/library/view/kubernetes-up-and/9781491935668/\"\u003e\u003cem\u003eKubernetes: Up and Running\u003c/em\u003e\u003c/a\u003e), and \u003ca href=\"https://twitter.com/gaunetes\"\u003eChris Gaun\u003c/a\u003e, Kubernetes product marketing manager at \u003ca href=\"https://mesosphere.com/\"\u003eMesosphere\u003c/a\u003e.\u003c/p\u003e\n\n\u003cp\u003e\u003ciframe src=\"https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/499896831\u0026amp;auto_play=false\u0026amp;hide_related=false\u0026amp;show_artwork=true\" height=\"166\" width=\"100%\" frameborder=\"no\" scrolling=\"no\"\u003e\u003c/iframe\u003e\u003c/p\u003e\n\n\u003cp\u003e\u003cstrong\u003eDiscussion points:\u003c/strong\u003e\u003c/p\u003e\n\n\n\u003cul\u003e\n\u003cli\u003eHightower and Gaun agree that the biggest issue people face when deciding to start using Kubernetes is an underestimation of the learning curve.\u003c/li\u003e\n\n\n\n\u003cli\u003eWhether or not there is a competition between Kubernetes containers and serverless\u003c/li\u003e\n\n\n\n\u003cli\u003eConsiderations when attempting to move an existing application to a serverless architecture\u003c/li\u003e\n\n\n\n\u003cli\u003eThe new open source frameworks that work on Kubernetes (including \u003ca href=\"https://kubeless.io/\"\u003eKubeless\u003c/a\u003e and \u003ca href=\"https://www.openfaas.com/\"\u003eOpenFaaS\u003c/a\u003e)\u003c/li\u003e\n\n\n\n\u003cli\u003eWorkflow engines being used on top of Kubernetes (including \u003ca href=\"https://www.kubeflow.org/\"\u003eKubeflow\u003c/a\u003e and \u003ca href=\"https://blog.argoproj.io/\"\u003eArgo\u003c/a\u003e)\u003c/li\u003e\n\n\n\n\u003cli\u003eSecurity issues regarding Kubernetes clusters\u003c/li\u003e\n\u003c/ul\u003e\n\n\n\n\n\u003cp\u003e\u003cem\u003eThis post is a collaboration between Mesosphere and O’Reilly. See our \u003c/em\u003e\u003ca href=\"http://www.oreilly.com/about/editorial_independence.html\"\u003e\u003cem\u003estatement of editorial independence\u003c/em\u003e\u003c/a\u003e.\u003c/p\u003e\n","title":"Kelsey Hightower and Chris Gaun on serverless and Kubernetes"},"post_slug":"kelsey-hightower-and-chris-gaun-on-serverless-and-kubernetes","production":true,"segment_write":"c1bqZBPpSt05Stv3bKthxtFmC2etfgEK"};

    var kalturaVideoId = "";
    var kalturaAccount = "";
    var kalturaPlayer = "";

    // This should be genetated on the API directly.
    tempData.allTopics = [{"flag-title":"Money","flag-slug":"money"},{"flag-title":"Internet of Things","flag-slug":"internet-of-things","parent-topic-slug":"data"},{"flag-title":"Open Source","flag-slug":"open-source","parent-topic-slug":"software-engineering"},{"flag-title":"Data marketplace","flag-slug":"data-marketplace","parent-topic-slug":"data"},{"flag-title":"Cognitive augmentation","flag-slug":"cognitive-augmentation","parent-topic-slug":"data"},{"flag-title":"Software Architecture","flag-slug":"software-architecture","parent-topic-slug":"software-engineering"},{"flag-title":"Economy","flag-slug":"economy"},{"flag-title":"Data science","flag-slug":"data-science","parent-topic-slug":"data"},{"flag-title":"Design and Business","flag-slug":"design-and-business","parent-topic-slug":"design"},{"flag-title":"Data perils","flag-slug":"data-perils","parent-topic-slug":"data"},{"flag-title":"Data design","flag-slug":"data-design","parent-topic-slug":"data"},{"flag-title":"Data","flag-slug":"data"},{"flag-title":"Data culture","flag-slug":"data-culture","parent-topic-slug":"data"},{"flag-title":"Software Engineering","flag-slug":"software-engineering"},{"flag-title":"Data Tools","flag-slug":"data-tools","parent-topic-slug":"data"},{"flag-title":"Design","flag-slug":"design"},{"flag-title":"Artificial intelligence","flag-slug":"artificial-intelligence","parent-topic-slug":"data"}];

    // Add metrics, using a different write key for dev than for prod
    injectSegment(tempData.segment_write)

    $(function() {
      app.metrics = new orm.Metrics();
      app.metrics.pageView();

      app.pageInit(tempData);

      // load data into events so it dispatched 'data:loaded'
      app.events.addData(tempData);
    })
  </script>

  <!-- Start Visual Website Optimizer Asynchronous Code -->
  <script type='text/javascript'>
    var _vwo_code=(function(){
    var account_id=244658,
    settings_tolerance=2000,
    library_tolerance=2500,
    use_existing_jquery=false,
  // DO NOT EDIT BELOW THIS LINE
  f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
  </script>
  <!-- End Visual Website Optimizer Asynchronous Code -->

  <!-- Marketo -->
  <script src="https://app-ab24.marketo.com/js/forms2/js/forms2.min.js" type="text/javascript"></script>

</head>
<body class="body t-software-engineering" data-section="ideas" >
  <div class="flashes"></div>
    <header id="page-header">
  <div id="header-bar" class="t-bkg">
    <h1 class="logo t-bkg" >
  <a href="/" class=" logo-white ">
  <svg role="heading" aria-label="O'Reilly">
    <title>O'Reilly</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
  </svg>
  </a>
</h1>
    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>


    <div class="right">
      <div id="search" class="hide">
        <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
      </div>
      <div id="user">
        <a href="https://www.oreilly.com/sign-in.html" class="t-c--d">Sign In</a>
      </div>
    </div>
    <a id="menu-toggle" class="invert" ><span class="icon icon-white icon-menu">
  <svg role="img" id="close" class="is-hidden">
    <title>Close Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#close"></use>
  </svg>
  <svg role="img" id="open">
    <title>Open Menu</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#menu"></use>
  </svg>
</span></a>
  </div>
     <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/jupyter" >Jupyter</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

  
  <div id="mobile-menu">

    <nav>
              <a href="/ideas">Ideas</a>
              <a href="https://www.safaribooksonline.com/home/?utm_medium=content&amp;utm_source=oreilly.com&amp;utm_campaign=lgen&amp;utm_content=20170601+nav">Learning Platform</a>
              <a href="http://www.oreilly.com/conferences/">Conferences</a>
              <a href="http://shop.oreilly.com/">Shop</a>
      
    </nav>
    <form class="search-form expanded" action="https://ssearch.oreilly.com" method="GET" target="_blank">
  <label class="hide" for="text">Search </label> <input class="transparent" name="q" type="text" placeholder="Search..."/>
  <a class="search-cta"><span class="icon icon-search   ">
  <svg role="img">
    <title>search</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#search"></use>
  </svg>
</span></a>
  <input class="hide" type="submit" value="Submit"/>
</form>
         <div class="topics" >
  <div class="scrollable">
    <h3>On our radar</h3>
    <div class="topics-list">
              <div class="flag t-bkg--before bg-ai--before flag--xsmall">
  
            <a href="/topics/ai" >AI</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-business--before flag--xsmall">
  
            <a href="/topics/business" >Business</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/data" >Data</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-design--before flag--xsmall">
  
            <a href="/topics/design" >Design</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-economy--before flag--xsmall">
  
            <a href="/topics/economy" >Economy</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-data--before flag--xsmall">
  
            <a href="/topics/jupyter" >Jupyter</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-operations--before flag--xsmall">
  
            <a href="/topics/operations" >Operations</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-security--before flag--xsmall">
  
            <a href="/topics/security" >Security</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-software-engineering--before flag--xsmall">
  
            <a href="/topics/software-engineering" >Software Engineering</a>
    
    
  
</div>
              <div class="flag t-bkg--before bg-web-programming--before flag--xsmall">
  
            <a href="/topics/web-programming" >Web Programming</a>
    
    
  
</div>
      
    </div>
  </div>
      <a href="/topics" class="t-bkg all-topics">See all</a>
  
</div>

    
  </div>

</header>



  <!-- Linked In -->
  <script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
  
<!-- Load Facebook SDK for JavaScript -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<main aria-live="polite">
  <article class="article" itemscope itemtype="http://schema.org/Article">
              <header class="article-header">
      <div class="flag t-bkg--before bg-software-engineering--before flag--small">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
  
  

  <h1 class="title t-c" itemprop="headline">Kelsey Hightower and Chris Gaun on serverless and Kubernetes</h1>

      <p class="dek" itemprop="alternativeHeadline">Exploring use cases for the two tools.</p>
  

  <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/jeff-bleiel" itemprop="name">Jeff Bleiel</a></span>
</div> <time class="date">September 13, 2018</time>

</header>

      

      <div class="article-body" itemprop="articleBody">
        
                              <figure class="article-image right">
  <img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/cube-3457851_1920_crop-c1b9fbabaefa96d2fcec9ea219dfefc4.jpg" alt="Cubes" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/cube-3457851_1920_crop-c1b9fbabaefa96d2fcec9ea219dfefc4.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/cube-3457851_1920_crop-c1b9fbabaefa96d2fcec9ea219dfefc4.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/cube-3457851_1920_crop-c1b9fbabaefa96d2fcec9ea219dfefc4.jpg 1440w" sizes="(min-width: 1390px) 420px, (min-width: 600px) 45vw, 100vw" class=""/>
  <figcaption>Cubes
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://pixabay.com/en/cube-cubes-architecture-abstract-3457851/">Pixabay</a>)
        
        
      </span>
    
    
  <figcaption>

</figure>
          
          
        

        

        <p>This episode of the O’Reilly Podcast, features a conversation on serverless and Kubernetes, with <a href="https://twitter.com/kelseyhightower">Kelsey Hightower</a>, developer advocate for Google Cloud Platform at Google (and co-author of <a href="https://www.safaribooksonline.com/library/view/kubernetes-up-and/9781491935668/"><em>Kubernetes: Up and Running</em></a>), and <a href="https://twitter.com/gaunetes">Chris Gaun</a>, Kubernetes product marketing manager at <a href="https://mesosphere.com/">Mesosphere</a>.</p>

<p><iframe src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/499896831&amp;auto_play=false&amp;hide_related=false&amp;show_artwork=true" height="166" width="100%" frameborder="no" scrolling="no"></iframe></p>

<p><strong>Discussion points:</strong></p>


<ul>
<li>Hightower and Gaun agree that the biggest issue people face when deciding to start using Kubernetes is an underestimation of the learning curve.</li>



<li>Whether or not there is a competition between Kubernetes containers and serverless</li>



<li>Considerations when attempting to move an existing application to a serverless architecture</li>



<li>The new open source frameworks that work on Kubernetes (including <a href="https://kubeless.io/">Kubeless</a> and <a href="https://www.openfaas.com/">OpenFaaS</a>)</li>



<li>Workflow engines being used on top of Kubernetes (including <a href="https://www.kubeflow.org/">Kubeflow</a> and <a href="https://blog.argoproj.io/">Argo</a>)</li>



<li>Security issues regarding Kubernetes clusters</li>
</ul>




<p><em>This post is a collaboration between Mesosphere and O’Reilly. See our </em><a href="http://www.oreilly.com/about/editorial_independence.html"><em>statement of editorial independence</em></a>.</p>


        
                  
        

                  <div class="image-credit">
  Article image: Cubes
          <span class="source-name">
                  (source: <a class="secondary" target="_blank" href="https://pixabay.com/en/cube-cubes-architecture-abstract-3457851/">Pixabay</a>).
        
        
      </span>
    
    
</div>
        

        

      </div>

      <div class="article-meta">

  <div class="article-share">
  <div class="article-share-text"> Share </div>
  <ol>
    <li><a href="https://twitter.com/share" class="twitter-share-button" data-via="oreillymedia" data-show-count="false">Tweet</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></li>
    <li>  <div class="fb-share-button" 
    data-href="https://www.oreilly.com/ideas/kelsey-hightower-and-chris-gaun-on-serverless-and-kubernetes" 
    data-layout="button_count">
  </div></li>
    <li><script type="IN/Share" data-url="https://www.oreilly.com/ideas/kelsey-hightower-and-chris-gaun-on-serverless-and-kubernetes" data-counter="right"></script></li>
  </ol>
  <hr>
</div>

  

      <article class="block block-common with-img person with-link">
    <div class="thumb">
    <div class="features">
    
    </div>
        <a href="/people/jeff-bleiel"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x360/jeff_bleiel-8762164b77ecdba194ec914a974644eb.jpg" alt="Jeff Bleiel" srcset="https://d3ucjech6zwjp8.cloudfront.net/360x360/jeff_bleiel-8762164b77ecdba194ec914a974644eb.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x720/jeff_bleiel-8762164b77ecdba194ec914a974644eb.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x1440/jeff_bleiel-8762164b77ecdba194ec914a974644eb.jpg 1440w"  class=""/></a>
    
    
  </div>
  

  

  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/people/jeff-bleiel">Jeff Bleiel</a>
    
    
    </h2>
    

    
          <p class="dek">Jeff Bleiel is an editor at O’Reilly Media, and the host and producer of the O’Reilly Programming Podcast.
</p>

    
          <a class="btn btn--xsmall" style="float: right;" href="/people/jeff-bleiel">more</a>
    
  </div>
</article>

  

</div>


      <hr class="t-bkg section-divider" />


      <aside class="article-related">
      <section class="block-rows columns-4 ">

    

    <section class="block-group">
                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/ideas/walking-the-tightrope-balancing-bias-to-action-and-planning"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/1902_wright_glider_fly_crop-f4bb736dc0c311d88ccc346a010ca5cd.jpg" alt="The 1902 Wright Glider on one of its more than 700 flights." srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/1902_wright_glider_fly_crop-f4bb736dc0c311d88ccc346a010ca5cd.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/1902_wright_glider_fly_crop-f4bb736dc0c311d88ccc346a010ca5cd.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/1902_wright_glider_fly_crop-f4bb736dc0c311d88ccc346a010ca5cd.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-software-engineering--before">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/walking-the-tightrope-balancing-bias-to-action-and-planning">Walking the tightrope: Balancing bias to action and planning</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/4a34a-dianne-marsh" itemprop="name">Dianne Marsh</a></span>
</div>
    
          <p class="dek">Dianne Marsh explains how microservices paved the way for traffic steering at Netflix, and she highlights current challenges. </p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/ideas/confessions-of-an-enterprise-architect"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/artgate_fondazione_cariplo_-_molteni_giuseppe,_la_confessione_crop-7d71e479a53b75c3ed13c47d59219a2b.jpg" alt="&#34;The Confession,&#34; by Giuseppe Molteni, 1838." srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/artgate_fondazione_cariplo_-_molteni_giuseppe,_la_confessione_crop-7d71e479a53b75c3ed13c47d59219a2b.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/artgate_fondazione_cariplo_-_molteni_giuseppe,_la_confessione_crop-7d71e479a53b75c3ed13c47d59219a2b.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/artgate_fondazione_cariplo_-_molteni_giuseppe,_la_confessione_crop-7d71e479a53b75c3ed13c47d59219a2b.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-software-engineering--before">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/confessions-of-an-enterprise-architect">Confessions of an enterprise architect</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/dd9b0-scott-shaw" itemprop="name">Scott Shaw</a></span>
</div>
    
          <p class="dek">Faced with business and regulatory complexity, Scott Shaw found himself committing some of the software development acts he once condemned. He confesses those sins and explains why they’re sometimes necessary.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/ideas/listening-to-the-design-pressures-software-architecture-san-francisco-2016"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/7646172924_21751d1df6_o_crop-dcb6a2398267b3a8e315a9426ae53a01.jpg" alt="Listening in." srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/7646172924_21751d1df6_o_crop-dcb6a2398267b3a8e315a9426ae53a01.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/7646172924_21751d1df6_o_crop-dcb6a2398267b3a8e315a9426ae53a01.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/7646172924_21751d1df6_o_crop-dcb6a2398267b3a8e315a9426ae53a01.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-software-engineering--before">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/listening-to-the-design-pressures-software-architecture-san-francisco-2016">Listening to the design pressures</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/9280b-martin-thompson" itemprop="name">Martin Thompson</a></span>
</div>
    
          <p class="dek">Martin Thompson explores the architectures that emerge from applying design patterns required for high performance, resilience, security, usability, and other quality-of-services measures.</p>

    
    
  </div>
</article>

                <article class="block block-common with-img inset-flag">
    <div class="thumb">
    <div class="features">
          <div class="feature">
        <span class="name">Video</span>
        <span class="icon icon-play t-fill">
  <svg role="img">
    <title>play</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#play"></use>
  </svg>
</span>
      </div>
    
    </div>
        <a href="/ideas/microservices-at-netflix-teams-and-services-are-tightly-aligned-and-loosely-coupled"><img src="https://d3ucjech6zwjp8.cloudfront.net/360x240/soft-eng-hooks-on-fence-crop-33f7e78e18898d8966b72c330080f6b6.jpg" alt="Hooks on a fence." srcset="https://d3ucjech6zwjp8.cloudfront.net/360x240/soft-eng-hooks-on-fence-crop-33f7e78e18898d8966b72c330080f6b6.jpg 360w, https://d3ucjech6zwjp8.cloudfront.net/720x480/soft-eng-hooks-on-fence-crop-33f7e78e18898d8966b72c330080f6b6.jpg 720w, https://d3ucjech6zwjp8.cloudfront.net/1440x960/soft-eng-hooks-on-fence-crop-33f7e78e18898d8966b72c330080f6b6.jpg 1440w" sizes="(min-width: 1390px) 310px, (min-width: 1000px) 25vw, (min-width: 600px) 50vw, 100vw" class=""/></a>
    
    
  </div>
  

  

      <div class="flag t-bkg--before flag--inset bg-software-engineering--before">
  
            <a href="/topics/software-architecture" >Software Architecture</a>
    
    
  
</div>
  

  <div class="text-group">
    

        <h2 class="block-title">
          <a href="/ideas/microservices-at-netflix-teams-and-services-are-tightly-aligned-and-loosely-coupled">Microservices at Netflix: Teams and services are tightly aligned and loosely coupled</a>
    
    
    </h2>
    

          <div class="byline">
  By <span class="author" itemscope itemtype="http://schema.org/Person"><a href="/people/0d2c1-mac-slocum" itemprop="name">Mac Slocum</a></span>
</div>
    
          <p class="dek">An interview with Dianne Marsh, Director of Engineering, Cloud Tools, at Netflix.</p>

    
    
  </div>
</article>

      
  	</section>
    

</section>
  
</aside>

  </article>
</main>








  <footer role="contentinfo">
  <div class="footer-inner">

    <div class="about-us">
      <h3 class="title">About Us</h3>
      <ul>
        <li><a href="http://oreilly.com/about/">Our Company</a></li>
        <li><a href="http://oreilly.com/work-with-us.html">Teach/Speak/Write</a></li>
        <li><a href="http://oreilly.com/careers/">Careers</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Customer Service</a></li>
        <li><a href="http://shop.oreilly.com/category/customer-service.do">Contact Us</a></li>
      </ul>
    </div>
    <div class="site-map">
      <h3 class="title">Site Map</h3>
      <ul>
        <li><a href="/ideas">Ideas</a></li>
        <li><a href="/topics/oreilly-learning">Learning</a></li>
        <li><a href="/topics">Topics</a></li>
        <li><a href="/all">All</a></li>
      </ul>
    </div>
    <div class="social">
      <ul>
        <li><a   class="icon-link " href="https://www.facebook.com/OReilly/"><span class="icon icon-facebook t-fill icon--white icon--large">
  <svg role="img">
    <title>facebook</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#facebook"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://twitter.com/oreillymedia"><span class="icon icon-twitter t-fill icon--white icon--large">
  <svg role="img">
    <title>twitter</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#twitter"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.youtube.com/user/OreillyMedia"><span class="icon icon-youtube-large t-fill icon--white icon--large">
  <svg role="img">
    <title>youtube-large</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#youtube-large"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://plus.google.com/+oreillymedia"><span class="icon icon-google t-fill icon--white icon--large">
  <svg role="img">
    <title>google</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#google"></use>
  </svg>
</span></a>
</li><li><a   class="icon-link " href="https://www.linkedin.com/company/oreilly-media"><span class="icon icon-linkedin t-fill icon--white icon--large">
  <svg role="img">
    <title>linkedin</title>
    <use xlink:href="/assets/icons-8812ab3f83.svg#linkedin"></use>
  </svg>
</span></a>
</li>
      </ul>
    </div>
  </div>
  <div class="legal">
	  <a href="/" class="logo logo-block t-bkg logo--medium">
<svg>
   <use xlink:href="/assets/icons-8812ab3f83.svg#oreilly-logo"></use>
</svg>
</a>
  	<p class="copyright">&copy; 2018 O'Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p><br>
  <a class="t-c" href="http://oreilly.com/terms/">Terms of Service</a>  <span class="bullet">&bull;</span>	<a class="t-c" href="http://oreilly.com/privacy.html">Privacy Policy</a> <span class="bullet">&bull;</span> <a class="t-c" href="http://www.oreilly.com/about/editorial_independence.html">Editorial Independence</a>
	</div>
	<figure class="animal"><img src="https://d3ebicv0uqgr7t.cloudfront.net/images/tarsier.png" class="animal-img" alt="Animal"></figure>
</footer>



  
  

    <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5P4V6Z"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
  

  
</body>
</html>
