O'Reilly logo

ActionScript 3.0 Bible by Roger Braunstein

Stay ahead with the world's most comprehensive technology and business learning platform.

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, tutorials, and more.

Start Free Trial

No credit card required

Introduction

Hello! Welcome to the Second Edition of ActionScript 3.0 Bible. This book aims to be a comprehensive resource on all things ActionScript 3.0. You can use it as an instructional textbook, as a reference book, or both. The Bible introduces concepts used in ActionScript 3.0 with both background information and real-world examples to enrich your understanding. Armed with the knowledge contained herein, you will be able to bring your ideas to life with ActionScript 3.0, whether they are applications, mobile apps, web sites, presentations, games, toys, art, or experiments.

ActionScript 3.0 is the language used in a range of tools developed by Adobe, including Flash Professional, the Flex framework, Flash Builder (formerly Flex Builder), AIR, and Flash Lite 4. This book's coverage remains agnostic of the tool you choose to use. In general, it will not cover topics specific to a single tool, but it will cover the commonality they all share: ActionScript 3.0. When something is handled differently between different tools, I let you know how. Accordingly, this is the right book for you to learn how to program with any of these tools.

What's New in This Edition

This book, the second edition of ActionScript 3.0 Bible, is the result of countless hours of revising, writing, drawing, editing, and yes, programming. I've exhaustively and repeatedly gone over the first edition, as well as feedback from readers, to make what I hope is the most comprehensive, easy-to-use, and up-to-date ActionScript ...

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, interactive tutorials, and more.

Start Free Trial

No credit card required