Installing on Windows

First, you need to install Ruby using the RubyInstaller for Windows package.[13] At the time of this writing, the latest version of Ruby available via RubyInstaller is Ruby 2.3.3. While Rails recommends Ruby version 2.4, this version will work with Rails 5.

Installing Ruby takes a few steps: first you need to install the base language and then the development kit.

Base installation is a snap. After you click Save/Download, click Run and then click OK. Select “I accept the License” (after reading it carefully, of course) and then click Next. Select “Add Ruby executables to your PATH,” click Install (see the following screenshot), and then click Finish.

Download and extract the development kit for Ruby 2.0 and ...

Get Agile Web Development with Rails 5.1 now with O’Reilly online learning.

O’Reilly members experience live online training, plus books, videos, and digital content from 200+ publishers.