O'Reilly logo

Apache Derby—Off to the Races: Includes Details of IBM® Cloudscape™ by Dan Scott, George Baklarz, Paul C. Zikopoulos

Stay ahead with the world's most comprehensive technology and business learning platform.

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, tutorials, and more.

Start Free Trial

No credit card required

Migration from Previous Versions of Cloudscape

Apache Derby and IBM Cloudscape Version 10.0 do not support the automatic upgrade of databases from previous versions of Cloudscape. The IBM Cloudscape database engine and SQL API have been rewritten so that applications built on these platforms are fully compatible with IBM DB2 Universal Database for Linux, UNIX, and Windows Version 8.1. For information on migrating databases created with previous versions of Cloudscape, see http://publib.boulder.ibm.com/epubs/html/c1894710.html.

If you have an existing pre-Version 10.0 installation of Cloudscape installed on your machine, do not install IBM Cloudscape Version 10.0 on top of it. You must uninstall the previous version of the product by running the ...

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, interactive tutorials, and more.

Start Free Trial

No credit card required