What you need for this book

Drupal 7 requires PHP 5.2.5 or higher to run the Drupal code. You will also need one of the following databases to run Drupal 7:

  • MySQL version 5.0.15 or 5.1.30 or higher
  • PostgreSQL 8.3 or later
  • SQLite 3.4.2 or later

You can use Apache HTTP, Nginx, or Microsoft IIS for the web server.

We recommend you to use a GNU/Linux, Apache, MySQL, and PHP setup, also known as LAMP, for best performance and community support.

Get Drupal 7 Media now with O’Reilly online learning.

O’Reilly members experience live online training, plus books, videos, and digital content from 200+ publishers.