<!DOCTYPE html>
<!--[if lt IE 10]><html class="no-js ie8 oldie" lang="en" prefix="og: http://ogp.me/ns/# og:book: http://ogp.me/ns/book# og:video: http://ogp.me/ns/video#"

  
    itemscope itemtype="http://schema.org/Book http://schema.org/CollectionPage" data-offline-url="/"
data-url="/library/view/football-analytics-with/9781492099611/"
data-reading-url="/library/view/football-analytics-with/9781492099611/ch01.html"
data-archive="9781492099611"
data-publishers="O&#x27;Reilly Media, Inc."

  
    data-book-overview="true"
  



data-federated-auth-enabled="true"

data-env="production"
data-debug="0" ><![endif]-->
<!--[if gt IE 9]><!--><html class="no-js" lang="en" prefix="og: http://ogp.me/ns/# og:book: http://ogp.me/ns/book# og:video: http://ogp.me/ns/video#"

  
    itemscope itemtype="http://schema.org/Book http://schema.org/CollectionPage" data-offline-url="/"
data-url="/library/view/football-analytics-with/9781492099611/"
data-reading-url="/library/view/football-analytics-with/9781492099611/ch01.html"
data-archive="9781492099611"
data-publishers="O&#x27;Reilly Media, Inc."

  
    data-book-overview="true"
  



data-federated-auth-enabled="true"

data-env="production"
data-debug="0" ><!--<![endif]-->
<head>
    <meta charset="UTF-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />
    <title>Football Analytics with Python &amp; R [Book]</title>
    <meta name="viewport" content="width=device-width, initial-scale=1" />
    <link rel="stylesheet" href="/library/view/static/CACHE/css/output.94bb4b1f410f.css" type="text/css">
    <link href='//fonts.googleapis.com/css?family=Source+Sans+Pro' rel='stylesheet' type='text/css' />
    <link rel="stylesheet" type="text/css" href="https://cdn.oreillystatic.com/assets/css/2018_font_face.css" />
    

    <meta property="og:title" content="Football Analytics with Python &amp; R" />
    <meta itemprop="name" content="Football Analytics with Python &amp; R" />
    
    <meta property="og:url" itemprop="url" content="https://www.oreilly.com/library/view/football-analytics-with/9781492099611/" />
    <meta property="og:site_name" content="O’Reilly Online Learning" />
    <meta property="og:image" itemprop="thumbnailUrl" content="https://www.oreilly.com/library/cover/9781492099611/" />
    
    <meta property="og:image:secure_url" itemprop="thumbnailUrl" content="https://learning.oreilly.com/library/cover/9781492099611/360h/">
    <meta property="og:description" itemprop="description" name="description" content="Baseball is not the only sport to use &quot;moneyball.&quot; American football fans, teams, and gamblers are increasingly using data to gain an edge against the competition. Professional and college teams …  - Selection from Football Analytics with Python &amp; R [Book]">
    
    <meta itemprop="inLanguage" content="en" />
    
    <meta itemprop="publisher" content="O&#x27;Reilly Media, Inc." />
    
    <meta property="og:type" content="article" />
    <meta property="og:book:isbn" itemprop="isbn" content="9781492099567" />
    
    <meta property="og:book:author" itemprop="author" content="Eric A. Eager" />
    <meta property="og:book:author" itemprop="author" content="Richard A. Erickson" />
    
    
    
    
    <meta property="og:image:width" content="400">
    <meta property="og:image:height" content="400">
    <meta name="twitter:card" content="summary">
    <meta name="twitter:site" content="@OReillyMedia">

<!-- Start Visual Website Optimizer Asynchronous Code -->
<script type='text/javascript'>
var _vwo_code=(function(){
var account_id=291788,
settings_tolerance=2000,
library_tolerance=2500,
use_existing_jquery=false,
/* DO NOT EDIT BELOW THIS LINE */
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
</script>
<!-- End Visual Website Optimizer Asynchronous Code -->

    <link class="t-canonical-link" rel="canonical" href="https://www.oreilly.com/library/view/football-analytics-with/9781492099611/" />

    <link rel="shortcut icon" href="//www.oreilly.com/favicon.ico" type="image/vnd.microsoft.icon" />
    <link rel="apple-touch-icon" href="/library/view/static/images/apple-touch-icon.png" />
    

</head>
<body class="js-preview-content  ">


<div class="skipToMain" id="skipToMain"><a href="#maincontent"><span class="skipToMain-text">Skip to main content</span></a></div>
<header role="banner" class="global">
  <div class="global-nav">
    <div class="content">
      <nav role="navigation" aria-label="site sections">
        <a href="https://www.oreilly.com" class="logo" title="home page" aria-current="page"><img src="https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red.svg" onerror="this.src='https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red_@2x.png'; this.onerror=null;" alt="O'Reilly home"></a>

        <button id="mobileNavButton" class="mobileNavButton mobileNavButton--collapse mobileNavButton--3dx" type="button" aria-expanded="false" aria-controls="menuList">
          <span class="mobileNavButton-box">
            <span class="mobileNavButton-inner"></span>
          </span>
        </button>


        <ul id="menuList" class="menuList mobileHidden ">
          <li class="menuList-itemsP1">
            <ul>
              
  <li class="menuList-item menuList-signIn"><a class="t-sign-in" href="/member/login/?next=/library/view/football-analytics-with/9781492099611/">Sign In</a></li>


              <li class="menuList-item menuList-tryNow"><a class="menuList-cta" href="https://learning.oreilly.com/p/register/">Try Now</a></li>
            </ul>
          </li>
          <li class="menuList-itemsP2">
            <ul>
              <li class="menuList-item menuList-itemWithSub"><a href="https://www.oreilly.com/online-learning/teams.html">Teams</a>
                <ul class="menuList-subList menuList-itemWithSub">
                  <li class="menuList-subItem menuList-extra"><a href="https://www.oreilly.com/online-learning/business.html">For business</a></li>
                  <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/government.html">For government</a></li>
                  <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/academic.html">For higher ed</a></li>
                </ul>
              </li>
              <li class="menuList-item"><a href="https://www.oreilly.com/online-learning/individuals.html">Individuals</a></li>
              <li class="menuList-item menuList-itemWithSub"><a href="https://www.oreilly.com/online-learning/features.html">Features</a>
                <ul class="menuList-subList">
                  <li class="menuList-subItem menuList-extra"><a href="https://www.oreilly.com/online-learning/features.html">All features</a></li>
                  <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/feature-certification.html">Certifications</a></li>
                  <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/intro-interactive-learning.html">Interactive learning</a></li>
                  <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/live-events.html">Live events</a></li>
                  <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/feature-answers.html">Answers</a></li>
                  <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/insights-dashboard.html">Insights reporting</a></li>
                </ul>
              </li>
              <li class="menuList-item"><a href="https://www.oreilly.com/radar/">Blog</a></li>
              <li class="menuList-item" id="nav-forMarketers"><a href="https://www.oreilly.com/content-marketing-solutions.html">Content sponsorship</a></li>
            </ul>
          </li>
        </ul>
      </nav>
    </div>
  </div>


  <div class="global-search">
    <div id="globalSearchContent" class="content">
      <form id="js-search-form" class="t-navigation-form" action="https://learning.oreilly.com/search/">
        
        <script type="application/ld+json">
        {
          "@context": "http://schema.org",
          "@type": "WebSite",
          "url": "https://learning.oreilly.com",
          "potentialAction": {
            "@type": "SearchAction",
            "target": "https://learning.oreilly.com/search/?q={search_term_string}",
            "query-input": "required name=search_term_string"
          }
        }
        </script>
        <input data-search-text-focus= "See everything available through the O’Reilly learning platform and start a free trial. Explore now." data-search-text-idle = "See everything available through the O’Reilly learning platform and start a free trial. Explore now." id="search" type="search" name="query" placeholder="See everything available through the O’Reilly learning platform and start a free trial. Explore now." autocomplete="off" required />
        <input type="submit" value="Search" class="search-submit" />
      </form>
    </div>
  </div>
</header>

    
    


</header>


<section id="trial-overlay">
  <div class="trial-overlay-content">
    <p>Get full access to <em>Football Analytics with Python &amp; R</em> and 60K+ other titles, with free 10-day trial of O'Reilly.</p>

    <p>There's also live online events, interactive content, certification prep materials, <span class="nowrap">and more.</span></p>

    <div class="controls">
      <a href="https://learning.oreilly.com/p/register/" class="button-primary" data-ga-label="Bottom CTA">Start your free trial</a>
    </div>
    <a class="modal-dismiss" aria-label="modal dismiss"></a>
  </div>
</section>

<main role="main" id="maincontent">
  <div role="document" class="document">
  	


<section id="sbo-reader" class="sbo-reader-title">
  <div class="title-info">
    <div class="content">
      <figure class="t-cover">
        <img class="t-cover-img" src="https://learning.oreilly.com/library/cover/9781492099611/250w/" alt="Football Analytics with Python &amp; R"/>
      </figure>

      <div class="metadata">
        <h1 class="t-title">Football Analytics with Python &amp; R</h1>
        

        <div class="t-authors">by <span class="author-name">Eric A. Eager</span>, <span class="author-name">Richard A. Erickson</span></div>
        <div class="t-release-date">Released October 2023</div>
        <div class="t-publisher">Publisher(s): O&#x27;Reilly Media, Inc.</div>
        <div class="t-isbn">ISBN: 9781492099567</div>

        <div id="titlePromo">
          <p class="t-promo">Read it now on the O’Reilly learning platform with a 10-day <span class="nowrap">free trial.</span></p>

          <p class="t-promo">O’Reilly members get unlimited access to live online training experiences, plus books, videos, and digital content from O’Reilly and nearly 200 trusted <span class="nowrap">publishing partners.</span></p>
        </div>

        <div class="controls">
        
          <a href="https://learning.oreilly.com/p/register/" id="startTrial" class="button-primary">Start <span class="mobile-hide">your</span> free trial</a>
        
        </div>

        <div id="next-edition">
        
        </div>
      </div>
    </div>
  </div>

  <div class="title-description t-description sbo-reader-content">
    <div class="content">
      <h2 class="t-description-heading">Book description</h2>
      <span><div><p>Baseball is not the only sport to use "moneyball." American football fans, teams, and gamblers are increasingly using data to gain an edge against the competition. Professional and college teams use data to help select players and identify team needs. Fans use data to guide fantasy team picks and strategies. Sports bettors and fantasy football players are using data to help inform decision making. This concise book provides a clear introduction to using statistical models to analyze football data.</p><p>Whether your goal is to produce a winning team, dominate your fantasy football league, qualify for an entry-level football analyst position, or simply learn R and Python using fun example cases, this book is your starting place. You'll learn how to:</p><ul><li>Apply basic statistical concepts to football datasets</li><li>Describe football data with quantitative methods</li><li>Create efficient workflows that offer reproducible results</li><li>Use data science skills such as web scraping, manipulating data, and plotting data</li><li>Implement statistical models for football data</li><li>Link data summaries and model outputs to create reports or presentations using tools such as R Markdown and R Shiny</li><li>And more</li></ul></div></span>

      <div id="showMoreDescription" class="showMore hidden"><button class="more"><span class="screen-reader-text">Show and hide more</span></button></div>

      
      <div id="publisher_resources" class="publisher-resources">
        <h2 class="t-description-heading">Publisher resources</h2>
          <p><a href="http://oreilly.com/catalog/0636920705727/errata">View/Submit Errata</a></p>
          
      </div>
      

      <div id="toc-start"></div>
    </div>
  </div>

  <div id="title-tabs" class="title-tabs"><button id="title-tab-toc" class="title-tab title-tab-active" data-target="toc">Table of contents</button><button id="title-tab-pi" class="title-tab" data-target="product-information">Product information</button></div>

  <div class="title-toc" id="toc">
    <div class="content">
      <h2>Table of contents</h2>

      <ol class="detail-toc">
          

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch01.html#chapter_intro" class="t-chapter js-chapter">1. Introducing to Python and R</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch01.html#idm46525770291456" class="t-chapter js-chapter">Tools for Football Analytics</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch01.html#idm46525768143392" class="t-chapter js-chapter">The Python Language</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch01.html#idm46525771014368" class="t-chapter js-chapter">The R Language</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch01.html#idm46525770290864" class="t-chapter js-chapter">First Steps in Python and R</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch01.html#idm46525761570304" class="t-chapter js-chapter">Scripts and Integrated Development Environments</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch01.html#idm46525767649600" class="t-chapter js-chapter">Overview of Datasets</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch01.html#idm46525761486480" class="t-chapter js-chapter">Suggested Reading</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch02.html#chapter_eda" class="t-chapter js-chapter">2. Exploratory Data Analysis</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch02.html#idm46525761461712" class="t-chapter js-chapter">Motivating Problem: How Do We “See” or Explore Passing Data?</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch02.html#idm46525761460800" class="t-chapter js-chapter">Applying EDA</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch02.html#idm46525761312912" class="t-chapter js-chapter">Histograms</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch02.html#idm46525761312000" class="t-chapter js-chapter">Boxplots</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch02.html#idm46525761137456" class="t-chapter js-chapter">Scatterplots</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch02.html#idm46525760984464" class="t-chapter js-chapter">Colors and shapes</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch02.html#idm46525760765232" class="t-chapter js-chapter">Application of plotting options</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch02.html#idm46525760477088" class="t-chapter js-chapter">Advanced plotting and customization</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch02.html#idm46525760310960" class="t-chapter js-chapter">Exercises with your data</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch02.html#idm46525760249808" class="t-chapter js-chapter">Suggested Reading</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch03.html#chapter_data_aquire" class="t-chapter js-chapter">3. Acquiring and reading in data</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch03.html#idm46525760228336" class="t-chapter js-chapter">Reading data into a computer</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch03.html#idm46525760227392" class="t-chapter js-chapter">Verifying data is correct</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch03.html#idm46525759466752" class="t-chapter js-chapter">Common problems</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch03.html#idm46525759444352" class="t-chapter js-chapter">Obtaining data from the web</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch03.html#idm46525759070832" class="t-chapter js-chapter">for loops</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch03.html#idm46525759027808" class="t-chapter js-chapter">Web scrapping with Python</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch03.html#idm46525759026256" class="t-chapter js-chapter">Web-scrapping in R</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch03.html#idm46525758413184" class="t-chapter js-chapter">Closing remarks on web scrapping</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch03.html#chp_03_refs" class="t-chapter js-chapter">Suggested reading</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch03.html#idm46525758038096" class="t-chapter js-chapter">Exercises</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch04.html#chapter_data_wrangling" class="t-chapter js-chapter">4. Data wrangling</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch04.html#idm46525757996480" class="t-chapter js-chapter">Logical operators</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch04.html#idm46525757994928" class="t-chapter js-chapter">Filtering and sorting data</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch04.html#idm46525757144048" class="t-chapter js-chapter">Cleaning</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch04.html#idm46525757109456" class="t-chapter js-chapter">Checking and cleaning data for outliers</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch04.html#idm46525756726976" class="t-chapter js-chapter">Merging multiple datasets</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch04.html#idm46525755615168" class="t-chapter js-chapter">Exercises</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch04.html#idm46525755484560" class="t-chapter js-chapter">Suggested reading</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch05.html#chapter_summary_stats" class="t-chapter js-chapter">5. Summary Statistics</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch05.html#idm46525755460192" class="t-chapter js-chapter">Basic statistics</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch05.html#idm46525755459184" class="t-chapter js-chapter">Averages</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch05.html#idm46525755458208" class="t-chapter js-chapter">Range and distribution</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch05.html#idm46525755358256" class="t-chapter js-chapter">Uncertainty around estimates</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch05.html#idm46525755297744" class="t-chapter js-chapter">Calculating summary statistics with Python and R</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch05.html#idm46525755296832" class="t-chapter js-chapter">Presenting summary statistics</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch05.html#idm46525754653616" class="t-chapter js-chapter">Exercises</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch05.html#idm46525754605472" class="t-chapter js-chapter">Future readings</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch06.html#chapter_lm" class="t-chapter js-chapter">6. Linear models</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch06.html#idm46525754567808" class="t-chapter js-chapter">Total passing yards</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch06.html#idm46525754567472" class="t-chapter js-chapter">Intercept only models</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch06.html#idm46525754426048" class="t-chapter js-chapter">Global intercept</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch06.html#idm46525754425072" class="t-chapter js-chapter">Multiple intercepts</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch06.html#idm46525754033744" class="t-chapter js-chapter">Design matrix</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch06.html#sec_slope_intercept" class="t-chapter js-chapter">Slopes and intercepts</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch06.html#idm46525753597440" class="t-chapter js-chapter">Residuals</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch06.html#sec_trans_and_norm" class="t-chapter js-chapter">Transformations</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch06.html#idm46525753168000" class="t-chapter js-chapter">Case Study: Score Through Years</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch06.html#idm46525752617248" class="t-chapter js-chapter">Exercises</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/ch06.html#future_reading_regression" class="t-chapter js-chapter">Further reading</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/football-analytics-with/9781492099611/colophon01.html#idm46525754595008" class="t-chapter js-chapter">About the Authors</a>
      
    
    
  </li>


      </ol>

      <div id="showMoreTOC" class="showMore hidden"><button class="more"><span class="screen-reader-text">Show and hide more</span></button></div>
    </div>
  </div>

  <div id="product-information" class="title-product-information">
    <div class="content">
      <h2>Product information</h2>

      <ul class="detail-product-information">
        <li><span class="name">Title:</span> <span class="value">Football Analytics with Python &amp; R</span></li>
        <li><span class="name">Author(s):</span> <span class="value authors">Eric A. Eager, Richard A. Erickson</span></li>
        <li><span class="name">Release date:</span> <span class="value">October 2023</span></li>
        <li><span class="name">Publisher(s):</span> <span class="value t-publishers">O&#x27;Reilly Media, Inc.</span></li>
        <li><span class="name">ISBN:</span> <span class="value t-isbn">9781492099567</span></li>
      </ul>
    </div>
  </div>


  
  <div class="title-recommendations" id="recommendations">
    <div class="content">
      <h2 class="t-recommendations-heading">You might also like</h2>

      <div class="recommendations">
      
        <a id="recommendation1" class="recommendations-item" href="https://learning.oreilly.com/videos/python-fundamentals/9780135917411" data-id="9780135917411">
          <figure class="recommendations-cover" style="background-image:url(https://learning.oreilly.com/library/cover/9780135917411//300h/)"></figure>
          <p class="recommendations-format recommendations-format-video">video</p>
          <h3 class="recommendations-title">Python Fundamentals</h3>
          <p class="recommendations-authors">
            by
            
              Paul J. Deitel
            
          </p>
          <p class="recommendations-description">51+ hours of video instruction. Overview The professional programmer’s Deitel® video guide to Python development with …</p>
        </a>
      
        <a id="recommendation2" class="recommendations-item" href="https://learning.oreilly.com/library/view/clean-code-a/9780136083238/" data-id="9780136083238">
          <figure class="recommendations-cover" style="background-image:url(https://learning.oreilly.com/library/cover/9780136083238//300h/)"></figure>
          <p class="recommendations-format recommendations-format-book">book</p>
          <h3 class="recommendations-title">Clean Code: A Handbook of Agile Software Craftsmanship</h3>
          <p class="recommendations-authors">
            by
            
              Robert C. Martin
            
          </p>
          <p class="recommendations-description">Even bad code can function. But if code isn&#x27;t clean, it can bring a development organization …</p>
        </a>
      
        <a id="recommendation3" class="recommendations-item" href="https://learning.oreilly.com/library/view/40-algorithms-every/9781789801217/" data-id="9781789801217">
          <figure class="recommendations-cover" style="background-image:url(https://learning.oreilly.com/library/cover/9781789801217//300h/)"></figure>
          <p class="recommendations-format recommendations-format-book">book</p>
          <h3 class="recommendations-title">40 Algorithms Every Programmer Should Know</h3>
          <p class="recommendations-authors">
            by
            
              Imran Ahmad
            
          </p>
          <p class="recommendations-description">Learn algorithms for solving classic computer science problems with this concise guide covering everything from fundamental …</p>
        </a>
      
        <a id="recommendation4" class="recommendations-item" href="https://learning.oreilly.com/library/view/python-for-programmers/9780135231364/" data-id="9780135231364">
          <figure class="recommendations-cover" style="background-image:url(https://learning.oreilly.com/library/cover/9780135231364//300h/)"></figure>
          <p class="recommendations-format recommendations-format-book">book</p>
          <h3 class="recommendations-title">Python for Programmers, First Edition</h3>
          <p class="recommendations-authors">
            by
            
              Paul J. Deitel,
            
              Paul Deitel,
            
              Harvey Deitel
            
          </p>
          <p class="recommendations-description">The professional programmer&#x27;s Deitel® guide to Python® with introductory artificial intelligence case studies Written for programmers …</p>
        </a>
      
      </div>
    </div>
  </div>
  

</section>


  </div>
</main>


  <footer id="footer" class="footer">
  <div class="content">
    <div class="footer-main" aria-label="company info">
      <div class="footer-mainLeft">
        <div class="footer-mainLeftOne">
          <div class="footer-approach">
            <h2 class="footer-header"><a href="https://www.oreilly.com/about/">About O’Reilly</a></h2>
            <ul class="footer-links">
              <li><a href="https://www.oreilly.com/work-with-us.html">Teach/write/train</a></li>
              <li><a href="https://www.oreilly.com/careers/">Careers</a></li>
              <li><a href="https://www.oreilly.com/partner/signup.csp">Community partners</a></li>
              <li><a href="https://www.oreilly.com/affiliates/">Affiliate program</a></li>
              <li><a href="https://www.oreilly.com/online-learning/rfp.html">Submit an RFP</a></li>
              <li><a href="https://www.oreilly.com/diversity/">Diversity</a></li>
              <li><a href="https://www.oreilly.com/content-marketing-solutions.html" id="footerSponsorshipLink">O’Reilly for marketers</a></li>
            </ul>
          </div>
        </div>
        <div class="footer-mainLeftTwo">
          <div class="footer-contact">
            <h2 class="footer-header"><a href="https://www.oreilly.com/online-learning/support/">Support</a></h2>

            <ul class="footer-links">
              <li><a href="https://www.oreilly.com/about/contact.html">Contact us</a></li>
              <li><a href="https://www.oreilly.com/emails/newsletters/">Newsletters</a></li>
              <li><a href="https://www.oreilly.com/privacy.html">Privacy policy</a></li>
            </ul>
          
            <a href="https://twitter.com/oreillymedia" target="_blank"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 400 400" style="enable-background:new 0 0 400 400;" xml:space="preserve"><style type="text/css">.st0{fill:#ee0000;}.st1{fill:#FFFFFF;}</style><g id="Red"><circle class="st0" cx="200" cy="200" r="200"/></g><g id="Logo__x2014__FIXED"><path class="st1" d="M163.4,305.5c88.7,0,137.2-73.5,137.2-137.2c0-2.1,0-4.2-0.1-6.2c9.4-6.8,17.6-15.3,24.1-25 c-8.6,3.8-17.9,6.4-27.7,7.6c10-6,17.6-15.4,21.2-26.7c-9.3,5.5-19.6,9.5-30.6,11.7c-8.8-9.4-21.3-15.2-35.2-15.2 c-26.6,0-48.2,21.6-48.2,48.2c0,3.8,0.4,7.5,1.3,11c-40.1-2-75.6-21.2-99.4-50.4c-4.1,7.1-6.5,15.4-6.5,24.2 c0,16.7,8.5,31.5,21.5,40.1c-7.9-0.2-15.3-2.4-21.8-6c0,0.2,0,0.4,0,0.6c0,23.4,16.6,42.8,38.7,47.3c-4,1.1-8.3,1.7-12.7,1.7 c-3.1,0-6.1-0.3-9.1-0.9c6.1,19.2,23.9,33.1,45,33.5c-16.5,12.9-37.3,20.6-59.9,20.6c-3.9,0-7.7-0.2-11.5-0.7 C110.8,297.5,136.2,305.5,163.4,305.5"/></g></svg></a>
            <a href="https://www.facebook.com/OReilly/" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>facebook-logo</title><path class="cls-1" d="M16.13,0A16.13,16.13,0,1,0,32.25,16.12,16.13,16.13,0,0,0,16.13,0Zm5.12,9.54H19.57a1.52,1.52,0,0,0-1.51,1.51v1.14h3.19v3.42H18.06V26.12H13.57V15.61H10.69V12.19h2.88v-2a4,4,0,0,1,4-4h3.65Z"/></svg></a>
            <a href="https://www.linkedin.com/company/oreilly-media" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>linkedin-logo</title><path class="cls-1" d="M17.43,13.53v0l0,0ZM16.12,0A16.13,16.13,0,1,0,32.25,16.12,16.12,16.12,0,0,0,16.12,0ZM11.77,22.92H8.12v-11h3.65ZM9.94,10.44h0a1.89,1.89,0,0,1-2-1.89A1.91,1.91,0,0,1,10,6.65a1.9,1.9,0,1,1,0,3.79Zm15,12.48H21.28V17.05c0-1.48-.53-2.49-1.85-2.49a2,2,0,0,0-1.88,1.34,2.63,2.63,0,0,0-.12.89v6.13H13.79s.05-10,0-11h3.64V13.5a3.63,3.63,0,0,1,3.29-1.82c2.4,0,4.21,1.57,4.21,4.95Z"/></svg></a>
            <a href="https://www.youtube.com/user/OreillyMedia" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>youtube-logo</title><path class="cls-1" d="M18.35,18.68a.89.89,0,0,0-.86.63V16.94h-1v7.59h1v-.59a.92.92,0,0,0,.89.74c.52,0,.86-.36,1-1.07a8.56,8.56,0,0,0,.14-1.9,10.47,10.47,0,0,0-.12-1.93C19.21,19.05,18.87,18.68,18.35,18.68Zm.09,4.14c-.05.52-.2.77-.45.77s-.43-.21-.49-.63a7.22,7.22,0,0,1,0-1c0-.72,0-1.14,0-1.26.07-.58.23-.88.51-.88s.4.27.46.79c0,.09,0,.47,0,1.13S18.46,22.71,18.44,22.82ZM8.61,18.19H9.86v6.34H11V18.19H12.2V16.94H8.61Zm7.71-6.12c.27,0,.43-.22.49-.66,0-.09,0-.45,0-1.07V9.78c0-.58,0-.93,0-1-.07-.43-.23-.65-.48-.65s-.41.19-.48.57a8.79,8.79,0,0,0,0,1v.53c0,.71,0,1.09,0,1.16C15.88,11.82,16.05,12.07,16.32,12.07Zm-1.74,10.4a2.92,2.92,0,0,1-.06.71c-.07.25-.2.37-.4.37s-.32-.11-.38-.34a2.63,2.63,0,0,1-.05-.66V18.83h-1v4.48c0,.91.33,1.37,1,1.37A1,1,0,0,0,14.6,24v.57h1v-5.7h-1Zm7.1-3.79a1.35,1.35,0,0,0-1.22.59,2.48,2.48,0,0,0-.3,1.07c0,.23,0,.61,0,1.16s0,1.13,0,1.37a2.93,2.93,0,0,0,.35,1.27,1.25,1.25,0,0,0,1.14.54,1.36,1.36,0,0,0,1.13-.45,2.29,2.29,0,0,0,.37-1.43s0-.07,0-.11v-.12h-1c0,.75-.17,1.12-.51,1.12s-.38-.18-.45-.56a4.68,4.68,0,0,1-.06-.9c0-.18,0-.31,0-.37h2v-.43a4.86,4.86,0,0,0-.3-2.11A1.28,1.28,0,0,0,21.68,18.68ZM22.15,21h-1c0-.05,0-.11,0-.16v-.08a1.64,1.64,0,0,1,.11-.8.39.39,0,0,1,.38-.23.42.42,0,0,1,.43.33,2.32,2.32,0,0,1,.07.7Zm-6-21A16.13,16.13,0,1,0,32.25,16.12,16.12,16.12,0,0,0,16.12,0Zm2.51,7.2h1V11a2.52,2.52,0,0,0,.06.66c.06.23.18.34.38.34s.34-.12.41-.37a3.76,3.76,0,0,0,.05-.71V7.2h1v5.74h-1v-.57a1,1,0,0,1-.93.72c-.66,0-1-.46-1-1.38ZM15,8a1.29,1.29,0,0,1,1.33-.92A1.3,1.3,0,0,1,17.65,8a6.77,6.77,0,0,1,.23,2.1,6.77,6.77,0,0,1-.23,2.1,1.3,1.3,0,0,1-1.32.92A1.29,1.29,0,0,1,15,12.17a6.77,6.77,0,0,1-.23-2.1A6.86,6.86,0,0,1,15,8ZM11.45,5.3l.89,2.87.88-2.87H14.4L12.88,9.7v3.24h-1.1V9.7L10.24,5.3ZM24.93,23.91a3,3,0,0,1-3,3h-12a3,3,0,0,1-3-3V18.05a3,3,0,0,1,3-3h12a3,3,0,0,1,3,3Z"/></svg></a>
          </div>

          <div class="footer-international">
            <h2 class="footer-header">International</h2>

            <ul class="footer-links">
              <li><a href="https://www.oreilly.com/anz/">Australia &amp; New Zealand</a></li>
              <li><a href="https://oreilly.hk/">Hong Kong &amp; Taiwan</a></li>
              <li><a href="https://oreillylearning.in/">India</a></li>
              <li><a href="https://oreilly.id/">Indonesia</a></li>
              <li><a href="https://www.oreilly.co.jp/index.shtml">Japan</a></li>
            </ul>
          </div>
        </div>
      </div>

      <div class="footer-download" id="download-info">
        <h2 class="footer-header">Download the O’Reilly App</h2>
        <p>Take O’Reilly with you and learn anywhere, anytime on your phone <span class="nowrap">and tablet.</span></p>

        <div class="footer-downloadLinks">
          <a href="https://itunes.apple.com/us/app/safari-to-go/id881697395"><img src="https://cdn.oreillystatic.com/oreilly/images/app-store-logo.png" alt="Apple app store" /></a>
          <a href="https://play.google.com/store/apps/details?id=com.safariflow.queue"><img src="https://cdn.oreillystatic.com/oreilly/images/google-play-logo.png"  alt="Google play store" /></a>
        </div>
      </div>

      <div class="footer-download" id="tv-info">
        <h2 class="footer-header">Watch on your big screen</h2>
        <p>View all O’Reilly videos, Superstream events, and Meet the Expert sessions on your <span class="nowrap">home TV.</span></p>

        <div class="footer-downloadLinks">
          <a href="https://channelstore.roku.com/details/c8a2d0096693eb9455f6ac165003ee06/oreilly"><img src="https://cdn.oreillystatic.com/oreilly/images/roku-tv-logo.png" alt="Roku Payers and TVs" /></a>
          <a href="https://www.amazon.com/OReilly-Media-Inc/dp/B087YYHL5C/ref=sr_1_2?dchild=1&keywords=oreilly&qid=1604964116&s=mobile-apps&sr=1-2"><img src="https://cdn.oreillystatic.com/oreilly/images/amazon-appstore-logo.png"  alt="Amazon appstore" /></a>
        </div>
      </div>

      <div class="footer-donotsell" id="donotsell-info">
        <h2 class="footer-header"><a href="https://www.oreilly.com/privacy.html?donotsell=show">Do not sell my personal information</a></h2>
      </div>
    </div>

    <div class="footer-subfooter">

      <a href="https://www.oreilly.com" title="home page" aria-current="page">
        <img 
        class="footer-subfooterLogo" 
        id="footer-subfooterLogo"
        src="https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red.svg" 
        onerror="this.src='https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red_@2x.png'; this.onerror=null;" 
        alt="O'Reilly home">
      </a>

      <p>&copy; 2022, O’Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p>
      
      

      <p><a href="https://www.oreilly.com/terms/">Terms of service</a> • <a href="https://www.oreilly.com/privacy.html">Privacy policy</a> • <a href="https://www.oreilly.com/about/editorial_independence.html">Editorial independence</a></p>
    </div>

  </div>
</footer>



  <div class="exitIntentOverlay" id="exitIntentOverlay">
    <div class="exitIntentOverlay-contents">
      <div class="exitIntentOverlay-columns">
        <div class="exitIntentOverlay-text">
          <h2>Don’t leave <span class="nowrap">empty-handed</span></h2>

          <p>Get Mark Richards’s <em>Software Architecture Patterns</em> ebook to better understand how to design components—and how they should interact.</p>

          <h3>It’s yours, free.</h3>

          <a class="exitIntentOverlay-cta" href="https://get.oreilly.com/ind_software-architecture-patterns.html">Get it now</a>
        </div>

        <figure class="exitIntentOverlay-figure"><img src="https://cdn.oreillystatic.com/oreilly/images/report-software-architecture-patterns-553x420.jpg" alt="Cover of Software Architecture Patterns"></figure>
      </div>

      <button class="exitIntentOverlay-close">Close</button>
    </div>
  </div>






<script>
  var g = {
    
  };
</script>
<script>
  window.dataLayer = window.dataLayer || [];
  window.dataLayer.push({
    'product.title': "Football Analytics with Python & R",
    'product.type': "book",
    'product.identifier': "9781492099611",
    'content.identifier': "9781492099611",
    'content.publisher': "O'Reilly Media, Inc.",
    'content.free': "no",
    //
    'content.subdirectory': "none",
    'content.subTopic': "none",
    'content.parentTopic': "none",
    'content.formatType': "book",
    'content.author': "Eric A. Eager, Richard A. Erickson",
    'content.releaseDate': "2023-10-25",
    'content.title': "Football Analytics with Python & R",
  });
</script>

<script>
  // Datadog RUM integration to measure performance and Core Web Vitals
  // https://docs.datadoghq.com/real_user_monitoring/browser/#overview
  // https://web.dev/vitals/
  (function(h,o,u,n,d) {
    h=h[d]=h[d]||{q:[],onReady:function(c){h.q.push(c)}}
    d=o.createElement(u);d.async=1;d.src=n
    n=o.getElementsByTagName(u)[0];n.parentNode.insertBefore(d,n)
  })(window,document,'script','https://www.datadoghq-browser-agent.com/datadog-rum.js','DD_RUM')
  DD_RUM.onReady(function() {
    DD_RUM.init({
      clientToken: 'pub1221d36d3b6dfda5f3c3b7ed22e3b6af',
      applicationId: '291bce39-f950-4fc6-a610-10abfead0661',
      site: 'datadoghq.com',
      service:'anybird',
      env:'production',
      // Specify a version number to identify the deployed version of your application in Datadog 
      // version: '1.0.0',
      sampleRate: 10,
      trackInteractions: true,
    })
  })
</script>






<script src="/library/view/static/CACHE/js/output.5afb42632826.js"></script>


<noscript> 
  <iframe src="//www.googletagmanager.com/ns.html?id=GTM-5P4V6Z"
          height="0" width="0"
          style="display:none;visibility:hidden">
  </iframe>
</noscript>


<script async defer src="/library/view/pageview.js"></script>

<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.0/jquery.min.js"></script>

<script src="https://cdn.oreillystatic.com/assets/js/anybird/promotion.js"></script>


<script>
  //Exit intent overlay scripts

  //Setter and getter for exit intent cookie
  const ExitIntentCookieService = {
    setCookie(name, value, days) {
      let expires = '';
  
      if (days) {
        const date = new Date();
        date.setTime(date.getTime() + (days * 24 * 60 * 60 * 1000));
        expires = '; expires=' + date.toUTCString();
      }
  
      document.cookie = name + '=' + (value || '')  + expires + ';';
    },
  
    getCookie(name) {
      const cookies = document.cookie.split(';');
  
      for (const cookie of cookies) {
        if (cookie.indexOf(name + '=') > -1) {
          return cookie.split('=')[1];
        }
      }
  
      return null;
    }
  };
  
  //When a user clicks outside overlay or close icon or hits escape key
  //close exit intent overlay 
  const exit = e => {
    const shouldExit =
      [...e.target.classList].includes('exitIntentOverlay') || // user clicks on mask
      e.target.className === 'exitIntentOverlay-close' || // user clicks on the close icon
      e.keyCode === 27; // user hits escape
  
    if (shouldExit) {
      document.querySelector('.exitIntentOverlay').classList.remove('visible');
    }
  };
  
  //When a user's cursor leaves the document
  //show exit intent overlay 
  const mouseEvent = e => {
    const shouldShowExitIntent = 
      !e.toElement && 
      !e.relatedTarget &&
      e.clientY < 10;
  
    if (shouldShowExitIntent) {
      document.removeEventListener('mouseout', mouseEvent);
      document.querySelector('.exitIntentOverlay').classList.add('visible');
      
      //Set exit intent cookie
      ExitIntentCookieService.setCookie('libraryExitIntentShown', true, 30);
    }
  };
  
  //If exit intentcookie doesn't exist,
  //then initialize exit intent overlay scripts
  if (!ExitIntentCookieService.getCookie('libraryExitIntentShown')) {
    setTimeout(() => {
      document.addEventListener('mouseout', mouseEvent);
      document.addEventListener('keydown', exit);
      document.querySelector('.exitIntentOverlay').addEventListener('click', exit);
    }, 0);
  }
</script>


<script>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</script>



<!-- MARC Intercept Support -->

<script src="https://service.seamlessaccess.org/thiss.js"></script>

<script src="/library/view/static/CACHE/js/output.f717a09a1deb.js"></script>


</body>
</html>
