O'Reilly logo

Hacking For Dummies, 4th Edition by Kevin Beaver

Stay ahead with the world's most comprehensive technology and business learning platform.

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, tutorials, and more.

Start Free Trial

No credit card required

Introduction

Welcome to Hacking For Dummies, 4th Edition. This book outlines — in plain English — computer hacker tricks and techniques that you can use to assess the security of your information systems, find the security vulnerabilities that matter, and fix the weaknesses before criminal hackers and malicious users take advantage of them. This hacking is the professional, aboveboard, and legal type of security testing — which I call ethical hacking throughout the book.

Computer and network security is a complex subject and an ever-moving target. You must stay on top of it to ensure that your information is protected from the bad guys. That’s where the tools and techniques outlined in this book can help.

You can implement all the security technologies and other best practices possible, and your information systems might be secure — as far as you know. However, until you understand how malicious attackers think, apply that knowledge, and use the right tools to assess your systems from their point of view, you can’t get a true sense of how secure your information really is.

Ethical hacking — which encompasses formal and methodical penetration testing, white hat hacking, and vulnerability testing — is necessary to find security flaws and to help validate that your information systems are truly secure on an ongoing basis. This book provides you with the knowledge to implement an ethical hacking program successfully, perform ethical hacking tests, and put the proper countermeasures ...

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, interactive tutorials, and more.

Start Free Trial

No credit card required