Installing NetBeans

NetBeans requires a Java Development Kit (JDK) Version 1.7 or newer to be available before it can be installed.

Note

Since this book is aimed at experienced Java developers, we will not spend much time explaining how to install and configure the JDK. We can safely assume that the target market for the book is more than likely to have a JDK installed. Installation instructions for the Java Development Kit can be found at http://docs.oracle.com/javase/7/docs/webnotes/install/index.html.

NetBeans installation varies slightly between the supported platforms. In the following few sections we explain how to install NetBeans on each supported platform.

Microsoft Windows

For Microsoft Windows platforms, NetBeans is downloaded as an executable ...

Get Java EE 7 Development with NetBeans 8 now with O’Reilly online learning.

O’Reilly members experience live online training, plus books, videos, and digital content from 200+ publishers.