O'Reilly logo

Mastering Magento 2 - Second Edition by Jonathan Bownds, Bret Williams

Stay ahead with the world's most comprehensive technology and business learning platform.

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, tutorials, and more.

Start Free Trial

No credit card required

What you need for this book

Store owners using this book to learn Magento 2 should have an installed version of Magento 2 to work with. Developers should have a development environment capable of supporting a Magento 2 installation:

  • A Unix operating system (Linux, MacOS X)
  • Composer
  • Apache 2.2 or 2.4, or Nginx 1.8.x web server
  • PHP 5.5, 5.6 or 7.0.2
  • MySQL 5.6.x

Developers are also required to have a good working knowledge of PHP, object-oriented programming, and MVC architecture.

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, interactive tutorials, and more.

Start Free Trial

No credit card required