What you need for this book

The only strong requirement for running the code in this book is an installation of R. This is freely available from http://www.r-project.org/ and runs on all the major operating systems. The code in this book has been tested with R version 3.1.3.

All the chapters introduce at least one new R package that does not come with the base installation of R. We do not explicitly show the installation of R packages in the text, but if a package is not currently installed on your system or if it requires updating, you can install it with the install.packages() function. For example, the following command installs the tm package:

> install.packages("tm")

All the packages we use are available on CRAN. An Internet connection is needed ...

Get Mastering Predictive Analytics with R now with O’Reilly online learning.

O’Reilly members experience live online training, plus books, videos, and digital content from 200+ publishers.