O'Reilly logo

Microsoft Excel im Personalwesen, 2., aktualisierte und erweiterte Auflage by Melanie Breden, Sven Mönkediek, Egbert Jeschke, Michael Paatz

Stay ahead with the world's most comprehensive technology and business learning platform.

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, tutorials, and more.

Start Free Trial

No credit card required

Projektzeiterfassung mit Excel
97
2.
Drücken Sie
(Strg)+(F3) oder wählen Sie den Menübefehl Einfügen/Namen/Definieren, um das
Dialogfeld Namen definieren zu öffnen (siehe Abbildung 3.21).
3. Geben Sie einen griffigen, möglichst selbsterklärenden Namen (z.B. Projekte) ein. Beenden Sie
Ihre Eingaben mit OK.
4. Wiederholen Sie diese Schritte für die erste Spalte der zweiten Liste. Im Beispiel wurde der Name
MA verwendet.
5. Geben Sie der gesamten zweiten Liste den Namen Solltabelle.
Die Vorarbeiten auf dem Blatt Stammdaten sind damit abgeschlossen.
Erstellen des Tabellenlayouts
Das Arbeitsblatt Zeiten, welches der Beschäftigte zur Erfassung seiner Arbeitszeiten nutzen soll, muss
nun gestaltet werden. In diesem Beispiel wird die erste Zeile für eine Überschrift, die zweite für Erläu-
terungen sowie Summenberechnungen und die dritte für die Spaltenüberschriften genutzt. In A3
angefangen, bilden Sie mit den Begriffen Projekt, Datum, von, bis, Projektzeit, Tagessumme, Sollzeit,
Mehrarbeit und Bemerkungen die Spalten. In der Zelle A2 wird der Name des Beschäftigten angezeigt.
Dieser soll allerdings nicht manuell eingetragen, sondern nur aus den zuvor definierten Namen
gewählt werden:
1. Setzen Sie die Einfügemarke in die Zelle A2 und rufen Sie den Befehl Daten/Gültigkeit auf, um das
Dialogfeld Gültigkeitsprüfung zu öffnen (siehe Abbildung 3.22).
2. Wählen Sie im Dropdown-Listenfeld Zulassen den Eintrag Liste aus.
3. Unter Quelle tragen Sie =MA ein.
4. Schließen Sie das Dialogfeld mit OK.
Die anderen Vorbelegungen des Dialogfeldes müssen nicht geändert werden, bieten allerdings die
Möglichkeit, dem Anwender etwas Hilfestellung beim Arbeiten mit der Datei zukommen zu lassen.
Auf der Registerkarte Eingabemeldung finden Sie alle Optionen, die Sie benötigen, um bei Auswahl
der Zelle einen Hilfetext anzuzeigen. Dieser gleicht optisch einem Kommentar einer Zelle.
Interessant ist vor allem die Registerkarte Fehlermeldung. Nutzern, die ihre Auswahl nicht über den
Dropdownpfeil treffen, sondern direkt per Tastatur eine Eingabe vornehmen, kann hier eine Infor-
Abbildung 3.21 Geben Sie den Listen aus dem Arbeitsblatt
Stammdaten Namen, die Ihnen die weitere Arbeit erleichtern
98
Kapitel 3: Rechnen mit Datum und Uhrzeit
mation hinterlegt werden, die automatisch auf einen nicht zugelassenen Wert hinweist und den
Abschluss der Eingabe verhindert. Fehleingaben sind somit ausgeschlossen.
Klickt man hingegen auf den Dropdownpfeil der Zelle A2, erscheint ein Zellenlistenfeld mit den Vor-
gabewerten aus der Liste des Stammdatenblattes.
Nun werden die Formate und Gültigkeitsregeln der eigentlichen Tabelle definiert. In der Zelle A4
wird wiederum die Gültigkeit auf eine Liste eingeschränkt, allerdings mit der Quelle Projekte. Das
Format in der Zelle B4 wird als Datum festgelegt, die Zellen C4 bis G4 als Uhrzeit und H4 als Zahl mit
zwei Dezimalstellen und roter Textfarbe bei negativen Werten. Die Differenz zwischen von- und bis-
Zeit soll in der Spalte E, Projektzeit, gebildet werden. Die daraus resultierende Formel =
D4-C4 wird um
eine
WENN()-Funktion erweitert, die verhindert, dass Fehler bei noch nicht erfasster bis-Zeit ausgege-
ben werden:
=WENN(D4=0;0;D4-C4)
Abbildung 3.23 Berechnung der Projektzeit
In der Spalte F, Tagessumme, werden alle Zeiten eines Kalendertages aufsummiert. Dies realisieren Sie
wiederum mit einer
WENN()-Funktion. Wenn der Datumswert der aktuellen Zeile dem Datumswert
der vorhergehenden Zeile entspricht, sollen die Projektzeiten aus der Spalte E aufsummiert werden,
andernfalls soll lediglich der Zeilenwert von E erscheinen. Als Formel ergibt sich:
=WENN(B4=B3;F3+E4;E4)
Abbildung 3.22 Die Gültigkeitsprüfung hilft, Fehleingaben
zu vermeiden

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, interactive tutorials, and more.

Start Free Trial

No credit card required