Skip to Content
Practical Internet Groupware
book

Practical Internet Groupware

by Jon Udell
October 1999
Beginner
521 pages
15h 28m
English
O'Reilly Media, Inc.
Content preview from Practical Internet Groupware

Web: Core Infrastructure

RFC1630 (June 1994, Universal Resource Identifiers in WWW) introduces three fundamental concepts:

Universal Resource Identifier (URI)

A general-purpose namespace mechanism

Uniform Resource Locator (URL)

An instance of a URI that is the address of some resource, accessible by means of a protocol such as HTTP or NNTP

Uniform Resource Name (URN)

An instance of a URI that, unlike a fragile URL, is guaranteed to remain always available

RFC1736 (February 1995, Functional Recommendations for Internet Resource Locators) recommends that URL schemes should be:

  • Global in scope

  • Readily parseable

  • Human readable and writable

  • Extensible

RFC1738 (December 1994, Uniform Resource Locators (URL)) describes common URL schemes, including http:, news:, mailto:, and file:. RFC1808 ( June 1995, Relative Uniform Resource Locators) defines the rules for relative URLs that are fully qualified with reference to a stated or implied base URL.

RFC2396 (August 1998, Uniform Resource Identifiers (URI): Generic Syntax) subsumes RFC1738 and RFC1808, defining “a single generic syntax for all URI.” A URI, say the authors, “can be further classifed as a name, a locator, or both.” It reiterates RFC1630’s URI/URL/URN taxonomy: “A URN differs from a URL in that its primary purpose is persistent labeling of a resource with an identifier.”

The URL/URN distinction can be misleading. A World Wide Web Consortium (W3C) document entitled “Cool URIs don’t change” (http://www.w3.org/Provider/Style/URI) notes astutely: ...

Become an O’Reilly member and get unlimited access to this title plus top books and audiobooks from O’Reilly and nearly 200 top publishers, thousands of courses curated by job role, 150+ live events each month,
and much more.

Read now

Unlock full access

More than 5,000 organizations count on O’Reilly

AirBnbBlueOriginElectronic ArtsHomeDepotNasdaqRakutenTata Consultancy Services

QuotationMarkO’Reilly covers everything we've got, with content to help us build a world-class technology community, upgrade the capabilities and competencies of our teams, and improve overall team performance as well as their engagement.
Julian F.
Head of Cybersecurity
QuotationMarkI wanted to learn C and C++, but it didn't click for me until I picked up an O'Reilly book. When I went on the O’Reilly platform, I was astonished to find all the books there, plus live events and sandboxes so you could play around with the technology.
Addison B.
Field Engineer
QuotationMarkI’ve been on the O’Reilly platform for more than eight years. I use a couple of learning platforms, but I'm on O'Reilly more than anybody else. When you're there, you start learning. I'm never disappointed.
Amir M.
Data Platform Tech Lead
QuotationMarkI'm always learning. So when I got on to O'Reilly, I was like a kid in a candy store. There are playlists. There are answers. There's on-demand training. It's worth its weight in gold, in terms of what it allows me to do.
Mark W.
Embedded Software Engineer

You might also like

How to Develop a Great Digital Strategy

How to Develop a Great Digital Strategy

Jeanne W. Ross, Cynthia M. Beath, Ina M. Sebastian
The Hidden Cost of AI-Assisted Creativity

The Hidden Cost of AI-Assisted Creativity

Léonard Boussioux, Anil Doshi, Oliver Hauser, Kartik Hosanagar
Are You an Authentic Leader or an Authentic Jerk?

Are You an Authentic Leader or an Authentic Jerk?

Hannes Leroy, Michael A. Daniels, Kristin L. Cullen-Lester, Alexandra Gerbasi
What Successful Project Managers Do

What Successful Project Managers Do

W. Scott Cameron, Jeffrey S. Russell, Edward J. Hoffman, Alexander Laufer

Publisher Resources

ISBN: 1565925378Catalog PageErrata