Getting Started

To interact with an SQLite database, you’ll need two things (aside from Ruby itself):

image  The SQLite software

image  The SQLite3 Ruby gem

The database software is available from www.sqlite.org. There are precompiled versions for Windows, Mac OS X, and Linux, or you can compile your own from the source code. Recent versions of Mac OS X come with SQLite3 pre-installed (it’s used widely by the OS), so no steps need to be taken. On Windows, you just need to copy the sqlite3.dll file to the WINDOWS\system32 directory.

Details for installing ...

Get Ruby: Visual Quickstart Guide now with the O’Reilly learning platform.

O’Reilly members experience live online training, plus books, videos, and digital content from nearly 200 publishers.