Errata

Java in a Nutshell

Errata for Java in a Nutshell

Submit your own errata for this product.

The errata list is a list of errors and their corrections that were found after the product was released. If the error was corrected in a later version or reprint the date of the correction will be displayed in the column titled "Date Corrected".

The following errata were submitted by our customers and approved as valid errors by the author or editor.

Color key: Serious technical mistake Minor technical mistake Language or formatting error Typo Question Note Update

Version Location Description Submitted By Date submitted Date corrected
Printed
Page 15
6th paragraph (3rd paragraph from bottom)

The sentence starting with "The conservative approach..." and ending with "...large user base" is a fragment (no verb). I think the author probably meant to use "is" after the word "taken".

Linus Arver  Jan 28, 2019  Jun 21, 2019
Printed
Page 39
2nd paragrpah

In the last sentence "As the operands of + are both +a, these are evaluated to ...", the font of "are both" is in monospaced text, which is incorrect as it is not code.

Also, the text should read "both ++a", not "both +a", because "+a" does not appear in the example above it.

Linus Arver  Jan 28, 2019  Jun 21, 2019
Printed
Page 53
last paragraph, last sentence

The word "discuss" is printed as "2discuss".

Linus Arver  Jan 28, 2019  Jun 21, 2019
Printed
Page 109
last paragraph, last sentence

"you;re" should be "you're"

Linus Arver  Jan 30, 2019  Jun 21, 2019
Printed
Page 118
2nd code block from top

The variable "origininside" should probably be renamed to "insideorigin", or better, "insideOrigin" (camelCase).

Linus Arver  Jan 30, 2019  Jun 21, 2019
Printed
Page 123
Caution note (scorpion icon)

The words

"the Liskov principle, which we will meet later"

should probably read instead

"the Liskov principle, which we will see in Chaper X".

where X is the Chapter where it is discussed. The term "Liskov" is not in the index, so I cannot tell where it is described without reading the rest of the book.

Linus Arver  Jan 30, 2019  Jun 21, 2019
Printed
Page 124
code block for Sports Car

There is "@Override" but the text does not discuss it at all, or what would happen if it was omitted. Please clarify what this "@Override" syntactical construct is.

Linus Arver  Jan 30, 2019  Jun 21, 2019
Printed
Page 126
3rd paragraph, 1st sentence

"an SportsCar" should be "a SportsCar"

Linus Arver  Jan 30, 2019  Jun 21, 2019
Printed
Page 126
2nd paragraph from bottom

"Chapter 4 for more details about compile-time and runtime type" should say "types" instead of "type".

Linus Arver  Jan 30, 2019  Jun 21, 2019
Printed
Page 159
2nd paragraph, last sentence

"You should avoided it when writing new code" should read "You should avoid it when writing new code". (s/avoided/avoid)

Linus Arver  Feb 04, 2019  Jun 21, 2019
Printed
Page 164
3rd paragraph from bottom, last sentence

The verb in "...or normally just called enums and annotations" does not line up with the subject "They" in the same sentence.

Solution 1: replace "normally just called" with "simply", like this:

"...or simply enums and annotations".

Solution 2: replace "or" with "but are", like this:

"...but are normally just called enums and annotations."

Linus Arver  Feb 04, 2019  Jun 21, 2019
Printed
Page 169
1st paragraph under "Lambda Expressions"

s/anticated/anticipated

Also, the parenthetical "(frequently referred to just as lambdas)" in this sentence does not parse well. This version is probably better:

"One of the most eagerly anticipated features of Java 8 was the introduction of lambda expressions, or simply 'lambdas'."

Linus Arver  Feb 04, 2019  Jun 21, 2019
Printed
Page 177
3rd paragraph, last sentence under "Nested Types"

This sentence has an errant verb "coexist":

"This means that they don't really have a completely independent existence as an entity, and only live in coexist."

Maybe replace "in coexist" to "to coexist"?

Linus Arver  Feb 06, 2019  Jun 21, 2019
Printed
Page 177
5th paragraph, last sentence under "Nested Types"

In the phrase "...been taken over by lambda expressions and the use of...", add a comma after "expressions", like this: "expressions, and"

As a general note, there are a lot of run-on sentences in the areas beginning with "Functional Programming" on page 173. E.g., on page 173, there is "Lambda expressions greatly simplify that syntax, and so it is only natural that more developers will be seeking to use aspects of functional programming in their Java code, now that it is considerably easier to do so." This could be shortened to just "Lambda expressions greatly simplify that syntax."

Linus Arver  Feb 06, 2019  Jun 21, 2019
Printed
Page 189
3rd paragraph, 1st sentence

The word 'var' in the phrase "for each distinct usage of var" is not set in monospaced font, unlike in the previous page.

Linus Arver  Feb 10, 2019  Jun 21, 2019
Printed
Page 190
1st paragraph, 1st sentence

"and is now on a par" should be "is now on par"

Linus Arver  Feb 10, 2019  Jun 21, 2019