SQL in a Nutshell

Errata for SQL in a Nutshell

Submit your own errata for this product.


The errata list is a list of errors and their corrections that were found after the product was released. If the error was corrected in a later version or reprint the date of the correction will be displayed in the column titled "Date Corrected".

The following errata were submitted by our customers and approved as valid errors by the author or editor.

Color Key: Serious Technical Mistake Minor Technical Mistake Language or formatting error Typo Question Note Update



Version Location Description Submitted By Date Submitted Date Corrected
Printed
Page v
List of covered databases

Says that version 8.2.1 of PostgreSQL is covered, The back cover and Chapter 1 states that 8.3 is the supported version.

Note from the Author or Editor:
Please change references of PostgreSQL v8.2.1 to v8.3

Michael Andreen  Aug 11, 2009 
Printed
Page 223
PostgreSQL section

Says that "PostgreSQL views are built only upon other tables, not upon other views", but at least as far back as 8.1 support creating views built upon other views.

Note from the Author or Editor:
Please change the sentence "PostgreSQL views are built only upon other tables, not upon other views" to "PostgreSQL views are built upon other tables and views",

Michael Andreen  Aug 11, 2009 
Printed
Page 308
JOIN platform support table

Says "Supported, with variations" for PostgreSQL, while the text on page 316 says that the ANSI standard is fully supported.

Note from the Author or Editor:
Please amend "PostgreSQL - Supported, with variations on p316 to "PostgreSQL - Supported"

Michael Andreen  Aug 11, 2009 
Printed
Page 320
MERGE platform support table

Incorrectly states that MERGE is supported for PostgreSQL, page 323 correctly says that it is not supported.

Note from the Author or Editor:
Please alter the table on p320 to show that MERGE is not supported by PostgreSQL

Michael Andreen  Aug 11, 2009 
Printed
Page 400
2nd paragraph

Says PostgreSQL doesn't support SET ROLE, but this has been supported since version 8.1 (the book claims to support 8.3 on the back, and 8.2 in chapter 1)

Note from the Author or Editor:
Alter the 2nd paragraph on p400 to show that PostgreSQL does not support SET ROLE

Michael Andreen  Aug 11, 2009 
Printed
Page 416
Table 3-7, platform-specific subquery support

Also PostgreSQL paragraph on page 418. Says PostgreSQL doesn't support scalar subqueries in select item list, but this has been supported since at least 8.1.

Note from the Author or Editor:
Change the reference from "...doesn't support scalar subqueries..." to "...doesn't support scalar subqueries before version 8.1..."

Michael Andreen  Aug 11, 2009