Errata

Java Power Tools

Errata for Java Power Tools

Submit your own errata for this product.

The errata list is a list of errors and their corrections that were found after the product was released.

The following errata were submitted by our customers and have not yet been approved or disproved by the author or editor. They solely represent the opinion of the customer.

Color Key: Serious technical mistake Minor technical mistake Language or formatting error Typo Question Note Update

Version Location Description Submitted by Date submitted
Printed Page 2
End of first paragraph

last line of the first paragraph, should be "more complicated than" instead of "more complicated then"

StephaneWeber  Mar 04, 2009 
Printed Page 3
Third paragraph from the end

"your choice may be influenced as ..." instead of "your choice may be as influenced as ..."

StephaneWeber  Mar 04, 2009 
20
Last paragarph

Hi,

I am not able to get the page number from the Safari Edition
so not sure of the page number where this error occurs.

In Section
12.2. Running Cobertura from Ant

The sample from the build file needed to generate coverage report using Cobertura is as below :

<property name="coveragereport.dir" value="${build.dir}/reports/cobertura" />
...
<target name="cobertura.report" depends="instrument, test">
[...]

But the chapter doesn't define any targets by name "test". The relevant target in this scenario is "test.coverage".

So the above line should be :
<target name="cobertura.report" depends="instrument, test.coverage">

Thanks for the great book.

thanks and regards,
sateesh

Sateesh Kumar  Mar 18, 2009 
Printed Page 34
first listing

the <batchtest> sample is missing the 'todir' attribute definition that it is supposed to illustrate:

<target name="test" ...
...
<batchtest>

should be replaced with:

<target name="test" ...
...
<batchtest todir="${reports.dir}">

Anonymous   
Printed Page 48
1st paragraph

${svnant.home} should be ${findbugs.home}

Anonymous  Feb 03, 2010 
Printed Page 54
2nd bullet

the corresponding entities ("<" ">" and "&"), and thus -- should be -- the corresponding entities (&lt; &gt; and &amp;), and thus

Anonymous  Feb 03, 2010 
Printed Page 61
Several places

5th line: rather then --> rather than

3rd line in last but one paragraph : we aren't taking --> we aren't talking

StephaneWeber  Mar 04, 2009 
Printed Page 71
First code snippet

Version of the artifact is 5.1 and not 5.5

StephaneWeber  Mar 04, 2009 
Printed Page 109
2nd paragragh

This example uses a number of properties, among them are th*tomcat.manager ...

==>

This example uses a number of properties, among them are tomcat.manager ...

Remove th*

StephaneWeber  Mar 04, 2009 
Printed Page 176
Middle of page

keywork must be replaced by keyword in sentence:

"Each entity indicates how a particular ... of keyword substitution and file merges."

StephaneWeber  Mar 04, 2009 
Printed Page 223
7th line from the end

"svn log" command is written twice in line :

$ svn log svn log -vr 10:15 # ...

Should be:

$ svn log -vr 10:15 # ...

StephaneWeber  Mar 04, 2009 
Printed Page 285
text is "see Table 5-2"

"see Table 5-2" should be "see Table 5-1"

ChrisP  Jan 01, 2009 
Printed Page 297
3rd paragraph (?)

"To do this, you provide webport and webport and jmxport command-line options, as follows:"

First "webport and" should be removed.

ChrisP  Jan 01, 2009 
Printed Page 392-393
392 last paragraph, 393 code example

@BeforeClass and @AfterClass cannot be annotated on member methods. Doing so will lead to a runtime error.
They only can be used on static method.
See also
http://junit.sourceforge.net/javadoc_40/org/junit/BeforeClass.html
This also invalidates the example for what those methods can be used.

{chapter 24}whereever the Jupiter URL is listed;
The URL to the Jupiter code review tool for Eclipse should be:

http://code.google.com/p/jupiter-eclipse-plugin/

We moved it from the CSDL site a year or so ago.

Anonymous   
Printed Page 392-393
All methods prefixed with the @Test annotation

The instruction PriceCalculator calculator = new PriceCalculator() should be removed, as this is done in the initialize method.

StephaneWeber  Mar 04, 2009 
Printed Page 396
Constructor of the code snippet

The first parameter of the constructor must be named revenue instead of input

StephaneWeber  Mar 04, 2009 
Printed Page 491
Last paragraph

"add a new method, setSequence>setSequence():"

should be

"add a new method, setSequence():"

SetSequence is repeated

StephaneWeber  Mar 04, 2009 
Printed Page 577
Second paragraph from the end

the bar charts are located on the lower right of the memory tab, not on the lower left as written.

StephaneWeber  Mar 05, 2009 
Printed Page 589
Last text paragraph

The paragraph refers to the JUnitPerf library, and specifies it is discussed in chapter 28.

It is actually chapter 15.

StephaneWeber  Mar 05, 2009