Skip to Content
Windows Server 2003 Network Administration
book

Windows Server 2003 Network Administration

by Craig Hunt, Roberta Bragg
September 2005
Beginner
696 pages
23h 47m
English
O'Reilly Media, Inc.
Content preview from Windows Server 2003 Network Administration

Appendix A. DHCP Options

The TCP/IP configuration values exchanged by a DHCP server and a client are called DHCP options . There are great many DHCP configuration options. While Table A-1 covers a large number of these, it does not cover them all. It does, however, cover all of the DHCP options that are listed under Available Options in the Scope Options window. In fact, it covers more than the options listed there. The additional options covered in the table are:

  • Those options discussed in Chapter 5 that the client sends to the server to identify itself as a member of a user or vendor class

  • Some additional options described in RFC 2132, DHCP Options and BOOTP Vendor Extensions

  • The Classless Static Routes option defined in RFC 3442, Classless Static Route Option for DHCPv4

  • The LCI option defined in RFC 3825, Dynamic Host Configuration Protocol Option for Coordinate-based Location Configuration Information, which was used as an example in the text

Table A-1. DHCP options

Code

Name

Description/value

1

Subnet mask

A signed 32-bit integer that specifies the address mask of the client subnet. Defined in the New Scope Wizard or the Scope Properties dialog. Cannot be set in the Scope Options or Server Options dialogs.

2

Time offset

A signed 32-bit integer that specifies the client’s offset from Universal Coordinated Time (UCT) in seconds.

3

Router

A preference-ordered list of IP addresses for routers on the client’s subnet.

4

Time server

A preference-ordered list of IP addresses of the RFC 868 time servers ...

Become an O’Reilly member and get unlimited access to this title plus top books and audiobooks from O’Reilly and nearly 200 top publishers, thousands of courses curated by job role, 150+ live events each month,
and much more.

Read now

Unlock full access

More than 5,000 organizations count on O’Reilly

AirBnbBlueOriginElectronic ArtsHomeDepotNasdaqRakutenTata Consultancy Services

QuotationMarkO’Reilly covers everything we've got, with content to help us build a world-class technology community, upgrade the capabilities and competencies of our teams, and improve overall team performance as well as their engagement.
Julian F.
Head of Cybersecurity
QuotationMarkI wanted to learn C and C++, but it didn't click for me until I picked up an O'Reilly book. When I went on the O’Reilly platform, I was astonished to find all the books there, plus live events and sandboxes so you could play around with the technology.
Addison B.
Field Engineer
QuotationMarkI’ve been on the O’Reilly platform for more than eight years. I use a couple of learning platforms, but I'm on O'Reilly more than anybody else. When you're there, you start learning. I'm never disappointed.
Amir M.
Data Platform Tech Lead
QuotationMarkI'm always learning. So when I got on to O'Reilly, I was like a kid in a candy store. There are playlists. There are answers. There's on-demand training. It's worth its weight in gold, in terms of what it allows me to do.
Mark W.
Embedded Software Engineer

You might also like

Windows NT TCP/IP Network Administration

Windows NT TCP/IP Network Administration

Craig Hunt, Robert Bruce Thompson
Windows Server 2016: Unleashed

Windows Server 2016: Unleashed

Rand Morimoto, Jeffrey Shapiro, Guy Yardeni, Omar Droubi, Michael Noel, Andrew Abbate, Chris Amaris
Windows Server® 2012 Unleashed

Windows Server® 2012 Unleashed

Rand Morimoto, Michael Noel, Guy Yardeni, Omar Droubi, Andrew Abbate, Chris Amaris

Publisher Resources

ISBN: 0596008007Errata Page