<!DOCTYPE html>
<!--[if lt IE 10]><html class="no-js ie8 oldie" lang="en" prefix="og: http://ogp.me/ns/# og:book: http://ogp.me/ns/book# og:video: http://ogp.me/ns/video#"

  
    itemscope itemtype="http://schema.org/Book http://schema.org/CollectionPage" data-offline-url="/"
data-url="/library/view/data-quality-fundamentals/9781098112035/"
data-reading-url="/library/view/data-quality-fundamentals/9781098112035/ch01.html"
data-archive="9781098112035"
data-publishers="O&#x27;Reilly Media, Inc."

  
    data-book-overview="true"
  



data-federated-auth-enabled="true"

data-env="production"
data-debug="0" ><![endif]-->
<!--[if gt IE 9]><!--><html class="no-js" lang="en" prefix="og: http://ogp.me/ns/# og:book: http://ogp.me/ns/book# og:video: http://ogp.me/ns/video#"

  
    itemscope itemtype="http://schema.org/Book http://schema.org/CollectionPage" data-offline-url="/"
data-url="/library/view/data-quality-fundamentals/9781098112035/"
data-reading-url="/library/view/data-quality-fundamentals/9781098112035/ch01.html"
data-archive="9781098112035"
data-publishers="O&#x27;Reilly Media, Inc."

  
    data-book-overview="true"
  



data-federated-auth-enabled="true"

data-env="production"
data-debug="0" ><!--<![endif]-->
<head>
    <meta charset="UTF-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />
    <title>Data Quality Fundamentals [Book]</title>
    <meta name="viewport" content="width=device-width, initial-scale=1" />
    <link rel="stylesheet" href="/library/view/static/CACHE/css/output.0a191aeefc87.css" type="text/css">
    <link href='//fonts.googleapis.com/css?family=Source+Sans+Pro' rel='stylesheet' type='text/css' />
    <link rel="stylesheet" type="text/css" href="https://cdn.oreillystatic.com/assets/css/2018_font_face.css" />
    

    <meta property="og:title" content="Data Quality Fundamentals" />
    <meta itemprop="name" content="Data Quality Fundamentals" />
    
    <meta property="og:url" itemprop="url" content="https://www.oreilly.com/library/view/data-quality-fundamentals/9781098112035/" />
    <meta property="og:site_name" content="O’Reilly Online Learning" />
    <meta property="og:image" itemprop="thumbnailUrl" content="https://www.oreilly.com/library/cover/9781098112035/" />
    
    <meta property="og:image:secure_url" itemprop="thumbnailUrl" content="https://learning.oreilly.com/library/cover/9781098112035/360h/">
    <meta property="og:description" itemprop="description" name="description" content="Do your product dashboards look funky? Are your quarterly reports stale? Is the dataset you&#x27;re using broken or just plain wrong? These problems affect almost every team, yet they&#x27;re usually …  - Selection from Data Quality Fundamentals [Book]">
    
    <meta itemprop="inLanguage" content="en" />
    
    <meta itemprop="publisher" content="O&#x27;Reilly Media, Inc." />
    
    <meta property="og:type" content="article" />
    <meta property="og:book:isbn" itemprop="isbn" content="9781098112042" />
    
    <meta property="og:book:author" itemprop="author" content="Barr Moses" />
    <meta property="og:book:author" itemprop="author" content="Lior Gavish" />
    <meta property="og:book:author" itemprop="author" content="Molly Vorwerck" />
    
    
    
    
    <meta property="og:image:width" content="400">
    <meta property="og:image:height" content="400">
    <meta name="twitter:card" content="summary">
    <meta name="twitter:site" content="@OReillyMedia">

<!-- Start Visual Website Optimizer Asynchronous Code -->
<script type='text/javascript'>
var _vwo_code=(function(){
var account_id=291788,
settings_tolerance=2000,
library_tolerance=2500,
use_existing_jquery=false,
/* DO NOT EDIT BELOW THIS LINE */
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
</script>
<!-- End Visual Website Optimizer Asynchronous Code -->

    <link class="t-canonical-link" rel="canonical" href="https://www.oreilly.com/library/view/data-quality-fundamentals/9781098112035/" />

    <link rel="shortcut icon" href="//www.oreilly.com/favicon.ico" type="image/vnd.microsoft.icon" />
    <link rel="apple-touch-icon" href="/library/view/static/images/apple-touch-icon.png" />
    

</head>
<body class="js-preview-content  ">


<div class="skipToMain" id="skipToMain"><a href="#maincontent"><span class="skipToMain-text">Skip to main content</span></a></div>
<header role="banner" class="global">
  <div class="global-nav">
    <div class="content">
      <nav role="navigation" aria-label="site sections">
        <a href="https://www.oreilly.com" class="logo" title="home page" aria-current="page"><img src="https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red.svg" onerror="this.src='https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red_@2x.png'; this.onerror=null;" alt="O'Reilly home"></a>

        <button id="mobileNavButton" class="mobileNavButton mobileNavButton--collapse mobileNavButton--3dx" type="button" aria-expanded="false" aria-controls="menuList">
          <span class="mobileNavButton-box">
            <span class="mobileNavButton-inner"></span>
          </span>
        </button>


        <ul id="menuList" class="menuList mobileHidden ">
          <li class="menuList-itemsP1">
            <ul>
              
  <li class="menuList-item menuList-signIn"><a class="t-sign-in" href="/member/login/?next=/library/view/data-quality-fundamentals/9781098112035/">Sign In</a></li>


              <li class="menuList-item menuList-tryNow"><a class="menuList-cta" href="https://learning.oreilly.com/p/register/">Try Now</a></li>
            </ul>
          </li>
          <li class="menuList-itemsP2">
            <ul>
              <li class="menuList-item menuList-itemWithSub"><a href="https://www.oreilly.com/online-learning/teams.html">Teams</a>
                <ul class="menuList-subList menuList-itemWithSub">
                  <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/business.html">For business</a></li>
                  <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/government.html">For government</a></li>
                  <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/academic.html">For higher ed</a></li>
                </ul>
              </li>
              <li class="menuList-item"><a href="https://www.oreilly.com/online-learning/individuals.html">Individuals</a></li>
              <li class="menuList-item menuList-itemWithSub"><a href="https://www.oreilly.com/online-learning/features.html">Features</a>
                <ul class="menuList-subList">
                  <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/feature-certification.html">Certifications</a></li>
                  <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/intro-interactive-learning.html">Interactive learning</a></li>
                  <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/live-events.html">Live events</a></li>
                  <li class="menuList-subItem"><a href="https://www.oreilly.com/online-learning/feature-answers.html">Answers</a></li>
                </ul>
              </li>
              <li class="menuList-item"><a href="https://www.oreilly.com/radar/">Blog</a></li>
              <li class="menuList-item" id="nav-forMarketers"><a href="https://www.oreilly.com/content-marketing-solutions.html">Content sponsorship</a></li>
            </ul>
          </li>
        </ul>
      </nav>
    </div>
  </div>


  <div class="global-search">
    <div id="globalSearchContent" class="content">
      <form id="js-search-form" class="t-navigation-form" action="https://learning.oreilly.com/search/">
        
        <script type="application/ld+json">
        {
          "@context": "http://schema.org",
          "@type": "WebSite",
          "url": "https://learning.oreilly.com",
          "potentialAction": {
            "@type": "SearchAction",
            "target": "https://learning.oreilly.com/search/?q={search_term_string}",
            "query-input": "required name=search_term_string"
          }
        }
        </script>
        <input data-search-text-focus= "See everything available through the O’Reilly learning platform and start a free trial. Explore now." data-search-text-idle = "See everything available through the O’Reilly learning platform and start a free trial. Explore now." id="search" type="search" name="query" placeholder="See everything available through the O’Reilly learning platform and start a free trial. Explore now." autocomplete="off" required />
        <input type="submit" value="Search" class="search-submit" />
      </form>
    </div>
  </div>
</header>

    
    


</header>


<section id="trial-overlay">
  <div class="trial-overlay-content">
    <p>Get full access to <em>Data Quality Fundamentals</em> and 60K+ other titles, with free 10-day trial of O'Reilly.</p>

    <p>There's also live online events, interactive content, certification prep materials, <span class="nowrap">and more.</span></p>

    <div class="controls">
      <a href="https://learning.oreilly.com/p/register/" class="button-primary" data-ga-label="Bottom CTA">Start your free trial</a>
    </div>
    <a class="modal-dismiss" aria-label="modal dismiss"></a>
  </div>
</section>

<main role="main" id="maincontent">
  <div role="document" class="document">
  	


<section id="sbo-reader" class="sbo-reader-title">
  <div class="title-info">
    <div class="content">
      <figure class="t-cover">
        <img class="t-cover-img" src="https://learning.oreilly.com/library/cover/9781098112035/250w/" alt="Data Quality Fundamentals"/>
      </figure>

      <div class="metadata">
        <h1 class="t-title">Data Quality Fundamentals</h1>
        

        <div class="t-authors">by <span class="author-name">Barr Moses</span>, <span class="author-name">Lior Gavish</span>, <span class="author-name">Molly Vorwerck</span></div>
        <div class="t-release-date">Released September 2022</div>
        <div class="t-publisher">Publisher(s): O&#x27;Reilly Media, Inc.</div>
        <div class="t-isbn">ISBN: 9781098112042</div>

        <div id="titlePromo">
          <p class="t-promo">Read it now on the O’Reilly learning platform with a 10-day <span class="nowrap">free trial.</span></p>

          <p class="t-promo">O’Reilly members get unlimited access to live online training experiences, plus books, videos, and digital content from O’Reilly and nearly 200 trusted <span class="nowrap">publishing partners.</span></p>
        </div>

        <div class="controls">
        
          <a href="https://learning.oreilly.com/p/register/" id="startTrial" class="button-primary">Start <span class="mobile-hide">your</span> free trial</a>
        
        </div>

        <div id="next-edition">
        
        </div>
      </div>
    </div>
  </div>

  <div class="title-description t-description sbo-reader-content">
    <div class="content">
      <h2 class="t-description-heading">Book description</h2>
      <span><div><p>Do your product dashboards look funky? Are your quarterly reports stale? Is the dataset you're using broken or just plain wrong? These problems affect almost every team, yet they're usually addressed on an ad hoc basis and in a reactive manner. If you answered yes to any of the questions above, this book is for you.</p><p>Many data engineering teams today face the "good pipelines, bad data" problem. It doesn't matter how advanced your data infrastructure is if the data you're piping is bad. In this book, Barr Moses, Lior Gavish, and Molly Vorwerck from the data reliability company Monte Carlo explain how to tackle data quality and trust at scale by leveraging best practices and technologies used by some of the world's most innovative companies.</p><ul><li>Build more trustworthy and reliable data pipelines</li><li>Write scripts to make data checks and identify broken pipelines with data observability</li><li>Program your own data quality monitors from scratch</li><li>Develop and lead data quality initiatives at your company</li><li>Generate a dashboard to highlight your company's key data assets</li><li>Automate data lineage graphs across your data ecosystem</li><li>Build anomaly detectors for your critical data assets</li></ul></div></span>

      <div id="showMoreDescription" class="showMore hidden"><button class="more"><span class="screen-reader-text">Show and hide more</span></button></div>

      
      <div id="publisher_resources" class="publisher-resources">
        <h2 class="t-description-heading">Publisher resources</h2>
          <p><a href="http://oreilly.com/catalog/0636920587309/errata">View/Submit Errata</a></p>
          
      </div>
      

      <div id="toc-start"></div>
    </div>
  </div>

  <div id="title-tabs" class="title-tabs"><button id="title-tab-toc" class="title-tab title-tab-active" data-target="toc">Table of contents</button><button id="title-tab-pi" class="title-tab" data-target="product-information">Product information</button></div>

  <div class="title-toc" id="toc">
    <div class="content">
      <h2>Table of contents</h2>

      <ol class="detail-toc">
          

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch01.html#why_data_quality_deserves_attention_now" class="t-chapter js-chapter">1. Why Data Quality Deserves Attention—Now</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch01.html#what_is_data_quality" class="t-chapter js-chapter">What Is Data Quality?</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch01.html#framing_the_current_moment" class="t-chapter js-chapter">Framing the Current Moment</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch01.html#understanding_the_rise_of_data_downtime" class="t-chapter js-chapter">Understanding the “Rise of Data Downtime”</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch01.html#other_industry_trends_contributing_to_the_current" class="t-chapter js-chapter">Other Industry Trends Contributing to the Current Moment</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch01.html#summary_idNwjrpB" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#architecting_for_data_reliability" class="t-chapter js-chapter">2. Architecting for Data Reliability</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#measuring_and_maintaining_high_data_reliability_at" class="t-chapter js-chapter">Measuring and Maintaining High Data Reliability at Ingestion</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#measuring_and_maintaining_data_quality_in_the_pipe" class="t-chapter js-chapter">Measuring and Maintaining Data Quality in the Pipeline</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#understanding_data_quality_downstream" class="t-chapter js-chapter">Understanding Data Quality Downstream</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#building_your_data_platform" class="t-chapter js-chapter">Building Your Data Platform</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#data_ingestion" class="t-chapter js-chapter">Data Ingestion </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#data_storage_and_processing" class="t-chapter js-chapter">Data Storage and Processing</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#data_transformation_and_modeling" class="t-chapter js-chapter">Data Transformation and Modeling</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#business_intelligence_and_analytics" class="t-chapter js-chapter">Business Intelligence and Analytics</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#data_discovery_and_governance" class="t-chapter js-chapter">Data Discovery and Governance</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#developing_trust_in_your_data" class="t-chapter js-chapter">Developing Trust in Your Data</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#data_observability" class="t-chapter js-chapter">Data Observability</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#measure_the_cost_of_broken_data" class="t-chapter js-chapter">Measure the Cost of Broken Data </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#how_to_set_slas_slos_and_slis_for_your_data" class="t-chapter js-chapter">How to Set SLAs, SLOs, and SLIs for Your Data </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#case_study_blinkist" class="t-chapter js-chapter">Case Study: Blinkist </a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch02.html#summary_id1KvFI0" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#fixing_data_quality_issues_at_scale" class="t-chapter js-chapter">3. Fixing Data Quality Issues at Scale</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#fixing_quality_issues_in_software_development" class="t-chapter js-chapter">Fixing Quality Issues in Software Development </a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#data_incident_management" class="t-chapter js-chapter">Data Incident Management</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#incident_detection" class="t-chapter js-chapter">Incident Detection</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#response_idOLldZH" class="t-chapter js-chapter">Response</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#root_cause_analysis" class="t-chapter js-chapter">Root Cause Analysis </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#resolution" class="t-chapter js-chapter">Resolution </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#blameless_post_mortem" class="t-chapter js-chapter">Blameless Post-mortem </a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#proactive_incident_prevention" class="t-chapter js-chapter">Proactive Incident Prevention</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#testing_idYEWgu2" class="t-chapter js-chapter">Testing </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#installing_circuit_breakers" class="t-chapter js-chapter">Installing Circuit Breakers</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#establish_a_routine_of_incident_management" class="t-chapter js-chapter">Establish a Routine of Incident Management</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#case_study_data_incident_management_at_pagerduty" class="t-chapter js-chapter">Case Study: Data Incident Management at PagerDuty</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#the_dataops_landscape_at_pagerduty" class="t-chapter js-chapter">The DataOps Landscape at PagerDuty</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#data_challenges_at_pagerduty" class="t-chapter js-chapter">Data Challenges at PagerDuty</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#using_devops_best_practices_to_scale_data_incident" class="t-chapter js-chapter">Using DevOps Best Practices to Scale Data Incident Management</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch03.html#summary_id7B5ptx" class="t-chapter js-chapter">Summary </a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#preventing_broken_data_systems" class="t-chapter js-chapter">4. Preventing Broken Data Systems</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#understanding_the_difference_between_operational_a" class="t-chapter js-chapter">Understanding the Difference Between Operational and Analytical Data</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#what_makes_them_different" class="t-chapter js-chapter">What Makes Them Different?</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#data_warehouses_vs_data_lakes" class="t-chapter js-chapter">Data warehouses vs. data lakes</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#data_warehouses_table_types_at_the_schema_level" class="t-chapter js-chapter">Data warehouses: table types at the schema level</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#data_lakes_manipulations_at_the_file_level" class="t-chapter js-chapter">Data lakes: manipulations at the file level</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#what_about_the_data_lakehouse" class="t-chapter js-chapter">What about the data lakehouse? </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#syncing_data_between_warehouses_and_lakes" class="t-chapter js-chapter">Syncing data between warehouses and lakes</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#collecting_data_quality_metrics" class="t-chapter js-chapter">Collecting data quality metrics</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#what_are_data_quality_metrics" class="t-chapter js-chapter">What are data quality metrics?</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#how_to_pull_data_quality_metrics" class="t-chapter js-chapter">How to pull data quality metrics</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#example_pulling_data_quality_metrics_from_snowfla" class="t-chapter js-chapter">Example: Pulling data quality metrics from Snowflake</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#using_query_logs_to_understand_data_quality_in_the_1" class="t-chapter js-chapter">Using query logs to understand data quality in the warehouse</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#using_query_logs_to_understand_data_quality_in_the_2" class="t-chapter js-chapter">Using query logs to understand data quality in the lake</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#designing_a_data_catalog" class="t-chapter js-chapter">Designing a data catalog</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#building_a_data_catalog" class="t-chapter js-chapter">Building a data catalog</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch04.html#summary_idd1AAkx" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#collecting_cleaning_transforming_and_testing_da" class="t-chapter js-chapter">5. Collecting, Cleaning, Transforming, and Testing Data</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#data_collecting" class="t-chapter js-chapter">Data Collecting</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#application_log_data" class="t-chapter js-chapter">Application Log Data</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#api_responses" class="t-chapter js-chapter">API Responses</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#sensor_data" class="t-chapter js-chapter">Sensor Data</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#data_cleaning" class="t-chapter js-chapter">Data Cleaning</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#batch_vs_stream_processing" class="t-chapter js-chapter">Batch vs. Stream Processing</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#data_quality_for_stream_processing" class="t-chapter js-chapter">Data quality for stream processing</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#aws_kinesis_1" class="t-chapter js-chapter">AWS Kinesis</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#apache_kafka" class="t-chapter js-chapter">Apache Kafka</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#data_normalization_or_operational_data_transform" class="t-chapter js-chapter">Data Normalization (or “Operational Data Transformations”)</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#handling_heterogeneous_data_sources" class="t-chapter js-chapter">Handling heterogeneous data sources</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#warehouse_data_vs_lake_data_heterogeneity_editio" class="t-chapter js-chapter">Warehouse data vs. lake data: heterogeneity edition</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#schema_checking_and_type_coercion" class="t-chapter js-chapter">Schema checking and type coercion</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#syntactic_vs_semantic_ambiguity_in_data" class="t-chapter js-chapter">Syntactic vs. semantic ambiguity in data</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#operational_data_transformations" class="t-chapter js-chapter">Operational data transformations</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#running_analytical_data_transformations" class="t-chapter js-chapter">Running Analytical Data Transformations</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#ensuring_data_quality_during_etl" class="t-chapter js-chapter">Ensuring Data Quality During ETL</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#ensuring_data_quality_during_transformation" class="t-chapter js-chapter">Ensuring data quality during transformation</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch05.html#summary_idnD39MC" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#monitoring_and_anomaly_detection_for_your_data_pip" class="t-chapter js-chapter">6. Monitoring and anomaly detection for your data pipelines</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#monitoring_and_anomaly_detection_the_basics" class="t-chapter js-chapter">Monitoring and Anomaly Detection: The Basics</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#why_anomaly_detection_is_easy_the_central_limit_t" class="t-chapter js-chapter">Why Anomaly Detection is Easy: The Central Limit Theorem</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#why_anomaly_detection_is_hard_anomalous_vs_inter" class="t-chapter js-chapter">Why Anomaly Detection is Hard: Anomalous vs. Interesting</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#error_signals_false_negatives_and_false_positives" class="t-chapter js-chapter">Error Signals: False Negatives and False Positives</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#precision_and_recall_1" class="t-chapter js-chapter">Precision and Recall</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#f_scores_idAWVy0V" class="t-chapter js-chapter">F-Scores</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#does_accuracy_matter" class="t-chapter js-chapter">Does Accuracy Matter?</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#defining_the_basics_of_monitoring_anomaly_detect" class="t-chapter js-chapter">Defining the basics of monitoring &amp; anomaly detection</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#anomaly_detection_techniques_for_data_pipelines" class="t-chapter js-chapter">Anomaly detection techniques for data pipelines</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#common_frameworks" class="t-chapter js-chapter">Common frameworks</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#experiment_tracking" class="t-chapter js-chapter">Experiment tracking</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#hyperparameter_tuning_and_search" class="t-chapter js-chapter">Hyperparameter tuning and search</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#designing_data_quality_monitors_for_warehouses_vs" class="t-chapter js-chapter">Designing data quality monitors for warehouses vs. lakes </a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#building_monitors_for_freshness_and_distribution" class="t-chapter js-chapter">Building monitors for freshness and distribution</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#freshness_idhuFOBB" class="t-chapter js-chapter">Freshness</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#distribution" class="t-chapter js-chapter">Distribution</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#building_monitors_for_schema_and_lineage" class="t-chapter js-chapter">Building monitors for schema and lineage</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#anomaly_detection_for_schema_changes_and_lineage" class="t-chapter js-chapter">Anomaly detection for schema changes and lineage</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#visualizing_lineage" class="t-chapter js-chapter">Visualizing lineage</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#investigating_a_data_anomaly" class="t-chapter js-chapter">Investigating a data anomaly</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#scaling_anomaly_detection_with_python_and_machine" class="t-chapter js-chapter">Scaling anomaly detection with Python and machine learning</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#improving_data_monitoring_alerting_with_machine_le" class="t-chapter js-chapter">Improving data monitoring alerting with machine learning</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#precision_and_recall_2" class="t-chapter js-chapter">Precision and recall</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#balancing_precision_and_recall" class="t-chapter js-chapter">Balancing precision and recall</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#detecting_freshness_incidents_with_data_monitoring" class="t-chapter js-chapter">Detecting freshness incidents with data monitoring </a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch06.html#summary_idDbEkfA" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#democratizing_data_quality" class="t-chapter js-chapter">7. Democratizing Data Quality</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#treating_your_data_like_a_product" class="t-chapter js-chapter">Treating your “Data” like a Product</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#perspectives_on_treating_data_like_a_product" class="t-chapter js-chapter">Perspectives on treating data like a product</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#applying_the_data_as_a_product_approach" class="t-chapter js-chapter">Applying the Data-as-a-Product approach</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#building_trust_in_your_data_platform" class="t-chapter js-chapter">Building Trust in your Data Platform </a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#align_your_product_s_goals_with_the_goals_of_the_b" class="t-chapter js-chapter">Align your product’s goals with the goals of the business</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#gain_feedback_and_buy_in_from_the_right_stakeholde" class="t-chapter js-chapter">Gain feedback and buy-in from the right stakeholders</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#prioritize_long_term_growth_and_sustainability_vs" class="t-chapter js-chapter">Prioritize long-term growth and sustainability vs. short-term gains</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#sign_off_on_baseline_metrics_for_your_data_and_how" class="t-chapter js-chapter">Sign-off on baseline metrics for your data and how you measure it</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#know_when_to_build_vs_buy" class="t-chapter js-chapter">Know when to build vs. buy</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#assigning_ownership_for_data_quality" class="t-chapter js-chapter">Assigning Ownership for Data Quality</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#chief_data_officer" class="t-chapter js-chapter">Chief Data Officer</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#business_intelligence_analyst" class="t-chapter js-chapter">Business Intelligence Analyst</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#analytics_engineer" class="t-chapter js-chapter">Analytics Engineer</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#data_scientist" class="t-chapter js-chapter">Data Scientist</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#data_governance_lead" class="t-chapter js-chapter">Data Governance Lead</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#data_engineer" class="t-chapter js-chapter">Data Engineer</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#data_product_manager" class="t-chapter js-chapter">Data Product Manager</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#who_is_responsible_for_data_reliability" class="t-chapter js-chapter">Who is responsible for data reliability? </a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#creating_accountability_for_data_quality" class="t-chapter js-chapter">Creating Accountability for Data Quality</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#balancing_data_accessibility_with_trust" class="t-chapter js-chapter">Balancing data accessibility with trust</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#certifying_your_data" class="t-chapter js-chapter">Certifying your data</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#section_6_steps_to_implementing_a_data_certification_progr" class="t-chapter js-chapter">6 steps to implementing a data certification program</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#step_1_build_out_your_data_observability_capabil" class="t-chapter js-chapter">Step 1:  Build out your data observability capabilities </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#step_2_determine_your_data_owners" class="t-chapter js-chapter">Step 2: Determine your data owners</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#step_3_understand_what_good_data_looks_like" class="t-chapter js-chapter">Step 3. Understand what “good” data looks like</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#step_4_set_clear_slas_for_your_most_important_dat" class="t-chapter js-chapter">Step 4: Set clear SLAs for your most important data sets </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#step_5_develop_your_communication_and_incident_ma" class="t-chapter js-chapter">Step 5: Develop your communication and incident management processes </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#step_6_determine_a_mechanism_to_tag_the_data_as_c" class="t-chapter js-chapter">Step 6: Determine a mechanism to tag the data as certified</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#step_7_train_your_data_team_and_downstream_consum" class="t-chapter js-chapter">Step 7: Train your data team and downstream consumers</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#case_study_toast_s_journey_to_finding_the_right_s" class="t-chapter js-chapter">Case Study: Toast’s Journey to Finding the Right Structure for their Data Team</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#in_the_beginning_when_a_small_team_struggles_to_m" class="t-chapter js-chapter">In the beginning: when a small team struggles to meet data demands </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#supporting_hypergrowth_as_a_decentralized_data_ope" class="t-chapter js-chapter">Supporting hypergrowth as a decentralized data operation</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#regrouping_re_centralizing_and_refocusing_on_dat" class="t-chapter js-chapter">Regrouping, re-centralizing, and refocusing on data trust</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#considerations_when_scaling_your_data_team" class="t-chapter js-chapter">Considerations when scaling your data team</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#increasing_data_literacy" class="t-chapter js-chapter">Increasing data literacy</a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#prioritizing_data_governance_and_compliance" class="t-chapter js-chapter">Prioritizing data governance and compliance </a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#prioritizing_a_data_catalog" class="t-chapter js-chapter">Prioritizing a data catalog</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#beyond_catalogs_enforcing_data_governance" class="t-chapter js-chapter">Beyond catalogs: enforcing data governance </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#building_a_data_quality_strategy" class="t-chapter js-chapter">Building a data quality strategy </a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch07.html#summary_idHTNsO8" class="t-chapter js-chapter">Summary </a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#building_a_data_reliability_workflow" class="t-chapter js-chapter">8. Building a data reliability workflow</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#implementing_the_dataops_lifecycle" class="t-chapter js-chapter">Implementing the DataOps lifecycle </a>
      
    
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#the_dataops_framework" class="t-chapter js-chapter">The DataOps framework</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#five_best_practices_of_dataops" class="t-chapter js-chapter">Five best practices of DataOps</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#three_under_the_radar_ways_organizations_can_benef" class="t-chapter js-chapter">Three under the radar ways organizations can benefit from DataOps</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#assembling_a_data_reliability_workflow" class="t-chapter js-chapter">Assembling a data reliability workflow</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#testing_idpORiFJ" class="t-chapter js-chapter">Testing</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#continuous_integration_ci_continuous_delivery" class="t-chapter js-chapter">Continuous Integration (CI) / Continuous Delivery (CD) </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#data_observability" class="t-chapter js-chapter">Data Observability</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#data_discovery" class="t-chapter js-chapter">Data discovery</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#building_end_to_end_field_level_lineage_for_modern" class="t-chapter js-chapter">Building End-to-End Field Level Lineage for Modern Data Systems</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#basic_lineage_requirements" class="t-chapter js-chapter">Basic lineage requirements</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#data_lineage_design" class="t-chapter js-chapter">Data lineage design</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#parsing_the_data" class="t-chapter js-chapter">Parsing the data</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#building_the_user_interface" class="t-chapter js-chapter">Building the user interface</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#case_study_architecting_for_data_reliability_at_f" class="t-chapter js-chapter">Case Study: Architecting for Data Reliability at Fox</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#exercise_controlled_freedom_when_dealing_with_st" class="t-chapter js-chapter">Exercise “Controlled Freedom” when dealing with stakeholders</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#invest_in_a_decentralized_data_team" class="t-chapter js-chapter">Invest in a decentralized data team </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#avoid_shiny_new_toys_in_favor_of_problem_solving_t" class="t-chapter js-chapter">Avoid shiny new toys in favor of problem-solving tech</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#to_make_analytics_self_serve_invest_in_data_trust" class="t-chapter js-chapter">To make analytics self-serve, invest in data trust</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch08.html#summary_idgHPpzF" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#data_quality_in_the_real_world_conversations_and" class="t-chapter js-chapter">9. Data Quality in the Real World: Conversations and Case Studies</a>
      
    
    
      <ol>
        

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#building_a_data_mesh_for_greater_data_quality" class="t-chapter js-chapter">Building a data mesh for greater data quality</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#domain_oriented_data_owners_and_pipelines" class="t-chapter js-chapter">
            Domain-oriented data owners and pipelines
          </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#self_serve_functionality" class="t-chapter js-chapter">
            Self-serve functionality
          </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#interoperability_and_standardization_of_communicat" class="t-chapter js-chapter">
            Interoperability and standardization of communications</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#why_implement_a_data_mesh" class="t-chapter js-chapter">Why implement a data mesh?</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#to_mesh_or_not_to_mesh_that_is_the_question" class="t-chapter js-chapter">To mesh or not to mesh: that is the question</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#calculating_your_data_mesh_score" class="t-chapter js-chapter">Calculating your data mesh score</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#a_conversation_with_zhamak_dehghani_the_role_of_d" class="t-chapter js-chapter">A conversation with Zhamak Dehghani: The role of data quality across the data mesh</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#can_you_build_a_data_mesh_from_a_single_solution" class="t-chapter js-chapter">Can you build a data mesh from a single solution?</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#is_data_mesh_another_word_for_data_virtualization" class="t-chapter js-chapter">Is data mesh another word for data virtualization? </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#does_each_data_product_team_manage_their_own_separ" class="t-chapter js-chapter">Does each data product team manage their own separate data stores? </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#is_a_self_serve_data_platform_the_same_thing_as_a" class="t-chapter js-chapter">Is a self-serve data platform the same thing as a decentralized data mesh? </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#is_the_data_mesh_right_for_all_data_teams" class="t-chapter js-chapter">Is the data mesh right for all data teams?  </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#does_one_person_on_your_team_own_the_data_mesh" class="t-chapter js-chapter">Does one person on your team “own” the data mesh? </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#does_the_data_mesh_cause_friction_between_data_eng" class="t-chapter js-chapter">Does the data mesh cause friction between data engineers and data analysts? </a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#case_study_kolibri_games_data_stack_journey" class="t-chapter js-chapter">Case Study: Kolibri Games’ Data Stack Journey</a>
      
    
    
      <ol>
        

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#section_2016_first_data_needs" class="t-chapter js-chapter">2016: First Data Needs</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#section_2017_pursuing_performance_marketing" class="t-chapter js-chapter">2017: Pursuing Performance Marketing</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#section_2017_data_tech_stack" class="t-chapter js-chapter">2017: Data Tech Stack</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#section_2018_professionalize_and_centralize" class="t-chapter js-chapter">2018: Professionalize and Centralize</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#section_2018_data_tech_stack" class="t-chapter js-chapter">2018: Data Tech Stack</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#section_2019_getting_data_oriented" class="t-chapter js-chapter">2019: Getting Data-Oriented</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#section_2020_getting_data_driven" class="t-chapter js-chapter">2020: Getting Data-Driven</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#section_2021_building_a_data_mesh" class="t-chapter js-chapter">2021: Building a Data Mesh</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#section_5_key_takeaways_from_a_5_year_data_evolution" class="t-chapter js-chapter">5 Key Takeaways from a 5-Year Data Evolution</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#knowledge_graphs_the_key_to_more_accessible_data" class="t-chapter js-chapter">Knowledge graphs: the key to more accessible data</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#unlocking_the_value_of_metadata_with_data_discover" class="t-chapter js-chapter">Unlocking the value of metadata with data discovery </a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#data_warehouse_lake_considerations" class="t-chapter js-chapter">Data warehouse / lake considerations</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#deciding_when_to_get_started_with_data_quality_at" class="t-chapter js-chapter">Deciding when to get started with data quality at your company</a>
      
    
    
  </li>

  <li class="toc-level-3 t-toc-level-3">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#data_quality_starts_with_trust" class="t-chapter js-chapter">Data quality starts with trust</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-2 t-toc-level-2">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/ch09.html#summary_idYsq6hi" class="t-chapter js-chapter">Summary</a>
      
    
    
  </li>


      </ol>
    
  </li>

  <li class="toc-level-1 t-toc-level-1">
    
      <a href="https://learning.oreilly.com/library/view/data-quality-fundamentals/9781098112035/colophon01.html#idm45849557425392" class="t-chapter js-chapter">About the Authors</a>
      
    
    
  </li>


      </ol>

      <div id="showMoreTOC" class="showMore hidden"><button class="more"><span class="screen-reader-text">Show and hide more</span></button></div>
    </div>
  </div>

  <div id="product-information" class="title-product-information">
    <div class="content">
      <h2>Product information</h2>

      <ul class="detail-product-information">
        <li><span class="name">Title:</span> <span class="value">Data Quality Fundamentals</span></li>
        <li><span class="name">Author(s):</span> <span class="value authors">Barr Moses, Lior Gavish, Molly Vorwerck</span></li>
        <li><span class="name">Release date:</span> <span class="value">September 2022</span></li>
        <li><span class="name">Publisher(s):</span> <span class="value t-publishers">O&#x27;Reilly Media, Inc.</span></li>
        <li><span class="name">ISBN:</span> <span class="value t-isbn">9781098112042</span></li>
      </ul>
    </div>
  </div>


  
  <div class="title-recommendations" id="recommendations">
    <div class="content">
      <h2 class="t-recommendations-heading">You might also like</h2>

      <div class="recommendations">
      
        <a id="recommendation1" class="recommendations-item" href="https://learning.oreilly.com/library/view/40-algorithms-every/9781789801217/" data-id="9781789801217">
          <figure class="recommendations-cover" style="background-image:url(https://learning.oreilly.com/library/cover/9781789801217//300h/)"></figure>
          <p class="recommendations-format recommendations-format-book">book</p>
          <h3 class="recommendations-title">40 Algorithms Every Programmer Should Know</h3>
          <p class="recommendations-authors">
            by
            
              Imran Ahmad
            
          </p>
          <p class="recommendations-description">Learn algorithms for solving classic computer science problems with this concise guide covering everything from fundamental …</p>
        </a>
      
        <a id="recommendation2" class="recommendations-item" href="https://learning.oreilly.com/library/view/clean-code-a/9780136083238/" data-id="9780136083238">
          <figure class="recommendations-cover" style="background-image:url(https://learning.oreilly.com/library/cover/9780136083238//300h/)"></figure>
          <p class="recommendations-format recommendations-format-book">book</p>
          <h3 class="recommendations-title">Clean Code: A Handbook of Agile Software Craftsmanship</h3>
          <p class="recommendations-authors">
            by
            
              Robert C. Martin
            
          </p>
          <p class="recommendations-description">Even bad code can function. But if code isn&#x27;t clean, it can bring a development organization …</p>
        </a>
      
        <a id="recommendation3" class="recommendations-item" href="https://learning.oreilly.com/videos/python-fundamentals/9780135917411" data-id="9780135917411">
          <figure class="recommendations-cover" style="background-image:url(https://learning.oreilly.com/library/cover/9780135917411//300h/)"></figure>
          <p class="recommendations-format recommendations-format-video">video</p>
          <h3 class="recommendations-title">Python Fundamentals</h3>
          <p class="recommendations-authors">
            by
            
              Paul J. Deitel
            
          </p>
          <p class="recommendations-description">51+ hours of video instruction. Overview The professional programmer’s Deitel® video guide to Python development with …</p>
        </a>
      
        <a id="recommendation4" class="recommendations-item" href="https://learning.oreilly.com/library/view/building-microservices-2nd/9781492034018/" data-id="9781492034018">
          <figure class="recommendations-cover" style="background-image:url(https://learning.oreilly.com/library/cover/9781492034018//300h/)"></figure>
          <p class="recommendations-format recommendations-format-book">book</p>
          <h3 class="recommendations-title">Building Microservices, 2nd Edition</h3>
          <p class="recommendations-authors">
            by
            
              Sam Newman
            
          </p>
          <p class="recommendations-description">Distributed systems have become more fine-grained as organizations shift from code-heavy monolithic applications to smaller, self-contained …</p>
        </a>
      
      </div>
    </div>
  </div>
  

</section>


  </div>
</main>


  <footer id="footer" class="footer">
  <div class="content">
    <div class="footer-main" aria-label="company info">
      <div class="footer-mainLeft">
        <div class="footer-mainLeftOne">
          <div class="footer-approach">
            <h2 class="footer-header"><a href="https://www.oreilly.com/about/">About O’Reilly</a></h2>
            <ul class="footer-links">
              <li><a href="https://www.oreilly.com/work-with-us.html">Teach/write/train</a></li>
              <li><a href="https://www.oreilly.com/careers/">Careers</a></li>
              <li><a href="https://www.oreilly.com/partner/signup.csp">Community partners</a></li>
              <li><a href="https://www.oreilly.com/affiliates/">Affiliate program</a></li>
              <li><a href="https://www.oreilly.com/online-learning/rfp.html">Submit an RFP</a></li>
              <li><a href="https://www.oreilly.com/diversity/">Diversity</a></li>
              <li><a href="https://www.oreilly.com/content-marketing-solutions.html" id="footerSponsorshipLink">O’Reilly for marketers</a></li>
            </ul>
          </div>
        </div>
        <div class="footer-mainLeftTwo">
          <div class="footer-contact">
            <h2 class="footer-header"><a href="https://www.oreilly.com/online-learning/support/">Support</a></h2>

            <ul class="footer-links">
              <li><a href="https://www.oreilly.com/about/contact.html">Contact us</a></li>
              <li><a href="https://www.oreilly.com/emails/newsletters/">Newsletters</a></li>
              <li><a href="https://www.oreilly.com/privacy.html">Privacy policy</a></li>
            </ul>
          
            <a href="https://twitter.com/oreillymedia" target="_blank"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 400 400" style="enable-background:new 0 0 400 400;" xml:space="preserve"><style type="text/css">.st0{fill:#ee0000;}.st1{fill:#FFFFFF;}</style><g id="Red"><circle class="st0" cx="200" cy="200" r="200"/></g><g id="Logo__x2014__FIXED"><path class="st1" d="M163.4,305.5c88.7,0,137.2-73.5,137.2-137.2c0-2.1,0-4.2-0.1-6.2c9.4-6.8,17.6-15.3,24.1-25 c-8.6,3.8-17.9,6.4-27.7,7.6c10-6,17.6-15.4,21.2-26.7c-9.3,5.5-19.6,9.5-30.6,11.7c-8.8-9.4-21.3-15.2-35.2-15.2 c-26.6,0-48.2,21.6-48.2,48.2c0,3.8,0.4,7.5,1.3,11c-40.1-2-75.6-21.2-99.4-50.4c-4.1,7.1-6.5,15.4-6.5,24.2 c0,16.7,8.5,31.5,21.5,40.1c-7.9-0.2-15.3-2.4-21.8-6c0,0.2,0,0.4,0,0.6c0,23.4,16.6,42.8,38.7,47.3c-4,1.1-8.3,1.7-12.7,1.7 c-3.1,0-6.1-0.3-9.1-0.9c6.1,19.2,23.9,33.1,45,33.5c-16.5,12.9-37.3,20.6-59.9,20.6c-3.9,0-7.7-0.2-11.5-0.7 C110.8,297.5,136.2,305.5,163.4,305.5"/></g></svg></a>
            <a href="https://www.facebook.com/OReilly/" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>facebook-logo</title><path class="cls-1" d="M16.13,0A16.13,16.13,0,1,0,32.25,16.12,16.13,16.13,0,0,0,16.13,0Zm5.12,9.54H19.57a1.52,1.52,0,0,0-1.51,1.51v1.14h3.19v3.42H18.06V26.12H13.57V15.61H10.69V12.19h2.88v-2a4,4,0,0,1,4-4h3.65Z"/></svg></a>
            <a href="https://www.linkedin.com/company/oreilly-media" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>linkedin-logo</title><path class="cls-1" d="M17.43,13.53v0l0,0ZM16.12,0A16.13,16.13,0,1,0,32.25,16.12,16.12,16.12,0,0,0,16.12,0ZM11.77,22.92H8.12v-11h3.65ZM9.94,10.44h0a1.89,1.89,0,0,1-2-1.89A1.91,1.91,0,0,1,10,6.65a1.9,1.9,0,1,1,0,3.79Zm15,12.48H21.28V17.05c0-1.48-.53-2.49-1.85-2.49a2,2,0,0,0-1.88,1.34,2.63,2.63,0,0,0-.12.89v6.13H13.79s.05-10,0-11h3.64V13.5a3.63,3.63,0,0,1,3.29-1.82c2.4,0,4.21,1.57,4.21,4.95Z"/></svg></a>
            <a href="https://www.youtube.com/user/OreillyMedia" target="_blank"><svg data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32.25 32.25"><defs><style>.cls-1{fill:#E00;fill-rule:evenodd;}</style></defs><title>youtube-logo</title><path class="cls-1" d="M18.35,18.68a.89.89,0,0,0-.86.63V16.94h-1v7.59h1v-.59a.92.92,0,0,0,.89.74c.52,0,.86-.36,1-1.07a8.56,8.56,0,0,0,.14-1.9,10.47,10.47,0,0,0-.12-1.93C19.21,19.05,18.87,18.68,18.35,18.68Zm.09,4.14c-.05.52-.2.77-.45.77s-.43-.21-.49-.63a7.22,7.22,0,0,1,0-1c0-.72,0-1.14,0-1.26.07-.58.23-.88.51-.88s.4.27.46.79c0,.09,0,.47,0,1.13S18.46,22.71,18.44,22.82ZM8.61,18.19H9.86v6.34H11V18.19H12.2V16.94H8.61Zm7.71-6.12c.27,0,.43-.22.49-.66,0-.09,0-.45,0-1.07V9.78c0-.58,0-.93,0-1-.07-.43-.23-.65-.48-.65s-.41.19-.48.57a8.79,8.79,0,0,0,0,1v.53c0,.71,0,1.09,0,1.16C15.88,11.82,16.05,12.07,16.32,12.07Zm-1.74,10.4a2.92,2.92,0,0,1-.06.71c-.07.25-.2.37-.4.37s-.32-.11-.38-.34a2.63,2.63,0,0,1-.05-.66V18.83h-1v4.48c0,.91.33,1.37,1,1.37A1,1,0,0,0,14.6,24v.57h1v-5.7h-1Zm7.1-3.79a1.35,1.35,0,0,0-1.22.59,2.48,2.48,0,0,0-.3,1.07c0,.23,0,.61,0,1.16s0,1.13,0,1.37a2.93,2.93,0,0,0,.35,1.27,1.25,1.25,0,0,0,1.14.54,1.36,1.36,0,0,0,1.13-.45,2.29,2.29,0,0,0,.37-1.43s0-.07,0-.11v-.12h-1c0,.75-.17,1.12-.51,1.12s-.38-.18-.45-.56a4.68,4.68,0,0,1-.06-.9c0-.18,0-.31,0-.37h2v-.43a4.86,4.86,0,0,0-.3-2.11A1.28,1.28,0,0,0,21.68,18.68ZM22.15,21h-1c0-.05,0-.11,0-.16v-.08a1.64,1.64,0,0,1,.11-.8.39.39,0,0,1,.38-.23.42.42,0,0,1,.43.33,2.32,2.32,0,0,1,.07.7Zm-6-21A16.13,16.13,0,1,0,32.25,16.12,16.12,16.12,0,0,0,16.12,0Zm2.51,7.2h1V11a2.52,2.52,0,0,0,.06.66c.06.23.18.34.38.34s.34-.12.41-.37a3.76,3.76,0,0,0,.05-.71V7.2h1v5.74h-1v-.57a1,1,0,0,1-.93.72c-.66,0-1-.46-1-1.38ZM15,8a1.29,1.29,0,0,1,1.33-.92A1.3,1.3,0,0,1,17.65,8a6.77,6.77,0,0,1,.23,2.1,6.77,6.77,0,0,1-.23,2.1,1.3,1.3,0,0,1-1.32.92A1.29,1.29,0,0,1,15,12.17a6.77,6.77,0,0,1-.23-2.1A6.86,6.86,0,0,1,15,8ZM11.45,5.3l.89,2.87.88-2.87H14.4L12.88,9.7v3.24h-1.1V9.7L10.24,5.3ZM24.93,23.91a3,3,0,0,1-3,3h-12a3,3,0,0,1-3-3V18.05a3,3,0,0,1,3-3h12a3,3,0,0,1,3,3Z"/></svg></a>
          </div>
        </div>
      </div>

      <div class="footer-download" id="download-info">
        <h2 class="footer-header">Download the O’Reilly App</h2>
        <p>Take O’Reilly with you and learn anywhere, anytime on your phone <span class="nowrap">and tablet.</span></p>

        <div class="footer-downloadLinks">
          <a href="https://itunes.apple.com/us/app/safari-to-go/id881697395"><img src="https://cdn.oreillystatic.com/oreilly/images/app-store-logo.png" alt="Apple app store" /></a>
          <a href="https://play.google.com/store/apps/details?id=com.safariflow.queue"><img src="https://cdn.oreillystatic.com/oreilly/images/google-play-logo.png"  alt="Google play store" /></a>
        </div>
      </div>

      <div class="footer-download" id="tv-info">
        <h2 class="footer-header">Watch on your big screen</h2>
        <p>View all O’Reilly videos, Superstream events, and Meet the Expert sessions on your <span class="nowrap">home TV.</span></p>

        <div class="footer-downloadLinks">
          <a href="https://channelstore.roku.com/details/c8a2d0096693eb9455f6ac165003ee06/oreilly"><img src="https://cdn.oreillystatic.com/oreilly/images/roku-tv-logo.png" alt="Roku Payers and TVs" /></a>
          <a href="https://www.amazon.com/OReilly-Media-Inc/dp/B087YYHL5C/ref=sr_1_2?dchild=1&keywords=oreilly&qid=1604964116&s=mobile-apps&sr=1-2"><img src="https://cdn.oreillystatic.com/oreilly/images/amazon-appstore-logo.png"  alt="Amazon appstore" /></a>
        </div>
      </div>

      <div class="footer-donotsell" id="donotsell-info">
        <h2 class="footer-header"><a href="https://www.oreilly.com/privacy.html?donotsell=show">Do not sell my personal information</a></h2>
      </div>
    </div>

    <div class="footer-subfooter">

      <a href="https://www.oreilly.com" title="home page" aria-current="page">
        <img 
        class="footer-subfooterLogo" 
        id="footer-subfooterLogo"
        src="https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red.svg" 
        onerror="this.src='https://cdn.oreillystatic.com/images/sitewide-headers/oreilly_logo_mark_red_@2x.png'; this.onerror=null;" 
        alt="O'Reilly home">
      </a>

      <p>&copy; 2022, O’Reilly Media, Inc. All trademarks and registered trademarks appearing on oreilly.com are the property of their respective owners.</p>
      
      

      <p><a href="https://www.oreilly.com/terms/">Terms of service</a> • <a href="https://www.oreilly.com/privacy.html">Privacy policy</a> • <a href="https://www.oreilly.com/about/editorial_independence.html">Editorial independence</a></p>
    </div>

  </div>
</footer>



  <div class="exitIntentOverlay">
    <div class="exitIntentOverlay-contents">
      <div class="exitIntentOverlay-columns">
        <div class="exitIntentOverlay-text">
          <h2>Don’t leave <span class="nowrap">empty-handed</span></h2>

          <p>Get Mark Richards’s <em>Software Architecture Patterns</em> ebook to better understand how to design components—and how they should interact.</p>

          <h3>It’s yours, free.</h3>

          <a class="exitIntentOverlay-cta" href="https://get.oreilly.com/ind_software-architecture-patterns.html">Get it now</a>
        </div>

        <figure class="exitIntentOverlay-figure"><img src="https://cdn.oreillystatic.com/oreilly/images/report-software-architecture-patterns-553x420.jpg" alt="Cover of Software Architecture Patterns"></figure>
      </div>

      <button class="exitIntentOverlay-close">Close</button>
    </div>
  </div>






<script>
  var g = {
    
  };
</script>
<script>
  window.dataLayer = window.dataLayer || [];
  window.dataLayer.push({
    'product.title': "Data Quality Fundamentals",
    'product.type': "book",
    'product.identifier': "9781098112035",
    'content.identifier': "9781098112035",
    'content.publisher': "O'Reilly Media, Inc.",
    'content.free': "no",
    //
    'content.subdirectory': "none",
    'content.subTopic': "none",
    'content.parentTopic': "none",
    'content.formatType': "book",
    'content.author': "Barr Moses, Lior Gavish, Molly Vorwerck",
    'content.releaseDate': "2022-09-25",
    'content.title': "Data Quality Fundamentals",
  });
</script>

<script>
  // Datadog RUM integration to measure performance and Core Web Vitals
  // https://docs.datadoghq.com/real_user_monitoring/browser/#overview
  // https://web.dev/vitals/
  (function(h,o,u,n,d) {
    h=h[d]=h[d]||{q:[],onReady:function(c){h.q.push(c)}}
    d=o.createElement(u);d.async=1;d.src=n
    n=o.getElementsByTagName(u)[0];n.parentNode.insertBefore(d,n)
  })(window,document,'script','https://www.datadoghq-browser-agent.com/datadog-rum.js','DD_RUM')
  DD_RUM.onReady(function() {
    DD_RUM.init({
      clientToken: 'pub1221d36d3b6dfda5f3c3b7ed22e3b6af',
      applicationId: '291bce39-f950-4fc6-a610-10abfead0661',
      site: 'datadoghq.com',
      service:'anybird',
      env:'production',
      // Specify a version number to identify the deployed version of your application in Datadog 
      // version: '1.0.0',
      sampleRate: 10,
      trackInteractions: true,
    })
  })
</script>






<script src="/library/view/static/CACHE/js/output.7bcbb5f0ecd8.js"></script>


<noscript> 
  <iframe src="//www.googletagmanager.com/ns.html?id=GTM-5P4V6Z"
          height="0" width="0"
          style="display:none;visibility:hidden">
  </iframe>
</noscript>


<script async defer src="/library/view/pageview.js"></script>

<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.0/jquery.min.js"></script>


<script>
  //Exit intent overlay scripts

  //Setter and getter for exit intent cookie
  const ExitIntentCookieService = {
    setCookie(name, value, days) {
      let expires = '';
  
      if (days) {
        const date = new Date();
        date.setTime(date.getTime() + (days * 24 * 60 * 60 * 1000));
        expires = '; expires=' + date.toUTCString();
      }
  
      document.cookie = name + '=' + (value || '')  + expires + ';';
    },
  
    getCookie(name) {
      const cookies = document.cookie.split(';');
  
      for (const cookie of cookies) {
        if (cookie.indexOf(name + '=') > -1) {
          return cookie.split('=')[1];
        }
      }
  
      return null;
    }
  };
  
  //When a user clicks outside overlay or close icon or hits escape key
  //close exit intent overlay 
  const exit = e => {
    const shouldExit =
      [...e.target.classList].includes('exitIntentOverlay') || // user clicks on mask
      e.target.className === 'exitIntentOverlay-close' || // user clicks on the close icon
      e.keyCode === 27; // user hits escape
  
    if (shouldExit) {
      document.querySelector('.exitIntentOverlay').classList.remove('visible');
    }
  };
  
  //When a user's cursor leaves the document
  //show exit intent overlay 
  const mouseEvent = e => {
    const shouldShowExitIntent = 
      !e.toElement && 
      !e.relatedTarget &&
      e.clientY < 10;
  
    if (shouldShowExitIntent) {
      document.removeEventListener('mouseout', mouseEvent);
      document.querySelector('.exitIntentOverlay').classList.add('visible');
      
      //Set exit intent cookie
      ExitIntentCookieService.setCookie('libraryExitIntentShown', true, 30);
    }
  };
  
  //If exit intentcookie doesn't exist,
  //then initialize exit intent overlay scripts
  if (!ExitIntentCookieService.getCookie('libraryExitIntentShown')) {
    setTimeout(() => {
      document.addEventListener('mouseout', mouseEvent);
      document.addEventListener('keydown', exit);
      document.querySelector('.exitIntentOverlay').addEventListener('click', exit);
    }, 0);
  }
</script>


<script>
  jQuery(document).ready(function($) {
    //Toggle isActive and mobileHidden classes for mobileNavButton
    $('nav #mobileNavButton').on('click', function() {
      var expanded = $(this).attr('aria-expanded') === 'true' || false;
      $(this).attr('aria-expanded', !expanded);
      $(this).toggleClass("isActive");
      $(this).next().toggleClass("mobileHidden");
    });

    //Toggle isFocused class for keyboard navigation of submenus
    $('nav #menuList .menuList-subItem a').each(function(navItem) {
      $(this).on('focus', function() {
        $(this).parent().parent().toggleClass('isFocused');
      });
      $(this).on('blur', function() {
        $(this).parent().parent().toggleClass('isFocused');
      });
    });

    //Toggle mobileHidden class accordian elements
    $('.mobileAccordian').each(function() {
      var $btn = $(this).find('button');
      var $target =  $(this).next();
      $btn.on('click', function() {
        var expanded = $btn.attr('aria-expanded') === 'true' || false;

        $btn.attr('aria-expanded', !expanded);
        $target.toggleClass("mobileHidden");
      });
    });


    //Hide title page's long description behind disclosure button
    var titleDescriptionExtra = $('.title-description p:first-of-type').nextAll(':nth-child(3)').nextAll();
    titleDescriptionExtra.wrapAll('<div id="titleDescriptionExtra" />');
    if (titleDescriptionExtra.length > 0) {
      $('#titleDescriptionExtra').toggle();
      $('#showMoreDescription').removeClass('hidden');
      $('#showMoreDescription button').on('click', function() {
        $(this).toggleClass('more');
        $('#titleDescriptionExtra').slideToggle();
      });
    }

    //Hide title page's long TOC behind disclosure button
    var titleTOCShort = $('.sbo-reader-title .detail-toc').find('li').slice(0,4);
    var titleTOCExtra = $('.sbo-reader-title .detail-toc').find('li').not(titleTOCShort);
    if (titleTOCExtra.length > 0) {
      titleTOCExtra.toggle();
      $('#showMoreTOC').removeClass('hidden');
      $('#showMoreTOC button').on('click', function() {
        $(this).toggleClass('more');
        titleTOCExtra.toggle();
      });
    }

    //Hide product information on page load
    $('#product-information').toggle();
    $('#title-tabs button').on('click', function() {
      var $thisTab = $(this);
      if (!$thisTab.hasClass('title-tab-active')) {
        var lastTabTarget = $('#title-tabs .title-tab-active').removeClass('title-tab-active').attr('data-target');
        $('#' + lastTabTarget).toggle();

        $thisTab.addClass('title-tab-active');
        var $tabTarget = $(this).attr('data-target');
        $('#' + $tabTarget).toggle();
      }
    });

    // Append highlight fragment hash to sign in link for highlighting
    if (window.location.hash.indexOf('#:-:text') > -1) {
      // encode the hash symbol to prevent it from being used as a location hash by groot-fe
      var highlightFragment = window.location.hash.replace('#:-:text', '%23:-:text');
      $('#chapter-sign-in').attr('href', $('#chapter-sign-in').attr('href') + highlightFragment);
    }

    //Trigger GA events for related products
    $('#recommendations .recommendations-item').each(function(i) {
      $(this).on('click', function(e) {
        var cardTitle = $(this).find('.recommendations-title').text().toLowerCase();
        var productType = $(this).find('.recommendations-format').text().toLowerCase();
        var contentID = $(this).attr('data-id');
        var eventLbl = String(i);

        dataLayer.push({
          'product.title': undefined,
          'content.formatType': undefined,
          'product.identifier': undefined,
          'content.title': undefined,
          'content.author': undefined,
          'content.publisher': undefined,
          'content.releaseDate': undefined,
          'content.free': undefined,
          'content.subdirectory': undefined,
          'content.parentTopic': undefined,
          'content.subTopic': undefined,
          'event': 'eventTracker',
          'eventCat': 'recommended titles',
          'eventAct': 'card click',
          'eventLbl': eventLbl,
          'eventVal': 0, 
          'nonInteraction': 0,
          'cardTitle': cardTitle,
          'product.type': productType,
          'content.identifier': contentID,
          'eventCallback': function() {
            dataLayer.push({'cardTitle': undefined});
          },
          'eventTimeout' : 2000
        });
      });
    });

  });

</script>



<!-- MARC Intercept Support -->

<script src="https://service.seamlessaccess.org/thiss.js"></script>

<script src="/library/view/static/CACHE/js/output.7f395b6ade85.js"></script>


</body>
</html>
