Chapter 2. Installation and the Requirements for Elasticsearch

The Java Runtime Environment (JRE) is the only requirement to run Elasticsearch.

The official Elasticsearch documentation recommends that you use either Oracle Java 8 (update 20 or later), or Oracle Java 7 (update 55 or later). Once you choose your version of the JRE, we recommend that all your nodes use the same version to maintain compatibility. Using different versions of Java across your cluster or using Java versions earlier than the ones specified here, can lead to data corruption. Once you choose a version of Elasticsearch, all the nodes in your cluster should use the same version.

While it is possible to run Elasticsearch on both Windows and Linux, this book focuses on using ...

Get Monitoring Elasticsearch now with O’Reilly online learning.

O’Reilly members experience live online training, plus books, videos, and digital content from 200+ publishers.