Chapter 2. iPhone

To develop for the iPhone or iPod touch, you will need an Intel-based Macintosh computer running OS X v10.5.7 or later. You will also need to install the latest version of the iPhone SDK and verify that your device operating systems are up-to-date. Download the iPhone SDK from the Apple Developers site (http://developer.apple.com/iphone), which includes the Xcode IDE, iPhone simulator, and a suite of additional tools for developing applications for iPhone and iPod touch. These tools will help you develop your application and allow you to run it in the simulator. From this point on in the text, whenever we refer to building or creating applications for the iPhone, we also mean for the iPod Touch of iPad, interchangeably. The iPod ...

Get Pro Smartphone Cross-Platform Development: iPhone, BlackBerry, Windows Mobile, and Android Development and Distribution now with O’Reilly online learning.

O’Reilly members experience live online training, plus books, videos, and digital content from 200+ publishers.