Prerequisites

Before proceeding with this chapter, you should already be familiar with developing in Solidity. If not, I recommend reading the previous chapterPeer-to-Peer Auctions in Ethereum . Moreover, the following prerequisites should be installed:

  • Ubuntu 16.04
  • MetaMask browser plugin
  • Node.js and NPM

Don't forget a cup of good coffee.

Get Blockchain By Example now with O’Reilly online learning.

O’Reilly members experience live online training, plus books, videos, and digital content from 200+ publishers.