HP-UX

SAM is still the easiest way to build a new kernel under HP-UX. However, you can build one manually if you prefer:[4]

# cd /stand                                      
            Move to kernel directory.
# mv vmunix vmunix.save                          
            Save current kernel.
# cd build                                       
            Move to build subdirectory.
# /usr/lbin/sysadm/system_prep -v -s system      
            Extract system file.
# kmtune -s 
            var
            =
            value
             -S /stand/build/system     
            Modify kernel parameters.
  ...
# mk_kernel -s ./system -o ./vmunix_new          
            Build new kernel.
# kmupdate /stand/build/vmunix_new               
            Schedule  kernel install.
# mv /stand/system /stand/system.prev            
            Save old system file.
# mv /stand/build/system /stand/system           
            Install new system file.

The system_prep script creates a new system configuration file by extracting the information from the running kernel. The kmtune command(s) specify the values of kernel variables for the new kernel.

The mk_kernel script calls the config command and initiates the make process automatically. Once the kernel is built, you use the kmupdate command to schedule its installation at the next reboot. You can then reboot to activate it.

If there is a problem with the new kernel, you can boot the saved kernel with a command like the following:

ISL> hpux /stand/vmunix.save

To determine what kernel object files are available, use the following command to list the contents of the /stand directory:

ISL> hpux ll /stand

The system file contains information about system devices and settings for various kernel parameters. Here are some examples of the latter:

maxfiles_lim ...

Get Essential System Administration, 3rd Edition now with the O’Reilly learning platform.

O’Reilly members experience books, live events, courses curated by job role, and more from O’Reilly and nearly 200 top publishers.