May 2018
Intermediate to advanced
256 pages
7h 6m
English
While workloads running on an OpenStack cloud are the stars of the show, the infrastructure is the real hero. Keeping the APIs available and running 100% without interruption should be the end goal of any operator when it comes to availability. However, it's simply not reality. Even with proper life cycle management and change procedures, data corruption can happen. Since the heart of OpenStack is a structured database running on MariaDB, it only makes sense to run it in a highly available configuration. However, what happens if, during operation, errors are made and are replicated across all HA nodes? Failure. Now, without backup and recovery, not only are the APIs offline, and the workloads could still ...
Read now
Unlock full access